]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
- add todo
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 # TODO
2 # - update pl
3 Summary:        Nagios remote plugin execution service/plugin
4 Summary(pl):    Demon i wtyczka zdalnego wywo³ywania wtyczek Nagios
5 Name:           nagios-nrpe
6 Version:        2.5.2
7 Release:        1
8 License:        GPL v2
9 Group:          Networking
10 Source0:        http://dl.sourceforge.net/nagios/nrpe-%{version}.tar.gz
11 # Source0-md5:  22afa197db8e4e5b13fac48636917b6d
12 Source1:        nrpe.init
13 Patch0:         %{name}-config.patch
14 URL:            http://www.nagios.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  openssl-tools
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(post,preun):   /sbin/chkconfig
20 Requires:       nagios-common
21 Requires:       rc-scripts
22 Provides:       nagios-core
23 Obsoletes:      netsaint-nrpe
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     /etc/nagios
27 %define         _datadir        %{_prefix}/share/%{name}
28 %define         _plugindir      %{_libdir}/nagios/plugins
29 %define         _libexecdir     %{_plugindir}
30 %define         _localstatedir  %{_var}/log/nagios
31 %define         nsport          5666
32
33 %description
34 NRPE is an addon for Nagios that allows you to execute "local" plugins
35 (like check_disk, check_procs, etc.) on remote hosts. The check_nrpe
36 plugin is called from Nagios and makes plugin execution requests to
37 the NRPE daemon running on the remote host (either as a standalone
38 daemon or as a service under inetd). Supports passing command
39 arguments to server, as well as native SSL/TLS encryption (anonymous
40 DH mode).
41
42 %description -l pl
43 Nagios npre pozwala zdalnie uruchamiaæ wtyczki na innych hostach, a
44 wynik ich dzia³ania zwracaæ z powrotem do hosta monitoruj±cego.
45
46 %package plugin
47 Summary:        check_nrpe plugin for Nagios
48 Summary(pl):    Wtyczka check_nrpe dla Nagiosa
49 Group:          Networking
50 Requires:       nagios-core
51
52 %description plugin
53 check_nrpe plugin for Nagios. This plugin allows running plugins on
54 remote machines using nrpe service.
55
56 %description plugin -l pl
57 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie wtyczek
58 na innych komputerach za pomoc± demona nrpe.
59
60 %prep
61 %setup -q -n nrpe-%{version}
62 %patch0 -p1
63
64 %build
65 %{__aclocal}
66 %{__autoconf}
67
68 %configure \
69         --with-init-dir=/etc/rc.d/init.d \
70         --with-nrpe-port=%{nsport} \
71         --with-nrpe-user=nagios \
72         --with-nrpe-grp=nagios \
73         --enable-ssl \
74         --enable-command-args
75
76 %{__make} all
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir},%{_libdir}/nagios/plugins,%{_sbindir}} \
81         $RPM_BUILD_ROOT%{_localstatedir}
82
83 install sample-config/nrpe.cfg $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.cfg
84 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
85 install src/nrpe $RPM_BUILD_ROOT%{_sbindir}
86 install src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 /sbin/chkconfig --add nrpe
93 %service nrpe restart
94
95 %preun
96 if [ "$1" = "0" ] ; then
97         %service nrpe stop
98         /sbin/chkconfig --del nrpe
99 fi
100
101 %files
102 %defattr(644,root,root,755)
103 %doc Changelog LEGAL README* SECURITY
104 %attr(754,root,root) /etc/rc.d/init.d/nrpe
105 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
106 %attr(755,root,root) %{_sbindir}/nrpe
107
108 %files plugin
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_plugindir}/*
This page took 0.044332 seconds and 3 git commands to generate.