]> git.pld-linux.org Git - packages/mythtv.git/commitdiff
- unfinished update to 0.24.1
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 16 Nov 2011 21:20:20 +0000 (21:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mythtv-compile_fixes_for_qt_4_7.patch -> 1.2
    mythtv-sbinpath.patch -> 1.5
    mythtv.spec -> 1.110

mythtv-compile_fixes_for_qt_4_7.patch
mythtv-sbinpath.patch
mythtv.spec

index 674720a4ca5a5b2af572813332556055d35fb4ea..90d123ceb01a575de9c08deb0d62fe47cb95f497 100644 (file)
@@ -1,58 +1,7 @@
 ---
- libs/libmyth/mythdeque.h          |    2      1 +     1 -     0 !
- libs/libmythtv/recordingprofile.h |    2      1 +     1 -     0 !
  libs/libmythtv/tv_rec.h           |    2      1 +     1 -     0 !
- libs/libmythupnp/eventing.h       |    4      2 +     2 -     0 !
  5 files changed, 6 insertions(+), 6 deletions(-)
 
-Index: mythtv/libs/libmythupnp/eventing.h
-===================================================================
---- mythtv.orig/libs/libmythupnp/eventing.h    2010-01-10 08:49:06.000000000 -0500
-+++ mythtv/libs/libmythupnp/eventing.h 2010-07-01 22:34:54.000000000 -0400
-@@ -233,7 +233,7 @@
-         {
-             SVMap::iterator it = m_map.find(sName);
-             if (it == m_map.end())
--                return T(0);
-+                return T();
-             StateVariable< T > *pVariable =
-                 dynamic_cast< StateVariable< T > *>( *it );
-@@ -241,7 +241,7 @@
-             if (pVariable != NULL)
-                 return pVariable->GetValue();
--            return T(0);
-+            return T();
-         }
-         uint BuildNotifyBody(QTextStream &ts, TaskTime ttLastNotified) const;
-Index: mythtv/libs/libmyth/audiooutputbase.cpp
-===================================================================
---- mythtv.orig/libs/libmyth/mythdeque.h       2009-09-11 15:07:19.000000000 -0400
-+++ mythtv/libs/libmyth/mythdeque.h    2010-07-01 22:34:54.000000000 -0400
-@@ -19,7 +19,7 @@
-     T dequeue()
-     {
-         if (deque<T>::empty())
--            return (T)(0);
-+            return T();
-         T item = deque<T>::front();
-         deque<T>::pop_front();
-         return item;
-Index: mythtv/libs/libmythtv/recordingprofile.h
-===================================================================
---- mythtv.orig/libs/libmythtv/recordingprofile.h      2010-05-16 14:58:08.000000000 -0400
-+++ mythtv/libs/libmythtv/recordingprofile.h   2010-07-01 22:34:54.000000000 -0400
-@@ -84,7 +84,7 @@
-   public:
-     // initializers
--    RecordingProfile(QString profName = NULL);
-+    RecordingProfile(QString profName = QString());
-     virtual void loadByID(int id);
-     virtual bool loadByType(const QString &name, const QString &cardtype);
-     virtual bool loadByGroup(const QString &name, const QString &group);
 Index: mythtv/libs/libmythtv/tv_rec.h
 ===================================================================
 --- mythtv.orig/libs/libmythtv/tv_rec.h        2010-05-16 14:58:08.000000000 -0400
index cf340d11196b4f0c7149a22aec06e0b90b3577af..e772a1b2aa4a676d763cebc9ceec8cfb389708e0 100644 (file)
@@ -22,18 +22,6 @@ diff -urN mythtv-0.22rc1.orig/libs/libmythtv/jobqueue.cpp mythtv-0.22rc1/libs/li
          command = QString("%1 -j %2 -V %3")
                            .arg(path).arg(jobID).arg(print_verbose_messages);
      }
-diff -urN mythtv-0.22rc1.orig/libs/libmythtv/previewgenerator.cpp mythtv-0.22rc1/libs/libmythtv/previewgenerator.cpp
---- mythtv-0.22rc1.orig/libs/libmythtv/previewgenerator.cpp    2009-09-29 15:49:11.000000000 +0200
-+++ mythtv-0.22rc1/libs/libmythtv/previewgenerator.cpp 2009-10-18 18:55:54.000000000 +0200
-@@ -224,7 +224,7 @@
-     {
-         // This is where we fork and run mythbackend to actually make preview
-         QString command = GetInstallPrefix() +
--                                    "/bin/mythbackend --generate-preview ";
-+                                    "/sbin/mythbackend --generate-preview ";
-         command += QString("%1x%2")
-             .arg(outSize.width()).arg(outSize.height());
-         if (captureTime >= 0)
 diff -urN mythtv-0.22rc1.orig/programs/mythbackend/mythbackend.pro mythtv-0.22rc1/programs/mythbackend/mythbackend.pro
 --- mythtv-0.22rc1.orig/programs/mythbackend/mythbackend.pro   2009-07-17 23:08:07.000000000 +0200
 +++ mythtv-0.22rc1/programs/mythbackend/mythbackend.pro        2009-10-18 18:55:54.000000000 +0200
index 596e73f9684d3b5df3675877642cc2f9ea7006cd..96c9870d82c863d63ef197dc155008c0d314126f 100644 (file)
@@ -4,6 +4,11 @@
 # - alpha, sparc, ppc arches?
 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
 # - vaapi support - check for compatible versions of libva?
+# - bindings:
+#   WARNING: disabling Python bindings; missing MySQLdb
+#   WARNING: disabling Perl bindings; missing Net::UPnP::QueryResponse
+#   WARNING: disabling Perl bindings; missing Net::UPnP::ControlPoint
+# - dozen of unpackaged files
 #
 # Specfile for MythTV
 #
@@ -32,6 +37,8 @@
 %bcond_with    vaapi           # enable vaapi
 %bcond_with     dshowserver    # enable directshow codecs server
 %bcond_with    directfb
+%bcond_with    perl
+%bcond_with    python
 %bcond_with    nvidia_headers  # build vdpau support with nvidia headers 
                                # instead of libvdpau
 
 Summary:       A personal video recorder (PVR) application
 Summary(pl.UTF-8):     Osobista aplikacja do nagrywania obrazu (PVR)
 Name:          mythtv
-Version:       0.23.1
-Release:       5
+Version:       0.24.1
+Release:       0.1
 License:       GPL v2
 Group:         Applications/Multimedia
 Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
-# Source0-md5: 3379a5fd12ae866cd10c5b5d23439898
+# Source0-md5: 6870c679619ec58456e76839745411d8
 Source1:       mythbackend.sysconfig
 Source2:       mythbackend.init
 Source3:       mythbackend.logrotate
@@ -123,6 +130,11 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        myth_api_version %(echo %{version} | cut -d. -f1,2)
 
+# libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
+# libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
+%define                skip_post_check_so      libmythavdevice.so libmythavcodec.so
+%define                no_install_post_check_so 1
+
 %description
 MythTV implements the following PVR features, and more, with a unified
 graphical interface:
@@ -332,10 +344,9 @@ Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
 
 %patch0  -p1
 %patch10 -p1
-%patch20 -p1
+%{?with_dshowserver:%patch20 -p1}
 #%patch30 -p1
 
-%{?with_dshowserver:%patch20 -p0}
 rm -rf database/old # not supported in PLD
 
 # lib64 fix - enable to update patch
@@ -384,7 +395,7 @@ chmod +x qmake-wrapper.sh
 
 # move perl bindings to vendor prefix
 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
-   bindings/perl/perl.pro
+  bindings/perl/Makefile
 
 %build
 
@@ -442,7 +453,7 @@ fi
        --enable-xv \
        --enable-x11 \
 
-%{_libdir}/qt4/bin/qmake mythtv.pro
+#%{_libdir}/qt4/bin/qmake mythtv.pro
 %{__make}
 
 %install
@@ -459,10 +470,10 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
 # Install the files that we added on top of mythtv's own stuff
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
-%{?with_dshowserver:install %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
+install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
+cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
+cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
+%{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
 
 # desktop entries
 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
@@ -566,7 +577,7 @@ fi
 %dir %{_libdir}/mythtv/filters
 %dir %{_libdir}/mythtv/plugins
 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
-%{_datadir}/mythtv/*.ttf
+%{_datadir}/mythtv/fonts/*.ttf
 %dir %{_datadir}/mythtv/i18n
 %if %{with dshowserver}
 %{_datadir}/mythtv/dshowcodecs
@@ -598,6 +609,7 @@ fi
 %files -n libmyth-static
 %defattr(644,root,root,755)
 
+%if %{with perl}
 %files -n perl-MythTV
 %defattr(644,root,root,755)
 %{perl_vendorlib}/MythTV.pm
@@ -606,10 +618,13 @@ fi
 %dir %{perl_vendorlib}/IO/Socket/INET
 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
+%endif
 
+%if %{with python}
 %files -n python-MythTV
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/mythpython
 %dir %{py_sitescriptdir}/MythTV
 %{py_sitescriptdir}/MythTV/*
 %{py_sitescriptdir}/*.egg-info
+%endif
This page took 0.122697 seconds and 4 git commands to generate.