]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- rel 0.2
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 # - vaapi support - check for compatible versions of libva?
7 # - bindings:
8 #   WARNING: disabling Python bindings; missing MySQLdb
9 #   WARNING: disabling Perl bindings; missing Net::UPnP::QueryResponse
10 #   WARNING: disabling Perl bindings; missing Net::UPnP::ControlPoint
11 # - dozen of unpackaged files
12 #
13 # Specfile for MythTV
14 #
15 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
16 #  building an rpm by hand on the machine it will be used on, I encourage you
17 #  to use "--with cpu_autodetect" to let mythtv decide for you.
18 #
19 # Conditional build:
20 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
21 %bcond_without  lirc            # lirc support
22 %bcond_without  alsa            # alsa support
23 %bcond_without  oss             # oss support
24 %bcond_without  jack            # jack audio connection kit
25 %bcond_without  pulseaudio      # pulseaudio support
26 %bcond_without  opengl          # opengl vsync
27 %bcond_without  dvb             # DVB support
28 %bcond_without  xrandr          # disable X11 resolution switching
29 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
30 %bcond_without  iptv
31 %bcond_without  firewire        # ieee1394 (NFY)
32 %bcond_without  xvmc            # do not use XvMCW
33 %bcond_without  vdpau           # disable nvidia vdpau support
34 %bcond_without  fftw3           # disable fftw3 support
35 %bcond_with     mmx             # enable MMX
36 %bcond_without  nellymoserdec
37 %bcond_with     vaapi           # enable vaapi
38 %bcond_with     dshowserver     # enable directshow codecs server
39 %bcond_with     directfb
40 %bcond_with     perl
41 %bcond_with     python
42 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers 
43                                 # instead of libvdpau
44
45 # enable mmx automatically on arches having it
46 %ifarch %{ix86} %{x8664}
47 %ifnarch i386 i486 i586 i686
48 %define with_mmx 1
49 %endif
50 %endif
51
52 # dshowserver is exclusive arch for x86 x86_64 only
53 %ifnarch %{ix86} %{x8664}
54 %undefine with_dshowserver
55 %endif
56
57 %include        /usr/lib/rpm/macros.perl
58 Summary:        A personal video recorder (PVR) application
59 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
60 Name:           mythtv
61 Version:        0.24.1
62 Release:        0.2
63 License:        GPL v2
64 Group:          Applications/Multimedia
65 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
66 # Source0-md5:  6870c679619ec58456e76839745411d8
67 Source1:        mythbackend.sysconfig
68 Source2:        mythbackend.init
69 Source3:        mythbackend.logrotate
70 Source5:        pld-mythfrontend.desktop
71 # Source5-md5:  f37a903ac97463683bebacdf29406951
72 Source6:        pld-mythfrontend.png
73 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
74 Source20:       dshowcodecs
75 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
76 Patch0:         %{name}-configure.patch
77 Patch10:        %{name}-sbinpath.patch
78 Patch20:        %{name}-compile_fixes_for_qt_4_7.patch
79 Patch30:        %{name}-dshowserver-0.22.patch
80 URL:            http://www.mythtv.org/
81 BuildRequires:  Mesa-libGLU-devel
82 BuildRequires:  OpenGL-devel
83 BuildRequires:  Qt3Support-devel
84 BuildRequires:  QtCore-devel
85 BuildRequires:  QtGui-devel
86 BuildRequires:  QtNetwork-devel
87 BuildRequires:  QtOpenGL-devel
88 BuildRequires:  QtScript-devel
89 BuildRequires:  QtSql-devel
90 BuildRequires:  QtWebKit-devel
91 BuildRequires:  QtXml-devel
92 %{?with_alsa:BuildRequires:     alsa-lib-devel}
93 BuildRequires:  ffmpeg-devel
94 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
95 BuildRequires:  freetype-devel >= 1:2.0.0
96 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
97 BuildRequires:  lame-libs-devel
98 %{?with_firewire:BuildRequires: libavc1394-devel}
99 BuildRequires:  libdts-devel
100 %{?with_dvb:BuildRequires:      libdvb-devel}
101 BuildRequires:  libdvdnav-devel
102 %{?with_firewire:BuildRequires: libiec61883-devel}
103 %{?with_firewire:BuildRequires: libraw1394-devel}
104 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
105 BuildRequires:  linux-libc-headers >= 7:2.6.10
106 %{?with_lirc:BuildRequires:     lirc-devel}
107 BuildRequires:  mysql-devel
108 BuildRequires:  perl-devel
109 BuildRequires:  perl-tools-pod
110 BuildRequires:  pkgconfig
111 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
112 BuildRequires:  python-devel
113 BuildRequires:  qt4-build
114 BuildRequires:  qt4-qmake
115 BuildRequires:  rpm-perlprov >= 4.1-13
116 BuildRequires:  rpm-pythonprov
117 BuildRequires:  rpmbuild(macros) >= 1.228
118 BuildRequires:  sed >= 4.0
119 BuildRequires:  which
120 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
121 BuildRequires:  xorg-lib-libXext-devel
122 %{?with_xvmc:BuildRequires:     xorg-lib-libXvMC-devel}
123 BuildRequires:  xorg-lib-libXxf86vm-devel
124 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
125 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
126 # for Perl bindings
127 BuildRequires:  perl-ExtUtils-MakeMaker
128 ExclusiveArch:  %{ix86} %{x8664} ppc
129 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
130
131 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
132
133 # libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
134 # libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
135 %define         skip_post_check_so      libmythavdevice.so libmythavcodec.so
136 %define         no_install_post_check_so 1
137
138 %description
139 MythTV implements the following PVR features, and more, with a unified
140 graphical interface:
141 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
142 - Video compression using RTjpeg or MPEG-4
143 - Program listing retrieval using XMLTV
144 - Themable, semi-transparent on-screen display
145 - Electronic program guide
146 - Scheduled recording of TV programs
147 - Resolution of conflicts between scheduled recordings
148 - Basic video editing
149
150 %description -l pl.UTF-8
151 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
152 ujednoliconym interfejsem graficznym:
153 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
154   przewijanie "żywej" telewizji
155 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
156 - odczyt listy programów przy użyciu XMLTV
157 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
158 - elektroniczny przewodnik po programie
159 - planowane nagrywanie programów telewizyjnych
160 - rozwiązywanie konfliktów między planowanymi nagraniami
161 - podstawowa edycja obrazu
162
163 %package backend
164 Summary:        Server component of mythtv (a PVR)
165 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
166 Group:          Applications/Multimedia
167 Requires(post,preun):   /sbin/chkconfig
168 Requires(postun):       /usr/sbin/groupdel
169 Requires(postun):       /usr/sbin/userdel
170 Requires(pre):  /bin/id
171 Requires(pre):  /usr/bin/getgid
172 Requires(pre):  /usr/sbin/groupadd
173 Requires(pre):  /usr/sbin/useradd
174 Requires:       libmyth = %{version}-%{release}
175 Requires:       mythtv = %{version}-%{release}
176 Suggests:       mysql
177 Provides:       group(mythtv)
178 Provides:       user(mythtv)
179
180 %description backend
181 MythTV provides a unified graphical interface for recording and
182 viewing television programs. Refer to the mythtv package for more
183 information.
184
185 This package contains only the server software, which provides video
186 and audio capture and encoding services. In order to be useful, it
187 requires a mythtv-frontend installation, either on the same system or
188 one reachable via the network.
189
190 %description backend -l pl.UTF-8
191 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
192 oglądania programów telewizyjnych. Więcej informacji w pakiecie
193 mythtv.
194
195 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
196 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
197 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
198 albo innym osiągalnym w sieci.
199
200 %package frontend
201 Summary:        Client component of mythtv (a PVR)
202 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
203 Group:          Applications/Multimedia
204 Requires:       libmyth = %{version}-%{release}
205 Requires:       mythtv = %{version}-%{release}
206 Requires:       mythtv-themes = %{version}-%{release}
207 Provides:       mythtv-frontend-api = %{myth_api_version}
208
209 %description frontend
210 MythTV provides a unified graphical interface for recording and
211 viewing television programs. Refer to the mythtv package for more
212 information.
213
214 This package contains only the client software, which provides a
215 front-end for playback and configuration. It requires access to a
216 mythtv-backend installation, either on the same system or one
217 reachable via the network.
218
219 %description frontend -l pl.UTF-8
220 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
221 oglądania programów telewizyjnych. Więcej informacji w pakiecie
222 mythtv.
223
224 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
225 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
226 mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
227
228 %package setup
229 Summary:        Setup the mythtv backend
230 Summary(pl.UTF-8):      Konfigurator backendu mythtv
231 Group:          Applications/Multimedia
232 Requires:       libmyth = %{version}-%{release}
233
234 %description setup
235 MythTV provides a unified graphical interface for recording and
236 viewing television programs. Refer to the mythtv package for more
237 information.
238
239 This package contains only the setup software for configuring the
240 mythtv backend.
241
242 %description setup -l pl.UTF-8
243 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
244 oglądania programów telewizyjnych. Więcej informacji w pakiecie
245 mythtv.
246
247 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
248
249 %package themes
250 Summary:        Base themes for mythtv's frontend
251 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
252 Group:          Themes
253 Requires:       %{name}-frontend = %{version}-%{release}
254
255 %description themes
256 MythTV provides a unified graphical interface for recording and
257 viewing television programs. Refer to the mythtv package for more
258 information.
259
260 This package contains only the base themes used by the frontend and
261 mythtvsetup.
262
263 %description themes -l pl.UTF-8
264 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
265 oglądania programów telewizyjnych. Więcej informacji w pakiecie
266 mythtv.
267
268 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
269 mythtvsetup.
270
271 %package -n libmyth
272 Summary:        Library providing mythtv support
273 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
274 Group:          Libraries
275 Requires:       QtSql-mysql
276 Requires:       freetype >= 1:2.0.0
277 Requires:       lame
278
279 %description -n libmyth
280 Common library code for MythTV and add-on modules (development) MythTV
281 provides a unified graphical interface for recording and viewing
282 television programs. Refer to the mythtv package for more information.
283
284 %description -n libmyth -l pl.UTF-8
285 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
286 dostarczający ujednolicony interfejs graficzny do nagrywania i
287 oglądania programów telewizyjnych. Więcej informacji w pakiecie
288 mythtv.
289
290 %package -n libmyth-devel
291 Summary:        Development files for libmyth
292 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
293 Group:          Development/Libraries
294 Requires:       libmyth = %{version}-%{release}
295
296 %description -n libmyth-devel
297 This package contains the header files for developing add-ons for
298 mythtv.
299
300 %description -n libmyth-devel -l pl.UTF-8
301 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
302
303 %package -n libmyth-static
304 Summary:        Static libmyth library
305 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
306 Group:          Development/Libraries
307 Requires:       libmyth-devel = %{version}-%{release}
308
309 %description -n libmyth-static
310 Static libmyth library.
311
312 %description -n libmyth-static -l pl.UTF-8
313 Statyczna biblioteka libmyth.
314
315 %package -n perl-MythTV
316 Summary:        MythTV Perl bindings
317 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
318 Group:          Libraries
319
320 %description -n perl-MythTV
321 MythTV Perl bindings.
322
323 %description -n perl-MythTV -l pl.UTF-8
324 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
325
326 %package -n python-MythTV
327 Summary:        MythTV Python bindings
328 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
329 Group:          Libraries
330 Requires:       python-MySQLdb
331
332 %description -n python-MythTV
333 MythTV Python bindings.
334
335 %description -n python-MythTV -l pl.UTF-8
336 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
337
338 %prep
339
340 %setup -q
341
342 %{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
343         programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
344
345 %patch0  -p1
346 %patch10 -p1
347 %{?with_dshowserver:%patch20 -p1}
348 #%patch30 -p1
349
350 rm -rf database/old # not supported in PLD
351
352 # lib64 fix - enable to update patch
353 %if %{_lib} != "lib" && 0
354 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
355 xargs grep -l /lib . | xargs sed -i -e '
356         s,/''usr/lib/,/%{_libdir}/,g
357         s,/''lib/mythtv,/%{_lib}/mythtv,g
358         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
359 '
360 exit 1
361 %endif
362
363 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
364 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
365 # prevent compiler finding libs from system when they should be looked
366 # from current buildtree.
367 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
368 # so we make QMAKE wrapper which will do sed subst after calling
369 # qmake. this is the wrapper.
370 cat > qmake-wrapper.sh <<'EOF'
371 #!/bin/sh
372 getmakefile() {
373         while [ $# -gt 0 ]; do
374                 case "$1" in
375                 -o)
376                         shift
377                         makefile="$1"
378                         return
379                         ;;
380         esac
381                 shift
382         done
383 }
384
385 qmake-qt4 "$@"
386 getmakefile "$@"
387 if [ "$makefile" ]; then
388         %{__sed} -i -e '
389                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
390                 s;-L$(QTDIR)/%{_lib};;
391         ' $makefile
392 fi
393 EOF
394 chmod +x qmake-wrapper.sh
395
396 # move perl bindings to vendor prefix
397 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
398   bindings/perl/Makefile
399
400 %build
401
402 %if %{with cpu_autodetect}
403 # Make sure we have /proc mounted
404 if [ ! -r /proc/cpuinfo ]; then
405         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
406         exit 1
407 fi
408 %endif
409
410 ./configure \
411         --prefix=%{_prefix} \
412         --libdir=%{_libdir} \
413         --libdir-name=%{_lib} \
414         --mandir=%{_mandir} \
415         --disable-distcc --disable-ccache \
416         --compile-type=%{?debug:debug}%{!?debug:release} \
417         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
418         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
419 %if %{with cpu_autodetect}
420         --enable-proc-opt \
421 %else
422         %ifarch %{ix86}
423                 %ifarch athlon
424                         --arch=athlon \
425                 %else
426                         --cpu=%{_target_cpu} --tune=pentium4 \
427                 %endif
428         %endif
429         %ifarch i386 i486 i586
430         --enable-disable-mmx-for-debugging \
431         %endif
432         %ifarch %{x8664}
433         --arch=x86_64 \
434         %endif
435         %{?with_mmx:--enable-mmx} \
436 %endif
437         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
438         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
439         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
440         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
441         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-vsync \
442         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
443         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
444         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
445         --%{?with_xvmc:en}%{!?with_xvmc:dis}able-xvmc \
446         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
447         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
448         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
449         --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
450         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
451         --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb \
452         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
453         --enable-xv \
454         --enable-x11 \
455
456 #%{_libdir}/qt4/bin/qmake mythtv.pro
457 %{__make}
458
459 %install
460 rm -rf $RPM_BUILD_ROOT
461 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
462                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
463                 $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
464                 $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
465                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
466                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
467                 $RPM_BUILD_ROOT%{_pixmapsdir}
468
469 %{__make} install \
470         INSTALL_ROOT=$RPM_BUILD_ROOT
471
472 # Install the files that we added on top of mythtv's own stuff
473 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
474 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
475 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
476 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
477
478 # desktop entries
479 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
480 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
481
482 # Install settings.pro so people can see the build options we used
483 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
484 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
485
486 for p in mythfrontend; do
487         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
488                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
489         done > $p.lang
490 done
491
492 # glibc language codes. attempt was made to change it on libmyth side,
493 # but that was just asking for trouble due large coverage of
494 # language.lower() usage.
495 sed -i -e '
496 s,%%lang(en_gb),%%lang(en_GB),
497 s,%%lang(zh_tw),%%lang(zh_TW),
498 s,%%lang(pt_br),%%lang(pt_BR),
499 ' *.lang
500
501 rm -rf mythtvosd mythwelcome mythlcdserver
502 install -d mythtvosd mythwelcome
503 cp -a programs/mythtvosd/{README,*.xml} mythtvosd
504 cp -a programs/mythwelcome/README mythwelcome
505 cp -a programs/mythlcdserver/README mythlcdserver
506
507 %clean
508 rm -rf $RPM_BUILD_ROOT
509
510 %pre backend
511 %groupadd -g 149 %{name}
512 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
513 %addusertogroup %{name} video
514 %addusertogroup %{name} audio
515
516 %post backend
517 /sbin/chkconfig --add mythbackend
518
519 %preun backend
520 if [ "$1" = "0" ]; then
521         %service -q mythbackend stop
522         /sbin/chkconfig --del mythbackend
523 fi
524
525 %postun backend
526 if [ "$1" = "0" ]; then
527         %userremove %{name}
528         %groupremove %{name}
529 fi
530
531 %post   -n libmyth -p /sbin/ldconfig
532 %postun -n libmyth -p /sbin/ldconfig
533
534 %post setup
535 if [ "$1" = 1 ]; then
536 %banner -e %{name}-setup <<EOF
537 To grant mysql permissions to mythtv, please run
538 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
539 EOF
540 fi
541
542 %files
543 %defattr(644,root,root,755)
544 %doc README* UPGRADING AUTHORS FAQ
545 %doc docs contrib config
546 %doc keys.txt mythtvosd mythwelcome mythlcdserver
547
548 %files backend
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_sbindir}/mythbackend
551 %attr(755,root,root) %{_sbindir}/mythcommflag
552 %attr(755,root,root) %{_bindir}/mythfilldatabase
553 %attr(755,root,root) %{_sbindir}/mythjobqueue
554 %attr(755,root,root) %{_sbindir}/mythlcdserver
555 %attr(755,root,root) %{_bindir}/mythtranscode
556 %attr(755,root,root) %{_bindir}/mythreplex
557 %attr(775,root,mythtv) %dir /var/lib/mythtv
558 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
559 %attr(775,root,mythtv) %dir /var/cache/mythtv
560 %attr(775,root,mythtv) %dir /var/run/mythtv
561 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
564 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
565
566 %files frontend -f mythfrontend.lang
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_bindir}/mythfrontend
569 %attr(755,root,root) %{_bindir}/mythshutdown
570 %attr(755,root,root) %{_bindir}/mythavtest
571 %attr(755,root,root) %{_bindir}/mythtvosd
572 %attr(755,root,root) %{_bindir}/mythwelcome
573 %dir %{_datadir}/mythtv
574 %dir %{_datadir}/mythtv/themes
575 %dir %{_libdir}/mythtv
576 %{_datadir}/mythtv/*.xml
577 %dir %{_libdir}/mythtv/filters
578 %dir %{_libdir}/mythtv/plugins
579 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
580 %{_datadir}/mythtv/fonts/*.ttf
581 %dir %{_datadir}/mythtv/i18n
582 %if %{with dshowserver}
583 %{_datadir}/mythtv/dshowcodecs
584 %endif
585 %{_desktopdir}/*.desktop
586 %{_pixmapsdir}/*.png
587
588 %files setup
589 %defattr(644,root,root,755)
590 %doc database
591 %attr(755,root,root) %{_bindir}/mythtv-setup
592
593 %files themes
594 %defattr(644,root,root,755)
595 %{_datadir}/mythtv/themes/*
596
597 %files -n libmyth
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_libdir}/lib*.so*
600 %attr(755,root,root) %{_libdir}/lib*.a
601 %{_datadir}/mythtv/*.pl
602
603 %files -n libmyth-devel
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/*.so
606 %{_includedir}/*
607 %{_datadir}/mythtv/build
608
609 %files -n libmyth-static
610 %defattr(644,root,root,755)
611
612 %if %{with perl}
613 %files -n perl-MythTV
614 %defattr(644,root,root,755)
615 %{perl_vendorlib}/MythTV.pm
616 %dir %{perl_vendorlib}/MythTV
617 %{perl_vendorlib}/MythTV/*.pm
618 %dir %{perl_vendorlib}/IO/Socket/INET
619 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
620 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
621 %endif
622
623 %if %{with python}
624 %files -n python-MythTV
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/mythpython
627 %dir %{py_sitescriptdir}/MythTV
628 %{py_sitescriptdir}/MythTV/*
629 %{py_sitescriptdir}/*.egg-info
630 %endif
This page took 0.104796 seconds and 3 git commands to generate.