]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- updated to build snv fixes for stable mythtv-0.22
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 #
7 # Specfile for MythTV
8 #
9 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
10 #  building an rpm by hand on the machine it will be used on, I encourage you
11 #  to use "--with cpu_autodetect" to let mythtv decide for you.
12 #
13 # Conditional build:
14 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
15 %bcond_without  lirc            # lirc support
16 %bcond_without  alsa            # alsa support
17 %bcond_without  oss             # oss support
18 %bcond_with     arts            # arts support
19 %bcond_without  jack            # jack audio connection kit
20 %bcond_without  pulseaudio      # pulseaudio support
21 %bcond_without  opengl          # opengl vsync
22 %bcond_without  dvb             # DVB support
23 %bcond_without  xrandr          # disable X11 resolution switching
24 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
25 %bcond_without  iptv
26 %bcond_without  firewire        # ieee1394 (NFY)
27 %bcond_without  xvmc            # do not use XvMCW
28 %bcond_without  vdpau           # disable nvidia vdpau support
29 %bcond_without  fftw3           # disable fftw3 support
30 %bcond_with     mmx             # enable MMX
31 %bcond_with     dshowserver     # enable directshow codecs server
32 %bcond_with     directfb
33 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers 
34                                 # instead of libvdpau   
35
36 # enable mmx automatically on arches having it
37 %ifarch %{ix86} %{x8664}
38 %ifnarch i386 i486 i586 i686
39 %define with_mmx 1
40 %endif
41 %endif
42
43 # dshowserver is exclusive arch for x86 x86_64 only
44 %ifnarch %{ix86} %{x8664}
45 %undefine with_dshowserver
46 %endif
47
48 %define fix 23095
49 Summary:        A personal video recorder (PVR) application
50 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
51 Name:           mythtv
52 Version:        0.22
53 Release:        fix%{fix}.1
54 License:        GPL v2
55 Group:          Applications/Multimedia
56 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}_%{fix}.tar.bz2
57 # Source0-md5:  3801e410792828c1a79a67744cb93ba9
58 Source1:        mythbackend.sysconfig
59 Source2:        mythbackend.init
60 Source3:        mythbackend.logrotate
61 Source5:        pld-mythfrontend.desktop
62 # Source5-md5:  f37a903ac97463683bebacdf29406951
63 Source6:        pld-mythfrontend.png
64 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
65 Source20:       dshowcodecs
66 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
67 #Patch100: %{name}-branch.diff
68 Patch0:         %{name}-configure.patch
69 #Patch1: %{name}-mythstream.patch
70 #Patch2: %{name}-pl.patch
71 Patch3:         %{name}-sbinpath.patch
72 #Patch4: %{name}-dvdnav-shared.patch
73 Patch20:        %{name}-dshowserver-0.22.patch
74 URL:            http://www.mythtv.org/
75 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
76 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
77 BuildRequires:  Mesa-libGLU-devel
78 #BuildRequires: OpenGL-GLU-devel
79 BuildRequires:  OpenGL-devel
80 BuildRequires:  Qt3Support-devel
81 BuildRequires:  QtCore-devel
82 BuildRequires:  QtGui-devel
83 BuildRequires:  QtNetwork-devel
84 BuildRequires:  QtOpenGL-devel
85 BuildRequires:  QtScript-devel
86 BuildRequires:  QtSql-devel
87 BuildRequires:  QtWebKit-devel
88 BuildRequires:  QtXml-devel
89 %{?with_alsa:BuildRequires:     alsa-lib-devel}
90 %{?with_arts:BuildRequires:     arts-devel >= 13:0.9.5}
91 BuildRequires:  ffmpeg-devel
92 BuildRequires:  freetype-devel >= 1:2.0.0
93 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
94 BuildRequires:  lame-libs-devel
95 %{?with_firewire:BuildRequires: libavc1394-devel}
96 BuildRequires:  libdts-devel
97 %{?with_dvb:BuildRequires:      libdvb-devel}
98 BuildRequires:  libdvdnav-devel
99 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
100 %{?with_firewire:BuildRequires: libiec61883-devel}
101 %{?with_firewire:BuildRequires: libraw1394-devel}
102 BuildRequires:  linux-libc-headers >= 7:2.6.10
103 %{?with_lirc:BuildRequires:     lirc-devel}
104 BuildRequires:  mysql-devel
105 #BuildRequires: patchutils
106 BuildRequires:  perl-devel
107 BuildRequires:  perl-tools-pod
108 BuildRequires:  pkgconfig
109 BuildRequires:  python-devel
110 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
111 %{?without_pulseaudio:BuildConflicts: pulseaudio-devel}
112 BuildRequires:  qt4-build
113 BuildRequires:  qt4-qmake
114 BuildRequires:  rpm-pythonprov
115 BuildRequires:  rpmbuild(macros) >= 1.228
116 BuildRequires:  sed >= 4.0
117 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
118 BuildRequires:  xorg-lib-libXext-devel
119 %{?with_xvmc:BuildRequires:     xorg-lib-libXvMC-devel}
120 BuildRequires:  xorg-lib-libXxf86vm-devel
121 # for Perl bindings
122 BuildRequires:  perl-ExtUtils-MakeMaker
123 ExclusiveArch:  %{ix86} %{x8664} ppc
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
127
128 %description
129 MythTV implements the following PVR features, and more, with a unified
130 graphical interface:
131 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
132 - Video compression using RTjpeg or MPEG-4
133 - Program listing retrieval using XMLTV
134 - Themable, semi-transparent on-screen display
135 - Electronic program guide
136 - Scheduled recording of TV programs
137 - Resolution of conflicts between scheduled recordings
138 - Basic video editing
139
140 %description -l pl.UTF-8
141 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
142 ujednoliconym interfejsem graficznym:
143 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
144   przewijanie "żywej" telewizji
145 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
146 - odczyt listy programów przy użyciu XMLTV
147 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
148 - elektroniczny przewodnik po programie
149 - planowane nagrywanie programów telewizyjnych
150 - rozwiązywanie konfliktów między planowanymi nagraniami
151 - podstawowa edycja obrazu
152
153 %package backend
154 Summary:        Server component of mythtv (a PVR)
155 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
156 Group:          Applications/Multimedia
157 Requires(post,preun):   /sbin/chkconfig
158 Requires(postun):       /usr/sbin/groupdel
159 Requires(postun):       /usr/sbin/userdel
160 Requires(pre):  /bin/id
161 Requires(pre):  /usr/bin/getgid
162 Requires(pre):  /usr/sbin/groupadd
163 Requires(pre):  /usr/sbin/useradd
164 Requires:       libmyth = %{version}-%{release}
165 Requires:       mythtv = %{version}-%{release}
166 Suggests:       mysql
167 Provides:       group(mythtv)
168 Provides:       user(mythtv)
169
170 %description backend
171 MythTV provides a unified graphical interface for recording and
172 viewing television programs. Refer to the mythtv package for more
173 information.
174
175 This package contains only the server software, which provides video
176 and audio capture and encoding services. In order to be useful, it
177 requires a mythtv-frontend installation, either on the same system or
178 one reachable via the network.
179
180 %description backend -l pl.UTF-8
181 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
182 oglądania programów telewizyjnych. Więcej informacji w pakiecie
183 mythtv.
184
185 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
186 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
187 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
188 albo innym osiągalnym w sieci.
189
190 %package frontend
191 Summary:        Client component of mythtv (a PVR)
192 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
193 Group:          Applications/Multimedia
194 Requires:       libmyth = %{version}-%{release}
195 Requires:       mythtv = %{version}-%{release}
196 Requires:       mythtv-themes = %{version}-%{release}
197 Provides:       mythtv-frontend-api = %{myth_api_version}
198
199 %description frontend
200 MythTV provides a unified graphical interface for recording and
201 viewing television programs. Refer to the mythtv package for more
202 information.
203
204 This package contains only the client software, which provides a
205 front-end for playback and configuration. It requires access to a
206 mythtv-backend installation, either on the same system or one
207 reachable via the network.
208
209 %description frontend -l pl.UTF-8
210 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
211 oglądania programów telewizyjnych. Więcej informacji w pakiecie
212 mythtv.
213
214 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
215 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
216 mythtv-backend - na tym samym systemie, albo innym osiągalnym w
217 sieci.
218
219 %package setup
220 Summary:        Setup the mythtv backend
221 Summary(pl.UTF-8):      Konfigurator backendu mythtv
222 Group:          Applications/Multimedia
223 Requires:       libmyth = %{version}-%{release}
224
225 %description setup
226 MythTV provides a unified graphical interface for recording and
227 viewing television programs. Refer to the mythtv package for more
228 information.
229
230 This package contains only the setup software for configuring the
231 mythtv backend.
232
233 %description setup -l pl.UTF-8
234 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
235 oglądania programów telewizyjnych. Więcej informacji w pakiecie
236 mythtv.
237
238 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
239
240 %package themes
241 Summary:        Base themes for mythtv's frontend
242 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
243 Group:          Themes
244 Requires:       %{name}-frontend = %{version}-%{release}
245
246 %description themes
247 MythTV provides a unified graphical interface for recording and
248 viewing television programs. Refer to the mythtv package for more
249 information.
250
251 This package contains only the base themes used by the frontend and
252 mythtvsetup.
253
254 %description themes -l pl.UTF-8
255 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
256 oglądania programów telewizyjnych. Więcej informacji w pakiecie
257 mythtv.
258
259 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
260 mythtvsetup.
261
262 %package -n libmyth
263 Summary:        Library providing mythtv support
264 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
265 Group:          Libraries
266 Requires:       QtSql-mysql
267 Requires:       freetype >= 1:2.0.0
268 Requires:       lame
269
270 %description -n libmyth
271 Common library code for MythTV and add-on modules (development) MythTV
272 provides a unified graphical interface for recording and viewing
273 television programs. Refer to the mythtv package for more information.
274
275 %description -n libmyth -l pl.UTF-8
276 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
277 dostarczający ujednolicony interfejs graficzny do nagrywania i
278 oglądania programów telewizyjnych. Więcej informacji w pakiecie
279 mythtv.
280
281 %package -n libmyth-devel
282 Summary:        Development files for libmyth
283 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
284 Group:          Development/Libraries
285 Requires:       libmyth = %{version}-%{release}
286
287 %description -n libmyth-devel
288 This package contains the header files for developing add-ons for
289 mythtv.
290
291 %description -n libmyth-devel -l pl.UTF-8
292 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
293
294 %package -n libmyth-static
295 Summary:        Static libmyth library
296 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
297 Group:          Development/Libraries
298 Requires:       libmyth-devel = %{version}-%{release}
299
300 %description -n libmyth-static
301 Static libmyth library.
302
303 %description -n libmyth-static -l pl.UTF-8
304 Statyczna biblioteka libmyth.
305
306 %package -n perl-MythTV
307 Summary:        MythTV Perl bindings
308 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
309 Group:          Libraries
310
311 %description -n perl-MythTV
312 MythTV Perl bindings.
313
314 %description -n perl-MythTV -l pl.UTF-8
315 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
316
317 %package -n python-MythTV
318 Summary:        MythTV Python bindings
319 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
320 Group:          Libraries
321 Requires:       python-MySQLdb
322
323 %description -n python-MythTV
324 MythTV Python bindings.
325
326 %description -n python-MythTV -l pl.UTF-8
327 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
328
329 %prep
330
331 %setup -q -n %{name}-%{version}_%{fix}
332
333
334 %patch0 -p1
335 #%patch1 -p1
336 #%patch2 -p1
337 %patch3 -p1
338 #%patch4 -p1
339
340 %{?with_dshowserver:%patch20 -p0}
341 rm -rf database/old # not supported in PLD
342
343 # lib64 fix - enable to update patch
344 %if %{_lib} != "lib" && 0
345 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
346 xargs grep -l /lib . | xargs sed -i -e '
347         s,/''usr/lib/,/%{_libdir}/,g
348         s,/''lib/mythtv,/%{_lib}/mythtv,g
349         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
350 '
351 exit 1
352 %endif
353
354 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
355 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
356 # prevent compiler finding libs from system when they should be looked
357 # from current buildtree.
358 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
359 # so we make QMAKE wrapper which will do sed subst after calling
360 # qmake. this is the wrapper.
361 cat > qmake-wrapper.sh <<'EOF'
362 #!/bin/sh
363 getmakefile() {
364         while [ $# -gt 0 ]; do
365                 case "$1" in
366                 -o)
367                         shift
368                         makefile="$1"
369                         return
370                         ;;
371         esac
372                 shift
373         done
374 }
375
376 qmake-qt4 "$@"
377 getmakefile "$@"
378 if [ "$makefile" ]; then
379         %{__sed} -i -e '
380                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
381                 s;-L$(QTDIR)/%{_lib};;
382         ' $makefile
383 fi
384 EOF
385 chmod +x qmake-wrapper.sh
386
387 # move perl bindings to vendor prefix
388 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
389    bindings/perl/perl.pro
390
391 %build
392
393 %if %{with cpu_autodetect}
394 # Make sure we have /proc mounted
395 if [ ! -r /proc/cpuinfo ]; then
396         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
397         exit 1
398 fi
399 %endif
400
401 ./configure \
402         --prefix=%{_prefix} \
403         --libdir=%{_libdir} \
404         --libdir-name=%{_lib} \
405         --mandir=%{_mandir} \
406         --disable-distcc --disable-ccache \
407         --compile-type=%{?debug:debug}%{!?debug:release} \
408         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
409         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
410 %if %{with cpu_autodetect}
411         --enable-proc-opt \
412 %else
413         %ifarch %{ix86}
414                 %ifarch athlon
415                         --arch=athlon \
416                 %else
417                         --cpu=i386 --tune=pentium4 \
418                 %endif
419         %endif
420         %ifarch %{x8664}
421         --arch=x86_64 \
422         %endif
423         %{?with_mmx:--enable-mmx} \
424 %endif
425         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
426         --%{?with_arts:en}%{!?with_arts:dis}able-audio-arts \
427         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
428         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
429         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
430         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-vsync \
431         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
432         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
433         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
434         --%{?with_xvmc:en}%{!?with_xvmc:dis}able-xvmc \
435         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
436         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
437         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
438         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
439         --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb \
440         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
441         --enable-xv \
442         --enable-x11 \
443
444 %{_libdir}/qt4/bin/qmake mythtv.pro
445 %{__make}
446
447 %install
448 rm -rf $RPM_BUILD_ROOT
449 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
450                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
451                 $RPM_BUILD_ROOT/var/{cache,lib,log,run}/mythtv \
452                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
453                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
454                 $RPM_BUILD_ROOT%{_pixmapsdir}
455
456 %{__make} install \
457         INSTALL_ROOT=$RPM_BUILD_ROOT
458
459 # required to build some plugins
460 #       install libs/libavcodec/*.h $RPM_BUILD_ROOT%{_includedir}/mythtv \
461 #               libs/libavformat/*.h $RPM_BUILD_ROOT%{_includedir}/mythtv \
462 #               libs/libavutil/*.h $RPM_BUILD_ROOT%{_includedir}/mythtv
463
464 # Install the files that we added on top of mythtv's own stuff
465 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
466 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
467 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
468 %{?with_dshowserver:install %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
469
470 # desktop entries
471 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
472 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
473
474 # Install settings.pro so people can see the build options we used
475 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
476 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
477
478 for p in mythfrontend; do
479         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
480                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
481         done > $p.lang
482 done
483
484 # glibc language codes. attempt was made to change it on libmyth side,
485 # but that was just asking for trouble due large coverage of
486 # language.lower() usage.
487 sed -i -e '
488 s,%%lang(en_gb),%%lang(en_GB),
489 s,%%lang(zh_tw),%%lang(zh_TW),
490 s,%%lang(pt_br),%%lang(pt_BR),
491 ' *.lang
492
493 rm -rf mythtvosd mythwelcome mythlcdserver
494 install -d mythtvosd mythwelcome
495 cp -a programs/mythtvosd/{README,*.xml} mythtvosd
496 cp -a programs/mythwelcome/README mythwelcome
497 cp -a programs/mythlcdserver/README mythlcdserver
498
499 %clean
500 rm -rf $RPM_BUILD_ROOT
501
502 # Empty newline after %addusertogroup %{name} video below is intended.
503 # Do not remove it until rpm stop joining lines with that macro.
504 %pre backend
505 %groupadd -g 149 %{name}
506 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
507 %addusertogroup %{name} video
508 %addusertogroup %{name} audio
509
510 %post backend
511 /sbin/chkconfig --add mythbackend
512
513 %preun backend
514 if [ "$1" = "0" ]; then
515         %service -q mythbackend stop
516         /sbin/chkconfig --del mythbackend
517 fi
518
519 %postun backend
520 if [ "$1" = "0" ]; then
521         %userremove %{name}
522         %groupremove %{name}
523 fi
524
525 %post   -n libmyth -p /sbin/ldconfig
526 %postun -n libmyth -p /sbin/ldconfig
527
528 %post setup
529 if [ "$1" = 1 ]; then
530 %banner -e %{name}-setup <<EOF
531 To grant mysql permissions to mythtv, please run
532 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
533 EOF
534 fi
535
536 %files
537 %defattr(644,root,root,755)
538 %doc README* UPGRADING AUTHORS FAQ
539 %doc docs contrib config
540 %doc keys.txt mythtvosd mythwelcome mythlcdserver
541
542 %files backend
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_sbindir}/mythbackend
545 %attr(755,root,root) %{_sbindir}/mythcommflag
546 %attr(755,root,root) %{_bindir}/mythfilldatabase
547 %attr(755,root,root) %{_sbindir}/mythjobqueue
548 %attr(755,root,root) %{_sbindir}/mythlcdserver
549 %attr(755,root,root) %{_bindir}/mythtranscode
550 %attr(755,root,root) %{_bindir}/mythreplex
551 %attr(775,root,mythtv) %dir /var/lib/mythtv
552 %attr(775,root,mythtv) %dir /var/cache/mythtv
553 %attr(775,root,mythtv) %dir /var/run/mythtv
554 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
557 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
558
559 %files frontend -f mythfrontend.lang
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_bindir}/mythfrontend
562 %attr(755,root,root) %{_bindir}/mythshutdown
563 %attr(755,root,root) %{_bindir}/mythavtest
564 %attr(755,root,root) %{_bindir}/mythtvosd
565 %attr(755,root,root) %{_bindir}/mythwelcome
566 %dir %{_datadir}/mythtv
567 %dir %{_datadir}/mythtv/themes
568 %dir %{_libdir}/mythtv
569 %{_datadir}/mythtv/*.xml
570 %dir %{_libdir}/mythtv/filters
571 %dir %{_libdir}/mythtv/plugins
572 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
573 %{_datadir}/mythtv/*.ttf
574 %dir %{_datadir}/mythtv/i18n
575 %if %{with dshowserver}
576 %{_datadir}/mythtv/dshowcodecs
577 %endif
578 %{_desktopdir}/*.desktop
579 %{_pixmapsdir}/*.png
580
581 %files setup
582 %defattr(644,root,root,755)
583 %doc database
584 %attr(755,root,root) %{_bindir}/mythtv-setup
585
586 %files themes
587 %defattr(644,root,root,755)
588 %{_datadir}/mythtv/themes/*
589
590 %files -n libmyth
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/lib*.so*
593 %attr(755,root,root) %{_libdir}/lib*.a
594 %{_datadir}/mythtv/*.pl
595
596 %files -n libmyth-devel
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/*.so
599 %{_includedir}/*
600 %{_datadir}/mythtv/build
601
602 %files -n libmyth-static
603 %defattr(644,root,root,755)
604
605 %files -n perl-MythTV
606 %defattr(644,root,root,755)
607 %{perl_vendorlib}/MythTV.pm
608 %dir %{perl_vendorlib}/MythTV
609 %{perl_vendorlib}/MythTV/*.pm
610 %dir %{perl_vendorlib}/IO/Socket/INET
611 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
612 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
613
614 %files -n python-MythTV
615 %defattr(644,root,root,755)
616 %dir %{py_sitescriptdir}/MythTV
617 # XXX: package .py[co] only
618 %{py_sitescriptdir}/MythTV/*
619 %{py_sitescriptdir}/*.egg-info
This page took 0.103643 seconds and 3 git commands to generate.