]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- updatd files
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 # - vaapi support - check for compatible versions of libva?
7 # - bindings:
8 #   WARNING: disabling Python bindings; missing MySQLdb
9 #   WARNING: disabling Perl bindings; missing Net::UPnP::QueryResponse
10 #   WARNING: disabling Perl bindings; missing Net::UPnP::ControlPoint
11 # - dozen of unpackaged files
12 #
13 # Specfile for MythTV
14 #
15 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
16 #  building an rpm by hand on the machine it will be used on, I encourage you
17 #  to use "--with cpu_autodetect" to let mythtv decide for you.
18 #
19 # Conditional build:
20 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
21 %bcond_without  lirc            # lirc support
22 %bcond_without  alsa            # alsa support
23 %bcond_without  oss             # oss support
24 %bcond_without  jack            # jack audio connection kit
25 %bcond_without  pulseaudio      # pulseaudio support
26 %bcond_without  dvb             # DVB support
27 %bcond_without  xrandr          # disable X11 resolution switching
28 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
29 %bcond_without  iptv
30 %bcond_without  firewire        # ieee1394 (NFY)
31 %bcond_without  vdpau           # disable nvidia vdpau support
32 %bcond_without  fftw3           # disable fftw3 support
33 %bcond_with     mmx             # enable MMX
34 %bcond_without  nellymoserdec
35 %bcond_with     vaapi           # enable vaapi
36 %bcond_with     dshowserver     # enable directshow codecs server
37 %bcond_with     perl
38 %bcond_with     php
39 %bcond_with     python
40 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers
41                                 # instead of libvdpau
42
43 # enable mmx automatically on arches having it
44 %ifarch %{ix86} %{x8664}
45 %ifnarch i386 i486 i586 i686
46 %define with_mmx 1
47 %endif
48 %endif
49
50 # dshowserver is exclusive arch for x86 x86_64 only
51 %ifnarch %{ix86} %{x8664}
52 %undefine with_dshowserver
53 %endif
54
55 %include        /usr/lib/rpm/macros.perl
56 Summary:        A personal video recorder (PVR) application
57 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
58 Name:           mythtv
59 Version:        0.26.0
60 Release:        1
61 License:        GPL v2
62 Group:          Applications/Multimedia
63 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
64 # Source0-md5:  f57066bf75e6f14824c494d41639f4f9
65 Source1:        mythbackend.sysconfig
66 Source2:        mythbackend.init
67 Source3:        mythbackend.logrotate
68 Source4:        %{name}.tmpfiles
69 Source5:        pld-mythfrontend.desktop
70 # Source5-md5:  f37a903ac97463683bebacdf29406951
71 Source6:        pld-mythfrontend.png
72 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
73 Source20:       dshowcodecs
74 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
75 Patch0:         %{name}-configure.patch
76 Patch1:         system-zeromq.patch
77 Patch20:        %{name}-compile_fixes_for_qt_4_7.patch
78 Patch30:        %{name}-dshowserver-0.22.patch
79 URL:            http://www.mythtv.org/
80 BuildRequires:  Mesa-libGLU-devel
81 BuildRequires:  OpenGL-devel
82 BuildRequires:  Qt3Support-devel
83 BuildRequires:  QtCore-devel
84 BuildRequires:  QtGui-devel
85 BuildRequires:  QtNetwork-devel
86 BuildRequires:  QtOpenGL-devel
87 BuildRequires:  QtScript-devel
88 BuildRequires:  QtSql-devel
89 BuildRequires:  QtWebKit-devel
90 BuildRequires:  QtXml-devel
91 %{?with_alsa:BuildRequires:     alsa-lib-devel}
92 BuildRequires:  ffmpeg-devel
93 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
94 BuildRequires:  freetype-devel >= 1:2.0.0
95 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
96 BuildRequires:  lame-libs-devel
97 %{?with_firewire:BuildRequires: libavc1394-devel}
98 BuildRequires:  libdts-devel
99 %{?with_dvb:BuildRequires:      libdvb-devel}
100 BuildRequires:  libdvdnav-devel
101 %{?with_firewire:BuildRequires: libiec61883-devel}
102 %{?with_firewire:BuildRequires: libraw1394-devel}
103 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
104 BuildRequires:  linux-libc-headers >= 7:2.6.10
105 %{?with_lirc:BuildRequires:     lirc-devel}
106 BuildRequires:  mysql-devel
107 BuildRequires:  perl-devel
108 BuildRequires:  perl-tools-pod
109 BuildRequires:  pkgconfig
110 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
111 BuildRequires:  python-devel
112 BuildRequires:  qt4-build
113 BuildRequires:  qt4-qmake
114 BuildRequires:  rpm-perlprov >= 4.1-13
115 BuildRequires:  rpm-pythonprov
116 BuildRequires:  rpmbuild(macros) >= 1.228
117 BuildRequires:  sed >= 4.0
118 BuildRequires:  which
119 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
120 BuildRequires:  xorg-lib-libXext-devel
121 BuildRequires:  xorg-lib-libXxf86vm-devel
122 BuildRequires:  zeromq-devel
123 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
124 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
125 # for Perl bindings
126 BuildRequires:  perl-ExtUtils-MakeMaker
127 ExclusiveArch:  %{ix86} %{x8664} ppc
128 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
129
130 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
131
132 # libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
133 # libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
134 %define         skip_post_check_so      libmythavdevice.so libmythavcodec.so
135 %define         no_install_post_check_so 1
136
137 %description
138 MythTV implements the following PVR features, and more, with a unified
139 graphical interface:
140 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
141 - Video compression using RTjpeg or MPEG-4
142 - Program listing retrieval using XMLTV
143 - Themable, semi-transparent on-screen display
144 - Electronic program guide
145 - Scheduled recording of TV programs
146 - Resolution of conflicts between scheduled recordings
147 - Basic video editing
148
149 %description -l pl.UTF-8
150 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
151 ujednoliconym interfejsem graficznym:
152 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
153   przewijanie "żywej" telewizji
154 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
155 - odczyt listy programów przy użyciu XMLTV
156 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
157 - elektroniczny przewodnik po programie
158 - planowane nagrywanie programów telewizyjnych
159 - rozwiązywanie konfliktów między planowanymi nagraniami
160 - podstawowa edycja obrazu
161
162 %package backend
163 Summary:        Server component of mythtv (a PVR)
164 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
165 Group:          Applications/Multimedia
166 Requires(post,preun):   /sbin/chkconfig
167 Requires(postun):       /usr/sbin/groupdel
168 Requires(postun):       /usr/sbin/userdel
169 Requires(pre):  /bin/id
170 Requires(pre):  /usr/bin/getgid
171 Requires(pre):  /usr/sbin/groupadd
172 Requires(pre):  /usr/sbin/useradd
173 Requires:       libmyth = %{version}-%{release}
174 Requires:       mythtv = %{version}-%{release}
175 Suggests:       mysql
176 Provides:       group(mythtv)
177 Provides:       user(mythtv)
178 Conflicts:      logrotate < 3.8.0
179
180 %description backend
181 MythTV provides a unified graphical interface for recording and
182 viewing television programs. Refer to the mythtv package for more
183 information.
184
185 This package contains only the server software, which provides video
186 and audio capture and encoding services. In order to be useful, it
187 requires a mythtv-frontend installation, either on the same system or
188 one reachable via the network.
189
190 %description backend -l pl.UTF-8
191 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
192 oglądania programów telewizyjnych. Więcej informacji w pakiecie
193 mythtv.
194
195 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
196 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
197 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
198 albo innym osiągalnym w sieci.
199
200 %package frontend
201 Summary:        Client component of mythtv (a PVR)
202 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
203 Group:          Applications/Multimedia
204 Requires:       libmyth = %{version}-%{release}
205 Requires:       mythtv = %{version}-%{release}
206 Requires:       mythtv-themes = %{version}-%{release}
207 Provides:       mythtv-frontend-api = %{myth_api_version}
208
209 %description frontend
210 MythTV provides a unified graphical interface for recording and
211 viewing television programs. Refer to the mythtv package for more
212 information.
213
214 This package contains only the client software, which provides a
215 front-end for playback and configuration. It requires access to a
216 mythtv-backend installation, either on the same system or one
217 reachable via the network.
218
219 %description frontend -l pl.UTF-8
220 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
221 oglądania programów telewizyjnych. Więcej informacji w pakiecie
222 mythtv.
223
224 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
225 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
226 mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
227
228 %package setup
229 Summary:        Setup the mythtv backend
230 Summary(pl.UTF-8):      Konfigurator backendu mythtv
231 Group:          Applications/Multimedia
232 Requires:       libmyth = %{version}-%{release}
233
234 %description setup
235 MythTV provides a unified graphical interface for recording and
236 viewing television programs. Refer to the mythtv package for more
237 information.
238
239 This package contains only the setup software for configuring the
240 mythtv backend.
241
242 %description setup -l pl.UTF-8
243 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
244 oglądania programów telewizyjnych. Więcej informacji w pakiecie
245 mythtv.
246
247 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
248
249 %package themes
250 Summary:        Base themes for mythtv's frontend
251 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
252 Group:          Themes
253 Requires:       %{name}-frontend = %{version}-%{release}
254
255 %description themes
256 MythTV provides a unified graphical interface for recording and
257 viewing television programs. Refer to the mythtv package for more
258 information.
259
260 This package contains only the base themes used by the frontend and
261 mythtvsetup.
262
263 %description themes -l pl.UTF-8
264 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
265 oglądania programów telewizyjnych. Więcej informacji w pakiecie
266 mythtv.
267
268 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
269 mythtvsetup.
270
271 %package -n libmyth
272 Summary:        Library providing mythtv support
273 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
274 Group:          Libraries
275 Requires:       QtSql-mysql
276 Requires:       freetype >= 1:2.0.0
277 Requires:       lame
278
279 %description -n libmyth
280 Common library code for MythTV and add-on modules (development) MythTV
281 provides a unified graphical interface for recording and viewing
282 television programs. Refer to the mythtv package for more information.
283
284 %description -n libmyth -l pl.UTF-8
285 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
286 dostarczający ujednolicony interfejs graficzny do nagrywania i
287 oglądania programów telewizyjnych. Więcej informacji w pakiecie
288 mythtv.
289
290 %package -n libmyth-devel
291 Summary:        Development files for libmyth
292 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
293 Group:          Development/Libraries
294 Requires:       libmyth = %{version}-%{release}
295
296 %description -n libmyth-devel
297 This package contains the header files for developing add-ons for
298 mythtv.
299
300 %description -n libmyth-devel -l pl.UTF-8
301 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
302
303 %package -n libmyth-static
304 Summary:        Static libmyth library
305 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
306 Group:          Development/Libraries
307 Requires:       libmyth-devel = %{version}-%{release}
308
309 %description -n libmyth-static
310 Static libmyth library.
311
312 %description -n libmyth-static -l pl.UTF-8
313 Statyczna biblioteka libmyth.
314
315 %package -n perl-MythTV
316 Summary:        MythTV Perl bindings
317 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
318 Group:          Libraries
319
320 %description -n perl-MythTV
321 MythTV Perl bindings.
322
323 %description -n perl-MythTV -l pl.UTF-8
324 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
325
326 %package -n python-MythTV
327 Summary:        MythTV Python bindings
328 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
329 Group:          Libraries
330 Requires:       python-MySQLdb
331
332 %description -n python-MythTV
333 MythTV Python bindings.
334
335 %description -n python-MythTV -l pl.UTF-8
336 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
337
338 %package -n php-MythTV
339 Summary:        MythTV PHP bindings
340 Summary(pl.UTF-8):      Interfejs PHP dla MythTV
341 Group:          Libraries
342
343 %description -n php-MythTV
344 MythTV PHP bindings.
345
346 %description -n php-MythTV -l pl.UTF-8
347 Ten pakiet zawiera moduły PHP do tworzenia dodatków dla mythtv.
348
349 %prep
350
351 %setup -q
352
353 %{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
354         programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
355
356 %patch0  -p1
357 %patch1  -p1
358 %{?with_dshowserver:%patch20 -p1}
359 #%patch30 -p1
360
361 rm -rf database/old # not supported in PLD
362
363 # lib64 fix - enable to update patch
364 %if %{_lib} != "lib" && 0
365 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
366 xargs grep -l /lib . | xargs sed -i -e '
367         s,/''usr/lib/,/%{_libdir}/,g
368         s,/''lib/mythtv,/%{_lib}/mythtv,g
369         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
370 '
371 exit 1
372 %endif
373
374 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
375 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
376 # prevent compiler finding libs from system when they should be looked
377 # from current buildtree.
378 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
379 # so we make QMAKE wrapper which will do sed subst after calling
380 # qmake. this is the wrapper.
381 cat > qmake-wrapper.sh <<'EOF'
382 #!/bin/sh
383 getmakefile() {
384         while [ $# -gt 0 ]; do
385                 case "$1" in
386                 -o)
387                         shift
388                         makefile="$1"
389                         return
390                         ;;
391         esac
392                 shift
393         done
394 }
395
396 qmake-qt4 "$@"
397 getmakefile "$@"
398 if [ "$makefile" ]; then
399         %{__sed} -i -e '
400                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
401                 s;-L$(QTDIR)/%{_lib};;
402         ' $makefile
403 fi
404 EOF
405 chmod +x qmake-wrapper.sh
406
407 # move perl bindings to vendor prefix
408 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
409   bindings/perl/Makefile
410
411 %build
412
413 %if %{with cpu_autodetect}
414 # Make sure we have /proc mounted
415 if [ ! -r /proc/cpuinfo ]; then
416         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
417         exit 1
418 fi
419 %endif
420
421 ./configure \
422         --prefix=%{_prefix} \
423         --libdir=%{_libdir} \
424         --libdir-name=%{_lib} \
425         --mandir=%{_mandir} \
426         --disable-distcc --disable-ccache \
427         --compile-type=%{?debug:debug}%{!?debug:release} \
428         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
429         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
430 %if %{with cpu_autodetect}
431         --enable-proc-opt \
432 %else
433         %ifarch %{ix86}
434                 %ifarch athlon
435                         --arch=athlon \
436                 %else
437                         --cpu=%{_target_cpu} --tune=pentium4 \
438                 %endif
439         %endif
440         %ifarch i386 i486 i586
441         --enable-disable-mmx-for-debugging \
442         %endif
443         %ifarch %{x8664}
444         --arch=x86_64 \
445         %endif
446         %{?with_mmx:--enable-mmx} \
447 %endif
448         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
449         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
450         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
451         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
452         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
453         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
454         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
455         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
456         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
457         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
458         --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
459         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
460         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
461         --enable-xv \
462         --enable-x11 \
463
464 #%{_libdir}/qt4/bin/qmake mythtv.pro
465 %{__make}
466
467 %install
468 rm -rf $RPM_BUILD_ROOT
469 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
470                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
471                 $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
472                 $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
473                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
474                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
475                 $RPM_BUILD_ROOT%{_pixmapsdir} \
476                 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
477
478 %{__make} install \
479         INSTALL_ROOT=$RPM_BUILD_ROOT
480
481 # Install the files that we added on top of mythtv's own stuff
482 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
483 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
484 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
485 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
486
487 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
488
489 # desktop entries
490 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
491 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
492
493 # Install settings.pro so people can see the build options we used
494 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
495 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
496
497 for p in mythfrontend; do
498         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
499                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
500         done > $p.lang
501 done
502
503 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/locales/*.xml; do
504         echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*/\(.*\).xml\),%%lang(\2) \1,"
505 done > mythbackend.lang
506
507 # glibc language codes. attempt was made to change it on libmyth side,
508 # but that was just asking for trouble due large coverage of
509 # language.lower() usage.
510 sed -i -e '
511 s,%%lang(en_gb),%%lang(en_GB),
512 s,%%lang(zh_tw),%%lang(zh_TW),
513 s,%%lang(pt_br),%%lang(pt_BR),
514 ' *.lang
515
516 rm -rf mythwelcome mythlcdserver
517 install -d mythwelcome
518 cp -a programs/mythwelcome/README mythwelcome
519 cp -a programs/mythlcdserver/README mythlcdserver
520
521 %clean
522 rm -rf $RPM_BUILD_ROOT
523
524 %pre backend
525 %groupadd -g 149 %{name}
526 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
527 %addusertogroup %{name} video
528 %addusertogroup %{name} audio
529
530 %post backend
531 /sbin/chkconfig --add mythbackend
532
533 %preun backend
534 if [ "$1" = "0" ]; then
535         %service -q mythbackend stop
536         /sbin/chkconfig --del mythbackend
537 fi
538
539 %postun backend
540 if [ "$1" = "0" ]; then
541         %userremove %{name}
542         %groupremove %{name}
543 fi
544
545 %post   -n libmyth -p /sbin/ldconfig
546 %postun -n libmyth -p /sbin/ldconfig
547
548 %post setup
549 if [ "$1" = 1 ]; then
550 %banner -e %{name}-setup <<EOF
551 To grant mysql permissions to mythtv, please run
552 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
553 EOF
554 fi
555
556 %files
557 %defattr(644,root,root,755)
558 %doc README* UPGRADING AUTHORS FAQ
559 %doc docs contrib
560 %doc keys.txt mythwelcome mythlcdserver
561
562 %files backend -f mythbackend.lang
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_bindir}/mythbackend
565 %attr(755,root,root) %{_bindir}/mythcommflag
566 %attr(755,root,root) %{_bindir}/mythfilldatabase
567 %attr(755,root,root) %{_bindir}/mythjobqueue
568 %attr(755,root,root) %{_bindir}/mythlcdserver
569 %attr(755,root,root) %{_bindir}/mythlogserver
570 %attr(755,root,root) %{_bindir}/mythmediaserver
571 %attr(755,root,root) %{_bindir}/mythtranscode
572 %attr(755,root,root) %{_bindir}/mythreplex
573 %attr(755,root,root) %{_bindir}/mythffmpeg
574 %attr(755,root,root) %{_bindir}/mythpreviewgen
575 %attr(755,root,root) %{_bindir}/mythccextractor
576 %attr(755,root,root) %{_bindir}/mythmetadatalookup
577 %attr(755,root,root) %{_bindir}/mythutil
578
579 %attr(775,root,mythtv) %dir /var/lib/mythtv
580 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
581 %attr(775,root,mythtv) %dir /var/cache/mythtv
582 %attr(775,root,mythtv) %dir /var/run/mythtv
583 /usr/lib/tmpfiles.d/%{name}.conf
584 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
585 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
586 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
587 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
588 %{_datadir}/mythtv/backend-config
589 %{_datadir}/mythtv/html
590
591 %files frontend -f mythfrontend.lang
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/mythfrontend
594 %attr(755,root,root) %{_bindir}/mythshutdown
595 %attr(755,root,root) %{_bindir}/mythavtest
596 %attr(755,root,root) %{_bindir}/mythwelcome
597 %dir %{_datadir}/mythtv
598 %dir %{_datadir}/mythtv/themes
599 %{_datadir}/mythtv/internetcontent
600 %{_datadir}/mythtv/metadata
601 %dir %{_libdir}/mythtv
602 %{_datadir}/mythtv/*.xml
603 %dir %{_libdir}/mythtv/filters
604 %dir %{_libdir}/mythtv/plugins
605 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
606 %{_datadir}/mythtv/fonts/*.ttf
607 %{_datadir}/mythtv/fonts/*.otf
608 %dir %{_datadir}/mythtv/i18n
609 %if %{with dshowserver}
610 %{_datadir}/mythtv/dshowcodecs
611 %endif
612 %{_desktopdir}/*.desktop
613 %{_pixmapsdir}/*.png
614
615 %files setup
616 %defattr(644,root,root,755)
617 %doc database
618 %attr(755,root,root) %{_bindir}/mythtv-setup
619
620 %files themes
621 %defattr(644,root,root,755)
622 %{_datadir}/mythtv/themes/*
623
624 %files -n libmyth
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/lib*.so.*
627 %attr(755,root,root) %{_libdir}/lib*.a
628 %dir %{_datadir}/mythtv
629 %{_datadir}/mythtv/*.pl
630 %{_datadir}/mythtv/hardwareprofile
631
632 %files -n libmyth-devel
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/*.so
635 %{_includedir}/*
636 %{_datadir}/mythtv/build
637
638 %files -n libmyth-static
639 %defattr(644,root,root,755)
640
641 %if %{with perl}
642 %files -n perl-MythTV
643 %defattr(644,root,root,755)
644 %{perl_vendorlib}/MythTV.pm
645 %dir %{perl_vendorlib}/MythTV
646 %{perl_vendorlib}/MythTV/*.pm
647 %dir %{perl_vendorlib}/IO/Socket/INET
648 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
649 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
650 %endif
651
652 %if %{with python}
653 %files -n python-MythTV
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_bindir}/mythpython
656 %dir %{py_sitescriptdir}/MythTV
657 %{py_sitescriptdir}/MythTV/*
658 %{py_sitescriptdir}/*.egg-info
659 %endif
660
661 %if %{with php}
662 %files -n php-MythTV
663 %defattr(644,root,root,755)
664 %endif
This page took 0.103668 seconds and 3 git commands to generate.