]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- fix python binding install
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 # - vaapi support - check for compatible versions of libva?
7 #
8 # Specfile for MythTV
9 #
10 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
11 #  building an rpm by hand on the machine it will be used on, I encourage you
12 #  to use "--with cpu_autodetect" to let mythtv decide for you.
13 #
14 # Conditional build:
15 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
16 %bcond_without  lirc            # lirc support
17 %bcond_without  alsa            # alsa support
18 %bcond_without  oss             # oss support
19 %bcond_without  jack            # jack audio connection kit
20 %bcond_without  pulseaudio      # pulseaudio support
21 %bcond_without  dvb             # DVB support
22 %bcond_without  xrandr          # disable X11 resolution switching
23 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
24 %bcond_without  iptv
25 %bcond_without  firewire        # ieee1394 (NFY)
26 %bcond_without  vdpau           # disable nvidia vdpau support
27 %bcond_without  fftw3           # disable fftw3 support
28 %bcond_with     mmx             # enable MMX
29 %bcond_without  nellymoserdec
30 %bcond_with     vaapi           # enable vaapi
31 %bcond_with     dshowserver     # enable directshow codecs server
32 %bcond_without  perl
33 %bcond_with     php
34 %bcond_without  python
35 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers
36                                 # instead of libvdpau
37
38 # enable mmx automatically on arches having it
39 %ifarch %{ix86} %{x8664}
40 %ifnarch i386 i486 i586 i686
41 %define with_mmx 1
42 %endif
43 %endif
44
45 # dshowserver is exclusive arch for x86 x86_64 only
46 %ifnarch %{ix86} %{x8664}
47 %undefine with_dshowserver
48 %endif
49
50 %include        /usr/lib/rpm/macros.perl
51 Summary:        A personal video recorder (PVR) application
52 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
53 Name:           mythtv
54 Version:        0.26.1
55 Release:        6
56 License:        GPL v2
57 Group:          Applications/Multimedia
58 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
59 # Source0-md5:  ef25a9b86f4a23d6f07d83791a1e5c9e
60 Source1:        mythbackend.sysconfig
61 Source2:        mythbackend.init
62 Source3:        mythbackend.logrotate
63 Source4:        %{name}.tmpfiles
64 Source5:        pld-mythfrontend.desktop
65 # Source5-md5:  f37a903ac97463683bebacdf29406951
66 Source6:        pld-mythfrontend.png
67 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
68 Source20:       dshowcodecs
69 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
70 Patch0:         %{name}-configure.patch
71 Patch1:         system-zeromq.patch
72 Patch2:         python-install.patch
73 Patch20:        %{name}-compile_fixes_for_qt_4_7.patch
74 Patch30:        %{name}-dshowserver-0.22.patch
75 URL:            http://www.mythtv.org/
76 BuildRequires:  Mesa-libGLU-devel
77 BuildRequires:  OpenGL-devel
78 BuildRequires:  Qt3Support-devel
79 BuildRequires:  QtCore-devel
80 BuildRequires:  QtGui-devel
81 BuildRequires:  QtNetwork-devel
82 BuildRequires:  QtOpenGL-devel
83 BuildRequires:  QtScript-devel
84 BuildRequires:  QtSql-devel
85 BuildRequires:  QtWebKit-devel
86 BuildRequires:  QtXml-devel
87 %{?with_alsa:BuildRequires:     alsa-lib-devel}
88 BuildRequires:  ffmpeg-devel
89 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
90 BuildRequires:  freetype-devel >= 1:2.0.0
91 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
92 BuildRequires:  lame-libs-devel
93 %{?with_firewire:BuildRequires: libavc1394-devel}
94 BuildRequires:  libdts-devel
95 %{?with_dvb:BuildRequires:      libdvb-devel}
96 BuildRequires:  libdvdnav-devel
97 %{?with_firewire:BuildRequires: libiec61883-devel}
98 %{?with_firewire:BuildRequires: libraw1394-devel}
99 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
100 BuildRequires:  linux-libc-headers >= 7:2.6.10
101 %{?with_lirc:BuildRequires:     lirc-devel}
102 BuildRequires:  mysql-devel
103 BuildRequires:  perl-devel
104 BuildRequires:  perl-tools-pod
105 %if %{with perl}
106 BuildRequires:  perl-DBI
107 BuildRequires:  perl-DBD-mysql
108 BuildRequires:  perl-HTTP-Message
109 BuildRequires:  perl-libwww
110 BuildRequires:  perl-Net-UPnP
111 BuildRequires:  perl-IO-Socket-INET6
112 %endif
113 %if %{with python}
114 BuildRequires:  python-MySQLdb
115 BuildRequires:  python-lxml
116 BuildRequires:  python-urlgrabber
117 %endif
118 BuildRequires:  pkgconfig
119 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
120 BuildRequires:  python-devel
121 BuildRequires:  qt4-build
122 BuildRequires:  qt4-qmake
123 BuildRequires:  rpm-perlprov >= 4.1-13
124 BuildRequires:  rpm-pythonprov
125 BuildRequires:  rpmbuild(macros) >= 1.228
126 BuildRequires:  sed >= 4.0
127 BuildRequires:  which
128 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
129 BuildRequires:  xorg-lib-libXext-devel
130 BuildRequires:  xorg-lib-libXxf86vm-devel
131 BuildRequires:  zeromq-devel
132 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
133 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
134 # for Perl bindings
135 BuildRequires:  perl-ExtUtils-MakeMaker
136 ExclusiveArch:  %{ix86} %{x8664} x32 ppc
137 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
138
139 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
140
141 # libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
142 # libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
143 %define         skip_post_check_so      libmythavdevice.so libmythavcodec.so
144 %define         no_install_post_check_so 1
145
146 %description
147 MythTV implements the following PVR features, and more, with a unified
148 graphical interface:
149 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
150 - Video compression using RTjpeg or MPEG-4
151 - Program listing retrieval using XMLTV
152 - Themable, semi-transparent on-screen display
153 - Electronic program guide
154 - Scheduled recording of TV programs
155 - Resolution of conflicts between scheduled recordings
156 - Basic video editing
157
158 %description -l pl.UTF-8
159 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
160 ujednoliconym interfejsem graficznym:
161 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
162   przewijanie "żywej" telewizji
163 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
164 - odczyt listy programów przy użyciu XMLTV
165 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
166 - elektroniczny przewodnik po programie
167 - planowane nagrywanie programów telewizyjnych
168 - rozwiązywanie konfliktów między planowanymi nagraniami
169 - podstawowa edycja obrazu
170
171 %package backend
172 Summary:        Server component of mythtv (a PVR)
173 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
174 Group:          Applications/Multimedia
175 Requires(post,preun):   /sbin/chkconfig
176 Requires(postun):       /usr/sbin/groupdel
177 Requires(postun):       /usr/sbin/userdel
178 Requires(pre):  /bin/id
179 Requires(pre):  /usr/bin/getgid
180 Requires(pre):  /usr/sbin/groupadd
181 Requires(pre):  /usr/sbin/useradd
182 Requires:       libmyth = %{version}-%{release}
183 Requires:       mythtv = %{version}-%{release}
184 Suggests:       mysql
185 Provides:       group(mythtv)
186 Provides:       user(mythtv)
187 Conflicts:      logrotate < 3.8.0
188
189 %description backend
190 MythTV provides a unified graphical interface for recording and
191 viewing television programs. Refer to the mythtv package for more
192 information.
193
194 This package contains only the server software, which provides video
195 and audio capture and encoding services. In order to be useful, it
196 requires a mythtv-frontend installation, either on the same system or
197 one reachable via the network.
198
199 %description backend -l pl.UTF-8
200 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
201 oglądania programów telewizyjnych. Więcej informacji w pakiecie
202 mythtv.
203
204 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
205 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
206 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
207 albo innym osiągalnym w sieci.
208
209 %package frontend
210 Summary:        Client component of mythtv (a PVR)
211 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
212 Group:          Applications/Multimedia
213 Requires:       libmyth = %{version}-%{release}
214 Requires:       mythtv = %{version}-%{release}
215 Requires:       mythtv-themes = %{version}-%{release}
216 Provides:       mythtv-frontend-api = %{myth_api_version}
217
218 %description frontend
219 MythTV provides a unified graphical interface for recording and
220 viewing television programs. Refer to the mythtv package for more
221 information.
222
223 This package contains only the client software, which provides a
224 front-end for playback and configuration. It requires access to a
225 mythtv-backend installation, either on the same system or one
226 reachable via the network.
227
228 %description frontend -l pl.UTF-8
229 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
230 oglądania programów telewizyjnych. Więcej informacji w pakiecie
231 mythtv.
232
233 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
234 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
235 mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
236
237 %package setup
238 Summary:        Setup the mythtv backend
239 Summary(pl.UTF-8):      Konfigurator backendu mythtv
240 Group:          Applications/Multimedia
241 Requires:       libmyth = %{version}-%{release}
242
243 %description setup
244 MythTV provides a unified graphical interface for recording and
245 viewing television programs. Refer to the mythtv package for more
246 information.
247
248 This package contains only the setup software for configuring the
249 mythtv backend.
250
251 %description setup -l pl.UTF-8
252 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
253 oglądania programów telewizyjnych. Więcej informacji w pakiecie
254 mythtv.
255
256 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
257
258 %package themes
259 Summary:        Base themes for mythtv's frontend
260 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
261 Group:          Themes
262 Requires:       %{name}-frontend = %{version}-%{release}
263
264 %description themes
265 MythTV provides a unified graphical interface for recording and
266 viewing television programs. Refer to the mythtv package for more
267 information.
268
269 This package contains only the base themes used by the frontend and
270 mythtvsetup.
271
272 %description themes -l pl.UTF-8
273 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
274 oglądania programów telewizyjnych. Więcej informacji w pakiecie
275 mythtv.
276
277 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
278 mythtvsetup.
279
280 %package -n libmyth
281 Summary:        Library providing mythtv support
282 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
283 Group:          Libraries
284 Requires:       QtSql-mysql
285 Requires:       freetype >= 1:2.0.0
286 Requires:       lame
287
288 %description -n libmyth
289 Common library code for MythTV and add-on modules (development) MythTV
290 provides a unified graphical interface for recording and viewing
291 television programs. Refer to the mythtv package for more information.
292
293 %description -n libmyth -l pl.UTF-8
294 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
295 dostarczający ujednolicony interfejs graficzny do nagrywania i
296 oglądania programów telewizyjnych. Więcej informacji w pakiecie
297 mythtv.
298
299 %package -n libmyth-devel
300 Summary:        Development files for libmyth
301 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
302 Group:          Development/Libraries
303 Requires:       libmyth = %{version}-%{release}
304
305 %description -n libmyth-devel
306 This package contains the header files for developing add-ons for
307 mythtv.
308
309 %description -n libmyth-devel -l pl.UTF-8
310 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
311
312 %package -n libmyth-static
313 Summary:        Static libmyth library
314 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
315 Group:          Development/Libraries
316 Requires:       libmyth-devel = %{version}-%{release}
317
318 %description -n libmyth-static
319 Static libmyth library.
320
321 %description -n libmyth-static -l pl.UTF-8
322 Statyczna biblioteka libmyth.
323
324 %package -n perl-MythTV
325 Summary:        MythTV Perl bindings
326 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
327 Group:          Libraries
328
329 %description -n perl-MythTV
330 MythTV Perl bindings.
331
332 %description -n perl-MythTV -l pl.UTF-8
333 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
334
335 %package -n python-MythTV
336 Summary:        MythTV Python bindings
337 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
338 Group:          Libraries
339 Requires:       python-MySQLdb
340
341 %description -n python-MythTV
342 MythTV Python bindings.
343
344 %description -n python-MythTV -l pl.UTF-8
345 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
346
347 %package -n php-MythTV
348 Summary:        MythTV PHP bindings
349 Summary(pl.UTF-8):      Interfejs PHP dla MythTV
350 Group:          Libraries
351
352 %description -n php-MythTV
353 MythTV PHP bindings.
354
355 %description -n php-MythTV -l pl.UTF-8
356 Ten pakiet zawiera moduły PHP do tworzenia dodatków dla mythtv.
357
358 %prep
359
360 %setup -q
361
362 %{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
363         programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
364
365 %patch0  -p1
366 %patch1  -p1
367 %patch2  -p1
368 %{?with_dshowserver:%patch20 -p1}
369 #%patch30 -p1
370
371 rm -rf database/old # not supported in PLD
372
373 # lib64 fix - enable to update patch
374 %if %{_lib} != "lib" && 0
375 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
376 xargs grep -l /lib . | xargs sed -i -e '
377         s,/''usr/lib/,/%{_libdir}/,g
378         s,/''lib/mythtv,/%{_lib}/mythtv,g
379         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
380 '
381 exit 1
382 %endif
383
384 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
385 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
386 # prevent compiler finding libs from system when they should be looked
387 # from current buildtree.
388 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
389 # so we make QMAKE wrapper which will do sed subst after calling
390 # qmake. this is the wrapper.
391 cat > qmake-wrapper.sh <<'EOF'
392 #!/bin/sh
393 getmakefile() {
394         while [ $# -gt 0 ]; do
395                 case "$1" in
396                 -o)
397                         shift
398                         makefile="$1"
399                         return
400                         ;;
401         esac
402                 shift
403         done
404 }
405
406 qmake-qt4 "$@"
407 getmakefile "$@"
408 if [ "$makefile" ]; then
409         %{__sed} -i -e '
410                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
411                 s;-L$(QTDIR)/%{_lib};;
412         ' $makefile
413 fi
414 EOF
415 chmod +x qmake-wrapper.sh
416
417 # move perl bindings to vendor prefix
418 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
419   bindings/perl/Makefile
420
421 %build
422
423 %if %{with cpu_autodetect}
424 # Make sure we have /proc mounted
425 if [ ! -r /proc/cpuinfo ]; then
426         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
427         exit 1
428 fi
429 %endif
430
431 ./configure \
432         --prefix=%{_prefix} \
433         --libdir=%{_libdir} \
434         --libdir-name=%{_lib} \
435         --mandir=%{_mandir} \
436         --disable-distcc --disable-ccache \
437         --compile-type=%{?debug:debug}%{!?debug:release} \
438         --extra-cflags="%{rpmcflags} -fomit-frame-pointer -fno-devirtualize" \
439         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer -fno-devirtualize" \
440 %if %{with cpu_autodetect}
441         --enable-proc-opt \
442 %else
443         %ifarch %{ix86}
444                 %ifarch athlon
445                         --arch=athlon \
446                 %else
447                         --cpu=%{_target_cpu} --tune=pentium4 \
448                 %endif
449         %endif
450         %ifarch i386 i486 i586
451         --enable-disable-mmx-for-debugging \
452         %endif
453         %ifarch %{x8664}
454         --arch=x86_64 \
455         %endif
456         %ifarch x32
457         --disable-asm \
458         %endif
459         %{?with_mmx:--enable-mmx} \
460 %endif
461         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
462         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
463         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
464         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
465         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
466         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
467         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
468         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
469         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
470         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
471         --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
472         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
473         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
474         --enable-xv \
475         --enable-x11 \
476
477 #%{_libdir}/qt4/bin/qmake mythtv.pro
478 %{__make}
479
480 %install
481 rm -rf $RPM_BUILD_ROOT
482 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
483                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
484                 $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
485                 $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
486                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
487                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
488                 $RPM_BUILD_ROOT%{_pixmapsdir} \
489                 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
490
491 %{__make} install \
492         py_sitescriptdir=%{py_sitescriptdir} \
493         py_sitedir=%{py_sitedir} \
494         INSTALL_ROOT=$RPM_BUILD_ROOT
495
496 # Install the files that we added on top of mythtv's own stuff
497 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
498 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
499 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
500 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
501
502 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
503
504 # desktop entries
505 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
506 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
507
508 # Install settings.pro so people can see the build options we used
509 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
510 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
511
512 for p in mythfrontend; do
513         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
514                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
515         done > $p.lang
516 done
517
518 echo "%dir %{_datadir}/mythtv/locales" > mythbackend.lang
519 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/locales/*.xml; do
520         echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*/\(.*\).xml\),%%lang(\2) \1,"
521 done >> mythbackend.lang
522
523 # glibc language codes. attempt was made to change it on libmyth side,
524 # but that was just asking for trouble due large coverage of
525 # language.lower() usage.
526 sed -i -e '
527 s,%%lang(en_gb),%%lang(en_GB),
528 s,%%lang(zh_tw),%%lang(zh_TW),
529 s,%%lang(pt_br),%%lang(pt_BR),
530 ' *.lang
531
532 rm -rf mythwelcome mythlcdserver
533 install -d mythwelcome
534 cp -a programs/mythwelcome/README mythwelcome
535 cp -a programs/mythlcdserver/README mythlcdserver
536
537 %clean
538 rm -rf $RPM_BUILD_ROOT
539
540 %pre backend
541 %groupadd -g 149 %{name}
542 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
543 %addusertogroup %{name} video
544 %addusertogroup %{name} audio
545
546 %post backend
547 /sbin/chkconfig --add mythbackend
548
549 %preun backend
550 if [ "$1" = "0" ]; then
551         %service -q mythbackend stop
552         /sbin/chkconfig --del mythbackend
553 fi
554
555 %postun backend
556 if [ "$1" = "0" ]; then
557         %userremove %{name}
558         %groupremove %{name}
559 fi
560
561 %post   -n libmyth -p /sbin/ldconfig
562 %postun -n libmyth -p /sbin/ldconfig
563
564 %post setup
565 if [ "$1" = 1 ]; then
566 %banner -e %{name}-setup <<EOF
567 To grant mysql permissions to mythtv, please run
568 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
569 EOF
570 fi
571
572 %files
573 %defattr(644,root,root,755)
574 %doc README* UPGRADING AUTHORS FAQ
575 %doc docs contrib
576 %doc keys.txt mythwelcome mythlcdserver
577
578 %files backend -f mythbackend.lang
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/mythbackend
581 %attr(755,root,root) %{_bindir}/mythcommflag
582 %attr(755,root,root) %{_bindir}/mythfilldatabase
583 %attr(755,root,root) %{_bindir}/mythjobqueue
584 %attr(755,root,root) %{_bindir}/mythlcdserver
585 %attr(755,root,root) %{_bindir}/mythlogserver
586 %attr(755,root,root) %{_bindir}/mythmediaserver
587 %attr(755,root,root) %{_bindir}/mythtranscode
588 %attr(755,root,root) %{_bindir}/mythreplex
589 %attr(755,root,root) %{_bindir}/mythffmpeg
590 %attr(755,root,root) %{_bindir}/mythpreviewgen
591 %attr(755,root,root) %{_bindir}/mythccextractor
592 %attr(755,root,root) %{_bindir}/mythmetadatalookup
593 %attr(755,root,root) %{_bindir}/mythutil
594
595 %attr(775,root,mythtv) %dir /var/lib/mythtv
596 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
597 %attr(775,root,mythtv) %dir /var/cache/mythtv
598 %attr(775,root,mythtv) %dir /var/run/mythtv
599 /usr/lib/tmpfiles.d/%{name}.conf
600 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
601 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
602 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
603 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
604 %{_datadir}/mythtv/backend-config
605 %{_datadir}/mythtv/html
606
607 %files frontend -f mythfrontend.lang
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_bindir}/mythfrontend
610 %attr(755,root,root) %{_bindir}/mythshutdown
611 %attr(755,root,root) %{_bindir}/mythavtest
612 %attr(755,root,root) %{_bindir}/mythwelcome
613 %dir %{_datadir}/mythtv
614 %dir %{_datadir}/mythtv/themes
615 %{_datadir}/mythtv/internetcontent
616 %if %{without perl}
617 %exclude %{_datadir}/mythtv/internetcontent/nv_perl_libs
618 %endif
619 %{_datadir}/mythtv/metadata
620 %dir %{_libdir}/mythtv
621 %{_datadir}/mythtv/*.xml
622 %dir %{_libdir}/mythtv/filters
623 %dir %{_libdir}/mythtv/plugins
624 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
625 %dir %{_datadir}/mythtv/fonts
626 %{_datadir}/mythtv/fonts/*.ttf
627 %{_datadir}/mythtv/fonts/*.otf
628 %dir %{_datadir}/mythtv/i18n
629 %if %{with dshowserver}
630 %{_datadir}/mythtv/dshowcodecs
631 %endif
632 %{_desktopdir}/*.desktop
633 %{_pixmapsdir}/*.png
634
635 %files setup
636 %defattr(644,root,root,755)
637 %doc database
638 %attr(755,root,root) %{_bindir}/mythtv-setup
639
640 %files themes
641 %defattr(644,root,root,755)
642 %{_datadir}/mythtv/themes/*
643
644 %files -n libmyth
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/lib*.so.*
647 %attr(755,root,root) %{_libdir}/lib*.a
648 %dir %{_datadir}/mythtv
649 %{_datadir}/mythtv/*.pl
650 %{_datadir}/mythtv/hardwareprofile
651
652 %files -n libmyth-devel
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/*.so
655 %{_includedir}/*
656 %{_datadir}/mythtv/build
657
658 %files -n libmyth-static
659 %defattr(644,root,root,755)
660
661 %if %{with perl}
662 %files -n perl-MythTV
663 %defattr(644,root,root,755)
664 %{perl_vendorlib}/MythTV.pm
665 %dir %{perl_vendorlib}/MythTV
666 %{perl_vendorlib}/MythTV/*.pm
667 %dir %{perl_vendorlib}/IO/Socket/INET
668 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
669 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
670 %endif
671
672 %if %{with python}
673 %files -n python-MythTV
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/mythpython
676 %dir %{py_sitescriptdir}/MythTV
677 %{py_sitescriptdir}/MythTV/*
678 %{py_sitescriptdir}/*.egg-info
679 %endif
680
681 %if %{with php}
682 %files -n php-MythTV
683 %defattr(644,root,root,755)
684 %endif
This page took 0.198123 seconds and 3 git commands to generate.