]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- add systemd tmpfiles config
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 # - vaapi support - check for compatible versions of libva?
7 # - bindings:
8 #   WARNING: disabling Python bindings; missing MySQLdb
9 #   WARNING: disabling Perl bindings; missing Net::UPnP::QueryResponse
10 #   WARNING: disabling Perl bindings; missing Net::UPnP::ControlPoint
11 # - dozen of unpackaged files
12 #
13 # Specfile for MythTV
14 #
15 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
16 #  building an rpm by hand on the machine it will be used on, I encourage you
17 #  to use "--with cpu_autodetect" to let mythtv decide for you.
18 #
19 # Conditional build:
20 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
21 %bcond_without  lirc            # lirc support
22 %bcond_without  alsa            # alsa support
23 %bcond_without  oss             # oss support
24 %bcond_without  jack            # jack audio connection kit
25 %bcond_without  pulseaudio      # pulseaudio support
26 %bcond_without  opengl          # opengl vsync
27 %bcond_without  dvb             # DVB support
28 %bcond_without  xrandr          # disable X11 resolution switching
29 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
30 %bcond_without  iptv
31 %bcond_without  firewire        # ieee1394 (NFY)
32 %bcond_without  xvmc            # do not use XvMCW
33 %bcond_without  vdpau           # disable nvidia vdpau support
34 %bcond_without  fftw3           # disable fftw3 support
35 %bcond_with     mmx             # enable MMX
36 %bcond_without  nellymoserdec
37 %bcond_with     vaapi           # enable vaapi
38 %bcond_with     dshowserver     # enable directshow codecs server
39 %bcond_with     directfb
40 %bcond_with     perl
41 %bcond_with     python
42 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers 
43                                 # instead of libvdpau
44
45 # enable mmx automatically on arches having it
46 %ifarch %{ix86} %{x8664}
47 %ifnarch i386 i486 i586 i686
48 %define with_mmx 1
49 %endif
50 %endif
51
52 # dshowserver is exclusive arch for x86 x86_64 only
53 %ifnarch %{ix86} %{x8664}
54 %undefine with_dshowserver
55 %endif
56
57 %include        /usr/lib/rpm/macros.perl
58 Summary:        A personal video recorder (PVR) application
59 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
60 Name:           mythtv
61 Version:        0.24.1
62 Release:        0.2
63 License:        GPL v2
64 Group:          Applications/Multimedia
65 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
66 # Source0-md5:  6870c679619ec58456e76839745411d8
67 Source1:        mythbackend.sysconfig
68 Source2:        mythbackend.init
69 Source3:        mythbackend.logrotate
70 Source5:        pld-mythfrontend.desktop
71 # Source5-md5:  f37a903ac97463683bebacdf29406951
72 Source6:        pld-mythfrontend.png
73 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
74 Source20:       dshowcodecs
75 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
76 Patch0:         %{name}-configure.patch
77 Patch10:        %{name}-sbinpath.patch
78 Patch20:        %{name}-compile_fixes_for_qt_4_7.patch
79 Patch30:        %{name}-dshowserver-0.22.patch
80 URL:            http://www.mythtv.org/
81 BuildRequires:  Mesa-libGLU-devel
82 BuildRequires:  OpenGL-devel
83 BuildRequires:  Qt3Support-devel
84 BuildRequires:  QtCore-devel
85 BuildRequires:  QtGui-devel
86 BuildRequires:  QtNetwork-devel
87 BuildRequires:  QtOpenGL-devel
88 BuildRequires:  QtScript-devel
89 BuildRequires:  QtSql-devel
90 BuildRequires:  QtWebKit-devel
91 BuildRequires:  QtXml-devel
92 %{?with_alsa:BuildRequires:     alsa-lib-devel}
93 BuildRequires:  ffmpeg-devel
94 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
95 BuildRequires:  freetype-devel >= 1:2.0.0
96 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
97 BuildRequires:  lame-libs-devel
98 %{?with_firewire:BuildRequires: libavc1394-devel}
99 BuildRequires:  libdts-devel
100 %{?with_dvb:BuildRequires:      libdvb-devel}
101 BuildRequires:  libdvdnav-devel
102 %{?with_firewire:BuildRequires: libiec61883-devel}
103 %{?with_firewire:BuildRequires: libraw1394-devel}
104 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
105 BuildRequires:  linux-libc-headers >= 7:2.6.10
106 %{?with_lirc:BuildRequires:     lirc-devel}
107 BuildRequires:  mysql-devel
108 BuildRequires:  perl-devel
109 BuildRequires:  perl-tools-pod
110 BuildRequires:  pkgconfig
111 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
112 BuildRequires:  python-devel
113 BuildRequires:  qt4-build
114 BuildRequires:  qt4-qmake
115 BuildRequires:  rpm-perlprov >= 4.1-13
116 BuildRequires:  rpm-pythonprov
117 BuildRequires:  rpmbuild(macros) >= 1.228
118 BuildRequires:  sed >= 4.0
119 BuildRequires:  which
120 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
121 BuildRequires:  xorg-lib-libXext-devel
122 %{?with_xvmc:BuildRequires:     xorg-lib-libXvMC-devel}
123 BuildRequires:  xorg-lib-libXxf86vm-devel
124 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
125 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
126 # for Perl bindings
127 BuildRequires:  perl-ExtUtils-MakeMaker
128 Conflicts:      logrotate < 3.8.0
129 ExclusiveArch:  %{ix86} %{x8664} ppc
130 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
131
132 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
133
134 # libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
135 # libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
136 %define         skip_post_check_so      libmythavdevice.so libmythavcodec.so
137 %define         no_install_post_check_so 1
138
139 %description
140 MythTV implements the following PVR features, and more, with a unified
141 graphical interface:
142 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
143 - Video compression using RTjpeg or MPEG-4
144 - Program listing retrieval using XMLTV
145 - Themable, semi-transparent on-screen display
146 - Electronic program guide
147 - Scheduled recording of TV programs
148 - Resolution of conflicts between scheduled recordings
149 - Basic video editing
150
151 %description -l pl.UTF-8
152 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
153 ujednoliconym interfejsem graficznym:
154 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
155   przewijanie "żywej" telewizji
156 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
157 - odczyt listy programów przy użyciu XMLTV
158 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
159 - elektroniczny przewodnik po programie
160 - planowane nagrywanie programów telewizyjnych
161 - rozwiązywanie konfliktów między planowanymi nagraniami
162 - podstawowa edycja obrazu
163
164 %package backend
165 Summary:        Server component of mythtv (a PVR)
166 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
167 Group:          Applications/Multimedia
168 Requires(post,preun):   /sbin/chkconfig
169 Requires(postun):       /usr/sbin/groupdel
170 Requires(postun):       /usr/sbin/userdel
171 Requires(pre):  /bin/id
172 Requires(pre):  /usr/bin/getgid
173 Requires(pre):  /usr/sbin/groupadd
174 Requires(pre):  /usr/sbin/useradd
175 Requires:       libmyth = %{version}-%{release}
176 Requires:       mythtv = %{version}-%{release}
177 Suggests:       mysql
178 Provides:       group(mythtv)
179 Provides:       user(mythtv)
180
181 %description backend
182 MythTV provides a unified graphical interface for recording and
183 viewing television programs. Refer to the mythtv package for more
184 information.
185
186 This package contains only the server software, which provides video
187 and audio capture and encoding services. In order to be useful, it
188 requires a mythtv-frontend installation, either on the same system or
189 one reachable via the network.
190
191 %description backend -l pl.UTF-8
192 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
193 oglądania programów telewizyjnych. Więcej informacji w pakiecie
194 mythtv.
195
196 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
197 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
198 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
199 albo innym osiągalnym w sieci.
200
201 %package frontend
202 Summary:        Client component of mythtv (a PVR)
203 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
204 Group:          Applications/Multimedia
205 Requires:       libmyth = %{version}-%{release}
206 Requires:       mythtv = %{version}-%{release}
207 Requires:       mythtv-themes = %{version}-%{release}
208 Provides:       mythtv-frontend-api = %{myth_api_version}
209
210 %description frontend
211 MythTV provides a unified graphical interface for recording and
212 viewing television programs. Refer to the mythtv package for more
213 information.
214
215 This package contains only the client software, which provides a
216 front-end for playback and configuration. It requires access to a
217 mythtv-backend installation, either on the same system or one
218 reachable via the network.
219
220 %description frontend -l pl.UTF-8
221 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
222 oglądania programów telewizyjnych. Więcej informacji w pakiecie
223 mythtv.
224
225 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
226 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
227 mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
228
229 %package setup
230 Summary:        Setup the mythtv backend
231 Summary(pl.UTF-8):      Konfigurator backendu mythtv
232 Group:          Applications/Multimedia
233 Requires:       libmyth = %{version}-%{release}
234
235 %description setup
236 MythTV provides a unified graphical interface for recording and
237 viewing television programs. Refer to the mythtv package for more
238 information.
239
240 This package contains only the setup software for configuring the
241 mythtv backend.
242
243 %description setup -l pl.UTF-8
244 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
245 oglądania programów telewizyjnych. Więcej informacji w pakiecie
246 mythtv.
247
248 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
249
250 %package themes
251 Summary:        Base themes for mythtv's frontend
252 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
253 Group:          Themes
254 Requires:       %{name}-frontend = %{version}-%{release}
255
256 %description themes
257 MythTV provides a unified graphical interface for recording and
258 viewing television programs. Refer to the mythtv package for more
259 information.
260
261 This package contains only the base themes used by the frontend and
262 mythtvsetup.
263
264 %description themes -l pl.UTF-8
265 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
266 oglądania programów telewizyjnych. Więcej informacji w pakiecie
267 mythtv.
268
269 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
270 mythtvsetup.
271
272 %package -n libmyth
273 Summary:        Library providing mythtv support
274 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
275 Group:          Libraries
276 Requires:       QtSql-mysql
277 Requires:       freetype >= 1:2.0.0
278 Requires:       lame
279
280 %description -n libmyth
281 Common library code for MythTV and add-on modules (development) MythTV
282 provides a unified graphical interface for recording and viewing
283 television programs. Refer to the mythtv package for more information.
284
285 %description -n libmyth -l pl.UTF-8
286 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
287 dostarczający ujednolicony interfejs graficzny do nagrywania i
288 oglądania programów telewizyjnych. Więcej informacji w pakiecie
289 mythtv.
290
291 %package -n libmyth-devel
292 Summary:        Development files for libmyth
293 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
294 Group:          Development/Libraries
295 Requires:       libmyth = %{version}-%{release}
296
297 %description -n libmyth-devel
298 This package contains the header files for developing add-ons for
299 mythtv.
300
301 %description -n libmyth-devel -l pl.UTF-8
302 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
303
304 %package -n libmyth-static
305 Summary:        Static libmyth library
306 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
307 Group:          Development/Libraries
308 Requires:       libmyth-devel = %{version}-%{release}
309
310 %description -n libmyth-static
311 Static libmyth library.
312
313 %description -n libmyth-static -l pl.UTF-8
314 Statyczna biblioteka libmyth.
315
316 %package -n perl-MythTV
317 Summary:        MythTV Perl bindings
318 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
319 Group:          Libraries
320
321 %description -n perl-MythTV
322 MythTV Perl bindings.
323
324 %description -n perl-MythTV -l pl.UTF-8
325 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
326
327 %package -n python-MythTV
328 Summary:        MythTV Python bindings
329 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
330 Group:          Libraries
331 Requires:       python-MySQLdb
332
333 %description -n python-MythTV
334 MythTV Python bindings.
335
336 %description -n python-MythTV -l pl.UTF-8
337 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
338
339 %prep
340
341 %setup -q
342
343 %{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
344         programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
345
346 %patch0  -p1
347 %patch10 -p1
348 %{?with_dshowserver:%patch20 -p1}
349 #%patch30 -p1
350
351 rm -rf database/old # not supported in PLD
352
353 # lib64 fix - enable to update patch
354 %if %{_lib} != "lib" && 0
355 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
356 xargs grep -l /lib . | xargs sed -i -e '
357         s,/''usr/lib/,/%{_libdir}/,g
358         s,/''lib/mythtv,/%{_lib}/mythtv,g
359         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
360 '
361 exit 1
362 %endif
363
364 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
365 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
366 # prevent compiler finding libs from system when they should be looked
367 # from current buildtree.
368 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
369 # so we make QMAKE wrapper which will do sed subst after calling
370 # qmake. this is the wrapper.
371 cat > qmake-wrapper.sh <<'EOF'
372 #!/bin/sh
373 getmakefile() {
374         while [ $# -gt 0 ]; do
375                 case "$1" in
376                 -o)
377                         shift
378                         makefile="$1"
379                         return
380                         ;;
381         esac
382                 shift
383         done
384 }
385
386 qmake-qt4 "$@"
387 getmakefile "$@"
388 if [ "$makefile" ]; then
389         %{__sed} -i -e '
390                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
391                 s;-L$(QTDIR)/%{_lib};;
392         ' $makefile
393 fi
394 EOF
395 chmod +x qmake-wrapper.sh
396
397 # move perl bindings to vendor prefix
398 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
399   bindings/perl/Makefile
400
401 %build
402
403 %if %{with cpu_autodetect}
404 # Make sure we have /proc mounted
405 if [ ! -r /proc/cpuinfo ]; then
406         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
407         exit 1
408 fi
409 %endif
410
411 ./configure \
412         --prefix=%{_prefix} \
413         --libdir=%{_libdir} \
414         --libdir-name=%{_lib} \
415         --mandir=%{_mandir} \
416         --disable-distcc --disable-ccache \
417         --compile-type=%{?debug:debug}%{!?debug:release} \
418         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
419         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
420 %if %{with cpu_autodetect}
421         --enable-proc-opt \
422 %else
423         %ifarch %{ix86}
424                 %ifarch athlon
425                         --arch=athlon \
426                 %else
427                         --cpu=%{_target_cpu} --tune=pentium4 \
428                 %endif
429         %endif
430         %ifarch i386 i486 i586
431         --enable-disable-mmx-for-debugging \
432         %endif
433         %ifarch %{x8664}
434         --arch=x86_64 \
435         %endif
436         %{?with_mmx:--enable-mmx} \
437 %endif
438         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
439         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
440         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
441         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
442         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-vsync \
443         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
444         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
445         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
446         --%{?with_xvmc:en}%{!?with_xvmc:dis}able-xvmc \
447         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
448         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
449         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
450         --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
451         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
452         --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb \
453         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
454         --enable-xv \
455         --enable-x11 \
456
457 #%{_libdir}/qt4/bin/qmake mythtv.pro
458 %{__make}
459
460 %install
461 rm -rf $RPM_BUILD_ROOT
462 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
463                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
464                 $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
465                 $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
466                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
467                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
468                 $RPM_BUILD_ROOT%{_pixmapsdir}
469
470 %{__make} install \
471         INSTALL_ROOT=$RPM_BUILD_ROOT
472
473 # Install the files that we added on top of mythtv's own stuff
474 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
475 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
476 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
477 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
478
479 # desktop entries
480 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
481 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
482
483 # Install settings.pro so people can see the build options we used
484 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
485 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
486
487 for p in mythfrontend; do
488         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
489                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
490         done > $p.lang
491 done
492
493 # glibc language codes. attempt was made to change it on libmyth side,
494 # but that was just asking for trouble due large coverage of
495 # language.lower() usage.
496 sed -i -e '
497 s,%%lang(en_gb),%%lang(en_GB),
498 s,%%lang(zh_tw),%%lang(zh_TW),
499 s,%%lang(pt_br),%%lang(pt_BR),
500 ' *.lang
501
502 rm -rf mythtvosd mythwelcome mythlcdserver
503 install -d mythtvosd mythwelcome
504 cp -a programs/mythtvosd/{README,*.xml} mythtvosd
505 cp -a programs/mythwelcome/README mythwelcome
506 cp -a programs/mythlcdserver/README mythlcdserver
507
508 %clean
509 rm -rf $RPM_BUILD_ROOT
510
511 %pre backend
512 %groupadd -g 149 %{name}
513 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
514 %addusertogroup %{name} video
515 %addusertogroup %{name} audio
516
517 %post backend
518 /sbin/chkconfig --add mythbackend
519
520 %preun backend
521 if [ "$1" = "0" ]; then
522         %service -q mythbackend stop
523         /sbin/chkconfig --del mythbackend
524 fi
525
526 %postun backend
527 if [ "$1" = "0" ]; then
528         %userremove %{name}
529         %groupremove %{name}
530 fi
531
532 %post   -n libmyth -p /sbin/ldconfig
533 %postun -n libmyth -p /sbin/ldconfig
534
535 %post setup
536 if [ "$1" = 1 ]; then
537 %banner -e %{name}-setup <<EOF
538 To grant mysql permissions to mythtv, please run
539 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
540 EOF
541 fi
542
543 %files
544 %defattr(644,root,root,755)
545 %doc README* UPGRADING AUTHORS FAQ
546 %doc docs contrib config
547 %doc keys.txt mythtvosd mythwelcome mythlcdserver
548
549 %files backend
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_sbindir}/mythbackend
552 %attr(755,root,root) %{_sbindir}/mythcommflag
553 %attr(755,root,root) %{_bindir}/mythfilldatabase
554 %attr(755,root,root) %{_sbindir}/mythjobqueue
555 %attr(755,root,root) %{_sbindir}/mythlcdserver
556 %attr(755,root,root) %{_bindir}/mythtranscode
557 %attr(755,root,root) %{_bindir}/mythreplex
558 %attr(775,root,mythtv) %dir /var/lib/mythtv
559 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
560 %attr(775,root,mythtv) %dir /var/cache/mythtv
561 %attr(775,root,mythtv) %dir /var/run/mythtv
562 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
565 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
566
567 %files frontend -f mythfrontend.lang
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_bindir}/mythfrontend
570 %attr(755,root,root) %{_bindir}/mythshutdown
571 %attr(755,root,root) %{_bindir}/mythavtest
572 %attr(755,root,root) %{_bindir}/mythtvosd
573 %attr(755,root,root) %{_bindir}/mythwelcome
574 %dir %{_datadir}/mythtv
575 %dir %{_datadir}/mythtv/themes
576 %dir %{_libdir}/mythtv
577 %{_datadir}/mythtv/*.xml
578 %dir %{_libdir}/mythtv/filters
579 %dir %{_libdir}/mythtv/plugins
580 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
581 %{_datadir}/mythtv/fonts/*.ttf
582 %dir %{_datadir}/mythtv/i18n
583 %if %{with dshowserver}
584 %{_datadir}/mythtv/dshowcodecs
585 %endif
586 %{_desktopdir}/*.desktop
587 %{_pixmapsdir}/*.png
588
589 %files setup
590 %defattr(644,root,root,755)
591 %doc database
592 %attr(755,root,root) %{_bindir}/mythtv-setup
593
594 %files themes
595 %defattr(644,root,root,755)
596 %{_datadir}/mythtv/themes/*
597
598 %files -n libmyth
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/lib*.so*
601 %attr(755,root,root) %{_libdir}/lib*.a
602 %{_datadir}/mythtv/*.pl
603
604 %files -n libmyth-devel
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/*.so
607 %{_includedir}/*
608 %{_datadir}/mythtv/build
609
610 %files -n libmyth-static
611 %defattr(644,root,root,755)
612
613 %if %{with perl}
614 %files -n perl-MythTV
615 %defattr(644,root,root,755)
616 %{perl_vendorlib}/MythTV.pm
617 %dir %{perl_vendorlib}/MythTV
618 %{perl_vendorlib}/MythTV/*.pm
619 %dir %{perl_vendorlib}/IO/Socket/INET
620 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
621 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
622 %endif
623
624 %if %{with python}
625 %files -n python-MythTV
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_bindir}/mythpython
628 %dir %{py_sitescriptdir}/MythTV
629 %{py_sitescriptdir}/MythTV/*
630 %{py_sitescriptdir}/*.egg-info
631 %endif
This page took 0.109357 seconds and 3 git commands to generate.