]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- updated to 0.23; new plugin - mythnetvision; mythflix removed
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_without  mythvideo       # disable building mythgallery plugin
14 %bcond_without  mythweather     # building mythgallery plugin disabled by default
15                                 # it looks unusable "due to msnbc webpage structure change
16 %bcond_without  mythweb         # disable building mythgallery plugin
17 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
18
19 %if !%{with binary}
20 %undefine       with_mytharchive
21 %undefine       with_mythbrowser
22 %undefine       with_mythmovies
23 %undefine       with_mythdvd
24 %undefine       with_mythnetvision
25 %undefine       with_mythgallery
26 %undefine       with_mythgame
27 %undefine       with_mythmusic
28 %undefine       with_mythnews
29 %undefine       with_mythvideo
30 %undefine       with_mythweather
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34
35 #%define fix     24635
36
37 Summary:        Main MythTV plugins
38 Summary(pl.UTF-8):      Główne wtyczki MythTV
39 Name:           mythplugins
40 Version:        0.23
41 #Release:       fix%{fix}.1
42 Release:        0.1
43 License:        GPL v2
44 Group:          Applications/Multimedia
45 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
46 # Source0-md5:  be44db841f9e03d0d17ab449545b38aa
47 Source1:        mythweb.conf
48 #Patch0: %{name}-lib64.patch
49 #Patch1: %{name}-paths.patch
50 Patch2:         mythweb-chdir.patch
51 Patch20:        %{name}-mytharchive-INT64.patch
52 #Patch21:       mythmusic_fftw3.patch
53 #Patch100:      mythtv-branch.diff
54 URL:            http://www.mythtv.org/
55 %if %{with binary}
56 %if %{with mythgallery} || %{with myhtmusic}
57 BuildRequires:  OpenGL-devel
58 %endif
59 BuildRequires:  Qt3Support-devel
60 BuildRequires:  QtCore-devel
61 BuildRequires:  QtGui-devel
62 BuildRequires:  QtNetwork-devel
63 BuildRequires:  QtOpenGL-devel
64 BuildRequires:  QtSql-devel
65 BuildRequires:  QtWebKit-devel
66 BuildRequires:  QtXml-devel
67 BuildRequires:  SDL-devel
68 BuildRequires:  a52dec-libs-devel
69 BuildRequires:  cdparanoia-III-devel
70 BuildRequires:  faad2-devel >= 2.0-5.2
71 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
72 BuildRequires:  flac-devel >= 1.0.4
73 BuildRequires:  freetype-devel
74 BuildRequires:  libcdaudio-devel >= 0.99.12p2
75 BuildRequires:  libdvdcss-devel >= 1.2.7
76 BuildRequires:  libdvdread-devel >= 0.9.4
77 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
78 BuildRequires:  libfame-devel >= 0.9.0
79 BuildRequires:  libid3tag-devel
80 BuildRequires:  libmad-devel
81 BuildRequires:  libmyth-devel > 0.21
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  libtiff-devel
84 BuildRequires:  libvorbis-devel >= 1:1.0
85 BuildRequires:  mjpegtools-devel >= 1.6.1
86 BuildRequires:  nasm
87 BuildRequires:  patchutils
88 BuildRequires:  qt4-build
89 BuildRequires:  qt4-qmake
90 BuildRequires:  rpm-perlprov >= 4.1-13
91 BuildRequires:  sed >= 4.0
92 %{?with_mythmusic:BuildRequires:        taglib-devel}
93 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xvid-devel >= 1:0.9.1
96 BuildRequires:  zlib-devel
97 %endif
98 %{?with_mytharchive:Requires:   mytharchive}
99 %{?with_mythbrowser:Requires:   mythbrowser}
100 %{?with_mythdvd:Requires:       mythdvd}
101 %{?with_mythnetvision:Requires: mythnetvision}
102 %{?with_mythgallery:Requires:   mythgallery}
103 %{?with_mythgame:Requires:      mythgame}
104 %{?with_mythmysic:Requires:     mythmusic}
105 %{?with_mythnews:Requires:      mythnews}
106 %{?with_mythvideo:Requires:     mythvideo}
107 %{?with_mythweather:Requires:   mythweather}
108 %{?with_mythweb:Requires:       mythweb}
109 ExclusiveArch:  %{ix86} %{x8664} ppc
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
113 %define         _webapps        /etc/webapps
114 %define         _webapp         mythweb
115
116 %description
117 This is a consolidation of all the official MythTV plugins that used
118 to be distributed as separate downloads from mythtv.org.
119
120 %description -l pl.UTF-8
121 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
122 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
123
124 %package -n mytharchive
125 Summary:        A MythTV module to create and burn DVDs
126 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
127 Group:          Applications/Multimedia
128 Requires:       dvdauthor
129 Requires:       mjpegtools
130 Requires:       mythtv-frontend-api = %{myth_api_version}
131 Requires:       python-MySQLdb
132 Requires:       python-PIL
133 Suggests:       dvdrtools-mkisofs
134
135 %description -n mytharchive
136 MythArchive is a MythTV style plugin that uses the Mythburn Script to
137 create and burn DVDs from MythTV recordings, MythVideo files or any
138 video files available on a MythTV system. It can also export
139 recordings to a native archive format that can then be imported back
140 into a MythTV system restoring all the associated metadata.
141
142 %description -n mytharchive -l pl.UTF-8
143 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
144 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
145 innych plików z filmami dostępnych w systemie MythTV. Może także
146 eksportować nagrania do natywnego formatu archiwum, który potem można
147 zaimportować z powrotem do systemu MythTV przywracając wszystkie
148 związane z nimi metadane.
149
150 %package -n mythmusic
151 Summary:        The music player add-on module for MythTV
152 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
153 Group:          Applications/Multimedia
154 BuildRequires:  libvisual-devel
155 Requires:       mythtv-frontend-api = %{myth_api_version}
156
157 %description -n mythmusic
158 Music add-on for MythTV.
159
160 %description -n mythmusic -l pl.UTF-8
161 Odtwarzacz muzyki dla MythTV.
162
163 %package -n mythvideo
164 Summary:        A generic video player frontend module for MythTV
165 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
166 Group:          Applications/Multimedia
167 Requires:       mplayer
168 Requires:       mythtv-frontend-api = %{myth_api_version}
169
170 %description -n mythvideo
171 A generic video and dvd player frontend module for MythTV.
172
173 %description -n mythvideo -l pl.UTF-8
174 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
175
176 %package -n mythweather
177 Summary:        A MythTV module that displays a weather forcast
178 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
179 Group:          Applications/Multimedia
180 Requires:       mythtv-frontend-api = %{myth_api_version}
181
182 %description -n mythweather
183 A MythTV module that displays a weather forcast.
184
185 %description -n mythweather -l pl.UTF-8
186 Moduł MythTV wyświetlający prognozę pogody.
187
188 %package -n mythgallery
189 Summary:        A gallery/slideshow module for MythTV
190 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
191 Group:          Applications/Multimedia
192 Requires:       mythtv-frontend-api = %{myth_api_version}
193
194 %description -n mythgallery
195 A gallery/slideshow module for MythTV.
196
197 %description -n mythgallery -l pl.UTF-8
198 Moduł galerii/pokazu slajdów dla MythTV.
199
200 %package -n mythgame
201 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
202 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
203 Group:          Applications/Multimedia
204 Requires:       mythtv-frontend-api = %{myth_api_version}
205
206 %description -n mythgame
207 A game frontend (xmame, nes, snes, pc) for MythTV.
208
209 %description -n mythgame -l pl.UTF-8
210 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
211
212 %package -n mythdvd
213 Summary:        A DVD ripper module for MythTV
214 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
215 Group:          Applications/Multimedia
216 Requires:       mythtv-frontend-api = %{myth_api_version}
217 Requires:       mythvideo
218 Requires:       transcode >= 0.6.8
219
220 %description -n mythdvd
221 MythDVD is a MythTV module that allows you to rip DVD's and transcode
222 their video and audio content to other (generally smaller) formats.
223 The playing features are simply myth-style wrappers for your favourite
224 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
225 based on and derived from the excellent transcode package.
226
227 %description -n mythdvd -l pl.UTF-8
228 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
229 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
230 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
231 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
232 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
233 pakietu transcode.
234
235 %package -n mythnews
236 Summary:        A RSS News Feed plugin for MythTV
237 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
238 Group:          Applications/Multimedia
239 Requires:       mythtv-frontend-api = %{myth_api_version}
240
241 %description -n mythnews
242 A RSS News Feed plugin for MythTV.
243
244 %description -n mythnews -l pl.UTF-8
245 Wtyczka czytnika nowinek RSS dla MythTV.
246
247 %package -n mythbrowser
248 Summary:        A small web browser module for MythTV
249 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
250 Group:          Applications/Multimedia
251 Requires:       mythtv-frontend-api = %{myth_api_version}
252
253 %description -n mythbrowser
254 MythBrowser is a full fledged web-browser (multiple tabs) to display
255 webpages in full-screen mode. Simple page navigation is possible.
256 Starting with version 0.13 it also has full support for mouse driven
257 navigation (right mouse opens and closes the popup menu).
258
259 MythBrowser also contains a BookmarkManager to manage the website
260 links in a simple mythplugin.
261
262 %description -n mythbrowser -l pl.UTF-8
263 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
264 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
265 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
266 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
267 menu).
268
269 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
270 do stron w prostej wtyczce myth.
271
272 %package -n mythweb
273 Summary:        The web interface to MythTV
274 Summary(pl.UTF-8):      Interfejs WWW do MythTV
275 Group:          Applications/Multimedia
276 Requires:       php(mysql)
277 Requires:       php(posix)
278 Requires:       webapps
279 Requires:       webserver(php) >= 4.3
280 #Suggests:      apache(mod_auth)
281 #Suggests:      apache(mod_env)
282
283 %description -n mythweb
284 The web interface to MythTV.
285
286 %description -n mythweb -l pl.UTF-8
287 Interfejs WWW do MythTV.
288
289 %package -n mythnetvision
290 Summary:        Mythtv extension to watch network movie shows
291 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
292 Group:          Applications/Multimedia
293 Requires:       mythtv-frontend-api = %{myth_api_version}
294
295 %description -n mythnetvision
296 Mythtv extension to watch network movie shows (ex. YouTube).
297
298 %description -n mythnetvision -l pl.UTF-8
299 Dodatek do MythTV do oglądania sieciowych transmisji.
300 Na przykład z YouTube.
301
302 %package -n mythmovies
303 Summary:        MythTV cinemas timetable
304 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
305 Group:          Applications/Multimedia
306 Requires:       mythtv-frontend-api = %{myth_api_version}
307
308 %description -n mythmovies
309 MythTV cinemas timetable.
310
311
312 %description -n mythmovies -l pl.UTF-8
313 Moduł MythTV do repertuaru kinowego.
314
315 %package -n mythzoneminder
316 Summary:        MythTV security TV manager
317 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
318 Group:          Applications/Multimedia
319 Requires:       mythtv-frontend-api = %{myth_api_version}
320
321 %description -n mythzoneminder
322 MythTV security TV manager.
323
324
325 %description -n mythzoneminder -l pl.UTF-8
326 Obsługa kamer przemysłowych dla MythTV.
327
328 %prep
329 %setup -q -n %{name}-%{version}
330 #%if %{_lib} != "lib"
331 #%patch0 -p1
332 #%endif
333 #%patch1 -p1
334 %patch2 -p1
335 %patch20 -p1
336 #%patch21 -p1
337 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
338
339 # make it visible
340 #mv mythweb/data/{.,}htaccess
341
342 # lib64 fix - enable to update patch
343 %if %{_lib} != "lib" && 0
344 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
345 xargs grep -l /lib/ . | xargs sed -i -e '
346         s,/usr/lib/,/%{_lib}/,g
347         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
348 '
349 exit 1
350 %endif
351
352 %build
353 %if %{with binary}
354 export QTDIR="%{_prefix}"
355 # Not gnu configure
356 %configure \
357         --libdir-name=`basename %{_lib}` \
358         --enable-all \
359         %{!?with_mytharchive:--disable-mytharchive} \
360         %{!?with_mythbrowser:--disable-mythbrowser} \
361         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
362         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
363         %{!?with_mythgame:--disable-mythgame} \
364         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
365         %{!?with_mythnews:--disable-mythnews} \
366         %{!?with_mythvideo:--disable-mythvideo} \
367         %{!?with_mythweather:--disable-mythweather} \
368         %{!?with_mythweb:--disable-mythweb} \
369         %{!?with_mythmovies:--disable-mythmovies} \
370         %{!?with_mythnetvision:--disable-mythnetvision} \
371
372 mv mythconfig.mak mythconfig.mak.old
373 cp mythconfig.mak.old mythconfig.mak
374 cat <<'EOF'>> mythconfig.mak
375 QMAKE_CXX=%{__cxx}
376 QMAKE_CC=%{__cc}
377 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
378 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
379 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
380 EOF
381
382 %{__make}
383 %endif
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387 %if %{with binary}
388 export QTDIR="%{_prefix}"
389 %{__make} install \
390         INSTALL_ROOT=$RPM_BUILD_ROOT
391
392 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
393 %if %{with mythgame}
394 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
395 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
396 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
397 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
398 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
399 %endif
400 %endif
401
402 %if %{with mythweb}
403 cd mythweb
404 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
405 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
406 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
407 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
408 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/data
409 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
410 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
411 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
412 cd -
413 %endif
414
415 rm -f $RPM_BUILD_ROOT%{_datadir}/data
416 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
417 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
418         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
419                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
420         done > $p.lang
421 done
422
423 %clean
424 rm -rf $RPM_BUILD_ROOT
425
426 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
427 %webapp_register apache %{_webapp}
428
429 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
430 %webapp_unregister apache %{_webapp}
431
432 %triggerin -n mythweb -- apache < 2.2.0, apache-base
433 %webapp_register httpd %{_webapp}
434
435 %triggerun -n mythweb -- apache < 2.2.0, apache-base
436 %webapp_unregister httpd %{_webapp}
437
438 %triggerpostun -n mythweb -- mythweb < 0.19
439 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
440         if [ -f /etc/mythweb/$i.rpmsave ]; then
441                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
442                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
443         fi
444 done
445 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
446
447 # migrate from apache-config macros
448 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
449         if [ -d /etc/apache/webapps.d ]; then
450                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
451                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
452         fi
453
454         if [ -d /etc/httpd/webapps.d ]; then
455                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
456                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
457         fi
458         rm -f /etc/mythweb/apache.conf.rpmsave
459 fi
460
461 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
462         rm -f /etc/apache/conf.d/99_mythplugins.conf
463         /usr/sbin/webapp register apache %{_webapp}
464         %service -q apache reload
465 fi
466 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
467         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
468         /usr/sbin/webapp register httpd %{_webapp}
469         %service -q httpd reload
470 fi
471
472 %files
473 %defattr(644,root,root,755)
474
475 %if %{with mytharchive}
476 %files -n mytharchive -f mytharchive.lang
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_bindir}/mytharchivehelper
479 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
480 %{_datadir}/mythtv/archivemenu.xml
481 %{_datadir}/mythtv/archiveutils.xml
482 %{_datadir}/mythtv/themes/default/ma_*.png
483 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
484 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
485 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
486 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
487 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
488 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
489 %{_datadir}/mythtv/mytharchive
490 %endif
491
492 %if %{with mythmusic}
493 %files -n mythmusic -f mythmusic.lang
494 %defattr(644,root,root,755)
495 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
496 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
497 /var/lib/mythmusic
498 %{_datadir}/mythtv/musicmenu.xml
499 %{_datadir}/mythtv/music_settings.xml
500 %{_datadir}/mythtv/themes/default/music-ui.xml
501 %{_datadir}/mythtv/themes/default/mm-titlelines.png
502 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
503 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
504 %{_datadir}/mythtv/themes/default/ff_button_off.png
505 %{_datadir}/mythtv/themes/default/ff_button_on.png
506 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
507 %{_datadir}/mythtv/themes/default/miniplayer_background.png
508 %{_datadir}/mythtv/themes/default/mm_*.png
509 %{_datadir}/mythtv/themes/default/music-sel-bg.png
510 %{_datadir}/mythtv/themes/default/next_button_off.png
511 %{_datadir}/mythtv/themes/default/next_button_on.png
512 %{_datadir}/mythtv/themes/default/next_button_pushed.png
513 %{_datadir}/mythtv/themes/default/pause_button_off.png
514 %{_datadir}/mythtv/themes/default/pause_button_on.png
515 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
516 %{_datadir}/mythtv/themes/default/play_button_off.png
517 %{_datadir}/mythtv/themes/default/play_button_on.png
518 %{_datadir}/mythtv/themes/default/play_button_pushed.png
519 %{_datadir}/mythtv/themes/default/prev_button_off.png
520 %{_datadir}/mythtv/themes/default/prev_button_on.png
521 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
522 %{_datadir}/mythtv/themes/default/rew_button_off.png
523 %{_datadir}/mythtv/themes/default/rew_button_on.png
524 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
525 %{_datadir}/mythtv/themes/default/selectionbar.png
526 %{_datadir}/mythtv/themes/default/stop_button_off.png
527 %{_datadir}/mythtv/themes/default/stop_button_on.png
528 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
529 %{_datadir}/mythtv/themes/default/track_info_background.png
530 %{_datadir}/mythtv/themes/default-wide/mm_*.png
531 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
532 %endif
533
534 %if %{with mythvideo}
535 %files -n mythvideo -f mythvideo.lang
536 %defattr(644,root,root,755)
537 %doc mythvideo/README mythvideo/videodb
538 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
539 %{_datadir}/mythtv/themes/default/video-ui.xml
540 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
541 %{_datadir}/mythtv/themes/default/mv_*.png
542 %{_datadir}/mythtv/themes/default-wide/mv_*.png
543 %{_datadir}/mythtv/video_settings.xml
544 %{_datadir}/mythtv/videomenu.xml
545 %dir %{_datadir}/mythtv/mythvideo
546 %dir %{_datadir}/mythtv/mythvideo/scripts
547 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
548 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
549 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
550 %{_datadir}/mythtv/mythvideo/scripts/README
551 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
552 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
553 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
554 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
555 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
556 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
557 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Television/*
558 /var/lib/mythvideo
559 %endif
560
561 %if %{with mythweather}
562 %files -n mythweather -f mythweather.lang
563 %defattr(644,root,root,755)
564 %doc mythweather/README
565 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
566 %{_datadir}/mythtv/mythweather
567 %{_datadir}/mythtv/weather_settings.xml
568 %{_datadir}/mythtv/themes/default/weather-ui.xml
569 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
570 %{_datadir}/mythtv/themes/default/cloudy.png
571 %{_datadir}/mythtv/themes/default/fair.png
572 %{_datadir}/mythtv/themes/default/flurries.png
573 %{_datadir}/mythtv/themes/default/fog.png
574 %{_datadir}/mythtv/themes/default/logo.png
575 %{_datadir}/mythtv/themes/default/lshowers.png
576 %{_datadir}/mythtv/themes/default/mcloudy.png
577 %{_datadir}/mythtv/themes/default/mw_*.png
578 %{_datadir}/mythtv/themes/default/mwmain.png
579 %{_datadir}/mythtv/themes/default/pcloudy.png
580 %{_datadir}/mythtv/themes/default/rainsnow.png
581 %{_datadir}/mythtv/themes/default/showers.png
582 %{_datadir}/mythtv/themes/default/snowshow.png
583 %{_datadir}/mythtv/themes/default/sunny.png
584 %{_datadir}/mythtv/themes/default/thunshowers.png
585 %{_datadir}/mythtv/themes/default/unknown.png
586 %{_datadir}/mythtv/themes/default-wide/mw-*.png
587 %endif
588
589 %if %{with mythgallery}
590 %files -n mythgallery -f mythgallery.lang
591 %defattr(644,root,root,755)
592 %doc mythgallery/README
593 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
594 %{_datadir}/mythtv/themes/default/gallery-ui.xml
595 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
596 %{_datadir}/mythtv/themes/default/gallery-*.png
597 # FIXME: this is definately stupid path
598 /var/lib/pictures
599 %endif
600
601 %if %{with mythgame}
602 %files -n mythgame -f mythgame.lang
603 %defattr(644,root,root,755)
604 #%doc mythgame/README
605 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
606 %{_datadir}/mythtv/games
607 %{_datadir}/mythtv/game_settings.xml
608 %{_datadir}/mythtv/themes/default/game-ui.xml
609 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
610 %endif
611
612 %if %{with mythdvd}
613 %files -n mythdvd
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_bindir}/mtd
616 %{_datadir}/mythtv/themes/default/dvd-ui.xml
617 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
618 %{_datadir}/mythtv/themes/default/md_*.png
619 %endif
620
621 %if %{with mythnews}
622 %files -n mythnews -f mythnews.lang
623 %defattr(644,root,root,755)
624 %doc mythnews/README mythnews/AUTHORS
625 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
626 %{_datadir}/mythtv/mythnews
627 %{_datadir}/mythtv/themes/default/news-ui.xml
628 # DUPLICATE WITH MYTHFLIX?
629 %{_datadir}/mythtv/themes/default/news-info-bg.png
630 %{_datadir}/mythtv/themes/default/enclosures.png
631 %{_datadir}/mythtv/themes/default/need-download.png
632 %{_datadir}/mythtv/themes/default/podcast.png
633 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
634 %endif
635
636 %if %{with mythbrowser}
637 %files -n mythbrowser -f mythbrowser.lang
638 %defattr(644,root,root,755)
639 %doc mythbrowser/README mythbrowser/AUTHORS
640 #%attr(755,root,root) %{_bindir}/mythbrowser
641 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
642 %{_datadir}/mythtv/themes/default/mb_progress*.png
643 %{_datadir}/mythtv/themes/default/browser-ui.xml
644 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
645 %endif
646
647 %if %{with mythweb}
648 %files -n mythweb
649 %defattr(644,root,root,755)
650 %doc mythweb/README mythweb/mythweb.conf.lighttpd
651 #%doc mythweb/data/htaccess
652 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
654 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
655 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
656 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
657 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
658 %{_datadir}/mythweb
659 %dir %attr(771,root,http) /var/cache/mythweb
660 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
661 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
662 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
663 %endif
664
665 %if %{with mythnetvision}
666 %files -n mythnetvision -f mythnetvision.lang
667 %defattr(644,root,root,755)
668 %doc mythnetvision/{AUTHORS,ChangeLog,README}
669 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
670 %dir %{_datadir}/mythtv/mythnetvision
671 %{_datadir}/mythtv/netvisionmenu.xml
672 %dir %{_datadir}/mythtv/mythnetvision/scripts
673 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
674 %dir %{_datadir}/mythtv/mythnetvision/icons
675 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
676 %{_datadir}/mythtv/mythnetvision/icons/*.png
677 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
678 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
679 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
680 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
681 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
682 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
683 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
684 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml   
685 %{_datadir}/mythtv/themes/default/netvision-ui.xml
686 %endif
687
688 %if %{with mythmovies}
689 %files -n mythmovies
690 %defattr(644,root,root,755)
691 #-f mythmovies.lang
692 %defattr(644,root,root,755)
693 %doc mythmovies/{README,TODO}
694 %attr(755,root,root) %{_bindir}/ignyte
695 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
696 %{_datadir}/mythtv/themes/default/movies-ui.xml
697 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
698 %{_datadir}/mythtv/i18n/mythmovies_*.qm
699 %endif
700
701 %if %{with mythzoneminder}
702 %files -n mythzoneminder
703 %defattr(644,root,root,755)
704 #-f mythmovies.lang
705 %defattr(644,root,root,755)
706 %doc mythzoneminder/{AUTHORS,README}
707 %attr(755,root,root) %{_bindir}/mythzmserver
708 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
709 %dir %{_datadir}/mythtv/zonemindermenu.xml
710 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
711 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
712 %{_datadir}/mythtv/themes/default/mz_*png
713 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
714 %endif
This page took 5.505448 seconds and 4 git commands to generate.