]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- merged 0.19 from DEVEL
[packages/mythplugins.git] / mythplugins.spec
1 # Conditional build:
2 %bcond_without  binary          # skip building binary plugins (build only mythweb)
3 %bcond_without  mythbrowser     # disable building mythbrowser plugin
4 %bcond_without  mythdvd         # disable building mythgallery plugin
5 %bcond_without  mythgallery     # disable building mythgallery plugin
6 %bcond_without  mythgame        # disable building mythgallery plugin
7 %bcond_without  mythmusic       # disable building mythmusic plugin
8 %bcond_without  mythnews        # disable building mythgallery plugin
9 %bcond_without  mythphone       # disable building mythgallery plugin
10 %bcond_without  mythvideo       # disable building mythgallery plugin
11 %bcond_without  mythweather     # disable building mythgallery plugin
12 %bcond_without  mythweb         # disable building mythgallery plugin
13 %bcond_without  mythflix        # disable building mythflix plugin
14 %bcond_without  mythcontrols    # disable mythcontrols plugin
15 #
16 %if %{without binary}
17 %undefine       with_mythbrowser
18 %undefine       with_mythdvd
19 %undefine       with_mythgallery
20 %undefine       with_mythgame
21 %undefine       with_mythmusic
22 %undefine       with_mythnews
23 %undefine       with_mythphone
24 %undefine       with_mythvideo
25 %undefine       with_mythweather
26 %undefine       with_mythcontrols
27 %undefine       with_mythflix
28 %endif
29
30 %include        /usr/lib/rpm/macros.perl
31
32 Summary:        Main MythTV plugins
33 Summary(pl):    G³ówne wtyczki MythTV
34 Name:           mythplugins
35 Version:        0.19
36 Release:        1
37 License:        GPL v2
38 Group:          Applications/Multimedia
39 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
40 # Source0-md5:  201d60d5d60222038d8c97831f7e4288
41 Source1:        mythweb.conf
42 Patch0:         %{name}-lib64.patch
43 Patch1:         %{name}-paths.patch
44 Patch2:         mythweb-config.patch
45 URL:            http://www.mythtv.org/
46 %if %{with binary}
47 %if %{with mythgallery} || %{with myhtmusic}
48 BuildRequires:  OpenGL-devel
49 %endif
50 BuildRequires:  SDL-devel
51 BuildRequires:  XFree86-devel
52 BuildRequires:  a52dec-libs-devel
53 BuildRequires:  cdparanoia-III-devel
54 BuildRequires:  faad2-devel >= 2.0-5.2
55 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
56 BuildRequires:  flac-devel >= 1.0.4
57 BuildRequires:  freetype-devel
58 BuildRequires:  kdelibs-devel
59 BuildRequires:  libcdaudio-devel >= 0.99.12p2
60 BuildRequires:  libdvdcss-devel >= 1.2.7
61 BuildRequires:  libdvdread-devel >= 0.9.4
62 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
63 BuildRequires:  libfame-devel >= 0.9.0
64 BuildRequires:  libid3tag-devel
65 BuildRequires:  libmad-devel
66 BuildRequires:  libmyth-devel >= 0.19
67 BuildRequires:  libstdc++-devel
68 BuildRequires:  libtiff-devel
69 BuildRequires:  libvorbis-devel >= 1:1.0
70 BuildRequires:  mjpegtools-devel >= 1.6.1
71 BuildRequires:  nasm
72 BuildRequires:  rpm-perlprov >= 4.1-13
73 BuildRequires:  sed >= 4.0
74 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
75 BuildRequires:  xvid-devel >= 1:0.9.1
76 BuildRequires:  zlib-devel
77 %endif
78 %{?with_mythbrowser:Requires:   mythbrowser}
79 %{?with_mythdvd:Requires:       mythdvd}
80 %{?with_mythflix:Requires:      mythflix}
81 %{?with_mythgallery:Requires:   mythgallery}
82 %{?with_mythgame:Requires:      mythgame}
83 %{?with_mythmysic:Requires:     mythmusic}
84 %{?with_mythnews:Requires:      mythnews}
85 %{?with_mythphone:Requires:     mythphone}
86 %{?with_mythvideo:Requires:     mythvideo}
87 %{?with_mythweather:Requires:   mythweather}
88 %{?with_mythweb:Requires:       mythweb}
89 ExclusiveArch:  %{ix86} %{x8664}
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
93 %define         _webapps        /etc/webapps
94 %define         _webapp         mythweb
95
96 %description
97 This is a consolidation of all the official MythTV plugins that used
98 to be distributed as separate downloads from mythtv.org.
99
100 %description -l pl
101 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które by³y
102 wcze¶niej rozpowszechniane jako osobne pakiety na mythtv.org.
103
104 %package -n mythmusic
105 Summary:        The music player add-on module for MythTV
106 Summary(pl):    Modu³ odtwarzacza muzyki dla MythTV
107 Group:          Applications/Multimedia
108 Requires:       mythtv-frontend-api = %{myth_api_version}
109
110 %description -n mythmusic
111 Music add-on for MythTV.
112
113 %description -n mythmusic -l pl
114 Odtwarzacz muzyki dla MythTV.
115
116 %package -n mythvideo
117 Summary:        A generic video player frontend module for MythTV
118 Summary(pl):    Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV
119 Group:          Applications/Multimedia
120 Requires:       mplayer
121 Requires:       mythtv-frontend-api = %{myth_api_version}
122
123 %description -n mythvideo
124 A generic video player frontend module for MythTV.
125
126 %description -n mythvideo -l pl
127 Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV.
128
129 %package -n mythweather
130 Summary:        A MythTV module that displays a weather forcast
131 Summary(pl):    Modu³ MythTV wy¶wietlaj±cy prognozê pogody
132 Group:          Applications/Multimedia
133 Requires:       mythtv-frontend-api = %{myth_api_version}
134
135 %description -n mythweather
136 A MythTV module that displays a weather forcast.
137
138 %description -n mythweather -l pl
139 Modu³ MythTV wy¶wietlaj±cy prognozê pogody.
140
141 %package -n mythgallery
142 Summary:        A gallery/slideshow module for MythTV
143 Summary(pl):    Modu³ galerii/pokazu slajdów dla MythTV
144 Group:          Applications/Multimedia
145 Requires:       mythtv-frontend-api = %{myth_api_version}
146
147 %description -n mythgallery
148 A gallery/slideshow module for MythTV.
149
150 %description -n mythgallery -l pl
151 Modu³ galerii/pokazu slajdów dla MythTV.
152
153 %package -n mythgame
154 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
155 Summary(pl):    Interfejs do gier (xmame, nes, snes, pc) dla MythTV
156 Group:          Applications/Multimedia
157 Requires:       mythtv-frontend-api = %{myth_api_version}
158
159 %description -n mythgame
160 A game frontend (xmame, nes, snes, pc) for MythTV.
161
162 %description -n mythgame -l pl
163 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
164
165 %package -n mythdvd
166 Summary:        A DVD player module for MythTV
167 Summary(pl):    Modu³ odtwarzacza DVD dla MythTV
168 Group:          Applications/Multimedia
169 Requires:       mythtv-frontend-api = %{myth_api_version}
170 Requires:       transcode >= 0.6.8
171
172 %description -n mythdvd
173 MythDVD is a MythTV module that allows you to play DVDs on a myth-box
174 and (optionally) rip DVD's and transcode their video and audio content
175 to other (generally smaller) formats. The playing features are simply
176 myth-style wrappers for your favourite DVD playing software (mplayer,
177 ogle, xine, etc). The transcoding is based on and derived from the
178 excellent transcode package.
179
180 %description -n mythdvd -l pl
181 MythDVD to modu³ MythTV umo¿liwiaj±cy odtwarzanie p³yt DVD w MythTV i
182 (opcjonalnie) rippowanie ich oraz przekodowywanie obrazu i d¼wiêku do
183 innych (zwykle mniej zajmuj±cych) formatów. Mo¿liwo¶ci odtwarzania to
184 po prostu obudowanie w stylu myth dla ulubionego oprogramowania do
185 odtwarzania DVD (mplayer, ogle, xine itp.). Przekodowywanie jest
186 oparte i wywodzi siê z wspania³ego pakietu transcode.
187
188 %package -n mythnews
189 Summary:        A RSS News Feed plugin for MythTV
190 Summary(pl):    Wtyczka czytnika nowinek RSS dla MythTV
191 Group:          Applications/Multimedia
192 Requires:       mythtv-frontend-api = %{myth_api_version}
193
194 %description -n mythnews
195 A RSS News Feed plugin for MythTV.
196
197 %description -n mythnews -l pl
198 Wtyczka czytnika nowinek RSS dla MythTV.
199
200 %package -n mythbrowser
201 Summary:        A small web browser module for MythTV
202 Summary(pl):    Modu³ ma³ej przegl±darki WWW dla MythTV
203 Group:          Applications/Multimedia
204 Requires:       mythtv-frontend-api = %{myth_api_version}
205
206 %description -n mythbrowser
207 MythBrowser is a full fledged web-browser (multiple tabs) to display
208 webpages in full-screen mode. Simple page navigation is possible.
209 Starting with version 0.13 it also has full support for mouse driven
210 navigation (right mouse opens and closes the popup menu).
211
212 MythBrowser also contains a BookmarkManager to manage the website
213 links in a simple mythplugin.
214
215 %description -n mythbrowser -l pl
216 MythBrowser to w pe³ni funkcjonalna przegl±darka WWW (z wieloma
217 zak³adkami) wy¶wietlaj±ca strony WWW w trybie pe³noekranowym. Mo¿liwa
218 jest prosta nawigacja po stronie. Pocz±wszy od wersji 0.13 ma pe³n±
219 obs³ugê nawigacji myszk± (prawy przycisk otwiera i zamywa wyskakuj±ce
220 menu).
221
222 MythBrowser zawiera tak¿e BookmarkManagera do zarz±dzania odno¶nikami
223 do stron w prostej wtyczce myth.
224
225 %package -n mythphone
226 Summary:        A video conferencing module for MythTV
227 Summary(pl):    Modu³ wideokonferencji dla MythTV
228 Group:          Applications/Multimedia
229 Requires:       mythtv-frontend-api = %{myth_api_version}
230
231 %description -n mythphone
232 Mythphone is a phone and videophone capability on Myth using the
233 standard SIP protocol. It is compatible with Microsoft XP Messenger
234 and with SIP Service Providers such as Free World Dialup
235 (fwd.pulver.com).
236
237 %description -n mythphone -l pl
238 Mythphone to funkcjonalno¶æ telefonu i wideofonu w Myth przy u¿yciu
239 standardowego protoko³u SIP. Jest kompatybilny z Microsoft XP
240 Messengerem oraz dostawcami us³ug SIP, takimi jak Free World Dialup
241 (fwd.pulver.com).
242
243 %package -n mythweb
244 Summary:        The web interface to MythTV
245 Summary(pl):    Interfejs WWW do MythTV
246 Group:          Applications/Multimedia
247 Requires:       webapps
248 #Suggests:      apache(mod_auth)
249 #Suggests:      apache(mod_env)
250 Requires:       php >= 3:4.3
251 Requires:       php-mysql
252 Requires:       php-posix
253
254 %description -n mythweb
255 The web interface to MythTV.
256
257 %description -n mythweb -l pl
258 Interfejs WWW do MythTV.
259
260 %package -n mythflix
261 Summary:        MythFlix (A NetFlix MythTV)
262 Summary(pl):    MythFlix (NetFlix MythTV)
263 Group:          Applications/Multimedia
264 Requires:       mythtv-frontend-api = %{myth_api_version}
265
266 %description -n mythflix
267 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
268 It currently supports the ability to view your queue and add movies to
269 your queue. The browse feature is based on the Netflix RSS feeds. This
270 plugin is not very mature, which means things might not work right
271 and/or it might break other things.
272
273 %description -n mythflix -l pl
274 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
275 Aktualnie daje mo¿liwo¶æ ogl±dania kolejki i dodawania do niej filmów.
276 Przegl±danie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
277 jeszcze zbyt dojrza³a, co znaczy, ¿e co¶ mo¿e nie dzia³aæ lub psuæ co¶
278 innego.
279
280 %package -n mythcontrols
281 Summary:        MythTV keybindings editor
282 Summary(pl):    Edytor przypisañ klawiszy MythTV
283 Group:          Applications/Multimedia
284 Requires:       mythtv-frontend-api = %{myth_api_version}
285
286 %description -n mythcontrols
287 This plugin allows you to configure your keybindings on the frontend
288 without having to use mythweb or edit tables by hand.
289
290 %description -n mythcontrols -l pl
291 Ta wtyczka pozwala konfigurowaæ przypisania klawiszy we frontendzie
292 bez konieczno¶ci u¿ywania mythweba ani rêcznego modyfikowania tabel.
293
294 %prep
295 %setup -q %{?_snap:-n %{name}}
296 %if %{_lib} != "lib"
297 %patch0 -p1
298 %endif
299 %patch1 -p1
300 %patch2 -p1
301
302 # make it visible
303 mv mythweb/{.,}htaccess
304
305 # lib64 fix - enable to update patch
306 %if %{_lib} != "lib" && 0
307 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
308 xargs grep -l /lib/ . | xargs sed -i -e '
309         s,/usr/lib/,/usr/%{_lib}/,g
310         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
311 '
312 exit 1
313 %endif
314
315 %build
316 %if %{with binary}
317 export QTDIR="%{_prefix}"
318 # Not gnu configure
319 %configure \
320         --enable-all \
321         %{!?with_mythbrowser:--disable-mythbrowser} \
322         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
323         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
324         %{!?with_mythgame:--disable-mythgame} \
325         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
326         %{!?with_mythnews:--disable-mythnews} \
327         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
328         %{!?with_mythvideo:--disable-mythvideo} \
329         %{!?with_mythweather:--disable-mythweather} \
330         %{!?with_mythweb:--disable-mythweb} \
331         %{!?with_mythcontrols:--disable-mythcontrols} \
332         %{!?with_mythflix:--disable-mythflix} \
333
334 mv mythconfig.mak mythconfig.mak.old
335 cp mythconfig.mak.old mythconfig.mak
336 cat <<'EOF'>> mythconfig.mak
337 QMAKE_CXX=%{__cxx}
338 QMAKE_CC=%{__cc}
339 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
340 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
341 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
342 EOF
343
344 %{__make}
345 %endif
346
347 %install
348 rm -rf $RPM_BUILD_ROOT
349
350 %if %{with binary}
351 export QTDIR="%{_prefix}"
352 %{__make} install \
353         INSTALL_ROOT=$RPM_BUILD_ROOT
354
355 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
356 %if %{with mythgame}
357 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
358 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
359 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
360 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
361 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
362 %endif
363 %endif
364
365 %if %{with mythweb}
366 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb/{includes,languages}
367 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
368 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
369 cp -a mythweb/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb
370 cp -a mythweb/languages/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/languages
371 cp -a mythweb/includes/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/includes
372 cp -a mythweb/{images,js,skins,modules,themes,templates} $RPM_BUILD_ROOT%{_datadir}/mythweb
373 cp -a mythweb/config/*.{php,dat} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
374 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
375 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
376 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
377 %endif
378
379 for p in mythmusic mythvideo mythweather mythgallery mythgame mythdvd mythnews mythbrowser mythphone mythflix mythcontrols; do
380         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
381                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
382         done > $p.lang
383 done
384
385 %clean
386 rm -rf $RPM_BUILD_ROOT
387
388 %triggerin -n mythweb -- apache1
389 %webapp_register apache %{_webapp}
390
391 %triggerun -n mythweb -- apache1
392 %webapp_unregister apache %{_webapp}
393
394 %triggerin -n mythweb -- apache < 2.2.0, apache-base
395 %webapp_register httpd %{_webapp}
396
397 %triggerun -n mythweb -- apache < 2.2.0, apache-base
398 %webapp_unregister httpd %{_webapp}
399
400 %triggerpostun -n mythweb -- mythweb < 0.19
401 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
402         if [ -f /etc/mythweb/$i.rpmsave ]; then
403                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
404                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
405         fi
406 done
407 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
408
409 # migrate from apache-config macros
410 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
411         if [ -d /etc/apache/webapps.d ]; then
412                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
413                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
414         fi
415
416         if [ -d /etc/httpd/webapps.d ]; then
417                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
418                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
419         fi
420         rm -f /etc/mythweb/apache.conf.rpmsave
421 fi
422
423 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
424         rm -f /etc/apache/conf.d/99_mythplugins.conf
425         /usr/sbin/webapp register apache %{_webapp}
426         %service -q apache reload
427 fi
428 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
429         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
430         /usr/sbin/webapp register httpd %{_webapp}
431         %service -q httpd reload
432 fi
433
434 %files
435 %defattr(644,root,root,755)
436
437 %if %{with mythmusic}
438 %files -n mythmusic -f mythmusic.lang
439 %defattr(644,root,root,755)
440 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
441 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
442 /var/lib/mythmusic
443 %{_datadir}/mythtv/musicmenu.xml
444 %{_datadir}/mythtv/music_settings.xml
445 %{_datadir}/mythtv/themes/default/music-ui.xml
446 %{_datadir}/mythtv/themes/default/ff_button_off.png
447 %{_datadir}/mythtv/themes/default/ff_button_on.png
448 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
449 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
450 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
451 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
452 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
453 %{_datadir}/mythtv/themes/default/mm_checked.png
454 %{_datadir}/mythtv/themes/default/mm_checked_high.png
455 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
456 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
457 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
458 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
459 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
460 %{_datadir}/mythtv/themes/default/mm_rating.png
461 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
462 %{_datadir}/mythtv/themes/default/mm_unchecked.png
463 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
464 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
465 %{_datadir}/mythtv/themes/default/mm_volume_background.png
466 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
467 %{_datadir}/mythtv/themes/default/mm_waiting.png
468 %{_datadir}/mythtv/themes/default/music-sel-bg.png
469 %{_datadir}/mythtv/themes/default/next_button_off.png
470 %{_datadir}/mythtv/themes/default/next_button_on.png
471 %{_datadir}/mythtv/themes/default/next_button_pushed.png
472 %{_datadir}/mythtv/themes/default/pause_button_off.png
473 %{_datadir}/mythtv/themes/default/pause_button_on.png
474 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
475 %{_datadir}/mythtv/themes/default/play_button_off.png
476 %{_datadir}/mythtv/themes/default/play_button_on.png
477 %{_datadir}/mythtv/themes/default/play_button_pushed.png
478 %{_datadir}/mythtv/themes/default/prev_button_off.png
479 %{_datadir}/mythtv/themes/default/prev_button_on.png
480 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
481 %{_datadir}/mythtv/themes/default/rew_button_off.png
482 %{_datadir}/mythtv/themes/default/rew_button_on.png
483 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
484 %{_datadir}/mythtv/themes/default/selectionbar.png
485 %{_datadir}/mythtv/themes/default/stop_button_off.png
486 %{_datadir}/mythtv/themes/default/stop_button_on.png
487 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
488 %{_datadir}/mythtv/themes/default/text_button_off.png
489 %{_datadir}/mythtv/themes/default/text_button_on.png
490 %{_datadir}/mythtv/themes/default/text_button_pushed.png
491 %{_datadir}/mythtv/themes/default/track_info_background.png
492 %endif
493
494 %if %{with mythvideo}
495 %files -n mythvideo -f mythvideo.lang
496 %defattr(644,root,root,755)
497 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
498 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
499 %{_datadir}/mythtv/themes/default/video-ui.xml
500 %{_datadir}/mythtv/themes/default/mv-*.png
501 %{_datadir}/mythtv/themes/default/mv_*.png
502 %{_datadir}/mythtv/video_settings.xml
503 %{_datadir}/mythtv/videomenu.xml
504 %dir %{_datadir}/mythtv/mythvideo
505 %dir %{_datadir}/mythtv/mythvideo/scripts
506 %{_datadir}/mythtv/mythvideo/scripts/README
507 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
508 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
509 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/ofdb.pl
510 /var/lib/mythvideo
511
512 %endif
513
514 %if %{with mythweather}
515 %files -n mythweather -f mythweather.lang
516 %defattr(644,root,root,755)
517 %doc mythweather/README
518 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
519 %{_datadir}/mythtv/mythweather
520 %{_datadir}/mythtv/themes/default/weather-ui.xml
521 %{_datadir}/mythtv/themes/default/cloudy.png
522 %{_datadir}/mythtv/themes/default/fair.png
523 %{_datadir}/mythtv/themes/default/flurries.png
524 %{_datadir}/mythtv/themes/default/fog.png
525 %{_datadir}/mythtv/themes/default/logo.png
526 %{_datadir}/mythtv/themes/default/lshowers.png
527 %{_datadir}/mythtv/themes/default/mcloudy.png
528 %{_datadir}/mythtv/themes/default/mw-*.png
529 %{_datadir}/mythtv/themes/default/mwmain.png
530 %{_datadir}/mythtv/themes/default/pcloudy.png
531 %{_datadir}/mythtv/themes/default/rainsnow.png
532 %{_datadir}/mythtv/themes/default/showers.png
533 %{_datadir}/mythtv/themes/default/snowshow.png
534 %{_datadir}/mythtv/themes/default/sunny.png
535 %{_datadir}/mythtv/themes/default/thunshowers.png
536 %{_datadir}/mythtv/themes/default/unknown.png
537 %endif
538
539 %if %{with mythgallery}
540 %files -n mythgallery -f mythgallery.lang
541 %defattr(644,root,root,755)
542 %doc mythgallery/README mythgallery/UPGRADING
543 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
544 %{_datadir}/mythtv/themes/default/gallery-ui.xml
545 %{_datadir}/mythtv/themes/default/gallery-*.png
546 # FIXME: this is definately stupid path
547 /var/lib/pictures
548 %endif
549
550 %if %{with mythgame}
551 %files -n mythgame -f mythgame.lang
552 %defattr(644,root,root,755)
553 %doc mythgame/README mythgame/UPGRADING
554 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
555 %{_datadir}/mythtv/games
556 %{_datadir}/mythtv/game_settings.xml
557 %{_datadir}/mythtv/themes/default/game-ui.xml
558 %endif
559
560 %if %{with mythdvd}
561 %files -n mythdvd -f mythdvd.lang
562 %defattr(644,root,root,755)
563 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
564 %attr(755,root,root) %{_bindir}/mtd
565 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
566 %{_datadir}/mythtv/dvd_settings.xml
567 %{_datadir}/mythtv/dvdmenu.xml
568 %{_datadir}/mythtv/themes/default/dvd-ui.xml
569 %{_datadir}/mythtv/themes/default/md_*.png
570 %endif
571
572 %if %{with mythnews}
573 %files -n mythnews -f mythnews.lang
574 %defattr(644,root,root,755)
575 %doc mythnews/README mythnews/AUTHORS
576 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
577 %{_datadir}/mythtv/mythnews
578 %{_datadir}/mythtv/themes/default/news-ui.xml
579 # DUPLICATE WITH MYTHFLIX?
580 %{_datadir}/mythtv/themes/default/news-info-bg.png
581 %endif
582
583 %if %{with mythbrowser}
584 %files -n mythbrowser -f mythbrowser.lang
585 %defattr(644,root,root,755)
586 %doc mythbrowser/README mythbrowser/AUTHORS
587 %attr(755,root,root) %{_bindir}/mythbrowser
588 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
589 %{_datadir}/mythtv/themes/default/webpage.png
590 %endif
591
592 %if %{with mythphone}
593 %files -n mythphone -f mythphone.lang
594 %defattr(644,root,root,755)
595 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
596 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
597 %{_datadir}/mythtv/themes/default/phone-ui.xml
598 %{_datadir}/mythtv/themes/default/webcam-ui.xml
599 %{_datadir}/mythtv/themes/default/mp_*.png
600 %{_datadir}/mythtv/themes/default/phone.png
601 %endif
602
603 %if %{with mythweb}
604 %files -n mythweb
605 %defattr(644,root,root,755)
606 %doc mythweb/{README,TODO} mythweb/languages/*.{pl,txt}
607 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
608 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
609 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
610 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
611 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
612 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
613 %{_datadir}/mythweb
614 %dir %attr(771,root,http) /var/cache/mythweb
615 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
616 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
617 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
618 %endif
619
620 %if %{with mythflix}
621 %files -n mythflix -f mythflix.lang
622 %defattr(644,root,root,755)
623 %doc mythflix/{AUTHORS,ChangeLog,README}
624 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
625 %dir %{_datadir}/mythtv/mythflix
626 %{_datadir}/mythtv/mythflix/netflix-rss.xml
627 %dir %{_datadir}/mythtv/mythflix/scripts
628 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
629 %{_datadir}/mythtv/netflix_menu.xml
630 %{_datadir}/mythtv/themes/default/title_netflix.png
631 %{_datadir}/mythtv/themes/default/netflix-ui.xml
632 # DUPLICATE WITH MYTHNEWS?
633 %{_datadir}/mythtv/themes/default/news-info-bg.png
634 %endif
635
636 %if %{with mythcontrols}
637 %files -n mythcontrols -f mythcontrols.lang
638 %defattr(644,root,root,755)
639 %doc mythcontrols/{AUTHORS,README,TODO}
640 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
641 %{_datadir}/mythtv/themes/default/controls-ui.xml
642 %{_datadir}/mythtv/themes/default/kb-button-off.png
643 %{_datadir}/mythtv/themes/default/kb-button-on.png
644 %endif
This page took 0.178767 seconds and 4 git commands to generate.