]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- use existing dir for mythdvd import
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # disable mythdvd plugin - mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgame plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythnews plugin
13 %bcond_without  mythvideo       # disable building mythvideo plugin
14 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
15 # not present by default in PLD
16 %bcond_with     mythweather     # enable building mythweather plugin
17 %bcond_without  mythweb         # disable building mythweb plugin
18 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
19
20 %if %{without binary}
21 %undefine       with_mytharchive
22 %undefine       with_mythbrowser
23 %undefine       with_mythmovies
24 %undefine       with_mythdvd
25 %undefine       with_mythnetvision
26 %undefine       with_mythgallery
27 %undefine       with_mythgame
28 %undefine       with_mythmusic
29 %undefine       with_mythnews
30 %undefine       with_mythvideo
31 %undefine       with_mythweather
32 %endif
33
34 %include        /usr/lib/rpm/macros.perl
35
36 Summary:        Main MythTV plugins
37 Summary(pl.UTF-8):      Główne wtyczki MythTV
38 Name:           mythplugins
39 Version:        0.23.1
40 Release:        4
41 License:        GPL v2
42 Group:          Applications/Multimedia
43 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
44 # Source0-md5:  edd9c5f8a9ae0189b1c8951fa8282c4d
45 Source1:        mythweb.conf
46 Source2:        mythweb_lighttpd.conf
47 Source3:        htdigest.sh
48 Source4:        http_servers_conf_tips.txt
49 Patch0:         mythweb-chdir.patch
50 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
51 Patch20:        %{name}-mytharchive-INT64.patch
52 URL:            http://www.mythtv.org/
53 %if %{with binary}
54 %if %{with mythgallery} || %{with myhtmusic}
55 BuildRequires:  OpenGL-devel
56 %endif
57 BuildRequires:  Qt3Support-devel
58 BuildRequires:  QtCore-devel
59 BuildRequires:  QtGui-devel
60 BuildRequires:  QtNetwork-devel
61 BuildRequires:  QtOpenGL-devel
62 BuildRequires:  QtSql-devel
63 BuildRequires:  QtWebKit-devel
64 BuildRequires:  QtXml-devel
65 BuildRequires:  SDL-devel
66 BuildRequires:  a52dec-libs-devel
67 BuildRequires:  cdparanoia-III-devel
68 BuildRequires:  faad2-devel >= 2.0-5.2
69 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
70 BuildRequires:  flac-devel >= 1.0.4
71 BuildRequires:  freetype-devel
72 BuildRequires:  libcdaudio-devel >= 0.99.12p2
73 BuildRequires:  libdvdcss-devel >= 1.2.7
74 BuildRequires:  libdvdread-devel >= 0.9.4
75 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
76 BuildRequires:  libfame-devel >= 0.9.0
77 BuildRequires:  libid3tag-devel
78 BuildRequires:  libmad-devel
79 BuildRequires:  libmyth-devel > 0.21
80 BuildRequires:  libstdc++-devel
81 BuildRequires:  libtiff-devel
82 BuildRequires:  libvorbis-devel >= 1:1.0
83 BuildRequires:  mjpegtools-devel >= 1.6.1
84 BuildRequires:  nasm
85 BuildRequires:  patchutils
86 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
87 %{?with_mythweather:BuildRequires:      perl-Image-Size}
88 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
89 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
90 BuildRequires:  qt4-build
91 BuildRequires:  qt4-qmake
92 BuildRequires:  rpm-perlprov >= 4.1-13
93 BuildRequires:  sed >= 4.0
94 %{?with_mythmusic:BuildRequires:        taglib-devel}
95 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xvid-devel >= 1:0.9.1
98 BuildRequires:  zlib-devel
99 %endif
100 %{?with_mytharchive:Requires:   mytharchive}
101 %{?with_mythbrowser:Requires:   mythbrowser}
102 %{?with_mythdvd:Requires:       mythdvd}
103 %{?with_mythgallery:Requires:   mythgallery}
104 %{?with_mythgame:Requires:      mythgame}
105 %{?with_mythmysic:Requires:     mythmusic}
106 %{?with_mythnetvision:Requires: mythnetvision}
107 %{?with_mythnews:Requires:      mythnews}
108 %{?with_mythvideo:Requires:     mythvideo}
109 %{?with_mythweather:Requires:   mythweather}
110 %{?with_mythweb:Requires:       mythweb}
111 ExclusiveArch:  %{ix86} %{x8664} ppc
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
115 %define         _webapps        /etc/webapps
116 %define         _webapp         mythweb
117
118 %description
119 This is a consolidation of all the official MythTV plugins that used
120 to be distributed as separate downloads from mythtv.org.
121
122 %description -l pl.UTF-8
123 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
124 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
125
126 %package -n mytharchive
127 Summary:        A MythTV module to create and burn DVDs
128 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
129 Group:          Applications/Multimedia
130 Requires:       dvdauthor
131 Requires:       mjpegtools
132 Requires:       mythtv-frontend-api = %{myth_api_version}
133 Requires:       python-MySQLdb
134 Requires:       python-PIL
135 Suggests:       dvdrtools-mkisofs
136
137 %description -n mytharchive
138 MythArchive is a MythTV style plugin that uses the Mythburn Script to
139 create and burn DVDs from MythTV recordings, MythVideo files or any
140 video files available on a MythTV system. It can also export
141 recordings to a native archive format that can then be imported back
142 into a MythTV system restoring all the associated metadata.
143
144 %description -n mytharchive -l pl.UTF-8
145 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
146 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
147 innych plików z filmami dostępnych w systemie MythTV. Może także
148 eksportować nagrania do natywnego formatu archiwum, który potem można
149 zaimportować z powrotem do systemu MythTV przywracając wszystkie
150 związane z nimi metadane.
151
152 %package -n mythmusic
153 Summary:        The music player add-on module for MythTV
154 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
155 Group:          Applications/Multimedia
156 BuildRequires:  libvisual-devel
157 Requires:       mythtv-frontend-api = %{myth_api_version}
158
159 %description -n mythmusic
160 Music add-on for MythTV. Support playlists, visualisations, tag
161 editing and plays many popular audio file formats - mp3, flac, wav,
162 ogg etc.
163
164 %description -n mythmusic -l pl.UTF-8
165 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
166 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
167 formatów audio - mp3, flac, wav, ogg itd.
168
169 %package -n mythvideo
170 Summary:        A generic video player frontend module for MythTV
171 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
172 Group:          Applications/Multimedia
173 Requires:       mplayer
174 Requires:       mythtv-frontend-api = %{myth_api_version}
175
176 %description -n mythvideo
177 A generic video and dvd player frontend module for MythTV.
178
179 %description -n mythvideo -l pl.UTF-8
180 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
181
182 %package -n mythweather
183 Summary:        A MythTV module that displays a weather forcast
184 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
185 Group:          Applications/Multimedia
186 Requires:       mythtv-frontend-api = %{myth_api_version}
187
188 %description -n mythweather
189 A MythTV module that displays a weather forcast.
190
191 %description -n mythweather -l pl.UTF-8
192 Moduł MythTV wyświetlający prognozę pogody.
193
194 %package -n mythgallery
195 Summary:        A gallery/slideshow module for MythTV
196 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
197 Group:          Applications/Multimedia
198 Requires:       mythtv-frontend-api = %{myth_api_version}
199
200 %description -n mythgallery
201 A gallery/slideshow module for MythTV.
202
203 %description -n mythgallery -l pl.UTF-8
204 Moduł galerii/pokazu slajdów dla MythTV.
205
206 %package -n mythgame
207 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
208 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
209 Group:          Applications/Multimedia
210 Requires:       mythtv-frontend-api = %{myth_api_version}
211
212 %description -n mythgame
213 A game frontend (xmame, nes, snes, pc) for MythTV.
214
215 %description -n mythgame -l pl.UTF-8
216 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
217
218 %package -n mythdvd
219 Summary:        A DVD ripper module for MythTV
220 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
221 Group:          Applications/Multimedia
222 Requires:       mythtv-frontend-api = %{myth_api_version}
223 Requires:       mythvideo
224 Requires:       transcode >= 0.6.8
225
226 %description -n mythdvd
227 MythDVD is a MythTV module that allows you to rip DVD's and transcode
228 their video and audio content to other (generally smaller) formats.
229 The playing features are simply myth-style wrappers for your favourite
230 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
231 based on and derived from the excellent transcode package.
232
233 %description -n mythdvd -l pl.UTF-8
234 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
235 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
236 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
237 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
238 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
239 pakietu transcode.
240
241 %package -n mythnews
242 Summary:        A RSS News Feed plugin for MythTV
243 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
244 Group:          Applications/Multimedia
245 Requires:       mythtv-frontend-api = %{myth_api_version}
246
247 %description -n mythnews
248 A RSS News Feed plugin for MythTV.
249
250 %description -n mythnews -l pl.UTF-8
251 Wtyczka czytnika nowinek RSS dla MythTV.
252
253 %package -n mythbrowser
254 Summary:        A small web browser module for MythTV
255 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
256 Group:          Applications/Multimedia
257 Requires:       mythtv-frontend-api = %{myth_api_version}
258
259 %description -n mythbrowser
260 MythBrowser is a full fledged web-browser (multiple tabs) to display
261 webpages in full-screen mode. Simple page navigation is possible.
262 Starting with version 0.13 it also has full support for mouse driven
263 navigation (right mouse opens and closes the popup menu).
264
265 MythBrowser also contains a BookmarkManager to manage the website
266 links in a simple mythplugin.
267
268 %description -n mythbrowser -l pl.UTF-8
269 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
270 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
271 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
272 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
273 menu).
274
275 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
276 do stron w prostej wtyczce myth.
277
278 %package -n mythweb
279 Summary:        The web interface to MythTV
280 Summary(pl.UTF-8):      Interfejs WWW do MythTV
281 Group:          Applications/Multimedia
282 Requires:       php(mysql)
283 Requires:       php(posix)
284 Requires:       webapps
285 Requires:       webserver(php) >= 4.3
286
287 %description -n mythweb
288 The web interface to MythTV.
289
290 %description -n mythweb -l pl.UTF-8
291 Interfejs WWW do MythTV.
292
293 %package -n mythnetvision
294 Summary:        Mythtv extension to watch network movie shows
295 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
296 Group:          Applications/Multimedia
297 Requires:       mythbrowser
298 Requires:       mythtv-frontend-api = %{myth_api_version}
299
300 %description -n mythnetvision
301 Mythtv extension to watch network movie shows (ex. YouTube).
302
303 %description -n mythnetvision -l pl.UTF-8
304 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
305 YouTube.
306
307 %package -n mythmovies
308 Summary:        MythTV cinemas timetable
309 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
310 Group:          Applications/Multimedia
311 Requires:       mythtv-frontend-api = %{myth_api_version}
312
313 %description -n mythmovies
314 MythTV cinemas timetable.
315
316
317 %description -n mythmovies -l pl.UTF-8
318 Moduł MythTV do repertuaru kinowego.
319
320 %package -n mythzoneminder
321 Summary:        MythTV security TV manager
322 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
323 Group:          Applications/Multimedia
324 Requires:       mythtv-frontend-api = %{myth_api_version}
325
326 %description -n mythzoneminder
327 MythTV security TV manager.
328
329
330 %description -n mythzoneminder -l pl.UTF-8
331 Obsługa kamer przemysłowych dla MythTV.
332
333 %prep
334 %setup -q
335 %patch0 -p1
336 %patch10 -p1
337 %patch20 -p1
338
339 %{__sed} -i -e 's,/var/lib/mythdvd/temp,/var/lib/mythtv/tmp,' \
340         mythvideo/mythvideo/globalsettings.cpp
341
342 # lib64 fix - enable to update patch
343 %if %{_lib} != "lib" && 0
344 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
345 xargs grep -l /lib/ . | xargs sed -i -e '
346 s,%{_prefix}/lib/,/%{_lib}/,g
347         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
348 '
349 exit 1
350 %endif
351
352 %build
353 %if %{with binary}
354 export QTDIR="%{_prefix}"
355 # Not gnu configure
356 %configure \
357         --libdir-name=`basename %{_lib}` \
358         --enable-all \
359         %{!?with_mytharchive:--disable-mytharchive} \
360         %{!?with_mythbrowser:--disable-mythbrowser} \
361         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
362         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
363         %{!?with_mythgame:--disable-mythgame} \
364         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
365         %{!?with_mythnews:--disable-mythnews} \
366         %{!?with_mythvideo:--disable-mythvideo} \
367         %{!?with_mythweather:--disable-mythweather} \
368         %{!?with_mythweb:--disable-mythweb} \
369         %{!?with_mythmovies:--disable-mythmovies} \
370         %{!?with_mythnetvision:--disable-mythnetvision} \
371
372 mv mythconfig.mak mythconfig.mak.old
373 cp mythconfig.mak.old mythconfig.mak
374 cat <<'EOF'>> mythconfig.mak
375 QMAKE_CXX=%{__cxx}
376 QMAKE_CC=%{__cc}
377 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
378 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
379 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
380 EOF
381
382 %{__make}
383 %endif
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387 %if %{with binary}
388 export QTDIR="%{_prefix}"
389 %{__make} install \
390         INSTALL_ROOT=$RPM_BUILD_ROOT
391
392 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
393 %if %{with mythgame}
394 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
395 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
396 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
397 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
398 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
399 %endif
400 %endif
401
402 %if %{with mythweb}
403 cd mythweb
404 cp -a %{SOURCE3} ./
405 cp -a %{SOURCE4} ./
406 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
407 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
408 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
409 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
410 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
411 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
412 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
413 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
414 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
415 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
416 cd -
417 %endif
418
419 rm -f $RPM_BUILD_ROOT%{_datadir}/data
420 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
421 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
422         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
423                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
424         done > $p.lang
425 done
426
427 %clean
428 rm -rf $RPM_BUILD_ROOT
429
430 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
431 %webapp_register apache %{_webapp}
432
433 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
434 %webapp_unregister apache %{_webapp}
435
436 %triggerin -n mythweb -- apache < 2.2.0, apache-base
437 %webapp_register httpd %{_webapp}
438
439 %triggerin -n mythweb -- lighttpd
440 %webapp_register lighttpd %{_webapp}
441
442 %triggerun -n mythweb -- apache < 2.2.0, apache-base
443 %webapp_unregister httpd %{_webapp}
444
445 %triggerun -n mythweb -- lighttpd
446 %webapp_unregister lighttpd %{_webapp}
447
448 %triggerpostun -n mythweb -- mythweb < 0.19
449 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
450         if [ -f /etc/mythweb/$i.rpmsave ]; then
451                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
452                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
453         fi
454 done
455 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
456
457 # migrate from apache-config macros
458 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
459         if [ -d /etc/apache/webapps.d ]; then
460                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
461                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
462         fi
463
464         if [ -d /etc/httpd/webapps.d ]; then
465                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
466                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
467         fi
468         rm -f /etc/mythweb/apache.conf.rpmsave
469 fi
470
471 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
472         rm -f /etc/apache/conf.d/99_mythplugins.conf
473         /usr/sbin/webapp register apache %{_webapp}
474         %service -q apache reload
475 fi
476 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
477         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
478         /usr/sbin/webapp register httpd %{_webapp}
479         %service -q httpd reload
480 fi
481
482 %post -n mythweb
483 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
484 which packages you can need to run mythweb and how to set it quickly."
485
486 %files
487 %defattr(644,root,root,755)
488
489 %if %{with mytharchive}
490 %files -n mytharchive -f mytharchive.lang
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/mytharchivehelper
493 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
494 %{_datadir}/mythtv/archivemenu.xml
495 %{_datadir}/mythtv/archiveutils.xml
496 %{_datadir}/mythtv/themes/default/ma_*.png
497 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
498 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
499 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
500 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
501 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
502 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
503 %{_datadir}/mythtv/mytharchive
504 %endif
505
506 %if %{with mythmusic}
507 %files -n mythmusic -f mythmusic.lang
508 %defattr(644,root,root,755)
509 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
510 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
511 /var/lib/mythmusic
512 %{_datadir}/mythtv/musicmenu.xml
513 %{_datadir}/mythtv/music_settings.xml
514 %{_datadir}/mythtv/themes/default/music-ui.xml
515 %{_datadir}/mythtv/themes/default/mm-titlelines.png
516 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
517 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
518 %{_datadir}/mythtv/themes/default/ff_button_off.png
519 %{_datadir}/mythtv/themes/default/ff_button_on.png
520 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
521 %{_datadir}/mythtv/themes/default/miniplayer_background.png
522 %{_datadir}/mythtv/themes/default/mm_*.png
523 %{_datadir}/mythtv/themes/default/music-sel-bg.png
524 %{_datadir}/mythtv/themes/default/next_button_off.png
525 %{_datadir}/mythtv/themes/default/next_button_on.png
526 %{_datadir}/mythtv/themes/default/next_button_pushed.png
527 %{_datadir}/mythtv/themes/default/pause_button_off.png
528 %{_datadir}/mythtv/themes/default/pause_button_on.png
529 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
530 %{_datadir}/mythtv/themes/default/play_button_off.png
531 %{_datadir}/mythtv/themes/default/play_button_on.png
532 %{_datadir}/mythtv/themes/default/play_button_pushed.png
533 %{_datadir}/mythtv/themes/default/prev_button_off.png
534 %{_datadir}/mythtv/themes/default/prev_button_on.png
535 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
536 %{_datadir}/mythtv/themes/default/rew_button_off.png
537 %{_datadir}/mythtv/themes/default/rew_button_on.png
538 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
539 %{_datadir}/mythtv/themes/default/selectionbar.png
540 %{_datadir}/mythtv/themes/default/stop_button_off.png
541 %{_datadir}/mythtv/themes/default/stop_button_on.png
542 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
543 %{_datadir}/mythtv/themes/default/track_info_background.png
544 %{_datadir}/mythtv/themes/default-wide/mm_*.png
545 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
546 %endif
547
548 %if %{with mythvideo}
549 %files -n mythvideo -f mythvideo.lang
550 %defattr(644,root,root,755)
551 %doc mythvideo/README mythvideo/videodb
552 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
553 %{_datadir}/mythtv/themes/default/video-ui.xml
554 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
555 %{_datadir}/mythtv/themes/default/mv_*.png
556 %{_datadir}/mythtv/themes/default-wide/mv_*.png
557 %{_datadir}/mythtv/video_settings.xml
558 %{_datadir}/mythtv/videomenu.xml
559 %dir %{_datadir}/mythtv/mythvideo
560 %dir %{_datadir}/mythtv/mythvideo/scripts
561 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
562 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
563 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
564 %{_datadir}/mythtv/mythvideo/scripts/README
565 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
566 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
567 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
568 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
569 %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
570 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
571 %{_datadir}/mythtv/mythvideo/scripts/Television/*
572 /var/lib/mythvideo
573 %endif
574
575 %if %{with mythweather}
576 %files -n mythweather -f mythweather.lang
577 %defattr(644,root,root,755)
578 %doc mythweather/README
579 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
580 %{_datadir}/mythtv/mythweather
581 %{_datadir}/mythtv/weather_settings.xml
582 %{_datadir}/mythtv/themes/default/weather-ui.xml
583 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
584 %{_datadir}/mythtv/themes/default/cloudy.png
585 %{_datadir}/mythtv/themes/default/fair.png
586 %{_datadir}/mythtv/themes/default/flurries.png
587 %{_datadir}/mythtv/themes/default/fog.png
588 %{_datadir}/mythtv/themes/default/logo.png
589 %{_datadir}/mythtv/themes/default/lshowers.png
590 %{_datadir}/mythtv/themes/default/mcloudy.png
591 %{_datadir}/mythtv/themes/default/mw_*.png
592 %{_datadir}/mythtv/themes/default/mwmain.png
593 %{_datadir}/mythtv/themes/default/pcloudy.png
594 %{_datadir}/mythtv/themes/default/rainsnow.png
595 %{_datadir}/mythtv/themes/default/showers.png
596 %{_datadir}/mythtv/themes/default/snowshow.png
597 %{_datadir}/mythtv/themes/default/sunny.png
598 %{_datadir}/mythtv/themes/default/thunshowers.png
599 %{_datadir}/mythtv/themes/default/unknown.png
600 %{_datadir}/mythtv/themes/default-wide/mw-*.png
601 %endif
602
603 %if %{with mythgallery}
604 %files -n mythgallery -f mythgallery.lang
605 %defattr(644,root,root,755)
606 %doc mythgallery/README
607 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
608 %{_datadir}/mythtv/themes/default/gallery-ui.xml
609 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
610 %{_datadir}/mythtv/themes/default/gallery-*.png
611 /var/lib/pictures
612 %endif
613
614 %if %{with mythgame}
615 %files -n mythgame -f mythgame.lang
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
618 %{_datadir}/mythtv/games
619 %{_datadir}/mythtv/game_settings.xml
620 %{_datadir}/mythtv/themes/default/game-ui.xml
621 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
622 %endif
623
624 %if %{with mythdvd}
625 %files -n mythdvd
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_bindir}/mtd
628 %{_datadir}/mythtv/themes/default/dvd-ui.xml
629 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
630 %{_datadir}/mythtv/themes/default/md_*.png
631 %endif
632
633 %if %{with mythnews}
634 %files -n mythnews -f mythnews.lang
635 %defattr(644,root,root,755)
636 %doc mythnews/README mythnews/AUTHORS
637 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
638 %{_datadir}/mythtv/mythnews
639 %{_datadir}/mythtv/themes/default/news-ui.xml
640 %{_datadir}/mythtv/themes/default/news-info-bg.png
641 %{_datadir}/mythtv/themes/default/enclosures.png
642 %{_datadir}/mythtv/themes/default/need-download.png
643 %{_datadir}/mythtv/themes/default/podcast.png
644 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
645 %endif
646
647 %if %{with mythbrowser}
648 %files -n mythbrowser -f mythbrowser.lang
649 %defattr(644,root,root,755)
650 %doc mythbrowser/README mythbrowser/AUTHORS
651 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
652 %{_datadir}/mythtv/themes/default/mb_progress*.png
653 %{_datadir}/mythtv/themes/default/browser-ui.xml
654 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
655 %endif
656
657 %if %{with mythweb}
658 %files -n mythweb
659 %defattr(644,root,root,755)
660 %doc mythweb/README mythweb/mythweb.conf.lighttpd
661 %doc mythweb/htdigest.sh
662 %doc mythweb/http_servers_conf_tips.txt
663 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
664 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
666 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
667 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
668 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
669 %{_datadir}/mythweb
670 %dir %attr(771,root,http) /var/cache/mythweb
671 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
672 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
673 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
674 %endif
675
676 %if %{with mythnetvision}
677 %files -n mythnetvision -f mythnetvision.lang
678 %defattr(644,root,root,755)
679 %doc mythnetvision/{AUTHORS,ChangeLog,README}
680 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
681 %dir %{_datadir}/mythtv/mythnetvision
682 %{_datadir}/mythtv/netvisionmenu.xml
683 %dir %{_datadir}/mythtv/mythnetvision/scripts
684 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
685 %dir %{_datadir}/mythtv/mythnetvision/icons
686 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
687 %{_datadir}/mythtv/mythnetvision/icons/*.png
688 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
689 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
690 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
691 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
692 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
693 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
694 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
695 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
696 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
697 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
698 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
699 %{_datadir}/mythtv/themes/default/netvision-ui.xml
700 %endif
701
702 %if %{with mythmovies}
703 %files -n mythmovies
704 %defattr(644,root,root,755)
705 %defattr(644,root,root,755)
706 %doc mythmovies/{README,TODO}
707 %attr(755,root,root) %{_bindir}/ignyte
708 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
709 %{_datadir}/mythtv/themes/default/movies-ui.xml
710 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
711 %{_datadir}/mythtv/i18n/mythmovies_*.qm
712 %endif
713
714 %if %{with mythzoneminder}
715 %files -n mythzoneminder
716 %defattr(644,root,root,755)
717 %defattr(644,root,root,755)
718 %doc mythzoneminder/{AUTHORS,README}
719 %attr(755,root,root) %{_bindir}/mythzmserver
720 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
721 %dir %{_datadir}/mythtv/zonemindermenu.xml
722 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
723 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
724 %{_datadir}/mythtv/themes/default/mz_*png
725 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
726 %endif
This page took 5.619539 seconds and 4 git commands to generate.