]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- clean up
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # disable mythdvd plugin - mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgame plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythnews plugin
13 %bcond_without  mythvideo       # disable building mythvideo plugin
14 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
15 # not present by default in PLD
16 %bcond_with     mythweather     # enable building mythweather plugin
17 %bcond_without  mythweb         # disable building mythweb plugin
18 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
19
20 %if !%{with binary}
21 %undefine       with_mytharchive
22 %undefine       with_mythbrowser
23 %undefine       with_mythmovies
24 %undefine       with_mythdvd
25 %undefine       with_mythnetvision
26 %undefine       with_mythgallery
27 %undefine       with_mythgame
28 %undefine       with_mythmusic
29 %undefine       with_mythnews
30 %undefine       with_mythvideo
31 %undefine       with_mythweather
32 %endif
33
34 %include        /usr/lib/rpm/macros.perl
35
36 #%define fix     24635
37
38 Summary:        Main MythTV plugins
39 Summary(pl.UTF-8):      Główne wtyczki MythTV
40 Name:           mythplugins
41 Version:        0.23.1
42 Release:        2
43 #Release:       fix%{fix}.1
44 License:        GPL v2
45 Group:          Applications/Multimedia
46 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
47 # Source0-md5:  edd9c5f8a9ae0189b1c8951fa8282c4d
48 Source1:        mythweb.conf
49 Source2:        mythweb_lighttpd.conf
50 Source3:        htdigest.sh
51 Source4:        http_servers_conf_tips.txt
52 Patch0:         mythweb-chdir.patch
53 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
54 Patch20:        %{name}-mytharchive-INT64.patch
55 URL:            http://www.mythtv.org/
56 %if %{with binary}
57 %if %{with mythgallery} || %{with myhtmusic}
58 BuildRequires:  OpenGL-devel
59 %endif
60 BuildRequires:  Qt3Support-devel
61 BuildRequires:  QtCore-devel
62 BuildRequires:  QtGui-devel
63 BuildRequires:  QtNetwork-devel
64 BuildRequires:  QtOpenGL-devel
65 BuildRequires:  QtSql-devel
66 BuildRequires:  QtWebKit-devel
67 BuildRequires:  QtXml-devel
68 BuildRequires:  SDL-devel
69 BuildRequires:  a52dec-libs-devel
70 BuildRequires:  cdparanoia-III-devel
71 BuildRequires:  faad2-devel >= 2.0-5.2
72 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
73 BuildRequires:  flac-devel >= 1.0.4
74 BuildRequires:  freetype-devel
75 BuildRequires:  libcdaudio-devel >= 0.99.12p2
76 BuildRequires:  libdvdcss-devel >= 1.2.7
77 BuildRequires:  libdvdread-devel >= 0.9.4
78 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
79 BuildRequires:  libfame-devel >= 0.9.0
80 BuildRequires:  libid3tag-devel
81 BuildRequires:  libmad-devel
82 BuildRequires:  libmyth-devel > 0.21
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtiff-devel
85 BuildRequires:  libvorbis-devel >= 1:1.0
86 BuildRequires:  mjpegtools-devel >= 1.6.1
87 BuildRequires:  nasm
88 BuildRequires:  patchutils
89 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
90 %{?with_mythweather:BuildRequires:      perl-Image-Size}
91 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
92 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
93 BuildRequires:  qt4-build
94 BuildRequires:  qt4-qmake
95 BuildRequires:  rpm-perlprov >= 4.1-13
96 BuildRequires:  sed >= 4.0
97 %{?with_mythmusic:BuildRequires:        taglib-devel}
98 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
99 BuildRequires:  xorg-lib-libX11-devel
100 BuildRequires:  xvid-devel >= 1:0.9.1
101 BuildRequires:  zlib-devel
102 %endif
103 %{?with_mytharchive:Requires:   mytharchive}
104 %{?with_mythbrowser:Requires:   mythbrowser}
105 %{?with_mythdvd:Requires:       mythdvd}
106 %{?with_mythgallery:Requires:   mythgallery}
107 %{?with_mythgame:Requires:      mythgame}
108 %{?with_mythmysic:Requires:     mythmusic}
109 %{?with_mythnetvision:Requires: mythnetvision}
110 %{?with_mythnews:Requires:      mythnews}
111 %{?with_mythvideo:Requires:     mythvideo}
112 %{?with_mythweather:Requires:   mythweather}
113 %{?with_mythweb:Requires:       mythweb}
114 ExclusiveArch:  %{ix86} %{x8664} ppc
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
118 %define         _webapps        /etc/webapps
119 %define         _webapp         mythweb
120
121 %description
122 This is a consolidation of all the official MythTV plugins that used
123 to be distributed as separate downloads from mythtv.org.
124
125 %description -l pl.UTF-8
126 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
127 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
128
129 %package -n mytharchive
130 Summary:        A MythTV module to create and burn DVDs
131 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
132 Group:          Applications/Multimedia
133 Requires:       dvdauthor
134 Requires:       mjpegtools
135 Requires:       mythtv-frontend-api = %{myth_api_version}
136 Requires:       python-MySQLdb
137 Requires:       python-PIL
138 Suggests:       dvdrtools-mkisofs
139
140 %description -n mytharchive
141 MythArchive is a MythTV style plugin that uses the Mythburn Script to
142 create and burn DVDs from MythTV recordings, MythVideo files or any
143 video files available on a MythTV system. It can also export
144 recordings to a native archive format that can then be imported back
145 into a MythTV system restoring all the associated metadata.
146
147 %description -n mytharchive -l pl.UTF-8
148 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
149 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
150 innych plików z filmami dostępnych w systemie MythTV. Może także
151 eksportować nagrania do natywnego formatu archiwum, który potem można
152 zaimportować z powrotem do systemu MythTV przywracając wszystkie
153 związane z nimi metadane.
154
155 %package -n mythmusic
156 Summary:        The music player add-on module for MythTV
157 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
158 Group:          Applications/Multimedia
159 BuildRequires:  libvisual-devel
160 Requires:       mythtv-frontend-api = %{myth_api_version}
161
162 %description -n mythmusic
163 Music add-on for MythTV. Support playlists, visualisations, tag
164 editing and plays many popular audio file formats - mp3, flac, wav,
165 ogg etc.
166
167 %description -n mythmusic -l pl.UTF-8
168 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
169 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
170 formatów audio - mp3, flac, wav, ogg itd.
171
172 %package -n mythvideo
173 Summary:        A generic video player frontend module for MythTV
174 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
175 Group:          Applications/Multimedia
176 Requires:       mplayer
177 Requires:       mythtv-frontend-api = %{myth_api_version}
178
179 %description -n mythvideo
180 A generic video and dvd player frontend module for MythTV.
181
182 %description -n mythvideo -l pl.UTF-8
183 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
184
185 %package -n mythweather
186 Summary:        A MythTV module that displays a weather forcast
187 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
188 Group:          Applications/Multimedia
189 Requires:       mythtv-frontend-api = %{myth_api_version}
190
191 %description -n mythweather
192 A MythTV module that displays a weather forcast.
193
194 %description -n mythweather -l pl.UTF-8
195 Moduł MythTV wyświetlający prognozę pogody.
196
197 %package -n mythgallery
198 Summary:        A gallery/slideshow module for MythTV
199 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
200 Group:          Applications/Multimedia
201 Requires:       mythtv-frontend-api = %{myth_api_version}
202
203 %description -n mythgallery
204 A gallery/slideshow module for MythTV.
205
206 %description -n mythgallery -l pl.UTF-8
207 Moduł galerii/pokazu slajdów dla MythTV.
208
209 %package -n mythgame
210 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
211 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
212 Group:          Applications/Multimedia
213 Requires:       mythtv-frontend-api = %{myth_api_version}
214
215 %description -n mythgame
216 A game frontend (xmame, nes, snes, pc) for MythTV.
217
218 %description -n mythgame -l pl.UTF-8
219 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
220
221 %package -n mythdvd
222 Summary:        A DVD ripper module for MythTV
223 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
224 Group:          Applications/Multimedia
225 Requires:       mythtv-frontend-api = %{myth_api_version}
226 Requires:       mythvideo
227 Requires:       transcode >= 0.6.8
228
229 %description -n mythdvd
230 MythDVD is a MythTV module that allows you to rip DVD's and transcode
231 their video and audio content to other (generally smaller) formats.
232 The playing features are simply myth-style wrappers for your favourite
233 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
234 based on and derived from the excellent transcode package.
235
236 %description -n mythdvd -l pl.UTF-8
237 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
238 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
239 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
240 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
241 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
242 pakietu transcode.
243
244 %package -n mythnews
245 Summary:        A RSS News Feed plugin for MythTV
246 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
247 Group:          Applications/Multimedia
248 Requires:       mythtv-frontend-api = %{myth_api_version}
249
250 %description -n mythnews
251 A RSS News Feed plugin for MythTV.
252
253 %description -n mythnews -l pl.UTF-8
254 Wtyczka czytnika nowinek RSS dla MythTV.
255
256 %package -n mythbrowser
257 Summary:        A small web browser module for MythTV
258 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
259 Group:          Applications/Multimedia
260 Requires:       mythtv-frontend-api = %{myth_api_version}
261
262 %description -n mythbrowser
263 MythBrowser is a full fledged web-browser (multiple tabs) to display
264 webpages in full-screen mode. Simple page navigation is possible.
265 Starting with version 0.13 it also has full support for mouse driven
266 navigation (right mouse opens and closes the popup menu).
267
268 MythBrowser also contains a BookmarkManager to manage the website
269 links in a simple mythplugin.
270
271 %description -n mythbrowser -l pl.UTF-8
272 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
273 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
274 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
275 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
276 menu).
277
278 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
279 do stron w prostej wtyczce myth.
280
281 %package -n mythweb
282 Summary:        The web interface to MythTV
283 Summary(pl.UTF-8):      Interfejs WWW do MythTV
284 Group:          Applications/Multimedia
285 Requires:       php(mysql)
286 Requires:       php(posix)
287 Requires:       webapps
288 Requires:       webserver(php) >= 4.3
289
290 %description -n mythweb
291 The web interface to MythTV.
292
293 %description -n mythweb -l pl.UTF-8
294 Interfejs WWW do MythTV.
295
296 %package -n mythnetvision
297 Summary:        Mythtv extension to watch network movie shows
298 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
299 Group:          Applications/Multimedia
300 Requires:       mythbrowser
301 Requires:       mythtv-frontend-api = %{myth_api_version}
302
303 %description -n mythnetvision
304 Mythtv extension to watch network movie shows (ex. YouTube).
305
306 %description -n mythnetvision -l pl.UTF-8
307 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
308 YouTube.
309
310 %package -n mythmovies
311 Summary:        MythTV cinemas timetable
312 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
313 Group:          Applications/Multimedia
314 Requires:       mythtv-frontend-api = %{myth_api_version}
315
316 %description -n mythmovies
317 MythTV cinemas timetable.
318
319
320 %description -n mythmovies -l pl.UTF-8
321 Moduł MythTV do repertuaru kinowego.
322
323 %package -n mythzoneminder
324 Summary:        MythTV security TV manager
325 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
326 Group:          Applications/Multimedia
327 Requires:       mythtv-frontend-api = %{myth_api_version}
328
329 %description -n mythzoneminder
330 MythTV security TV manager.
331
332
333 %description -n mythzoneminder -l pl.UTF-8
334 Obsługa kamer przemysłowych dla MythTV.
335
336 %prep
337 %setup -q
338 %patch0 -p1
339 %patch10 -p1
340 %patch20 -p1
341
342 # lib64 fix - enable to update patch
343 %if %{_lib} != "lib" && 0
344 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
345 xargs grep -l /lib/ . | xargs sed -i -e '
346 s,%{_prefix}/lib/,/%{_lib}/,g
347         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
348 '
349 exit 1
350 %endif
351
352 %build
353 %if %{with binary}
354 export QTDIR="%{_prefix}"
355 # Not gnu configure
356 %configure \
357         --libdir-name=`basename %{_lib}` \
358         --enable-all \
359         %{!?with_mytharchive:--disable-mytharchive} \
360         %{!?with_mythbrowser:--disable-mythbrowser} \
361         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
362         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
363         %{!?with_mythgame:--disable-mythgame} \
364         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
365         %{!?with_mythnews:--disable-mythnews} \
366         %{!?with_mythvideo:--disable-mythvideo} \
367         %{!?with_mythweather:--disable-mythweather} \
368         %{!?with_mythweb:--disable-mythweb} \
369         %{!?with_mythmovies:--disable-mythmovies} \
370         %{!?with_mythnetvision:--disable-mythnetvision} \
371
372 mv mythconfig.mak mythconfig.mak.old
373 cp mythconfig.mak.old mythconfig.mak
374 cat <<'EOF'>> mythconfig.mak
375 QMAKE_CXX=%{__cxx}
376 QMAKE_CC=%{__cc}
377 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
378 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
379 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
380 EOF
381
382 %{__make}
383 %endif
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387 %if %{with binary}
388 export QTDIR="%{_prefix}"
389 %{__make} install \
390         INSTALL_ROOT=$RPM_BUILD_ROOT
391
392 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
393 %if %{with mythgame}
394 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
395 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
396 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
397 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
398 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
399 %endif
400 %endif
401
402 %if %{with mythweb}
403 cd mythweb
404 cp -a %{SOURCE3} ./
405 cp -a %{SOURCE4} ./
406 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
407 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
408 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
409 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
410 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
411 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
412 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
413 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
414 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
415 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
416 cd -
417 %endif
418
419 rm -f $RPM_BUILD_ROOT%{_datadir}/data
420 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
421 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
422         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
423                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
424         done > $p.lang
425 done
426
427 %clean
428 rm -rf $RPM_BUILD_ROOT
429
430 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
431 %webapp_register apache %{_webapp}
432
433 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
434 %webapp_unregister apache %{_webapp}
435
436 %triggerin -n mythweb -- apache < 2.2.0, apache-base
437 %webapp_register httpd %{_webapp}
438
439 %triggerin -n mythweb -- lighttpd
440 %webapp_register lighttpd %{_webapp}
441
442 %triggerun -n mythweb -- apache < 2.2.0, apache-base
443 %webapp_unregister httpd %{_webapp}
444
445 %triggerun -n mythweb -- lighttpd
446 %webapp_unregister lighttpd %{_webapp}
447
448 %triggerpostun -n mythweb -- mythweb < 0.19
449 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
450         if [ -f /etc/mythweb/$i.rpmsave ]; then
451                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
452                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
453         fi
454 done
455 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
456
457 # migrate from apache-config macros
458 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
459         if [ -d /etc/apache/webapps.d ]; then
460                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
461                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
462         fi
463
464         if [ -d /etc/httpd/webapps.d ]; then
465                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
466                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
467         fi
468         rm -f /etc/mythweb/apache.conf.rpmsave
469 fi
470
471 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
472         rm -f /etc/apache/conf.d/99_mythplugins.conf
473         /usr/sbin/webapp register apache %{_webapp}
474         %service -q apache reload
475 fi
476 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
477         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
478         /usr/sbin/webapp register httpd %{_webapp}
479         %service -q httpd reload
480 fi
481
482 %post -n mythweb
483 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
484 which packages you can need to run mythweb and how to set it quickly."
485
486 %files
487 %defattr(644,root,root,755)
488
489 %if %{with mytharchive}
490 %files -n mytharchive -f mytharchive.lang
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/mytharchivehelper
493 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
494 %{_datadir}/mythtv/archivemenu.xml
495 %{_datadir}/mythtv/archiveutils.xml
496 %{_datadir}/mythtv/themes/default/ma_*.png
497 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
498 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
499 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
500 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
501 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
502 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
503 %{_datadir}/mythtv/mytharchive
504 %endif
505
506 %if %{with mythmusic}
507 %files -n mythmusic -f mythmusic.lang
508 %defattr(644,root,root,755)
509 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
510 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
511 /var/lib/mythmusic
512 %{_datadir}/mythtv/musicmenu.xml
513 %{_datadir}/mythtv/music_settings.xml
514 %{_datadir}/mythtv/themes/default/music-ui.xml
515 %{_datadir}/mythtv/themes/default/mm-titlelines.png
516 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
517 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
518 %{_datadir}/mythtv/themes/default/ff_button_off.png
519 %{_datadir}/mythtv/themes/default/ff_button_on.png
520 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
521 %{_datadir}/mythtv/themes/default/miniplayer_background.png
522 %{_datadir}/mythtv/themes/default/mm_*.png
523 %{_datadir}/mythtv/themes/default/music-sel-bg.png
524 %{_datadir}/mythtv/themes/default/next_button_off.png
525 %{_datadir}/mythtv/themes/default/next_button_on.png
526 %{_datadir}/mythtv/themes/default/next_button_pushed.png
527 %{_datadir}/mythtv/themes/default/pause_button_off.png
528 %{_datadir}/mythtv/themes/default/pause_button_on.png
529 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
530 %{_datadir}/mythtv/themes/default/play_button_off.png
531 %{_datadir}/mythtv/themes/default/play_button_on.png
532 %{_datadir}/mythtv/themes/default/play_button_pushed.png
533 %{_datadir}/mythtv/themes/default/prev_button_off.png
534 %{_datadir}/mythtv/themes/default/prev_button_on.png
535 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
536 %{_datadir}/mythtv/themes/default/rew_button_off.png
537 %{_datadir}/mythtv/themes/default/rew_button_on.png
538 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
539 %{_datadir}/mythtv/themes/default/selectionbar.png
540 %{_datadir}/mythtv/themes/default/stop_button_off.png
541 %{_datadir}/mythtv/themes/default/stop_button_on.png
542 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
543 %{_datadir}/mythtv/themes/default/track_info_background.png
544 %{_datadir}/mythtv/themes/default-wide/mm_*.png
545 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
546 %endif
547
548 %if %{with mythvideo}
549 %files -n mythvideo -f mythvideo.lang
550 %defattr(644,root,root,755)
551 %doc mythvideo/README mythvideo/videodb
552 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
553 %{_datadir}/mythtv/themes/default/video-ui.xml
554 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
555 %{_datadir}/mythtv/themes/default/mv_*.png
556 %{_datadir}/mythtv/themes/default-wide/mv_*.png
557 %{_datadir}/mythtv/video_settings.xml
558 %{_datadir}/mythtv/videomenu.xml
559 %dir %{_datadir}/mythtv/mythvideo
560 %dir %{_datadir}/mythtv/mythvideo/scripts
561 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
562 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
563 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
564 %{_datadir}/mythtv/mythvideo/scripts/README
565 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
566 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
567 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
568 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
569 %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
570 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
571 %{_datadir}/mythtv/mythvideo/scripts/Television/*
572 /var/lib/mythvideo
573 %endif
574
575 %if %{with mythweather}
576 %files -n mythweather -f mythweather.lang
577 %defattr(644,root,root,755)
578 %doc mythweather/README
579 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
580 %{_datadir}/mythtv/mythweather
581 %{_datadir}/mythtv/weather_settings.xml
582 %{_datadir}/mythtv/themes/default/weather-ui.xml
583 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
584 %{_datadir}/mythtv/themes/default/cloudy.png
585 %{_datadir}/mythtv/themes/default/fair.png
586 %{_datadir}/mythtv/themes/default/flurries.png
587 %{_datadir}/mythtv/themes/default/fog.png
588 %{_datadir}/mythtv/themes/default/logo.png
589 %{_datadir}/mythtv/themes/default/lshowers.png
590 %{_datadir}/mythtv/themes/default/mcloudy.png
591 %{_datadir}/mythtv/themes/default/mw_*.png
592 %{_datadir}/mythtv/themes/default/mwmain.png
593 %{_datadir}/mythtv/themes/default/pcloudy.png
594 %{_datadir}/mythtv/themes/default/rainsnow.png
595 %{_datadir}/mythtv/themes/default/showers.png
596 %{_datadir}/mythtv/themes/default/snowshow.png
597 %{_datadir}/mythtv/themes/default/sunny.png
598 %{_datadir}/mythtv/themes/default/thunshowers.png
599 %{_datadir}/mythtv/themes/default/unknown.png
600 %{_datadir}/mythtv/themes/default-wide/mw-*.png
601 %endif
602
603 %if %{with mythgallery}
604 %files -n mythgallery -f mythgallery.lang
605 %defattr(644,root,root,755)
606 %doc mythgallery/README
607 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
608 %{_datadir}/mythtv/themes/default/gallery-ui.xml
609 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
610 %{_datadir}/mythtv/themes/default/gallery-*.png
611 /var/lib/pictures
612 %endif
613
614 %if %{with mythgame}
615 %files -n mythgame -f mythgame.lang
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
618 %{_datadir}/mythtv/games
619 %{_datadir}/mythtv/game_settings.xml
620 %{_datadir}/mythtv/themes/default/game-ui.xml
621 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
622 %endif
623
624 %if %{with mythdvd}
625 %files -n mythdvd
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_bindir}/mtd
628 %{_datadir}/mythtv/themes/default/dvd-ui.xml
629 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
630 %{_datadir}/mythtv/themes/default/md_*.png
631 %endif
632
633 %if %{with mythnews}
634 %files -n mythnews -f mythnews.lang
635 %defattr(644,root,root,755)
636 %doc mythnews/README mythnews/AUTHORS
637 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
638 %{_datadir}/mythtv/mythnews
639 %{_datadir}/mythtv/themes/default/news-ui.xml
640 %{_datadir}/mythtv/themes/default/news-info-bg.png
641 %{_datadir}/mythtv/themes/default/enclosures.png
642 %{_datadir}/mythtv/themes/default/need-download.png
643 %{_datadir}/mythtv/themes/default/podcast.png
644 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
645 %endif
646
647 %if %{with mythbrowser}
648 %files -n mythbrowser -f mythbrowser.lang
649 %defattr(644,root,root,755)
650 %doc mythbrowser/README mythbrowser/AUTHORS
651 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
652 %{_datadir}/mythtv/themes/default/mb_progress*.png
653 %{_datadir}/mythtv/themes/default/browser-ui.xml
654 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
655 %endif
656
657 %if %{with mythweb}
658 %files -n mythweb
659 %defattr(644,root,root,755)
660 %doc mythweb/README mythweb/mythweb.conf.lighttpd
661 %doc mythweb/htdigest.sh
662 %doc mythweb/http_servers_conf_tips.txt
663 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
664 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
666 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
667 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
668 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
669 %{_datadir}/mythweb
670 %dir %attr(771,root,http) /var/cache/mythweb
671 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
672 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
673 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
674 %endif
675
676 %if %{with mythnetvision}
677 %files -n mythnetvision -f mythnetvision.lang
678 %defattr(644,root,root,755)
679 %doc mythnetvision/{AUTHORS,ChangeLog,README}
680 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
681 %dir %{_datadir}/mythtv/mythnetvision
682 %{_datadir}/mythtv/netvisionmenu.xml
683 %dir %{_datadir}/mythtv/mythnetvision/scripts
684 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
685 %dir %{_datadir}/mythtv/mythnetvision/icons
686 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
687 %{_datadir}/mythtv/mythnetvision/icons/*.png
688 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
689 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
690 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
691 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
692 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
693 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
694 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
695 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
696 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
697 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
698 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
699 %{_datadir}/mythtv/themes/default/netvision-ui.xml
700 %endif
701
702 %if %{with mythmovies}
703 %files -n mythmovies
704 %defattr(644,root,root,755)
705 %defattr(644,root,root,755)
706 %doc mythmovies/{README,TODO}
707 %attr(755,root,root) %{_bindir}/ignyte
708 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
709 %{_datadir}/mythtv/themes/default/movies-ui.xml
710 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
711 %{_datadir}/mythtv/i18n/mythmovies_*.qm
712 %endif
713
714 %if %{with mythzoneminder}
715 %files -n mythzoneminder
716 %defattr(644,root,root,755)
717 %defattr(644,root,root,755)
718 %doc mythzoneminder/{AUTHORS,README}
719 %attr(755,root,root) %{_bindir}/mythzmserver
720 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
721 %dir %{_datadir}/mythtv/zonemindermenu.xml
722 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
723 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
724 %{_datadir}/mythtv/themes/default/mz_*png
725 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
726 %endif
This page took 0.837702 seconds and 4 git commands to generate.