]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- more settings paths changes in programs
[packages/mythplugins.git] / mythplugins.spec
1 # disable mythmusic,mythphone due to https://bugs.pld-linux.org/?do=details&id=5687
2 %bcond_without  mythmusic
3 %bcond_without mythphone
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Main MythTV plugins.
7 Name:           mythplugins
8 Version:        0.18.1
9 Release:        0.112.9
10 License:        GPL v2
11 Group:          Applications/Multimedia
12 URL:            http://www.mythtv.org/
13 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  1d94d19e2a13c24a408ced9b6c4f5b47
15 Patch0:         %{name}-configure.patch
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  SDL-devel
19 BuildRequires:  X11-OpenGL-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  a52dec-libs-devel
22 BuildRequires:  cdparanoia-III-devel
23 BuildRequires:  faad2-devel >= 2.0-5.2
24 BuildRequires:  fftw-devel >= 2.1.3
25 BuildRequires:  flac-devel >= 1.0.4
26 BuildRequires:  freetype-devel
27 BuildRequires:  kdelibs-devel
28 BuildRequires:  libcdaudio-devel
29 BuildRequires:  libdvdcss-devel >= 1.2.7
30 BuildRequires:  libdvdread-devel >= 0.9.4
31 BuildRequires:  libexif-devel
32 BuildRequires:  libfame-devel >= 0.9.0
33 BuildRequires:  libid3tag-devel
34 BuildRequires:  libmad-devel
35 BuildRequires:  libmyth-devel >= 0.18.1-0.21
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtiff-devel
38 BuildRequires:  libvorbis-devel >= 1.0
39 BuildRequires:  mjpegtools-devel >= 1.6.1
40 BuildRequires:  nasm
41 BuildRequires:  transcode >= 0.6.8
42 BuildRequires:  xvid-devel >= 1:0.9.1
43 BuildRequires:  zlib-devel
44 Requires:       mythbrowser
45 Requires:       mythdvd
46 Requires:       mythgallery
47 Requires:       mythgame
48 %{?with_mythmusic:Requires:     mythmusic}
49 Requires:       mythnews
50 %{?with_mythphone:Requires:     mythphone}
51 Requires:       mythvideo
52 Requires:       mythweather
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         api_ver %(echo %{version} | cut -d. -f1,2)
56
57 %description
58 This is a consolidation of all the official MythTV plugins that used
59 to be distributed as separate downloads from mythtv.org.
60
61 %package -n mythmusic
62 Summary:        The music player add-on module for MythTV.
63 Group:          Applications/Multimedia
64 Requires:       mythtv-frontend-api = %{api_ver}
65
66 %description -n mythmusic
67 Music add-on for mythtv.
68
69 %package -n mythvideo
70 Summary:        A generic video player frontend module for MythTV.
71 Group:          Applications/Multimedia
72 Requires:       mplayer
73 Requires:       mythtv-frontend-api = %{api_ver}
74
75 %description -n mythvideo
76 A generic video player frontend module for MythTV.
77
78 %package -n mythweather
79 Summary:        A MythTV module that displays a weather forcast.
80 Group:          Applications/Multimedia
81 Requires:       mythtv-frontend-api = %{api_ver}
82
83 %description -n mythweather
84 A MythTV module that displays a weather forcast.
85
86 %package -n mythgallery
87 Summary:        A gallery/slideshow module for MythTV.
88 Group:          Applications/Multimedia
89 Requires:       mythtv-frontend-api = %{api_ver}
90
91 %description -n mythgallery
92 A gallery/slideshow module for MythTV.
93
94 %package -n mythgame
95 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV.
96 Group:          Applications/Multimedia
97 Requires:       mythtv-frontend-api = %{api_ver}
98
99 %description -n mythgame
100 A game frontend (xmame, nes, snes, pc) for MythTV.
101
102 %package -n mythdvd
103 Summary:        A DVD player module for MythTV.
104 Group:          Applications/Multimedia
105 Requires:       mythtv-frontend-api = %{api_ver}
106 Requires:       transcode >= 0.6.8
107
108 %description -n mythdvd
109 MythDVD is a MythTV module that allows you to play DVD's on a myth-box
110 and (optionally) rip DVD's and transcode their video and audio content
111 to other (generally smaller) formats. The playing features are simply
112 myth-style wrappers for your favourite DVD playing software (mplayer,
113 ogle, xine, etc). The transcoding is based on and derived from the
114 excellent transcode package.
115
116 %package -n mythnews
117 Summary:        A RSS News Feed Plugin for MythTV.
118 Group:          Applications/Multimedia
119 Requires:       mythtv-frontend-api = %{api_ver}
120
121 %description -n mythnews
122
123 %package -n mythbrowser
124 Summary:        A small web browser module for MythTV.
125 Group:          Applications/Multimedia
126 Requires:       mythtv-frontend-api = %{api_ver}
127
128 %description -n mythbrowser
129 MythBrowser is a full fledged web-browser (multiple tabs) to display
130 webpages in full-screen mode. Simple page navigation is possible.
131 Starting with version 0.13 it also has full support for mouse driven
132 navigation (right mouse opens and clos es the popup menu).
133
134 MythBrowser also contains a BookmarkManager to manage the website
135 links in a simple mythplugin.
136
137 %package -n mythphone
138 Summary:        A video conferencing module for MythTV.
139 Group:          Applications/Multimedia
140 Requires:       mythtv-frontend-api = %{api_ver}
141
142 %description -n mythphone
143 Mythphone is a phone and videophone capability on MYTH using the
144 standard SIP protocol. It is compatible with Microsoft XP Messenger
145 and with SIP Service Providers such as Free World Dialup
146 (fwd.pulver.com).
147
148 %prep
149 %setup -q
150 %patch0 -p1
151
152 # lib64 fix
153 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
154 xargs grep -l /lib/ . | xargs sed -i -e '
155         s,/usr/lib/,/usr/%{_lib}/,g
156         s,{PREFIX}/lib,{PREFIX}/%{_lib}/,g
157 '
158
159 sed -i -e 's|/mnt/store/music|/var/lib/mythmusic|' mythmusic/mythmusic/globalsettings.cpp
160 sed -i -e 's|/share/Movies/dvd|/var/lib/mythvideo|' mythvideo/mythvideo/globalsettings.cpp
161 sed -i -e 's|/mnt/cdrom:/mnt/camera|/media/cdrom:/mnt/camera|' mythgallery/mythgallery/gallerysettings.cpp
162
163
164 # include mythtv build settings
165 cp %{_datadir}/mythtv/build/config.mak .
166 sed -i -e '1iinclude(config.mak)'  settings.pro
167
168 %ifarch %{x8664}
169         # mmx asm isn't x86_64 compatible in mythmusic
170     echo 'DEFINES -= HAVE_MMX' >> settings.pro
171 %endif
172
173
174 %build
175 export QTDIR="%{_prefix}"
176 # Not gnu configure
177 %configure \
178         --enable-all \
179         --disable-festival \
180         %{!?with_mythmusic:--disable-mythmusic} \
181         %{!?with_mythphone:--disable-mythphone}
182
183 #       --enable-opengl          enable OpenGL (Music and Gallery) [default=no]
184 #       --enable-transcode       enable DVD ripping and transcoding [default=no]
185 #       --enable-vcd             enable VCD playing [default=no]
186 #       --enable-exif            enable reading of EXIF headers [default=no]
187 #       --enable-fftw            enable fftw visualizers [default=no]
188 #       --enable-sdl             use SDL for the synaesthesia output [default=no]
189 #       --enable-aac             enable AAC/MP4 audio file decompression [default=no]
190 #       --enable-festival        enable festival TTS Engine [default=no]
191
192 qmake mythplugins.pro
193 %{__make}
194
195 %install
196 rm -rf $RPM_BUILD_ROOT
197
198 export QTDIR="%{_prefix}"
199 %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
200
201 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
202 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
203 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
204 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
205 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
206 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %files
212 %defattr(644,root,root,755)
213
214 %if %{with mythmusic}
215 %files -n mythmusic
216 %defattr(644,root,root,755)
217 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
218 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
219 /var/lib/mythmusic
220 %{_datadir}/mythtv/musicmenu.xml
221 %{_datadir}/mythtv/music_settings.xml
222 %{_datadir}/mythtv/i18n/mythmusic_*.qm
223 %{_datadir}/mythtv/themes/default/ff_button_off.png
224 %{_datadir}/mythtv/themes/default/ff_button_on.png
225 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
226 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
227 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
228 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
229 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
230 %{_datadir}/mythtv/themes/default/mm_checked.png
231 %{_datadir}/mythtv/themes/default/mm_checked_high.png
232 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
233 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
234 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
235 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
236 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
237 %{_datadir}/mythtv/themes/default/mm_rating.png
238 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
239 %{_datadir}/mythtv/themes/default/mm_unchecked.png
240 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
241 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
242 %{_datadir}/mythtv/themes/default/mm_volume_background.png
243 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
244 %{_datadir}/mythtv/themes/default/mm_waiting.png
245 %{_datadir}/mythtv/themes/default/music-sel-bg.png
246 %{_datadir}/mythtv/themes/default/music-ui.xml
247 %{_datadir}/mythtv/themes/default/next_button_off.png
248 %{_datadir}/mythtv/themes/default/next_button_on.png
249 %{_datadir}/mythtv/themes/default/next_button_pushed.png
250 %{_datadir}/mythtv/themes/default/pause_button_off.png
251 %{_datadir}/mythtv/themes/default/pause_button_on.png
252 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
253 %{_datadir}/mythtv/themes/default/play_button_off.png
254 %{_datadir}/mythtv/themes/default/play_button_on.png
255 %{_datadir}/mythtv/themes/default/play_button_pushed.png
256 %{_datadir}/mythtv/themes/default/prev_button_off.png
257 %{_datadir}/mythtv/themes/default/prev_button_on.png
258 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
259 %{_datadir}/mythtv/themes/default/rew_button_off.png
260 %{_datadir}/mythtv/themes/default/rew_button_on.png
261 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
262 %{_datadir}/mythtv/themes/default/selectionbar.png
263 %{_datadir}/mythtv/themes/default/stop_button_off.png
264 %{_datadir}/mythtv/themes/default/stop_button_on.png
265 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
266 %{_datadir}/mythtv/themes/default/text_button_off.png
267 %{_datadir}/mythtv/themes/default/text_button_on.png
268 %{_datadir}/mythtv/themes/default/text_button_pushed.png
269 %{_datadir}/mythtv/themes/default/track_info_background.png
270 %endif
271
272 %files -n mythvideo
273 %defattr(644,root,root,755)
274 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
275 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
276 %{_datadir}/mythtv/i18n/mythvideo_*.qm
277 %{_datadir}/mythtv/themes/default/video-ui.xml
278 %{_datadir}/mythtv/themes/default/mv-*.png
279 %{_datadir}/mythtv/themes/default/mv_*.png
280 %{_datadir}/mythtv/video_settings.xml
281 %{_datadir}/mythtv/videomenu.xml
282 %dir %{_datadir}/mythtv/mythvideo
283 %dir %{_datadir}/mythtv/mythvideo/scripts
284 %{_datadir}/mythtv/mythvideo/scripts/README
285 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
286 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
287 /var/lib/mythvideo
288
289 %files -n mythweather
290 %defattr(644,root,root,755)
291 %doc mythweather/README
292 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
293 %{_datadir}/mythtv/i18n/mythweather_*.qm
294 %{_datadir}/mythtv/mythweather
295 %{_datadir}/mythtv/themes/default/weather-ui.xml
296 %{_datadir}/mythtv/themes/default/cloudy.png
297 %{_datadir}/mythtv/themes/default/fair.png
298 %{_datadir}/mythtv/themes/default/flurries.png
299 %{_datadir}/mythtv/themes/default/fog.png
300 %{_datadir}/mythtv/themes/default/logo.png
301 %{_datadir}/mythtv/themes/default/lshowers.png
302 %{_datadir}/mythtv/themes/default/mcloudy.png
303 %{_datadir}/mythtv/themes/default/mw-*.png
304 %{_datadir}/mythtv/themes/default/mwmain.png
305 %{_datadir}/mythtv/themes/default/pcloudy.png
306 %{_datadir}/mythtv/themes/default/rainsnow.png
307 %{_datadir}/mythtv/themes/default/showers.png
308 %{_datadir}/mythtv/themes/default/snowshow.png
309 %{_datadir}/mythtv/themes/default/sunny.png
310 %{_datadir}/mythtv/themes/default/thunshowers.png
311 %{_datadir}/mythtv/themes/default/unknown.png
312
313 %files -n mythgallery
314 %defattr(644,root,root,755)
315 %doc mythgallery/README mythgallery/UPGRADING
316 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
317 %{_datadir}/mythtv/themes/default/gallery-ui.xml
318 %{_datadir}/mythtv/themes/default/gallery-*.png
319 %{_datadir}/mythtv/i18n/mythgallery_*.qm
320 /var/lib/pictures
321
322 %files -n mythgame
323 %defattr(644,root,root,755)
324 %doc mythgame/README mythgame/UPGRADING
325 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
326 %{_datadir}/mythtv/games
327 #%config %{_datadir}/mythtv/games/PC/gamelist.xml
328 #%{_datadir}/xmame/screens
329 #%{_datadir}/xmame/flyers
330 %{_datadir}/mythtv/game_settings.xml
331 %{_datadir}/mythtv/themes/default/game-ui.xml
332 %{_datadir}/mythtv/i18n/mythgame_*.qm
333
334 %files -n mythdvd
335 %defattr(644,root,root,755)
336 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
337 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
338 %{_datadir}/mythtv/dvd_settings.xml
339 %{_datadir}/mythtv/dvdmenu.xml
340 %{_datadir}/mythtv/themes/default/dvd-ui.xml
341 %{_datadir}/mythtv/themes/default/md_*.png
342 %{_datadir}/mythtv/i18n/mythdvd_*.qm
343 %attr(755,root,root) %{_bindir}/mtd
344
345 %files -n mythnews
346 %defattr(644,root,root,755)
347 %doc mythnews/README mythnews/AUTHORS
348 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
349 %{_datadir}/mythtv/mythnews
350 %{_datadir}/mythtv/themes/default/news-ui.xml
351 %{_datadir}/mythtv/themes/default/news-info-bg.png
352 %{_datadir}/mythtv/i18n/mythnews_*.qm
353
354 %files -n mythbrowser
355 %defattr(644,root,root,755)
356 %doc mythbrowser/README mythbrowser/AUTHORS
357 %attr(755,root,root) %{_bindir}/mythbrowser
358 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
359 %{_datadir}/mythtv/themes/default/webpage.png
360 %{_datadir}/mythtv/i18n/mythbrowser_*.qm
361
362 %if %{with mythphone}
363 %files -n mythphone
364 %defattr(644,root,root,755)
365 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
366 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
367 %{_datadir}/mythtv/themes/default/phone-ui.xml
368 %{_datadir}/mythtv/themes/default/webcam-ui.xml
369 %{_datadir}/mythtv/themes/default/mp_*.png
370 %{_datadir}/mythtv/themes/default/phone.png
371 %{_datadir}/mythtv/i18n/mythphone_*.qm
372 %endif
This page took 0.067315 seconds and 4 git commands to generate.