]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- clean up; adapterized
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_without  mythvideo       # disable building mythgallery plugin
14 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
15 # not present by default in PLD
16 %bcond_with     mythweather     # building mythgallery plugin disabled by default
17                                 # it looks unusable "due to msnbc webpage structure change
18 %bcond_without  mythweb         # disable building mythgallery plugin
19 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
20
21 %if !%{with binary}
22 %undefine       with_mytharchive
23 %undefine       with_mythbrowser
24 %undefine       with_mythmovies
25 %undefine       with_mythdvd
26 %undefine       with_mythnetvision
27 %undefine       with_mythgallery
28 %undefine       with_mythgame
29 %undefine       with_mythmusic
30 %undefine       with_mythnews
31 %undefine       with_mythvideo
32 %undefine       with_mythweather
33 %endif
34
35 %include        /usr/lib/rpm/macros.perl
36
37 #%define fix     24635
38
39 Summary:        Main MythTV plugins
40 Summary(pl.UTF-8):      Główne wtyczki MythTV
41 Name:           mythplugins
42 Version:        0.23.1
43 Release:        2
44 #Release:       fix%{fix}.1
45 License:        GPL v2
46 Group:          Applications/Multimedia
47 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
48 # Source0-md5:  edd9c5f8a9ae0189b1c8951fa8282c4d
49 Source1:        mythweb.conf
50 Source2:        mythweb_lighttpd.conf
51 Source3:        htdigest.sh
52 Source4:        http_servers_conf_tips.txt
53 Patch0:         mythweb-chdir.patch
54 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
55 Patch20:        %{name}-mytharchive-INT64.patch
56 URL:            http://www.mythtv.org/
57 %if %{with binary}
58 %if %{with mythgallery} || %{with myhtmusic}
59 BuildRequires:  OpenGL-devel
60 %endif
61 BuildRequires:  Qt3Support-devel
62 BuildRequires:  QtCore-devel
63 BuildRequires:  QtGui-devel
64 BuildRequires:  QtNetwork-devel
65 BuildRequires:  QtOpenGL-devel
66 BuildRequires:  QtSql-devel
67 BuildRequires:  QtWebKit-devel
68 BuildRequires:  QtXml-devel
69 BuildRequires:  SDL-devel
70 BuildRequires:  a52dec-libs-devel
71 BuildRequires:  cdparanoia-III-devel
72 BuildRequires:  faad2-devel >= 2.0-5.2
73 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
74 BuildRequires:  flac-devel >= 1.0.4
75 BuildRequires:  freetype-devel
76 BuildRequires:  libcdaudio-devel >= 0.99.12p2
77 BuildRequires:  libdvdcss-devel >= 1.2.7
78 BuildRequires:  libdvdread-devel >= 0.9.4
79 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
80 BuildRequires:  libfame-devel >= 0.9.0
81 BuildRequires:  libid3tag-devel
82 BuildRequires:  libmad-devel
83 BuildRequires:  libmyth-devel > 0.21
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  libtiff-devel
86 BuildRequires:  libvorbis-devel >= 1:1.0
87 BuildRequires:  mjpegtools-devel >= 1.6.1
88 BuildRequires:  nasm
89 BuildRequires:  patchutils
90 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
91 %{?with_mythweather:BuildRequires:      perl-Image-Size}
92 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
93 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
94 BuildRequires:  qt4-build
95 BuildRequires:  qt4-qmake
96 BuildRequires:  rpm-perlprov >= 4.1-13
97 BuildRequires:  sed >= 4.0
98 %{?with_mythmusic:BuildRequires:        taglib-devel}
99 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
100 BuildRequires:  xorg-lib-libX11-devel
101 BuildRequires:  xvid-devel >= 1:0.9.1
102 BuildRequires:  zlib-devel
103 %endif
104 %{?with_mytharchive:Requires:   mytharchive}
105 %{?with_mythbrowser:Requires:   mythbrowser}
106 %{?with_mythdvd:Requires:       mythdvd}
107 %{?with_mythgallery:Requires:   mythgallery}
108 %{?with_mythgame:Requires:      mythgame}
109 %{?with_mythmysic:Requires:     mythmusic}
110 %{?with_mythnetvision:Requires: mythnetvision}
111 %{?with_mythnews:Requires:      mythnews}
112 %{?with_mythvideo:Requires:     mythvideo}
113 %{?with_mythweather:Requires:   mythweather}
114 %{?with_mythweb:Requires:       mythweb}
115 ExclusiveArch:  %{ix86} %{x8664} ppc
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
119 %define         _webapps        /etc/webapps
120 %define         _webapp         mythweb
121
122 %description
123 This is a consolidation of all the official MythTV plugins that used
124 to be distributed as separate downloads from mythtv.org.
125
126 %description -l pl.UTF-8
127 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
128 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
129
130 %package -n mytharchive
131 Summary:        A MythTV module to create and burn DVDs
132 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
133 Group:          Applications/Multimedia
134 Requires:       dvdauthor
135 Requires:       mjpegtools
136 Requires:       mythtv-frontend-api = %{myth_api_version}
137 Requires:       python-MySQLdb
138 Requires:       python-PIL
139 Suggests:       dvdrtools-mkisofs
140
141 %description -n mytharchive
142 MythArchive is a MythTV style plugin that uses the Mythburn Script to
143 create and burn DVDs from MythTV recordings, MythVideo files or any
144 video files available on a MythTV system. It can also export
145 recordings to a native archive format that can then be imported back
146 into a MythTV system restoring all the associated metadata.
147
148 %description -n mytharchive -l pl.UTF-8
149 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
150 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
151 innych plików z filmami dostępnych w systemie MythTV. Może także
152 eksportować nagrania do natywnego formatu archiwum, który potem można
153 zaimportować z powrotem do systemu MythTV przywracając wszystkie
154 związane z nimi metadane.
155
156 %package -n mythmusic
157 Summary:        The music player add-on module for MythTV
158 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
159 Group:          Applications/Multimedia
160 BuildRequires:  libvisual-devel
161 Requires:       mythtv-frontend-api = %{myth_api_version}
162
163 %description -n mythmusic
164 Music add-on for MythTV. Support playlists, visualisations, tag
165 editing and plays many popular audio file formats - mp3, flac, wav,
166 ogg etc.
167
168 %description -n mythmusic -l pl.UTF-8
169 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
170 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
171 formatów audio - mp3, flac, wav, ogg itd.
172
173 %package -n mythvideo
174 Summary:        A generic video player frontend module for MythTV
175 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
176 Group:          Applications/Multimedia
177 Requires:       mplayer
178 Requires:       mythtv-frontend-api = %{myth_api_version}
179
180 %description -n mythvideo
181 A generic video and dvd player frontend module for MythTV.
182
183 %description -n mythvideo -l pl.UTF-8
184 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
185
186 %package -n mythweather
187 Summary:        A MythTV module that displays a weather forcast
188 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
189 Group:          Applications/Multimedia
190 Requires:       mythtv-frontend-api = %{myth_api_version}
191
192 %description -n mythweather
193 A MythTV module that displays a weather forcast.
194
195 %description -n mythweather -l pl.UTF-8
196 Moduł MythTV wyświetlający prognozę pogody.
197
198 %package -n mythgallery
199 Summary:        A gallery/slideshow module for MythTV
200 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
201 Group:          Applications/Multimedia
202 Requires:       mythtv-frontend-api = %{myth_api_version}
203
204 %description -n mythgallery
205 A gallery/slideshow module for MythTV.
206
207 %description -n mythgallery -l pl.UTF-8
208 Moduł galerii/pokazu slajdów dla MythTV.
209
210 %package -n mythgame
211 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
212 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
213 Group:          Applications/Multimedia
214 Requires:       mythtv-frontend-api = %{myth_api_version}
215
216 %description -n mythgame
217 A game frontend (xmame, nes, snes, pc) for MythTV.
218
219 %description -n mythgame -l pl.UTF-8
220 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
221
222 %package -n mythdvd
223 Summary:        A DVD ripper module for MythTV
224 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
225 Group:          Applications/Multimedia
226 Requires:       mythtv-frontend-api = %{myth_api_version}
227 Requires:       mythvideo
228 Requires:       transcode >= 0.6.8
229
230 %description -n mythdvd
231 MythDVD is a MythTV module that allows you to rip DVD's and transcode
232 their video and audio content to other (generally smaller) formats.
233 The playing features are simply myth-style wrappers for your favourite
234 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
235 based on and derived from the excellent transcode package.
236
237 %description -n mythdvd -l pl.UTF-8
238 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
239 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
240 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
241 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
242 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
243 pakietu transcode.
244
245 %package -n mythnews
246 Summary:        A RSS News Feed plugin for MythTV
247 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
248 Group:          Applications/Multimedia
249 Requires:       mythtv-frontend-api = %{myth_api_version}
250
251 %description -n mythnews
252 A RSS News Feed plugin for MythTV.
253
254 %description -n mythnews -l pl.UTF-8
255 Wtyczka czytnika nowinek RSS dla MythTV.
256
257 %package -n mythbrowser
258 Summary:        A small web browser module for MythTV
259 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
260 Group:          Applications/Multimedia
261 Requires:       mythtv-frontend-api = %{myth_api_version}
262
263 %description -n mythbrowser
264 MythBrowser is a full fledged web-browser (multiple tabs) to display
265 webpages in full-screen mode. Simple page navigation is possible.
266 Starting with version 0.13 it also has full support for mouse driven
267 navigation (right mouse opens and closes the popup menu).
268
269 MythBrowser also contains a BookmarkManager to manage the website
270 links in a simple mythplugin.
271
272 %description -n mythbrowser -l pl.UTF-8
273 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
274 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
275 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
276 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
277 menu).
278
279 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
280 do stron w prostej wtyczce myth.
281
282 %package -n mythweb
283 Summary:        The web interface to MythTV
284 Summary(pl.UTF-8):      Interfejs WWW do MythTV
285 Group:          Applications/Multimedia
286 Requires:       php(mysql)
287 Requires:       php(posix)
288 Requires:       webapps
289 Requires:       webserver(php) >= 4.3
290
291 %description -n mythweb
292 The web interface to MythTV.
293
294 %description -n mythweb -l pl.UTF-8
295 Interfejs WWW do MythTV.
296
297 %package -n mythnetvision
298 Summary:        Mythtv extension to watch network movie shows
299 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
300 Group:          Applications/Multimedia
301 Requires:       mythbrowser
302 Requires:       mythtv-frontend-api = %{myth_api_version}
303
304 %description -n mythnetvision
305 Mythtv extension to watch network movie shows (ex. YouTube).
306
307 %description -n mythnetvision -l pl.UTF-8
308 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
309 YouTube.
310
311 %package -n mythmovies
312 Summary:        MythTV cinemas timetable
313 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
314 Group:          Applications/Multimedia
315 Requires:       mythtv-frontend-api = %{myth_api_version}
316
317 %description -n mythmovies
318 MythTV cinemas timetable.
319
320
321 %description -n mythmovies -l pl.UTF-8
322 Moduł MythTV do repertuaru kinowego.
323
324 %package -n mythzoneminder
325 Summary:        MythTV security TV manager
326 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
327 Group:          Applications/Multimedia
328 Requires:       mythtv-frontend-api = %{myth_api_version}
329
330 %description -n mythzoneminder
331 MythTV security TV manager.
332
333
334 %description -n mythzoneminder -l pl.UTF-8
335 Obsługa kamer przemysłowych dla MythTV.
336
337 %prep
338 %setup -q
339 %patch0 -p1
340 %patch10 -p1
341 %patch20 -p1
342
343 # lib64 fix - enable to update patch
344 %if %{_lib} != "lib" && 0
345 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
346 xargs grep -l /lib/ . | xargs sed -i -e '
347 s,%{_prefix}/lib/,/%{_lib}/,g
348         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
349 '
350 exit 1
351 %endif
352
353 %build
354 %if %{with binary}
355 export QTDIR="%{_prefix}"
356 # Not gnu configure
357 %configure \
358         --libdir-name=`basename %{_lib}` \
359         --enable-all \
360         %{!?with_mytharchive:--disable-mytharchive} \
361         %{!?with_mythbrowser:--disable-mythbrowser} \
362         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
363         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
364         %{!?with_mythgame:--disable-mythgame} \
365         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
366         %{!?with_mythnews:--disable-mythnews} \
367         %{!?with_mythvideo:--disable-mythvideo} \
368         %{!?with_mythweather:--disable-mythweather} \
369         %{!?with_mythweb:--disable-mythweb} \
370         %{!?with_mythmovies:--disable-mythmovies} \
371         %{!?with_mythnetvision:--disable-mythnetvision} \
372
373 mv mythconfig.mak mythconfig.mak.old
374 cp mythconfig.mak.old mythconfig.mak
375 cat <<'EOF'>> mythconfig.mak
376 QMAKE_CXX=%{__cxx}
377 QMAKE_CC=%{__cc}
378 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
379 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
380 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
381 EOF
382
383 %{__make}
384 %endif
385
386 %install
387 rm -rf $RPM_BUILD_ROOT
388 %if %{with binary}
389 export QTDIR="%{_prefix}"
390 %{__make} install \
391         INSTALL_ROOT=$RPM_BUILD_ROOT
392
393 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
394 %if %{with mythgame}
395 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
396 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
397 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
398 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
399 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
400 %endif
401 %endif
402
403 %if %{with mythweb}
404 cd mythweb
405 cp -a %{SOURCE3} ./
406 cp -a %{SOURCE4} ./
407 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
408 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
409 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
410 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
411 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
412 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
413 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
414 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
415 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
416 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
417 cd -
418 %endif
419
420 rm -f $RPM_BUILD_ROOT%{_datadir}/data
421 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
422 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
423         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
424                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
425         done > $p.lang
426 done
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
432 %webapp_register apache %{_webapp}
433
434 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
435 %webapp_unregister apache %{_webapp}
436
437 %triggerin -n mythweb -- apache < 2.2.0, apache-base
438 %webapp_register httpd %{_webapp}
439
440 %triggerin -n mythweb -- lighttpd
441 %webapp_register lighttpd %{_webapp}
442
443 %triggerun -n mythweb -- apache < 2.2.0, apache-base
444 %webapp_unregister httpd %{_webapp}
445
446 %triggerun -n mythweb -- lighttpd
447 %webapp_unregister lighttpd %{_webapp}
448
449 %triggerpostun -n mythweb -- mythweb < 0.19
450 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
451         if [ -f /etc/mythweb/$i.rpmsave ]; then
452                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
453                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
454         fi
455 done
456 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
457
458 # migrate from apache-config macros
459 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
460         if [ -d /etc/apache/webapps.d ]; then
461                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
462                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
463         fi
464
465         if [ -d /etc/httpd/webapps.d ]; then
466                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
467                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
468         fi
469         rm -f /etc/mythweb/apache.conf.rpmsave
470 fi
471
472 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
473         rm -f /etc/apache/conf.d/99_mythplugins.conf
474         /usr/sbin/webapp register apache %{_webapp}
475         %service -q apache reload
476 fi
477 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
478         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
479         /usr/sbin/webapp register httpd %{_webapp}
480         %service -q httpd reload
481 fi
482
483 %post -n mythweb
484 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
485 which packages you can need to run mythweb and how to set it quickly."
486
487 %files
488 %defattr(644,root,root,755)
489
490 %if %{with mytharchive}
491 %files -n mytharchive -f mytharchive.lang
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_bindir}/mytharchivehelper
494 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
495 %{_datadir}/mythtv/archivemenu.xml
496 %{_datadir}/mythtv/archiveutils.xml
497 %{_datadir}/mythtv/themes/default/ma_*.png
498 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
499 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
500 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
501 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
502 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
503 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
504 %{_datadir}/mythtv/mytharchive
505 %endif
506
507 %if %{with mythmusic}
508 %files -n mythmusic -f mythmusic.lang
509 %defattr(644,root,root,755)
510 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
511 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
512 /var/lib/mythmusic
513 %{_datadir}/mythtv/musicmenu.xml
514 %{_datadir}/mythtv/music_settings.xml
515 %{_datadir}/mythtv/themes/default/music-ui.xml
516 %{_datadir}/mythtv/themes/default/mm-titlelines.png
517 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
518 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
519 %{_datadir}/mythtv/themes/default/ff_button_off.png
520 %{_datadir}/mythtv/themes/default/ff_button_on.png
521 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
522 %{_datadir}/mythtv/themes/default/miniplayer_background.png
523 %{_datadir}/mythtv/themes/default/mm_*.png
524 %{_datadir}/mythtv/themes/default/music-sel-bg.png
525 %{_datadir}/mythtv/themes/default/next_button_off.png
526 %{_datadir}/mythtv/themes/default/next_button_on.png
527 %{_datadir}/mythtv/themes/default/next_button_pushed.png
528 %{_datadir}/mythtv/themes/default/pause_button_off.png
529 %{_datadir}/mythtv/themes/default/pause_button_on.png
530 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
531 %{_datadir}/mythtv/themes/default/play_button_off.png
532 %{_datadir}/mythtv/themes/default/play_button_on.png
533 %{_datadir}/mythtv/themes/default/play_button_pushed.png
534 %{_datadir}/mythtv/themes/default/prev_button_off.png
535 %{_datadir}/mythtv/themes/default/prev_button_on.png
536 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
537 %{_datadir}/mythtv/themes/default/rew_button_off.png
538 %{_datadir}/mythtv/themes/default/rew_button_on.png
539 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
540 %{_datadir}/mythtv/themes/default/selectionbar.png
541 %{_datadir}/mythtv/themes/default/stop_button_off.png
542 %{_datadir}/mythtv/themes/default/stop_button_on.png
543 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
544 %{_datadir}/mythtv/themes/default/track_info_background.png
545 %{_datadir}/mythtv/themes/default-wide/mm_*.png
546 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
547 %endif
548
549 %if %{with mythvideo}
550 %files -n mythvideo -f mythvideo.lang
551 %defattr(644,root,root,755)
552 %doc mythvideo/README mythvideo/videodb
553 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
554 %{_datadir}/mythtv/themes/default/video-ui.xml
555 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
556 %{_datadir}/mythtv/themes/default/mv_*.png
557 %{_datadir}/mythtv/themes/default-wide/mv_*.png
558 %{_datadir}/mythtv/video_settings.xml
559 %{_datadir}/mythtv/videomenu.xml
560 %dir %{_datadir}/mythtv/mythvideo
561 %dir %{_datadir}/mythtv/mythvideo/scripts
562 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
563 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
564 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
565 %{_datadir}/mythtv/mythvideo/scripts/README
566 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
567 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
568 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
569 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
570 %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
571 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
572 %{_datadir}/mythtv/mythvideo/scripts/Television/*
573 /var/lib/mythvideo
574 %endif
575
576 %if %{with mythweather}
577 %files -n mythweather -f mythweather.lang
578 %defattr(644,root,root,755)
579 %doc mythweather/README
580 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
581 %{_datadir}/mythtv/mythweather
582 %{_datadir}/mythtv/weather_settings.xml
583 %{_datadir}/mythtv/themes/default/weather-ui.xml
584 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
585 %{_datadir}/mythtv/themes/default/cloudy.png
586 %{_datadir}/mythtv/themes/default/fair.png
587 %{_datadir}/mythtv/themes/default/flurries.png
588 %{_datadir}/mythtv/themes/default/fog.png
589 %{_datadir}/mythtv/themes/default/logo.png
590 %{_datadir}/mythtv/themes/default/lshowers.png
591 %{_datadir}/mythtv/themes/default/mcloudy.png
592 %{_datadir}/mythtv/themes/default/mw_*.png
593 %{_datadir}/mythtv/themes/default/mwmain.png
594 %{_datadir}/mythtv/themes/default/pcloudy.png
595 %{_datadir}/mythtv/themes/default/rainsnow.png
596 %{_datadir}/mythtv/themes/default/showers.png
597 %{_datadir}/mythtv/themes/default/snowshow.png
598 %{_datadir}/mythtv/themes/default/sunny.png
599 %{_datadir}/mythtv/themes/default/thunshowers.png
600 %{_datadir}/mythtv/themes/default/unknown.png
601 %{_datadir}/mythtv/themes/default-wide/mw-*.png
602 %endif
603
604 %if %{with mythgallery}
605 %files -n mythgallery -f mythgallery.lang
606 %defattr(644,root,root,755)
607 %doc mythgallery/README
608 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
609 %{_datadir}/mythtv/themes/default/gallery-ui.xml
610 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
611 %{_datadir}/mythtv/themes/default/gallery-*.png
612 # FIXME: this is definately stupid path
613 /var/lib/pictures
614 %endif
615
616 %if %{with mythgame}
617 %files -n mythgame -f mythgame.lang
618 %defattr(644,root,root,755)
619 #%doc mythgame/README
620 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
621 %{_datadir}/mythtv/games
622 %{_datadir}/mythtv/game_settings.xml
623 %{_datadir}/mythtv/themes/default/game-ui.xml
624 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
625 %endif
626
627 %if %{with mythdvd}
628 %files -n mythdvd
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_bindir}/mtd
631 %{_datadir}/mythtv/themes/default/dvd-ui.xml
632 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
633 %{_datadir}/mythtv/themes/default/md_*.png
634 %endif
635
636 %if %{with mythnews}
637 %files -n mythnews -f mythnews.lang
638 %defattr(644,root,root,755)
639 %doc mythnews/README mythnews/AUTHORS
640 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
641 %{_datadir}/mythtv/mythnews
642 %{_datadir}/mythtv/themes/default/news-ui.xml
643 # DUPLICATE WITH MYTHFLIX?
644 %{_datadir}/mythtv/themes/default/news-info-bg.png
645 %{_datadir}/mythtv/themes/default/enclosures.png
646 %{_datadir}/mythtv/themes/default/need-download.png
647 %{_datadir}/mythtv/themes/default/podcast.png
648 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
649 %endif
650
651 %if %{with mythbrowser}
652 %files -n mythbrowser -f mythbrowser.lang
653 %defattr(644,root,root,755)
654 %doc mythbrowser/README mythbrowser/AUTHORS
655 #%attr(755,root,root) %{_bindir}/mythbrowser
656 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
657 %{_datadir}/mythtv/themes/default/mb_progress*.png
658 %{_datadir}/mythtv/themes/default/browser-ui.xml
659 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
660 %endif
661
662 %if %{with mythweb}
663 %files -n mythweb
664 %defattr(644,root,root,755)
665 %doc mythweb/README mythweb/mythweb.conf.lighttpd
666 %doc mythweb/htdigest.sh
667 %doc mythweb/http_servers_conf_tips.txt
668 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
669 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
670 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
671 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
672 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
673 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
674 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
675 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
676 %{_datadir}/mythweb
677 %dir %attr(771,root,http) /var/cache/mythweb
678 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
679 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
680 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
681 %endif
682
683 %if %{with mythnetvision}
684 %files -n mythnetvision -f mythnetvision.lang
685 %defattr(644,root,root,755)
686 %doc mythnetvision/{AUTHORS,ChangeLog,README}
687 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
688 %dir %{_datadir}/mythtv/mythnetvision
689 %{_datadir}/mythtv/netvisionmenu.xml
690 %dir %{_datadir}/mythtv/mythnetvision/scripts
691 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
692 %dir %{_datadir}/mythtv/mythnetvision/icons
693 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
694 %{_datadir}/mythtv/mythnetvision/icons/*.png
695 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
696 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
697 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
698 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
699 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
700 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
701 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
702 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
703 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
704 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
705 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
706 %{_datadir}/mythtv/themes/default/netvision-ui.xml
707 %endif
708
709 %if %{with mythmovies}
710 %files -n mythmovies
711 %defattr(644,root,root,755)
712 #-f mythmovies.lang
713 %defattr(644,root,root,755)
714 %doc mythmovies/{README,TODO}
715 %attr(755,root,root) %{_bindir}/ignyte
716 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
717 %{_datadir}/mythtv/themes/default/movies-ui.xml
718 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
719 %{_datadir}/mythtv/i18n/mythmovies_*.qm
720 %endif
721
722 %if %{with mythzoneminder}
723 %files -n mythzoneminder
724 %defattr(644,root,root,755)
725 #-f mythmovies.lang
726 %defattr(644,root,root,755)
727 %doc mythzoneminder/{AUTHORS,README}
728 %attr(755,root,root) %{_bindir}/mythzmserver
729 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
730 %dir %{_datadir}/mythtv/zonemindermenu.xml
731 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
732 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
733 %{_datadir}/mythtv/themes/default/mz_*png
734 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
735 %endif
This page took 0.217878 seconds and 4 git commands to generate.