]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- release 5
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # disable mythdvd plugin - mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgame plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythnews plugin
13 %bcond_without  mythvideo       # disable building mythvideo plugin
14 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
15 # not present by default in PLD
16 %bcond_with     mythweather     # enable building mythweather plugin
17 %bcond_without  mythweb         # disable building mythweb plugin
18 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
19
20 %if %{without binary}
21 %undefine       with_mytharchive
22 %undefine       with_mythbrowser
23 %undefine       with_mythmovies
24 %undefine       with_mythdvd
25 %undefine       with_mythnetvision
26 %undefine       with_mythgallery
27 %undefine       with_mythgame
28 %undefine       with_mythmusic
29 %undefine       with_mythnews
30 %undefine       with_mythvideo
31 %undefine       with_mythweather
32 %endif
33
34 %include        /usr/lib/rpm/macros.perl
35
36 Summary:        Main MythTV plugins
37 Summary(pl.UTF-8):      Główne wtyczki MythTV
38 Name:           mythplugins
39 Version:        0.23.1
40 Release:        5
41 License:        GPL v2
42 Group:          Applications/Multimedia
43 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
44 # Source0-md5:  edd9c5f8a9ae0189b1c8951fa8282c4d
45 Source1:        mythweb.conf
46 Source2:        mythweb_lighttpd.conf
47 Source3:        htdigest.sh
48 Source4:        http_servers_conf_tips.txt
49 Patch0:         mythweb-chdir.patch
50 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
51 Patch20:        %{name}-mytharchive-INT64.patch
52 URL:            http://www.mythtv.org/
53 %if %{with binary}
54 %if %{with mythgallery} || %{with myhtmusic}
55 BuildRequires:  OpenGL-devel
56 %endif
57 BuildRequires:  Qt3Support-devel
58 BuildRequires:  QtCore-devel
59 BuildRequires:  QtGui-devel
60 BuildRequires:  QtNetwork-devel
61 BuildRequires:  QtOpenGL-devel
62 BuildRequires:  QtSql-devel
63 BuildRequires:  QtWebKit-devel
64 BuildRequires:  QtXml-devel
65 BuildRequires:  SDL-devel
66 BuildRequires:  a52dec-libs-devel
67 BuildRequires:  cdparanoia-III-devel
68 BuildRequires:  faad2-devel >= 2.0-5.2
69 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
70 BuildRequires:  flac-devel >= 1.0.4
71 BuildRequires:  freetype-devel
72 BuildRequires:  libcdaudio-devel >= 0.99.12p2
73 BuildRequires:  libdvdcss-devel >= 1.2.7
74 BuildRequires:  libdvdread-devel >= 0.9.4
75 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
76 BuildRequires:  libfame-devel >= 0.9.0
77 BuildRequires:  libid3tag-devel
78 BuildRequires:  libmad-devel
79 BuildRequires:  libmyth-devel > 0.21
80 BuildRequires:  libstdc++-devel
81 BuildRequires:  libtiff-devel
82 BuildRequires:  libvisual-devel
83 BuildRequires:  libvorbis-devel >= 1:1.0
84 BuildRequires:  mjpegtools-devel >= 1.6.1
85 BuildRequires:  nasm
86 BuildRequires:  patchutils
87 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
88 %{?with_mythweather:BuildRequires:      perl-Image-Size}
89 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
90 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
91 BuildRequires:  qt4-build
92 BuildRequires:  qt4-qmake
93 BuildRequires:  rpm-perlprov >= 4.1-13
94 BuildRequires:  sed >= 4.0
95 %{?with_mythmusic:BuildRequires:        taglib-devel}
96 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
97 BuildRequires:  xorg-lib-libX11-devel
98 BuildRequires:  xvid-devel >= 1:0.9.1
99 BuildRequires:  zlib-devel
100 %endif
101 %{?with_mytharchive:Requires:   mytharchive}
102 %{?with_mythbrowser:Requires:   mythbrowser}
103 %{?with_mythdvd:Requires:       mythdvd}
104 %{?with_mythgallery:Requires:   mythgallery}
105 %{?with_mythgame:Requires:      mythgame}
106 %{?with_mythmysic:Requires:     mythmusic}
107 %{?with_mythnetvision:Requires: mythnetvision}
108 %{?with_mythnews:Requires:      mythnews}
109 %{?with_mythvideo:Requires:     mythvideo}
110 %{?with_mythweather:Requires:   mythweather}
111 %{?with_mythweb:Requires:       mythweb}
112 ExclusiveArch:  %{ix86} %{x8664} ppc
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
116 %define         _webapps        /etc/webapps
117 %define         _webapp         mythweb
118
119 %description
120 This is a consolidation of all the official MythTV plugins that used
121 to be distributed as separate downloads from mythtv.org.
122
123 %description -l pl.UTF-8
124 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
125 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
126
127 %package -n mytharchive
128 Summary:        A MythTV module to create and burn DVDs
129 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
130 Group:          Applications/Multimedia
131 Requires:       dvdauthor
132 Requires:       mjpegtools
133 Requires:       mythtv-frontend-api = %{myth_api_version}
134 Requires:       python-MySQLdb
135 Requires:       python-PIL
136 Suggests:       dvdrtools-mkisofs
137
138 %description -n mytharchive
139 MythArchive is a MythTV style plugin that uses the Mythburn Script to
140 create and burn DVDs from MythTV recordings, MythVideo files or any
141 video files available on a MythTV system. It can also export
142 recordings to a native archive format that can then be imported back
143 into a MythTV system restoring all the associated metadata.
144
145 %description -n mytharchive -l pl.UTF-8
146 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
147 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
148 innych plików z filmami dostępnych w systemie MythTV. Może także
149 eksportować nagrania do natywnego formatu archiwum, który potem można
150 zaimportować z powrotem do systemu MythTV przywracając wszystkie
151 związane z nimi metadane.
152
153 %package -n mythmusic
154 Summary:        The music player add-on module for MythTV
155 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
156 Group:          Applications/Multimedia
157 Requires:       mythtv-frontend-api = %{myth_api_version}
158
159 %description -n mythmusic
160 Music add-on for MythTV. Support playlists, visualisations, tag
161 editing and plays many popular audio file formats - mp3, flac, wav,
162 ogg etc.
163
164 %description -n mythmusic -l pl.UTF-8
165 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
166 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
167 formatów audio - mp3, flac, wav, ogg itd.
168
169 %package -n mythvideo
170 Summary:        A generic video player frontend module for MythTV
171 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
172 Group:          Applications/Multimedia
173 Requires:       mplayer
174 Requires:       mythtv-frontend-api = %{myth_api_version}
175
176 %description -n mythvideo
177 A generic video and dvd player frontend module for MythTV.
178
179 %description -n mythvideo -l pl.UTF-8
180 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
181
182 %package -n mythweather
183 Summary:        A MythTV module that displays a weather forcast
184 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
185 Group:          Applications/Multimedia
186 Requires:       mythtv-frontend-api = %{myth_api_version}
187
188 %description -n mythweather
189 A MythTV module that displays a weather forcast.
190
191 %description -n mythweather -l pl.UTF-8
192 Moduł MythTV wyświetlający prognozę pogody.
193
194 %package -n mythgallery
195 Summary:        A gallery/slideshow module for MythTV
196 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
197 Group:          Applications/Multimedia
198 Requires:       mythtv-frontend-api = %{myth_api_version}
199
200 %description -n mythgallery
201 A gallery/slideshow module for MythTV.
202
203 %description -n mythgallery -l pl.UTF-8
204 Moduł galerii/pokazu slajdów dla MythTV.
205
206 %package -n mythgame
207 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
208 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
209 Group:          Applications/Multimedia
210 Requires:       mythtv-frontend-api = %{myth_api_version}
211
212 %description -n mythgame
213 A game frontend (xmame, nes, snes, pc) for MythTV.
214
215 %description -n mythgame -l pl.UTF-8
216 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
217
218 %package -n mythdvd
219 Summary:        A DVD ripper module for MythTV
220 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
221 Group:          Applications/Multimedia
222 Requires:       mythtv-frontend-api = %{myth_api_version}
223 Requires:       mythvideo
224 Requires:       transcode >= 0.6.8
225
226 %description -n mythdvd
227 MythDVD is a MythTV module that allows you to rip DVD's and transcode
228 their video and audio content to other (generally smaller) formats.
229 The playing features are simply myth-style wrappers for your favourite
230 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
231 based on and derived from the excellent transcode package.
232
233 %description -n mythdvd -l pl.UTF-8
234 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
235 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
236 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
237 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
238 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
239 pakietu transcode.
240
241 %package -n mythnews
242 Summary:        A RSS News Feed plugin for MythTV
243 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
244 Group:          Applications/Multimedia
245 Requires:       mythtv-frontend-api = %{myth_api_version}
246
247 %description -n mythnews
248 A RSS News Feed plugin for MythTV.
249
250 %description -n mythnews -l pl.UTF-8
251 Wtyczka czytnika nowinek RSS dla MythTV.
252
253 %package -n mythbrowser
254 Summary:        A small web browser module for MythTV
255 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
256 Group:          Applications/Multimedia
257 Requires:       mythtv-frontend-api = %{myth_api_version}
258
259 %description -n mythbrowser
260 MythBrowser is a full fledged web-browser (multiple tabs) to display
261 webpages in full-screen mode. Simple page navigation is possible.
262 Starting with version 0.13 it also has full support for mouse driven
263 navigation (right mouse opens and closes the popup menu).
264
265 MythBrowser also contains a BookmarkManager to manage the website
266 links in a simple mythplugin.
267
268 %description -n mythbrowser -l pl.UTF-8
269 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
270 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
271 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
272 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
273 menu).
274
275 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
276 do stron w prostej wtyczce myth.
277
278 %package -n mythweb
279 Summary:        The web interface to MythTV
280 Summary(pl.UTF-8):      Interfejs WWW do MythTV
281 Group:          Applications/Multimedia
282 Requires:       php(mysql)
283 Requires:       php(posix)
284 Requires:       webapps
285 Requires:       webserver(php) >= 4.3
286
287 %description -n mythweb
288 The web interface to MythTV.
289
290 %description -n mythweb -l pl.UTF-8
291 Interfejs WWW do MythTV.
292
293 %package -n mythnetvision
294 Summary:        Mythtv extension to watch network movie shows
295 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
296 Group:          Applications/Multimedia
297 Requires:       mythbrowser
298 Requires:       mythtv-frontend-api = %{myth_api_version}
299
300 %description -n mythnetvision
301 Mythtv extension to watch network movie shows (ex. YouTube).
302
303 %description -n mythnetvision -l pl.UTF-8
304 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
305 YouTube.
306
307 %package -n mythmovies
308 Summary:        MythTV cinemas timetable
309 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
310 Group:          Applications/Multimedia
311 Requires:       mythtv-frontend-api = %{myth_api_version}
312
313 %description -n mythmovies
314 MythTV cinemas timetable.
315
316
317 %description -n mythmovies -l pl.UTF-8
318 Moduł MythTV do repertuaru kinowego.
319
320 %package -n mythzoneminder
321 Summary:        MythTV security TV manager
322 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
323 Group:          Applications/Multimedia
324 Requires:       mythtv-frontend-api = %{myth_api_version}
325
326 %description -n mythzoneminder
327 MythTV security TV manager.
328
329
330 %description -n mythzoneminder -l pl.UTF-8
331 Obsługa kamer przemysłowych dla MythTV.
332
333 %prep
334 %setup -q
335 %patch0 -p1
336 %patch10 -p1
337 %patch20 -p1
338
339 %{__sed} -i -e 's,/var/lib/mythdvd/temp,/var/lib/mythtv/tmp,' \
340         mythvideo/mythvideo/globalsettings.cpp
341
342 # lib64 fix - enable to update patch
343 %if %{_lib} != "lib" && 0
344 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
345 xargs grep -l /lib/ . | xargs sed -i -e '
346 s,%{_prefix}/lib/,/%{_lib}/,g
347         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
348 '
349 exit 1
350 %endif
351
352 %build
353 %if %{with binary}
354 export QTDIR="%{_prefix}"
355 # Not gnu configure
356 %configure \
357         --libdir-name=`basename %{_lib}` \
358         --enable-all \
359         %{!?with_mytharchive:--disable-mytharchive} \
360         %{!?with_mythbrowser:--disable-mythbrowser} \
361         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
362         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
363         %{!?with_mythgame:--disable-mythgame} \
364         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
365         %{!?with_mythnews:--disable-mythnews} \
366         %{!?with_mythvideo:--disable-mythvideo} \
367         %{!?with_mythweather:--disable-mythweather} \
368         %{!?with_mythweb:--disable-mythweb} \
369         %{!?with_mythmovies:--disable-mythmovies} \
370         %{!?with_mythnetvision:--disable-mythnetvision} \
371
372 mv mythconfig.mak mythconfig.mak.old
373 cp mythconfig.mak.old mythconfig.mak
374 cat <<'EOF'>> mythconfig.mak
375 QMAKE_CXX=%{__cxx}
376 QMAKE_CC=%{__cc}
377 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
378 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
379 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
380 EOF
381
382 %{__make}
383 %endif
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387 %if %{with binary}
388 export QTDIR="%{_prefix}"
389 %{__make} install \
390         INSTALL_ROOT=$RPM_BUILD_ROOT
391
392 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
393 %if %{with mythgame}
394 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
395 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
396 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
397 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
398 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
399 %endif
400 %endif
401
402 %if %{with mythweb}
403 cd mythweb
404 cp -a %{SOURCE3} ./
405 cp -a %{SOURCE4} ./
406 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
407 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
408 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
409 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
410 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
411 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
412 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
413 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
414 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
415 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
416 cd -
417 %endif
418
419 rm -f $RPM_BUILD_ROOT%{_datadir}/data
420 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
421 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
422         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
423                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
424         done > $p.lang
425 done
426
427 %clean
428 rm -rf $RPM_BUILD_ROOT
429
430 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
431 %webapp_register apache %{_webapp}
432
433 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
434 %webapp_unregister apache %{_webapp}
435
436 %triggerin -n mythweb -- apache < 2.2.0, apache-base
437 %webapp_register httpd %{_webapp}
438
439 %triggerin -n mythweb -- lighttpd
440 %webapp_register lighttpd %{_webapp}
441
442 %triggerun -n mythweb -- apache < 2.2.0, apache-base
443 %webapp_unregister httpd %{_webapp}
444
445 %triggerun -n mythweb -- lighttpd
446 %webapp_unregister lighttpd %{_webapp}
447
448 %triggerpostun -n mythweb -- mythweb < 0.19
449 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
450         if [ -f /etc/mythweb/$i.rpmsave ]; then
451                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
452                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
453         fi
454 done
455 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
456
457 # migrate from apache-config macros
458 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
459         if [ -d /etc/apache/webapps.d ]; then
460                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
461                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
462         fi
463
464         if [ -d /etc/httpd/webapps.d ]; then
465                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
466                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
467         fi
468         rm -f /etc/mythweb/apache.conf.rpmsave
469 fi
470
471 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
472         rm -f /etc/apache/conf.d/99_mythplugins.conf
473         /usr/sbin/webapp register apache %{_webapp}
474         %service -q apache reload
475 fi
476 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
477         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
478         /usr/sbin/webapp register httpd %{_webapp}
479         %service -q httpd reload
480 fi
481
482 %post -n mythweb
483 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
484 which packages you can need to run mythweb and how to set it quickly."
485
486 %files
487 %defattr(644,root,root,755)
488
489 %if %{with mytharchive}
490 %files -n mytharchive -f mytharchive.lang
491 %defattr(644,root,root,755)
492 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
493 %attr(755,root,root) %{_bindir}/mytharchivehelper
494 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
495 %{_datadir}/mythtv/archivemenu.xml
496 %{_datadir}/mythtv/archiveutils.xml
497 %{_datadir}/mythtv/themes/default/ma_*.png
498 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
499 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
500 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
501 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
502 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
503 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
504 %{_datadir}/mythtv/mytharchive
505 %endif
506
507 %if %{with mythmusic}
508 %files -n mythmusic -f mythmusic.lang
509 %defattr(644,root,root,755)
510 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
511 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
512 /var/lib/mythmusic
513 %{_datadir}/mythtv/musicmenu.xml
514 %{_datadir}/mythtv/music_settings.xml
515 %{_datadir}/mythtv/themes/default/music-ui.xml
516 %{_datadir}/mythtv/themes/default/mm-titlelines.png
517 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
518 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
519 %{_datadir}/mythtv/themes/default/ff_button_off.png
520 %{_datadir}/mythtv/themes/default/ff_button_on.png
521 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
522 %{_datadir}/mythtv/themes/default/miniplayer_background.png
523 %{_datadir}/mythtv/themes/default/mm_*.png
524 %{_datadir}/mythtv/themes/default/music-sel-bg.png
525 %{_datadir}/mythtv/themes/default/next_button_off.png
526 %{_datadir}/mythtv/themes/default/next_button_on.png
527 %{_datadir}/mythtv/themes/default/next_button_pushed.png
528 %{_datadir}/mythtv/themes/default/pause_button_off.png
529 %{_datadir}/mythtv/themes/default/pause_button_on.png
530 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
531 %{_datadir}/mythtv/themes/default/play_button_off.png
532 %{_datadir}/mythtv/themes/default/play_button_on.png
533 %{_datadir}/mythtv/themes/default/play_button_pushed.png
534 %{_datadir}/mythtv/themes/default/prev_button_off.png
535 %{_datadir}/mythtv/themes/default/prev_button_on.png
536 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
537 %{_datadir}/mythtv/themes/default/rew_button_off.png
538 %{_datadir}/mythtv/themes/default/rew_button_on.png
539 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
540 %{_datadir}/mythtv/themes/default/selectionbar.png
541 %{_datadir}/mythtv/themes/default/stop_button_off.png
542 %{_datadir}/mythtv/themes/default/stop_button_on.png
543 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
544 %{_datadir}/mythtv/themes/default/track_info_background.png
545 %{_datadir}/mythtv/themes/default-wide/mm_*.png
546 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
547 %endif
548
549 %if %{with mythvideo}
550 %files -n mythvideo -f mythvideo.lang
551 %defattr(644,root,root,755)
552 %doc mythvideo/README* mythvideo/videodb mythvideo/contrib
553 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
554 %{_datadir}/mythtv/themes/default/video-ui.xml
555 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
556 %{_datadir}/mythtv/themes/default/mv_*.png
557 %{_datadir}/mythtv/themes/default-wide/mv_*.png
558 %{_datadir}/mythtv/video_settings.xml
559 %{_datadir}/mythtv/videomenu.xml
560 %dir %{_datadir}/mythtv/mythvideo
561 %dir %{_datadir}/mythtv/mythvideo/scripts
562 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
563 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
564 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
565 %{_datadir}/mythtv/mythvideo/scripts/README
566 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
567 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
568 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
569 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
570 %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
571 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
572 %{_datadir}/mythtv/mythvideo/scripts/Television/*
573 /var/lib/mythvideo
574 %endif
575
576 %if %{with mythweather}
577 %files -n mythweather -f mythweather.lang
578 %defattr(644,root,root,755)
579 %doc mythweather/AUTHORS mythweather/README
580 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
581 %{_datadir}/mythtv/mythweather
582 %{_datadir}/mythtv/weather_settings.xml
583 %{_datadir}/mythtv/themes/default/weather-ui.xml
584 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
585 %{_datadir}/mythtv/themes/default/cloudy.png
586 %{_datadir}/mythtv/themes/default/fair.png
587 %{_datadir}/mythtv/themes/default/flurries.png
588 %{_datadir}/mythtv/themes/default/fog.png
589 %{_datadir}/mythtv/themes/default/logo.png
590 %{_datadir}/mythtv/themes/default/lshowers.png
591 %{_datadir}/mythtv/themes/default/mcloudy.png
592 %{_datadir}/mythtv/themes/default/mw_*.png
593 %{_datadir}/mythtv/themes/default/mwmain.png
594 %{_datadir}/mythtv/themes/default/pcloudy.png
595 %{_datadir}/mythtv/themes/default/rainsnow.png
596 %{_datadir}/mythtv/themes/default/showers.png
597 %{_datadir}/mythtv/themes/default/snowshow.png
598 %{_datadir}/mythtv/themes/default/sunny.png
599 %{_datadir}/mythtv/themes/default/thunshowers.png
600 %{_datadir}/mythtv/themes/default/unknown.png
601 %{_datadir}/mythtv/themes/default-wide/mw-*.png
602 %endif
603
604 %if %{with mythgallery}
605 %files -n mythgallery -f mythgallery.lang
606 %defattr(644,root,root,755)
607 %doc mythgallery/AUTHORS mythgallery/README
608 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
609 %{_datadir}/mythtv/themes/default/gallery-ui.xml
610 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
611 %{_datadir}/mythtv/themes/default/gallery-*.png
612 /var/lib/pictures
613 %endif
614
615 %if %{with mythgame}
616 %files -n mythgame -f mythgame.lang
617 %defattr(644,root,root,755)
618 %doc mythgame/contrib
619 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
620 %{_datadir}/mythtv/games
621 %{_datadir}/mythtv/game_settings.xml
622 %{_datadir}/mythtv/themes/default/game-ui.xml
623 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
624 %endif
625
626 %if %{with mythdvd}
627 %files -n mythdvd
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/mtd
630 %{_datadir}/mythtv/themes/default/dvd-ui.xml
631 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
632 %{_datadir}/mythtv/themes/default/md_*.png
633 %endif
634
635 %if %{with mythnews}
636 %files -n mythnews -f mythnews.lang
637 %defattr(644,root,root,755)
638 %doc mythnews/README mythnews/AUTHORS
639 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
640 %{_datadir}/mythtv/mythnews
641 %{_datadir}/mythtv/themes/default/news-ui.xml
642 %{_datadir}/mythtv/themes/default/news-info-bg.png
643 %{_datadir}/mythtv/themes/default/enclosures.png
644 %{_datadir}/mythtv/themes/default/need-download.png
645 %{_datadir}/mythtv/themes/default/podcast.png
646 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
647 %endif
648
649 %if %{with mythbrowser}
650 %files -n mythbrowser -f mythbrowser.lang
651 %defattr(644,root,root,755)
652 %doc mythbrowser/README mythbrowser/AUTHORS
653 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
654 %{_datadir}/mythtv/themes/default/mb_progress*.png
655 %{_datadir}/mythtv/themes/default/browser-ui.xml
656 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
657 %endif
658
659 %if %{with mythweb}
660 %files -n mythweb
661 %defattr(644,root,root,755)
662 %doc mythweb/README mythweb/mythweb.conf.lighttpd
663 %doc mythweb/htdigest.sh
664 %doc mythweb/http_servers_conf_tips.txt
665 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
666 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
668 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
669 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
670 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
671 %{_datadir}/mythweb
672 %dir %attr(771,root,http) /var/cache/mythweb
673 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
674 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
675 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
676 %endif
677
678 %if %{with mythnetvision}
679 %files -n mythnetvision -f mythnetvision.lang
680 %defattr(644,root,root,755)
681 %doc mythnetvision/{AUTHORS,ChangeLog,README}
682 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
683 %dir %{_datadir}/mythtv/mythnetvision
684 %{_datadir}/mythtv/netvisionmenu.xml
685 %dir %{_datadir}/mythtv/mythnetvision/scripts
686 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
687 %dir %{_datadir}/mythtv/mythnetvision/icons
688 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
689 %{_datadir}/mythtv/mythnetvision/icons/*.png
690 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
691 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
692 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
693 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
694 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
695 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
696 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
697 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
698 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
699 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
700 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
701 %{_datadir}/mythtv/themes/default/netvision-ui.xml
702 %endif
703
704 %if %{with mythmovies}
705 %files -n mythmovies
706 %defattr(644,root,root,755)
707 %defattr(644,root,root,755)
708 %doc mythmovies/{README,TODO}
709 %attr(755,root,root) %{_bindir}/ignyte
710 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
711 %{_datadir}/mythtv/themes/default/movies-ui.xml
712 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
713 %{_datadir}/mythtv/i18n/mythmovies_*.qm
714 %endif
715
716 %if %{with mythzoneminder}
717 %files -n mythzoneminder
718 %defattr(644,root,root,755)
719 %defattr(644,root,root,755)
720 %doc mythzoneminder/{AUTHORS,README}
721 %attr(755,root,root) %{_bindir}/mythzmserver
722 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
723 %dir %{_datadir}/mythtv/zonemindermenu.xml
724 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
725 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
726 %{_datadir}/mythtv/themes/default/mz_*png
727 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
728 %endif
This page took 0.115521 seconds and 4 git commands to generate.