]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- removed COPYING from %doc (GPL)
[packages/mythplugins.git] / mythplugins.spec
1 # disable mythmusic,mythphone due to https://bugs.pld-linux.org/?do=details&id=5687
2 %bcond_with     mythmusic
3 %bcond_with mythphone
4 Summary:        Main MythTV plugins.
5 Name:           mythplugins
6 Version:        0.18.1
7 Release:        0.112.2
8 License:        GPL v2
9 Group:          Applications/Multimedia
10 URL:            http://www.mythtv.org/
11 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
12 # Source0-md5:  1d94d19e2a13c24a408ced9b6c4f5b47
13 ###
14 Patch0:         %{name}-configure.patch
15 #Patch1:        mythmusic-0.18-fftw2singleprec.patch
16 #Patch2:        mythmusic-0.12-cdda.patch
17 #Patch10:       mythvideo-0.16-math.patch
18 BuildRequires:  SDL-devel
19 BuildRequires:  X11-OpenGL-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  a52dec-libs-devel
22 BuildRequires:  cdparanoia-III-devel
23 BuildRequires:  faad2-devel >= 2.0-5.2
24 BuildRequires:  fftw-devel >= 2.1.3
25 BuildRequires:  flac-devel >= 1.0.4
26 BuildRequires:  freetype-devel
27 BuildRequires:  kdelibs-devel
28 BuildRequires:  libcdaudio-devel
29 BuildRequires:  libdvdcss-devel >= 1.2.7
30 BuildRequires:  libdvdread-devel >= 0.9.4
31 BuildRequires:  libexif-devel
32 BuildRequires:  libfame-devel >= 0.9.0
33 BuildRequires:  libid3tag-devel
34 BuildRequires:  libmad-devel
35 BuildRequires:  libmyth-devel >= 0:%{version}
36 BuildRequires:  libstdc++-devel
37 #BuildRequires: libtermcap-devel
38 BuildRequires:  libtiff-devel
39 BuildRequires:  libvorbis-devel >= 1.0
40 BuildRequires:  mjpegtools-devel >= 1.6.1
41 BuildRequires:  nasm
42 BuildRequires:  transcode >= 0.6.8
43 BuildRequires:  xvid-devel >= 1:0.9.1
44 BuildRequires:  zlib-devel
45 Requires:       mythbrowser
46 Requires:       mythdvd
47 Requires:       mythgallery
48 Requires:       mythgame
49 %{?with_mythmusic:Requires:     mythmusic}
50 Requires:       mythnews
51 %{?with_mythphone:Requires:     mythphone}
52 Requires:       mythvideo
53 Requires:       mythweather
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         api_ver %(echo %{version} | cut -d. -f1,2)
57
58 %description
59 This is a consolidation of all the official MythTV plugins that used
60 to be distributed as separate downloads from mythtv.org.
61
62 %package -n mythmusic
63 Summary:        The music player add-on module for MythTV.
64 Group:          Applications/Multimedia
65 Requires:       mythtv-frontend-api = %{api_ver}
66
67 %description -n mythmusic
68 Music add-on for mythtv.
69
70 %package -n mythvideo
71 Summary:        A generic video player frontend module for MythTV.
72 Group:          Applications/Multimedia
73 Requires:       mplayer
74 Requires:       mythtv-frontend-api = %{api_ver}
75
76 %description -n mythvideo
77 A generic video player frontend module for MythTV.
78
79 %package -n mythweather
80 Summary:        A MythTV module that displays a weather forcast.
81 Group:          Applications/Multimedia
82 Requires:       mythtv-frontend-api = %{api_ver}
83
84 %description -n mythweather
85 A MythTV module that displays a weather forcast.
86
87 %package -n mythgallery
88 Summary:        A gallery/slideshow module for MythTV.
89 Group:          Applications/Multimedia
90 Requires:       mythtv-frontend-api = %{api_ver}
91
92 %description -n mythgallery
93 A gallery/slideshow module for MythTV.
94
95 %package -n mythgame
96 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV.
97 Group:          Applications/Multimedia
98 Requires:       mythtv-frontend-api = %{api_ver}
99
100 %description -n mythgame
101 A game frontend (xmame, nes, snes, pc) for MythTV.
102
103 %package -n mythdvd
104 Summary:        A DVD player module for MythTV.
105 Group:          Applications/Multimedia
106 Requires:       mythtv-frontend-api = %{api_ver}
107 Requires:       transcode >= 0.6.8
108
109 %description -n mythdvd
110 MythDVD is a MythTV module that allows you to play DVD's on a myth-box
111 and (optionally) rip DVD's and transcode their video and audio content
112 to other (generally smaller) formats. The playing features are simply
113 myth-style wrappers for your favourite DVD playing software (mplayer,
114 ogle, xine, etc). The transcoding is based on and derived from the
115 excellent transcode package.
116
117 %package -n mythnews
118 Summary:        A RSS News Feed Plugin for MythTV.
119 Group:          Applications/Multimedia
120 Requires:       mythtv-frontend-api = %{api_ver}
121
122 %description -n mythnews
123
124 %package -n mythbrowser
125 Summary:        A small web browser module for MythTV.
126 Group:          Applications/Multimedia
127 Requires:       mythtv-frontend-api = %{api_ver}
128
129 %description -n mythbrowser
130 MythBrowser is a full fledged web-browser (multiple tabs) to display
131 webpages in full-screen mode. Simple page navigation is possible.
132 Starting with version 0.13 it also has full support for mouse driven
133 navigation (right mouse opens and clos es the popup menu).
134
135 MythBrowser also contains a BookmarkManager to manage the website
136 links in a simple mythplugin.
137
138 %package -n mythphone
139 Summary:        A video conferencing module for MythTV.
140 Group:          Applications/Multimedia
141 Requires:       mythtv-frontend-api = %{api_ver}
142
143 %description -n mythphone
144 Mythphone is a phone and videophone capability on MYTH using the
145 standard SIP protocol. It is compatible with Microsoft XP Messenger
146 and with SIP Service Providers such as Free World Dialup
147 (fwd.pulver.com).
148
149 %prep
150 %setup -q
151 %patch0 -p1
152
153 # lib64 fix
154 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
155         xargs grep -l /lib/ . | xargs sed -i -e 's,/lib/,/%{_lib}/,g'
156
157 #grep -rl %{_prefix}/local . | xargs perl -pi -e's|%{_prefix}/local|'%{_prefix}'|g'
158
159 # include mythtv build settings
160 cp %{_datadir}/mythtv/build/config.mak .
161 sed -i -e '1iinclude(config.mak)'  settings.pro
162 #sed -i -e '1iinclude(%{_datadir}/mythtv/build/settings.pro)'  settings.pro
163 exit 0
164
165 #%ifnarch %{ix86}
166 #cat >> settings.pro << EOF
167 #DEFINES -= HAVE_MMX
168 #EOF
169 #%endif
170
171
172 #%patch1 -p0 -b .sfftw
173 cd mythmusic
174 #%patch2 -p0 -b .cdda
175
176
177 # Fix /mnt/store -> /var/lib/mythmusic
178 perl -pi -e's|/mnt/store/music|/var/lib/mythmusic|' mythmusic/globalsettings.cpp
179
180 cd ..
181 cd mythvideo
182 #%patch10 -p0 -b .math
183
184 #find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
185
186 # Fix /mnt/store -> /var/lib/mythmusic
187 perl -pi -e's|/share/Movies/dvd|/var/lib/mythvideo|' mythvideo/globalsettings.cpp
188
189 cd ..
190 cd mythweather
191 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
192 cd ..
193 cd mythgallery
194 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
195
196 cd ..
197 cd mythgame
198 #FIXME
199 #patch20 -p1 -b .paths
200 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
201
202 cd ..
203 cd mythdvd
204 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
205
206 cd ..
207 cd mythnews
208 #patch30 -p0 -b .toTime
209 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
210
211 cd ..
212 cd mythbrowser
213 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
214
215 cd ..
216 cd mythphone
217 #patch40 -p0
218 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
219
220 cat >> ../settings.pro << EOF
221 INCLUDEPATH += %{_includedir}/mythtv
222 INCLUDEPATH += %{_includedir}/speech_tools
223 EOF
224 cd ..
225
226 %build
227 export QTDIR="%{_prefix}"
228 # not gnu configure
229 %configure \
230         --enable-all \
231         --disable-festival \
232         %{!?with_mythmusic:--disable-mythmusic} \
233         %{!?with_mythphone:--disable-mythphone}
234
235 #       --enable-all             Enable all options
236 #       --enable-opengl          enable OpenGL (Music and Gallery) [default=no]
237 #
238 #       --enable-transcode       enable DVD ripping and transcoding [default=no]
239 #       --enable-vcd             enable VCD playing [default=no]
240 #
241 #       --enable-exif            enable reading of EXIF headers [default=no]
242 #
243 #       --enable-fftw            enable fftw visualizers [default=no]
244 #       --enable-sdl             use SDL for the synaesthesia output [default=no]
245 #       --enable-aac             enable AAC/MP4 audio file decompression [default=no]
246 #
247 #       --enable-festival        enable festival TTS Engine [default=no]
248
249
250 qmake mythplugins.pro
251 %{__make}
252 #cd mythbrowser
253 #qmake mythbrowser.pro
254 #cd ..
255 #make -C mythbrowser
256
257 %install
258 rm -rf $RPM_BUILD_ROOT
259
260 export QTDIR="%{_prefix}"
261 %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
262 #%{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT -C mythbrowser
263
264 install -d $RPM_BUILD_ROOT/var/lib/mythmusic
265 install -d $RPM_BUILD_ROOT/var/lib/mythvideo
266 install -d $RPM_BUILD_ROOT/var/lib/pictures
267 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
268 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
269 #install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
270 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
271 install -d $RPM_BUILD_ROOT%{_datadir}/xmame
272 ln -s %{_datadir}/xmame $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame
273 install -d $RPM_BUILD_ROOT%{_datadir}/xmame/flyers
274 ln -s snap $RPM_BUILD_ROOT%{_datadir}/xmame/screens
275
276 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/
277
278 %clean
279 rm -rf $RPM_BUILD_ROOT
280
281 %files
282 %defattr(644,root,root,755)
283
284 %if %{with mythmusic}
285 %files -n mythmusic
286 %defattr(644,root,root,755)
287 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
288 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
289 /var/lib/mythmusic
290 %{_datadir}/mythtv/musicmenu.xml
291 %{_datadir}/mythtv/music_settings.xml
292 %{_datadir}/mythtv/i18n/mythmusic_*.qm
293 %{_datadir}/mythtv/themes/default/ff_button_off.png
294 %{_datadir}/mythtv/themes/default/ff_button_on.png
295 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
296 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
297 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
298 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
299 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
300 %{_datadir}/mythtv/themes/default/mm_checked.png
301 %{_datadir}/mythtv/themes/default/mm_checked_high.png
302 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
303 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
304 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
305 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
306 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
307 %{_datadir}/mythtv/themes/default/mm_rating.png
308 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
309 %{_datadir}/mythtv/themes/default/mm_unchecked.png
310 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
311 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
312 %{_datadir}/mythtv/themes/default/mm_volume_background.png
313 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
314 %{_datadir}/mythtv/themes/default/mm_waiting.png
315 %{_datadir}/mythtv/themes/default/music-sel-bg.png
316 %{_datadir}/mythtv/themes/default/music-ui.xml
317 %{_datadir}/mythtv/themes/default/next_button_off.png
318 %{_datadir}/mythtv/themes/default/next_button_on.png
319 %{_datadir}/mythtv/themes/default/next_button_pushed.png
320 %{_datadir}/mythtv/themes/default/pause_button_off.png
321 %{_datadir}/mythtv/themes/default/pause_button_on.png
322 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
323 %{_datadir}/mythtv/themes/default/play_button_off.png
324 %{_datadir}/mythtv/themes/default/play_button_on.png
325 %{_datadir}/mythtv/themes/default/play_button_pushed.png
326 %{_datadir}/mythtv/themes/default/prev_button_off.png
327 %{_datadir}/mythtv/themes/default/prev_button_on.png
328 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
329 %{_datadir}/mythtv/themes/default/rew_button_off.png
330 %{_datadir}/mythtv/themes/default/rew_button_on.png
331 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
332 %{_datadir}/mythtv/themes/default/selectionbar.png
333 %{_datadir}/mythtv/themes/default/stop_button_off.png
334 %{_datadir}/mythtv/themes/default/stop_button_on.png
335 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
336 %{_datadir}/mythtv/themes/default/text_button_off.png
337 %{_datadir}/mythtv/themes/default/text_button_on.png
338 %{_datadir}/mythtv/themes/default/text_button_pushed.png
339 %{_datadir}/mythtv/themes/default/track_info_background.png
340 %endif
341
342 %files -n mythvideo
343 %defattr(644,root,root,755)
344 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
345 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
346 %{_datadir}/mythtv/i18n/mythvideo_*.qm
347 %{_datadir}/mythtv/themes/default/video-ui.xml
348 %{_datadir}/mythtv/themes/default/mv-*.png
349 %{_datadir}/mythtv/themes/default/mv_*.png
350 %{_datadir}/mythtv/video_settings.xml
351 %{_datadir}/mythtv/videomenu.xml
352 %{_datadir}/mythtv/mythvideo/scripts/README
353 %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
354 %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
355 /var/lib/mythvideo
356
357 %files -n mythweather
358 %defattr(644,root,root,755)
359 %doc mythweather/README
360 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
361 %{_datadir}/mythtv/i18n/mythweather_*.qm
362 %{_datadir}/mythtv/mythweather
363 %{_datadir}/mythtv/themes/default/weather-ui.xml
364 %{_datadir}/mythtv/themes/default/cloudy.png
365 %{_datadir}/mythtv/themes/default/fair.png
366 %{_datadir}/mythtv/themes/default/flurries.png
367 %{_datadir}/mythtv/themes/default/fog.png
368 %{_datadir}/mythtv/themes/default/logo.png
369 %{_datadir}/mythtv/themes/default/lshowers.png
370 %{_datadir}/mythtv/themes/default/mcloudy.png
371 %{_datadir}/mythtv/themes/default/mw-*.png
372 %{_datadir}/mythtv/themes/default/mwmain.png
373 %{_datadir}/mythtv/themes/default/pcloudy.png
374 %{_datadir}/mythtv/themes/default/rainsnow.png
375 %{_datadir}/mythtv/themes/default/showers.png
376 %{_datadir}/mythtv/themes/default/snowshow.png
377 %{_datadir}/mythtv/themes/default/sunny.png
378 %{_datadir}/mythtv/themes/default/thunshowers.png
379 %{_datadir}/mythtv/themes/default/unknown.png
380
381 %files -n mythgallery
382 %defattr(644,root,root,755)
383 %doc mythgallery/README mythgallery/UPGRADING
384 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
385 %{_datadir}/mythtv/themes/default/gallery-ui.xml
386 %{_datadir}/mythtv/themes/default/gallery-*.png
387 %{_datadir}/mythtv/i18n/mythgallery_*.qm
388 /var/lib/pictures
389
390 %files -n mythgame
391 %defattr(644,root,root,755)
392 %doc mythgame/README mythgame/UPGRADING
393 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
394 %{_datadir}/mythtv/games
395 #%config %{_datadir}/mythtv/games/PC/gamelist.xml
396 %{_datadir}/xmame/screens
397 %{_datadir}/xmame/flyers
398 %{_datadir}/mythtv/game_settings.xml
399 %{_datadir}/mythtv/themes/default/game-ui.xml
400 %{_datadir}/mythtv/i18n/mythgame_*.qm
401
402 %files -n mythdvd
403 %defattr(644,root,root,755)
404 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
405 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
406 %{_datadir}/mythtv/dvd_settings.xml
407 %{_datadir}/mythtv/dvdmenu.xml
408 %{_datadir}/mythtv/themes/default/dvd-ui.xml
409 %{_datadir}/mythtv/themes/default/md_*.png
410 %{_datadir}/mythtv/i18n/mythdvd_*.qm
411 %attr(755,root,root) %{_bindir}/mtd
412
413 %files -n mythnews
414 %defattr(644,root,root,755)
415 %doc mythnews/README mythnews/AUTHOR
416 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
417 %{_datadir}/mythtv/mythnews
418 %{_datadir}/mythtv/themes/default/news-ui.xml
419 %{_datadir}/mythtv/themes/default/news-info-bg.png
420 %{_datadir}/mythtv/i18n/mythnews_*.qm
421
422 %files -n mythbrowser
423 %defattr(644,root,root,755)
424 %doc mythbrowser/README mythbrowser/AUTHORS
425 %attr(755,root,root) %{_bindir}/mythbrowser
426 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
427 %{_datadir}/mythtv/themes/default/webpage.png
428 %{_datadir}/mythtv/i18n/mythbrowser_*.qm
429
430 %if %{with mythphone}
431 %files -n mythphone
432 %defattr(644,root,root,755)
433 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
434 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
435 %{_datadir}/mythtv/themes/default/phone-ui.xml
436 %{_datadir}/mythtv/themes/default/webcam-ui.xml
437 %{_datadir}/mythtv/themes/default/mp_*.png
438 %{_datadir}/mythtv/themes/default/phone.png
439 %{_datadir}/mythtv/i18n/mythphone_*.qm
440 %endif
This page took 0.068621 seconds and 4 git commands to generate.