]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- fixed amd64 build
[packages/mythplugins.git] / mythplugins.spec
1 # disable mythmusic,mythphone due to https://bugs.pld-linux.org/?do=details&id=5687
2 %bcond_without  mythmusic
3 %bcond_without mythphone
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Main MythTV plugins.
7 Name:           mythplugins
8 Version:        0.18.1
9 Release:        0.112.9
10 License:        GPL v2
11 Group:          Applications/Multimedia
12 URL:            http://www.mythtv.org/
13 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  1d94d19e2a13c24a408ced9b6c4f5b47
15 Patch0:         %{name}-configure.patch
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  SDL-devel
19 BuildRequires:  X11-OpenGL-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  a52dec-libs-devel
22 BuildRequires:  cdparanoia-III-devel
23 BuildRequires:  faad2-devel >= 2.0-5.2
24 BuildRequires:  fftw-devel >= 2.1.3
25 BuildRequires:  flac-devel >= 1.0.4
26 BuildRequires:  freetype-devel
27 BuildRequires:  kdelibs-devel
28 BuildRequires:  libcdaudio-devel
29 BuildRequires:  libdvdcss-devel >= 1.2.7
30 BuildRequires:  libdvdread-devel >= 0.9.4
31 BuildRequires:  libexif-devel
32 BuildRequires:  libfame-devel >= 0.9.0
33 BuildRequires:  libid3tag-devel
34 BuildRequires:  libmad-devel
35 BuildRequires:  libmyth-devel >= 0.18.1-0.21
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtiff-devel
38 BuildRequires:  libvorbis-devel >= 1.0
39 BuildRequires:  mjpegtools-devel >= 1.6.1
40 BuildRequires:  nasm
41 BuildRequires:  transcode >= 0.6.8
42 BuildRequires:  xvid-devel >= 1:0.9.1
43 BuildRequires:  zlib-devel
44 Requires:       mythbrowser
45 Requires:       mythdvd
46 Requires:       mythgallery
47 Requires:       mythgame
48 %{?with_mythmusic:Requires:     mythmusic}
49 Requires:       mythnews
50 %{?with_mythphone:Requires:     mythphone}
51 Requires:       mythvideo
52 Requires:       mythweather
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         api_ver %(echo %{version} | cut -d. -f1,2)
56
57 %description
58 This is a consolidation of all the official MythTV plugins that used
59 to be distributed as separate downloads from mythtv.org.
60
61 %package -n mythmusic
62 Summary:        The music player add-on module for MythTV.
63 Group:          Applications/Multimedia
64 Requires:       mythtv-frontend-api = %{api_ver}
65
66 %description -n mythmusic
67 Music add-on for mythtv.
68
69 %package -n mythvideo
70 Summary:        A generic video player frontend module for MythTV.
71 Group:          Applications/Multimedia
72 Requires:       mplayer
73 Requires:       mythtv-frontend-api = %{api_ver}
74
75 %description -n mythvideo
76 A generic video player frontend module for MythTV.
77
78 %package -n mythweather
79 Summary:        A MythTV module that displays a weather forcast.
80 Group:          Applications/Multimedia
81 Requires:       mythtv-frontend-api = %{api_ver}
82
83 %description -n mythweather
84 A MythTV module that displays a weather forcast.
85
86 %package -n mythgallery
87 Summary:        A gallery/slideshow module for MythTV.
88 Group:          Applications/Multimedia
89 Requires:       mythtv-frontend-api = %{api_ver}
90
91 %description -n mythgallery
92 A gallery/slideshow module for MythTV.
93
94 %package -n mythgame
95 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV.
96 Group:          Applications/Multimedia
97 Requires:       mythtv-frontend-api = %{api_ver}
98
99 %description -n mythgame
100 A game frontend (xmame, nes, snes, pc) for MythTV.
101
102 %package -n mythdvd
103 Summary:        A DVD player module for MythTV.
104 Group:          Applications/Multimedia
105 Requires:       mythtv-frontend-api = %{api_ver}
106 Requires:       transcode >= 0.6.8
107
108 %description -n mythdvd
109 MythDVD is a MythTV module that allows you to play DVD's on a myth-box
110 and (optionally) rip DVD's and transcode their video and audio content
111 to other (generally smaller) formats. The playing features are simply
112 myth-style wrappers for your favourite DVD playing software (mplayer,
113 ogle, xine, etc). The transcoding is based on and derived from the
114 excellent transcode package.
115
116 %package -n mythnews
117 Summary:        A RSS News Feed Plugin for MythTV.
118 Group:          Applications/Multimedia
119 Requires:       mythtv-frontend-api = %{api_ver}
120
121 %description -n mythnews
122
123 %package -n mythbrowser
124 Summary:        A small web browser module for MythTV.
125 Group:          Applications/Multimedia
126 Requires:       mythtv-frontend-api = %{api_ver}
127
128 %description -n mythbrowser
129 MythBrowser is a full fledged web-browser (multiple tabs) to display
130 webpages in full-screen mode. Simple page navigation is possible.
131 Starting with version 0.13 it also has full support for mouse driven
132 navigation (right mouse opens and clos es the popup menu).
133
134 MythBrowser also contains a BookmarkManager to manage the website
135 links in a simple mythplugin.
136
137 %package -n mythphone
138 Summary:        A video conferencing module for MythTV.
139 Group:          Applications/Multimedia
140 Requires:       mythtv-frontend-api = %{api_ver}
141
142 %description -n mythphone
143 Mythphone is a phone and videophone capability on MYTH using the
144 standard SIP protocol. It is compatible with Microsoft XP Messenger
145 and with SIP Service Providers such as Free World Dialup
146 (fwd.pulver.com).
147
148 %prep
149 %setup -q
150 %patch0 -p1
151
152 # lib64 fix
153 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
154 xargs grep -l /lib/ . | xargs sed -i -e '
155         s,/usr/lib/,/usr/%{_lib}/,g
156         s,{PREFIX}/lib,{PREFIX}/%{_lib}/,g
157 '
158
159 # include mythtv build settings
160 cp %{_datadir}/mythtv/build/config.mak .
161 sed -i -e '1iinclude(config.mak)'  settings.pro
162
163 %ifarch %{x8664}
164         # mmx asm isn't x86_64 compatible in mythmusic
165     echo 'DEFINES -= HAVE_MMX' >> settings.pro
166 %endif
167
168 # Fix /mnt/store -> /var/lib/mythmusic
169 sed -i -e's|/mnt/store/music|/var/lib/mythmusic|' mythmusic/mythmusic/globalsettings.cpp
170 # Fix /mnt/store -> /var/lib/mythmusic
171 sed -i -e's|/share/Movies/dvd|/var/lib/mythvideo|' mythvideo/mythvideo/globalsettings.cpp
172
173 %build
174 export QTDIR="%{_prefix}"
175 # Not gnu configure
176 %configure \
177         --enable-all \
178         --disable-festival \
179         %{!?with_mythmusic:--disable-mythmusic} \
180         %{!?with_mythphone:--disable-mythphone}
181
182 #       --enable-opengl          enable OpenGL (Music and Gallery) [default=no]
183 #       --enable-transcode       enable DVD ripping and transcoding [default=no]
184 #       --enable-vcd             enable VCD playing [default=no]
185 #       --enable-exif            enable reading of EXIF headers [default=no]
186 #       --enable-fftw            enable fftw visualizers [default=no]
187 #       --enable-sdl             use SDL for the synaesthesia output [default=no]
188 #       --enable-aac             enable AAC/MP4 audio file decompression [default=no]
189 #       --enable-festival        enable festival TTS Engine [default=no]
190
191 qmake mythplugins.pro
192 %{__make}
193
194 %install
195 rm -rf $RPM_BUILD_ROOT
196
197 export QTDIR="%{_prefix}"
198 %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
199
200 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
201 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
202 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
203 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
204 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
205 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
206
207 %clean
208 rm -rf $RPM_BUILD_ROOT
209
210 %files
211 %defattr(644,root,root,755)
212
213 %if %{with mythmusic}
214 %files -n mythmusic
215 %defattr(644,root,root,755)
216 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
217 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
218 /var/lib/mythmusic
219 %{_datadir}/mythtv/musicmenu.xml
220 %{_datadir}/mythtv/music_settings.xml
221 %{_datadir}/mythtv/i18n/mythmusic_*.qm
222 %{_datadir}/mythtv/themes/default/ff_button_off.png
223 %{_datadir}/mythtv/themes/default/ff_button_on.png
224 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
225 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
226 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
227 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
228 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
229 %{_datadir}/mythtv/themes/default/mm_checked.png
230 %{_datadir}/mythtv/themes/default/mm_checked_high.png
231 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
232 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
233 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
234 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
235 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
236 %{_datadir}/mythtv/themes/default/mm_rating.png
237 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
238 %{_datadir}/mythtv/themes/default/mm_unchecked.png
239 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
240 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
241 %{_datadir}/mythtv/themes/default/mm_volume_background.png
242 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
243 %{_datadir}/mythtv/themes/default/mm_waiting.png
244 %{_datadir}/mythtv/themes/default/music-sel-bg.png
245 %{_datadir}/mythtv/themes/default/music-ui.xml
246 %{_datadir}/mythtv/themes/default/next_button_off.png
247 %{_datadir}/mythtv/themes/default/next_button_on.png
248 %{_datadir}/mythtv/themes/default/next_button_pushed.png
249 %{_datadir}/mythtv/themes/default/pause_button_off.png
250 %{_datadir}/mythtv/themes/default/pause_button_on.png
251 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
252 %{_datadir}/mythtv/themes/default/play_button_off.png
253 %{_datadir}/mythtv/themes/default/play_button_on.png
254 %{_datadir}/mythtv/themes/default/play_button_pushed.png
255 %{_datadir}/mythtv/themes/default/prev_button_off.png
256 %{_datadir}/mythtv/themes/default/prev_button_on.png
257 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
258 %{_datadir}/mythtv/themes/default/rew_button_off.png
259 %{_datadir}/mythtv/themes/default/rew_button_on.png
260 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
261 %{_datadir}/mythtv/themes/default/selectionbar.png
262 %{_datadir}/mythtv/themes/default/stop_button_off.png
263 %{_datadir}/mythtv/themes/default/stop_button_on.png
264 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
265 %{_datadir}/mythtv/themes/default/text_button_off.png
266 %{_datadir}/mythtv/themes/default/text_button_on.png
267 %{_datadir}/mythtv/themes/default/text_button_pushed.png
268 %{_datadir}/mythtv/themes/default/track_info_background.png
269 %endif
270
271 %files -n mythvideo
272 %defattr(644,root,root,755)
273 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
274 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
275 %{_datadir}/mythtv/i18n/mythvideo_*.qm
276 %{_datadir}/mythtv/themes/default/video-ui.xml
277 %{_datadir}/mythtv/themes/default/mv-*.png
278 %{_datadir}/mythtv/themes/default/mv_*.png
279 %{_datadir}/mythtv/video_settings.xml
280 %{_datadir}/mythtv/videomenu.xml
281 %dir %{_datadir}/mythtv/mythvideo
282 %dir %{_datadir}/mythtv/mythvideo/scripts
283 %{_datadir}/mythtv/mythvideo/scripts/README
284 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
285 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
286 /var/lib/mythvideo
287
288 %files -n mythweather
289 %defattr(644,root,root,755)
290 %doc mythweather/README
291 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
292 %{_datadir}/mythtv/i18n/mythweather_*.qm
293 %{_datadir}/mythtv/mythweather
294 %{_datadir}/mythtv/themes/default/weather-ui.xml
295 %{_datadir}/mythtv/themes/default/cloudy.png
296 %{_datadir}/mythtv/themes/default/fair.png
297 %{_datadir}/mythtv/themes/default/flurries.png
298 %{_datadir}/mythtv/themes/default/fog.png
299 %{_datadir}/mythtv/themes/default/logo.png
300 %{_datadir}/mythtv/themes/default/lshowers.png
301 %{_datadir}/mythtv/themes/default/mcloudy.png
302 %{_datadir}/mythtv/themes/default/mw-*.png
303 %{_datadir}/mythtv/themes/default/mwmain.png
304 %{_datadir}/mythtv/themes/default/pcloudy.png
305 %{_datadir}/mythtv/themes/default/rainsnow.png
306 %{_datadir}/mythtv/themes/default/showers.png
307 %{_datadir}/mythtv/themes/default/snowshow.png
308 %{_datadir}/mythtv/themes/default/sunny.png
309 %{_datadir}/mythtv/themes/default/thunshowers.png
310 %{_datadir}/mythtv/themes/default/unknown.png
311
312 %files -n mythgallery
313 %defattr(644,root,root,755)
314 %doc mythgallery/README mythgallery/UPGRADING
315 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
316 %{_datadir}/mythtv/themes/default/gallery-ui.xml
317 %{_datadir}/mythtv/themes/default/gallery-*.png
318 %{_datadir}/mythtv/i18n/mythgallery_*.qm
319 /var/lib/pictures
320
321 %files -n mythgame
322 %defattr(644,root,root,755)
323 %doc mythgame/README mythgame/UPGRADING
324 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
325 %{_datadir}/mythtv/games
326 #%config %{_datadir}/mythtv/games/PC/gamelist.xml
327 #%{_datadir}/xmame/screens
328 #%{_datadir}/xmame/flyers
329 %{_datadir}/mythtv/game_settings.xml
330 %{_datadir}/mythtv/themes/default/game-ui.xml
331 %{_datadir}/mythtv/i18n/mythgame_*.qm
332
333 %files -n mythdvd
334 %defattr(644,root,root,755)
335 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
336 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
337 %{_datadir}/mythtv/dvd_settings.xml
338 %{_datadir}/mythtv/dvdmenu.xml
339 %{_datadir}/mythtv/themes/default/dvd-ui.xml
340 %{_datadir}/mythtv/themes/default/md_*.png
341 %{_datadir}/mythtv/i18n/mythdvd_*.qm
342 %attr(755,root,root) %{_bindir}/mtd
343
344 %files -n mythnews
345 %defattr(644,root,root,755)
346 %doc mythnews/README mythnews/AUTHORS
347 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
348 %{_datadir}/mythtv/mythnews
349 %{_datadir}/mythtv/themes/default/news-ui.xml
350 %{_datadir}/mythtv/themes/default/news-info-bg.png
351 %{_datadir}/mythtv/i18n/mythnews_*.qm
352
353 %files -n mythbrowser
354 %defattr(644,root,root,755)
355 %doc mythbrowser/README mythbrowser/AUTHORS
356 %attr(755,root,root) %{_bindir}/mythbrowser
357 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
358 %{_datadir}/mythtv/themes/default/webpage.png
359 %{_datadir}/mythtv/i18n/mythbrowser_*.qm
360
361 %if %{with mythphone}
362 %files -n mythphone
363 %defattr(644,root,root,755)
364 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
365 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
366 %{_datadir}/mythtv/themes/default/phone-ui.xml
367 %{_datadir}/mythtv/themes/default/webcam-ui.xml
368 %{_datadir}/mythtv/themes/default/mp_*.png
369 %{_datadir}/mythtv/themes/default/phone.png
370 %{_datadir}/mythtv/i18n/mythphone_*.qm
371 %endif
This page took 0.104381 seconds and 4 git commands to generate.