]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- fix libmyth-devel BR
[packages/mythplugins.git] / mythplugins.spec
1 # disable mythmusic,mythphone due to https://bugs.pld-linux.org/?do=details&id=5687
2 %bcond_with     mythmusic
3 %bcond_with mythphone
4 #
5 Summary:        Main MythTV plugins.
6 Name:           mythplugins
7 Version:        0.18.1
8 Release:        0.112.3
9 License:        GPL v2
10 Group:          Applications/Multimedia
11 URL:            http://www.mythtv.org/
12 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  1d94d19e2a13c24a408ced9b6c4f5b47
14 Patch0:         %{name}-configure.patch
15 BuildRequires:  SDL-devel
16 BuildRequires:  X11-OpenGL-devel
17 BuildRequires:  XFree86-devel
18 BuildRequires:  a52dec-libs-devel
19 BuildRequires:  cdparanoia-III-devel
20 BuildRequires:  faad2-devel >= 2.0-5.2
21 BuildRequires:  fftw-devel >= 2.1.3
22 BuildRequires:  flac-devel >= 1.0.4
23 BuildRequires:  freetype-devel
24 BuildRequires:  kdelibs-devel
25 BuildRequires:  libcdaudio-devel
26 BuildRequires:  libdvdcss-devel >= 1.2.7
27 BuildRequires:  libdvdread-devel >= 0.9.4
28 BuildRequires:  libexif-devel
29 BuildRequires:  libfame-devel >= 0.9.0
30 BuildRequires:  libid3tag-devel
31 BuildRequires:  libmad-devel
32 BuildRequires:  libmyth-devel >= 0.18.1-0.21
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  libvorbis-devel >= 1.0
36 BuildRequires:  mjpegtools-devel >= 1.6.1
37 BuildRequires:  nasm
38 BuildRequires:  transcode >= 0.6.8
39 BuildRequires:  xvid-devel >= 1:0.9.1
40 BuildRequires:  zlib-devel
41 Requires:       mythbrowser
42 Requires:       mythdvd
43 Requires:       mythgallery
44 Requires:       mythgame
45 %{?with_mythmusic:Requires:     mythmusic}
46 Requires:       mythnews
47 %{?with_mythphone:Requires:     mythphone}
48 Requires:       mythvideo
49 Requires:       mythweather
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         api_ver %(echo %{version} | cut -d. -f1,2)
53
54 %description
55 This is a consolidation of all the official MythTV plugins that used
56 to be distributed as separate downloads from mythtv.org.
57
58 %package -n mythmusic
59 Summary:        The music player add-on module for MythTV.
60 Group:          Applications/Multimedia
61 Requires:       mythtv-frontend-api = %{api_ver}
62
63 %description -n mythmusic
64 Music add-on for mythtv.
65
66 %package -n mythvideo
67 Summary:        A generic video player frontend module for MythTV.
68 Group:          Applications/Multimedia
69 Requires:       mplayer
70 Requires:       mythtv-frontend-api = %{api_ver}
71
72 %description -n mythvideo
73 A generic video player frontend module for MythTV.
74
75 %package -n mythweather
76 Summary:        A MythTV module that displays a weather forcast.
77 Group:          Applications/Multimedia
78 Requires:       mythtv-frontend-api = %{api_ver}
79
80 %description -n mythweather
81 A MythTV module that displays a weather forcast.
82
83 %package -n mythgallery
84 Summary:        A gallery/slideshow module for MythTV.
85 Group:          Applications/Multimedia
86 Requires:       mythtv-frontend-api = %{api_ver}
87
88 %description -n mythgallery
89 A gallery/slideshow module for MythTV.
90
91 %package -n mythgame
92 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV.
93 Group:          Applications/Multimedia
94 Requires:       mythtv-frontend-api = %{api_ver}
95
96 %description -n mythgame
97 A game frontend (xmame, nes, snes, pc) for MythTV.
98
99 %package -n mythdvd
100 Summary:        A DVD player module for MythTV.
101 Group:          Applications/Multimedia
102 Requires:       mythtv-frontend-api = %{api_ver}
103 Requires:       transcode >= 0.6.8
104
105 %description -n mythdvd
106 MythDVD is a MythTV module that allows you to play DVD's on a myth-box
107 and (optionally) rip DVD's and transcode their video and audio content
108 to other (generally smaller) formats. The playing features are simply
109 myth-style wrappers for your favourite DVD playing software (mplayer,
110 ogle, xine, etc). The transcoding is based on and derived from the
111 excellent transcode package.
112
113 %package -n mythnews
114 Summary:        A RSS News Feed Plugin for MythTV.
115 Group:          Applications/Multimedia
116 Requires:       mythtv-frontend-api = %{api_ver}
117
118 %description -n mythnews
119
120 %package -n mythbrowser
121 Summary:        A small web browser module for MythTV.
122 Group:          Applications/Multimedia
123 Requires:       mythtv-frontend-api = %{api_ver}
124
125 %description -n mythbrowser
126 MythBrowser is a full fledged web-browser (multiple tabs) to display
127 webpages in full-screen mode. Simple page navigation is possible.
128 Starting with version 0.13 it also has full support for mouse driven
129 navigation (right mouse opens and clos es the popup menu).
130
131 MythBrowser also contains a BookmarkManager to manage the website
132 links in a simple mythplugin.
133
134 %package -n mythphone
135 Summary:        A video conferencing module for MythTV.
136 Group:          Applications/Multimedia
137 Requires:       mythtv-frontend-api = %{api_ver}
138
139 %description -n mythphone
140 Mythphone is a phone and videophone capability on MYTH using the
141 standard SIP protocol. It is compatible with Microsoft XP Messenger
142 and with SIP Service Providers such as Free World Dialup
143 (fwd.pulver.com).
144
145 %prep
146 %setup -q
147 %patch0 -p1
148
149 # lib64 fix
150 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
151 xargs grep -l /lib/ . | xargs sed -i -e '
152         s,/usr/lib/,/usr/%{_lib}/,g
153         s,{PREFIX}/lib,{PREFIX}/%{_lib}/,g
154 '
155
156 # include mythtv build settings
157 cp %{_datadir}/mythtv/build/config.mak .
158 sed -i -e '1iinclude(config.mak)'  settings.pro
159
160 # Fix /mnt/store -> /var/lib/mythmusic
161 sed -i -e's|/mnt/store/music|/var/lib/mythmusic|' mythmusic/mythmusic/globalsettings.cpp
162 # Fix /mnt/store -> /var/lib/mythmusic
163 sed -i -e's|/share/Movies/dvd|/var/lib/mythvideo|' mythvideo/mythvideo/globalsettings.cpp
164
165 %build
166 export QTDIR="%{_prefix}"
167 # Not gnu configure
168 %configure \
169         --enable-all \
170         --disable-festival \
171         %{!?with_mythmusic:--disable-mythmusic} \
172         %{!?with_mythphone:--disable-mythphone}
173
174 #       --enable-opengl          enable OpenGL (Music and Gallery) [default=no]
175 #       --enable-transcode       enable DVD ripping and transcoding [default=no]
176 #       --enable-vcd             enable VCD playing [default=no]
177 #       --enable-exif            enable reading of EXIF headers [default=no]
178 #       --enable-fftw            enable fftw visualizers [default=no]
179 #       --enable-sdl             use SDL for the synaesthesia output [default=no]
180 #       --enable-aac             enable AAC/MP4 audio file decompression [default=no]
181 #       --enable-festival        enable festival TTS Engine [default=no]
182
183 qmake mythplugins.pro
184 %{__make}
185
186 %install
187 rm -rf $RPM_BUILD_ROOT
188
189 export QTDIR="%{_prefix}"
190 %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
191
192 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
193 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
194 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
195 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
196 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
197 install -d $RPM_BUILD_ROOT%{_datadir}/xmame
198 ln -s %{_datadir}/xmame $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame
199 install -d $RPM_BUILD_ROOT%{_datadir}/xmame/flyers
200 ln -s snap $RPM_BUILD_ROOT%{_datadir}/xmame/screens
201
202 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/
203
204 %clean
205 rm -rf $RPM_BUILD_ROOT
206
207 %files
208 %defattr(644,root,root,755)
209
210 %if %{with mythmusic}
211 %files -n mythmusic
212 %defattr(644,root,root,755)
213 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
214 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
215 /var/lib/mythmusic
216 %{_datadir}/mythtv/musicmenu.xml
217 %{_datadir}/mythtv/music_settings.xml
218 %{_datadir}/mythtv/i18n/mythmusic_*.qm
219 %{_datadir}/mythtv/themes/default/ff_button_off.png
220 %{_datadir}/mythtv/themes/default/ff_button_on.png
221 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
222 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
223 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
224 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
225 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
226 %{_datadir}/mythtv/themes/default/mm_checked.png
227 %{_datadir}/mythtv/themes/default/mm_checked_high.png
228 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
229 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
230 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
231 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
232 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
233 %{_datadir}/mythtv/themes/default/mm_rating.png
234 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
235 %{_datadir}/mythtv/themes/default/mm_unchecked.png
236 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
237 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
238 %{_datadir}/mythtv/themes/default/mm_volume_background.png
239 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
240 %{_datadir}/mythtv/themes/default/mm_waiting.png
241 %{_datadir}/mythtv/themes/default/music-sel-bg.png
242 %{_datadir}/mythtv/themes/default/music-ui.xml
243 %{_datadir}/mythtv/themes/default/next_button_off.png
244 %{_datadir}/mythtv/themes/default/next_button_on.png
245 %{_datadir}/mythtv/themes/default/next_button_pushed.png
246 %{_datadir}/mythtv/themes/default/pause_button_off.png
247 %{_datadir}/mythtv/themes/default/pause_button_on.png
248 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
249 %{_datadir}/mythtv/themes/default/play_button_off.png
250 %{_datadir}/mythtv/themes/default/play_button_on.png
251 %{_datadir}/mythtv/themes/default/play_button_pushed.png
252 %{_datadir}/mythtv/themes/default/prev_button_off.png
253 %{_datadir}/mythtv/themes/default/prev_button_on.png
254 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
255 %{_datadir}/mythtv/themes/default/rew_button_off.png
256 %{_datadir}/mythtv/themes/default/rew_button_on.png
257 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
258 %{_datadir}/mythtv/themes/default/selectionbar.png
259 %{_datadir}/mythtv/themes/default/stop_button_off.png
260 %{_datadir}/mythtv/themes/default/stop_button_on.png
261 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
262 %{_datadir}/mythtv/themes/default/text_button_off.png
263 %{_datadir}/mythtv/themes/default/text_button_on.png
264 %{_datadir}/mythtv/themes/default/text_button_pushed.png
265 %{_datadir}/mythtv/themes/default/track_info_background.png
266 %endif
267
268 %files -n mythvideo
269 %defattr(644,root,root,755)
270 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
271 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
272 %{_datadir}/mythtv/i18n/mythvideo_*.qm
273 %{_datadir}/mythtv/themes/default/video-ui.xml
274 %{_datadir}/mythtv/themes/default/mv-*.png
275 %{_datadir}/mythtv/themes/default/mv_*.png
276 %{_datadir}/mythtv/video_settings.xml
277 %{_datadir}/mythtv/videomenu.xml
278 %{_datadir}/mythtv/mythvideo/scripts/README
279 %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
280 %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
281 /var/lib/mythvideo
282
283 %files -n mythweather
284 %defattr(644,root,root,755)
285 %doc mythweather/README
286 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
287 %{_datadir}/mythtv/i18n/mythweather_*.qm
288 %{_datadir}/mythtv/mythweather
289 %{_datadir}/mythtv/themes/default/weather-ui.xml
290 %{_datadir}/mythtv/themes/default/cloudy.png
291 %{_datadir}/mythtv/themes/default/fair.png
292 %{_datadir}/mythtv/themes/default/flurries.png
293 %{_datadir}/mythtv/themes/default/fog.png
294 %{_datadir}/mythtv/themes/default/logo.png
295 %{_datadir}/mythtv/themes/default/lshowers.png
296 %{_datadir}/mythtv/themes/default/mcloudy.png
297 %{_datadir}/mythtv/themes/default/mw-*.png
298 %{_datadir}/mythtv/themes/default/mwmain.png
299 %{_datadir}/mythtv/themes/default/pcloudy.png
300 %{_datadir}/mythtv/themes/default/rainsnow.png
301 %{_datadir}/mythtv/themes/default/showers.png
302 %{_datadir}/mythtv/themes/default/snowshow.png
303 %{_datadir}/mythtv/themes/default/sunny.png
304 %{_datadir}/mythtv/themes/default/thunshowers.png
305 %{_datadir}/mythtv/themes/default/unknown.png
306
307 %files -n mythgallery
308 %defattr(644,root,root,755)
309 %doc mythgallery/README mythgallery/UPGRADING
310 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
311 %{_datadir}/mythtv/themes/default/gallery-ui.xml
312 %{_datadir}/mythtv/themes/default/gallery-*.png
313 %{_datadir}/mythtv/i18n/mythgallery_*.qm
314 /var/lib/pictures
315
316 %files -n mythgame
317 %defattr(644,root,root,755)
318 %doc mythgame/README mythgame/UPGRADING
319 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
320 %{_datadir}/mythtv/games
321 #%config %{_datadir}/mythtv/games/PC/gamelist.xml
322 %{_datadir}/xmame/screens
323 %{_datadir}/xmame/flyers
324 %{_datadir}/mythtv/game_settings.xml
325 %{_datadir}/mythtv/themes/default/game-ui.xml
326 %{_datadir}/mythtv/i18n/mythgame_*.qm
327
328 %files -n mythdvd
329 %defattr(644,root,root,755)
330 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
331 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
332 %{_datadir}/mythtv/dvd_settings.xml
333 %{_datadir}/mythtv/dvdmenu.xml
334 %{_datadir}/mythtv/themes/default/dvd-ui.xml
335 %{_datadir}/mythtv/themes/default/md_*.png
336 %{_datadir}/mythtv/i18n/mythdvd_*.qm
337 %attr(755,root,root) %{_bindir}/mtd
338
339 %files -n mythnews
340 %defattr(644,root,root,755)
341 %doc mythnews/README mythnews/AUTHORS
342 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
343 %{_datadir}/mythtv/mythnews
344 %{_datadir}/mythtv/themes/default/news-ui.xml
345 %{_datadir}/mythtv/themes/default/news-info-bg.png
346 %{_datadir}/mythtv/i18n/mythnews_*.qm
347
348 %files -n mythbrowser
349 %defattr(644,root,root,755)
350 %doc mythbrowser/README mythbrowser/AUTHORS
351 %attr(755,root,root) %{_bindir}/mythbrowser
352 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
353 %{_datadir}/mythtv/themes/default/webpage.png
354 %{_datadir}/mythtv/i18n/mythbrowser_*.qm
355
356 %if %{with mythphone}
357 %files -n mythphone
358 %defattr(644,root,root,755)
359 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
360 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
361 %{_datadir}/mythtv/themes/default/phone-ui.xml
362 %{_datadir}/mythtv/themes/default/webcam-ui.xml
363 %{_datadir}/mythtv/themes/default/mp_*.png
364 %{_datadir}/mythtv/themes/default/phone.png
365 %{_datadir}/mythtv/i18n/mythphone_*.qm
366 %endif
This page took 0.070858 seconds and 4 git commands to generate.