]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- rel 3
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mythbrowser     # disable building mythbrowser plugin
5 %bcond_without  mythdvd         # disable building mythgallery plugin
6 %bcond_without  mythgallery     # disable building mythgallery plugin
7 %bcond_without  mythgame        # disable building mythgallery plugin
8 %bcond_without  mythmusic       # disable building mythmusic plugin
9 %bcond_without  mythnews        # disable building mythgallery plugin
10 %bcond_without  mythphone       # disable building mythgallery plugin
11 %bcond_without  mythvideo       # disable building mythgallery plugin
12 %bcond_without  mythweather     # disable building mythgallery plugin
13 %bcond_without  mythweb         # disable building mythgallery plugin
14 %bcond_without  mythflix        # disable building mythflix plugin
15 %bcond_without  mythcontrols    # disable mythcontrols plugin
16 #
17 %if %{without binary}
18 %undefine       with_mythbrowser
19 %undefine       with_mythdvd
20 %undefine       with_mythgallery
21 %undefine       with_mythgame
22 %undefine       with_mythmusic
23 %undefine       with_mythnews
24 %undefine       with_mythphone
25 %undefine       with_mythvideo
26 %undefine       with_mythweather
27 %undefine       with_mythcontrols
28 %undefine       with_mythflix
29 %endif
30
31 %include        /usr/lib/rpm/macros.perl
32
33 Summary:        Main MythTV plugins
34 Summary(pl):    G³ówne wtyczki MythTV
35 Name:           mythplugins
36 Version:        0.19
37 Release:        3
38 License:        GPL v2
39 Group:          Applications/Multimedia
40 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
41 # Source0-md5:  201d60d5d60222038d8c97831f7e4288
42 Source1:        mythweb.conf
43 Patch0:         %{name}-lib64.patch
44 Patch1:         %{name}-paths.patch
45 Patch2:         mythweb-config.patch
46 URL:            http://www.mythtv.org/
47 %if %{with binary}
48 %if %{with mythgallery} || %{with myhtmusic}
49 BuildRequires:  OpenGL-devel
50 %endif
51 BuildRequires:  SDL-devel
52 BuildRequires:  XFree86-devel
53 BuildRequires:  a52dec-libs-devel
54 BuildRequires:  cdparanoia-III-devel
55 BuildRequires:  faad2-devel >= 2.0-5.2
56 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
57 BuildRequires:  flac-devel >= 1.0.4
58 BuildRequires:  freetype-devel
59 BuildRequires:  kdelibs-devel
60 BuildRequires:  libcdaudio-devel >= 0.99.12p2
61 BuildRequires:  libdvdcss-devel >= 1.2.7
62 BuildRequires:  libdvdread-devel >= 0.9.4
63 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
64 BuildRequires:  libfame-devel >= 0.9.0
65 BuildRequires:  libid3tag-devel
66 BuildRequires:  libmad-devel
67 BuildRequires:  libmyth-devel >= 0.19
68 BuildRequires:  libstdc++-devel
69 BuildRequires:  libtiff-devel
70 BuildRequires:  libvorbis-devel >= 1:1.0
71 BuildRequires:  mjpegtools-devel >= 1.6.1
72 BuildRequires:  nasm
73 BuildRequires:  rpm-perlprov >= 4.1-13
74 BuildRequires:  sed >= 4.0
75 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
76 BuildRequires:  xvid-devel >= 1:0.9.1
77 BuildRequires:  zlib-devel
78 %endif
79 %{?with_mythbrowser:Requires:   mythbrowser}
80 %{?with_mythdvd:Requires:       mythdvd}
81 %{?with_mythflix:Requires:      mythflix}
82 %{?with_mythgallery:Requires:   mythgallery}
83 %{?with_mythgame:Requires:      mythgame}
84 %{?with_mythmysic:Requires:     mythmusic}
85 %{?with_mythnews:Requires:      mythnews}
86 %{?with_mythphone:Requires:     mythphone}
87 %{?with_mythvideo:Requires:     mythvideo}
88 %{?with_mythweather:Requires:   mythweather}
89 %{?with_mythweb:Requires:       mythweb}
90 ExclusiveArch:  %{ix86} %{x8664} ppc
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
94 %define         _webapps        /etc/webapps
95 %define         _webapp         mythweb
96
97 %description
98 This is a consolidation of all the official MythTV plugins that used
99 to be distributed as separate downloads from mythtv.org.
100
101 %description -l pl
102 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które by³y
103 wcze¶niej rozpowszechniane jako osobne pakiety na mythtv.org.
104
105 %package -n mythmusic
106 Summary:        The music player add-on module for MythTV
107 Summary(pl):    Modu³ odtwarzacza muzyki dla MythTV
108 Group:          Applications/Multimedia
109 Requires:       mythtv-frontend-api = %{myth_api_version}
110
111 %description -n mythmusic
112 Music add-on for MythTV.
113
114 %description -n mythmusic -l pl
115 Odtwarzacz muzyki dla MythTV.
116
117 %package -n mythvideo
118 Summary:        A generic video player frontend module for MythTV
119 Summary(pl):    Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV
120 Group:          Applications/Multimedia
121 Requires:       mplayer
122 Requires:       mythtv-frontend-api = %{myth_api_version}
123
124 %description -n mythvideo
125 A generic video player frontend module for MythTV.
126
127 %description -n mythvideo -l pl
128 Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV.
129
130 %package -n mythweather
131 Summary:        A MythTV module that displays a weather forcast
132 Summary(pl):    Modu³ MythTV wy¶wietlaj±cy prognozê pogody
133 Group:          Applications/Multimedia
134 Requires:       mythtv-frontend-api = %{myth_api_version}
135
136 %description -n mythweather
137 A MythTV module that displays a weather forcast.
138
139 %description -n mythweather -l pl
140 Modu³ MythTV wy¶wietlaj±cy prognozê pogody.
141
142 %package -n mythgallery
143 Summary:        A gallery/slideshow module for MythTV
144 Summary(pl):    Modu³ galerii/pokazu slajdów dla MythTV
145 Group:          Applications/Multimedia
146 Requires:       mythtv-frontend-api = %{myth_api_version}
147
148 %description -n mythgallery
149 A gallery/slideshow module for MythTV.
150
151 %description -n mythgallery -l pl
152 Modu³ galerii/pokazu slajdów dla MythTV.
153
154 %package -n mythgame
155 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
156 Summary(pl):    Interfejs do gier (xmame, nes, snes, pc) dla MythTV
157 Group:          Applications/Multimedia
158 Requires:       mythtv-frontend-api = %{myth_api_version}
159
160 %description -n mythgame
161 A game frontend (xmame, nes, snes, pc) for MythTV.
162
163 %description -n mythgame -l pl
164 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
165
166 %package -n mythdvd
167 Summary:        A DVD player module for MythTV
168 Summary(pl):    Modu³ odtwarzacza DVD dla MythTV
169 Group:          Applications/Multimedia
170 Requires:       mythtv-frontend-api = %{myth_api_version}
171 Requires:       transcode >= 0.6.8
172
173 %description -n mythdvd
174 MythDVD is a MythTV module that allows you to play DVDs on a myth-box
175 and (optionally) rip DVD's and transcode their video and audio content
176 to other (generally smaller) formats. The playing features are simply
177 myth-style wrappers for your favourite DVD playing software (mplayer,
178 ogle, xine, etc). The transcoding is based on and derived from the
179 excellent transcode package.
180
181 %description -n mythdvd -l pl
182 MythDVD to modu³ MythTV umo¿liwiaj±cy odtwarzanie p³yt DVD w MythTV i
183 (opcjonalnie) rippowanie ich oraz przekodowywanie obrazu i d¼wiêku do
184 innych (zwykle mniej zajmuj±cych) formatów. Mo¿liwo¶ci odtwarzania to
185 po prostu obudowanie w stylu myth dla ulubionego oprogramowania do
186 odtwarzania DVD (mplayer, ogle, xine itp.). Przekodowywanie jest
187 oparte i wywodzi siê z wspania³ego pakietu transcode.
188
189 %package -n mythnews
190 Summary:        A RSS News Feed plugin for MythTV
191 Summary(pl):    Wtyczka czytnika nowinek RSS dla MythTV
192 Group:          Applications/Multimedia
193 Requires:       mythtv-frontend-api = %{myth_api_version}
194
195 %description -n mythnews
196 A RSS News Feed plugin for MythTV.
197
198 %description -n mythnews -l pl
199 Wtyczka czytnika nowinek RSS dla MythTV.
200
201 %package -n mythbrowser
202 Summary:        A small web browser module for MythTV
203 Summary(pl):    Modu³ ma³ej przegl±darki WWW dla MythTV
204 Group:          Applications/Multimedia
205 Requires:       mythtv-frontend-api = %{myth_api_version}
206
207 %description -n mythbrowser
208 MythBrowser is a full fledged web-browser (multiple tabs) to display
209 webpages in full-screen mode. Simple page navigation is possible.
210 Starting with version 0.13 it also has full support for mouse driven
211 navigation (right mouse opens and closes the popup menu).
212
213 MythBrowser also contains a BookmarkManager to manage the website
214 links in a simple mythplugin.
215
216 %description -n mythbrowser -l pl
217 MythBrowser to w pe³ni funkcjonalna przegl±darka WWW (z wieloma
218 zak³adkami) wy¶wietlaj±ca strony WWW w trybie pe³noekranowym. Mo¿liwa
219 jest prosta nawigacja po stronie. Pocz±wszy od wersji 0.13 ma pe³n±
220 obs³ugê nawigacji myszk± (prawy przycisk otwiera i zamywa wyskakuj±ce
221 menu).
222
223 MythBrowser zawiera tak¿e BookmarkManagera do zarz±dzania odno¶nikami
224 do stron w prostej wtyczce myth.
225
226 %package -n mythphone
227 Summary:        A video conferencing module for MythTV
228 Summary(pl):    Modu³ wideokonferencji dla MythTV
229 Group:          Applications/Multimedia
230 Requires:       mythtv-frontend-api = %{myth_api_version}
231
232 %description -n mythphone
233 Mythphone is a phone and videophone capability on Myth using the
234 standard SIP protocol. It is compatible with Microsoft XP Messenger
235 and with SIP Service Providers such as Free World Dialup
236 (fwd.pulver.com).
237
238 %description -n mythphone -l pl
239 Mythphone to funkcjonalno¶æ telefonu i wideofonu w Myth przy u¿yciu
240 standardowego protoko³u SIP. Jest kompatybilny z Microsoft XP
241 Messengerem oraz dostawcami us³ug SIP, takimi jak Free World Dialup
242 (fwd.pulver.com).
243
244 %package -n mythweb
245 Summary:        The web interface to MythTV
246 Summary(pl):    Interfejs WWW do MythTV
247 Group:          Applications/Multimedia
248 Requires:       webapps
249 #Suggests:      apache(mod_auth)
250 #Suggests:      apache(mod_env)
251 Requires:       php >= 3:4.3
252 Requires:       php-mysql
253 Requires:       php-posix
254
255 %description -n mythweb
256 The web interface to MythTV.
257
258 %description -n mythweb -l pl
259 Interfejs WWW do MythTV.
260
261 %package -n mythflix
262 Summary:        MythFlix (A NetFlix MythTV)
263 Summary(pl):    MythFlix (NetFlix MythTV)
264 Group:          Applications/Multimedia
265 Requires:       mythtv-frontend-api = %{myth_api_version}
266
267 %description -n mythflix
268 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
269 It currently supports the ability to view your queue and add movies to
270 your queue. The browse feature is based on the Netflix RSS feeds. This
271 plugin is not very mature, which means things might not work right
272 and/or it might break other things.
273
274 %description -n mythflix -l pl
275 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
276 Aktualnie daje mo¿liwo¶æ ogl±dania kolejki i dodawania do niej filmów.
277 Przegl±danie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
278 jeszcze zbyt dojrza³a, co znaczy, ¿e co¶ mo¿e nie dzia³aæ lub psuæ co¶
279 innego.
280
281 %package -n mythcontrols
282 Summary:        MythTV keybindings editor
283 Summary(pl):    Edytor przypisañ klawiszy MythTV
284 Group:          Applications/Multimedia
285 Requires:       mythtv-frontend-api = %{myth_api_version}
286
287 %description -n mythcontrols
288 This plugin allows you to configure your keybindings on the frontend
289 without having to use mythweb or edit tables by hand.
290
291 %description -n mythcontrols -l pl
292 Ta wtyczka pozwala konfigurowaæ przypisania klawiszy we frontendzie
293 bez konieczno¶ci u¿ywania mythweba ani rêcznego modyfikowania tabel.
294
295 %prep
296 %setup -q %{?_snap:-n %{name}}
297 %if %{_lib} != "lib"
298 %patch0 -p1
299 %endif
300 %patch1 -p1
301 %patch2 -p1
302
303 # make it visible
304 mv mythweb/{.,}htaccess
305
306 # lib64 fix - enable to update patch
307 %if %{_lib} != "lib" && 0
308 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
309 xargs grep -l /lib/ . | xargs sed -i -e '
310         s,/usr/lib/,/usr/%{_lib}/,g
311         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
312 '
313 exit 1
314 %endif
315
316 %build
317 %if %{with binary}
318 export QTDIR="%{_prefix}"
319 # Not gnu configure
320 %configure \
321         --enable-all \
322         %{!?with_mythbrowser:--disable-mythbrowser} \
323         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
324         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
325         %{!?with_mythgame:--disable-mythgame} \
326         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
327         %{!?with_mythnews:--disable-mythnews} \
328         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
329         %{!?with_mythvideo:--disable-mythvideo} \
330         %{!?with_mythweather:--disable-mythweather} \
331         %{!?with_mythweb:--disable-mythweb} \
332         %{!?with_mythcontrols:--disable-mythcontrols} \
333         %{!?with_mythflix:--disable-mythflix} \
334
335 mv mythconfig.mak mythconfig.mak.old
336 cp mythconfig.mak.old mythconfig.mak
337 cat <<'EOF'>> mythconfig.mak
338 QMAKE_CXX=%{__cxx}
339 QMAKE_CC=%{__cc}
340 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
341 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
342 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
343 EOF
344
345 %{__make}
346 %endif
347
348 %install
349 rm -rf $RPM_BUILD_ROOT
350
351 %if %{with binary}
352 export QTDIR="%{_prefix}"
353 %{__make} install \
354         INSTALL_ROOT=$RPM_BUILD_ROOT
355
356 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
357 %if %{with mythgame}
358 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
359 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
360 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
361 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
362 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
363 %endif
364 %endif
365
366 %if %{with mythweb}
367 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb/{includes,languages}
368 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
369 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
370 cp -a mythweb/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb
371 cp -a mythweb/languages/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/languages
372 cp -a mythweb/includes/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/includes
373 cp -a mythweb/{images,js,skins,modules,themes,templates} $RPM_BUILD_ROOT%{_datadir}/mythweb
374 cp -a mythweb/config/*.{php,dat} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
375 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
376 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
377 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
378 %endif
379
380 for p in mythmusic mythvideo mythweather mythgallery mythgame mythdvd mythnews mythbrowser mythphone mythflix mythcontrols; do
381         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
382                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
383         done > $p.lang
384 done
385
386 %clean
387 rm -rf $RPM_BUILD_ROOT
388
389 %triggerin -n mythweb -- apache1
390 %webapp_register apache %{_webapp}
391
392 %triggerun -n mythweb -- apache1
393 %webapp_unregister apache %{_webapp}
394
395 %triggerin -n mythweb -- apache < 2.2.0, apache-base
396 %webapp_register httpd %{_webapp}
397
398 %triggerun -n mythweb -- apache < 2.2.0, apache-base
399 %webapp_unregister httpd %{_webapp}
400
401 %triggerpostun -n mythweb -- mythweb < 0.19
402 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
403         if [ -f /etc/mythweb/$i.rpmsave ]; then
404                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
405                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
406         fi
407 done
408 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
409
410 # migrate from apache-config macros
411 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
412         if [ -d /etc/apache/webapps.d ]; then
413                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
414                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
415         fi
416
417         if [ -d /etc/httpd/webapps.d ]; then
418                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
419                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
420         fi
421         rm -f /etc/mythweb/apache.conf.rpmsave
422 fi
423
424 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
425         rm -f /etc/apache/conf.d/99_mythplugins.conf
426         /usr/sbin/webapp register apache %{_webapp}
427         %service -q apache reload
428 fi
429 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
430         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
431         /usr/sbin/webapp register httpd %{_webapp}
432         %service -q httpd reload
433 fi
434
435 %files
436 %defattr(644,root,root,755)
437
438 %if %{with mythmusic}
439 %files -n mythmusic -f mythmusic.lang
440 %defattr(644,root,root,755)
441 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
442 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
443 /var/lib/mythmusic
444 %{_datadir}/mythtv/musicmenu.xml
445 %{_datadir}/mythtv/music_settings.xml
446 %{_datadir}/mythtv/themes/default/music-ui.xml
447 %{_datadir}/mythtv/themes/default/ff_button_off.png
448 %{_datadir}/mythtv/themes/default/ff_button_on.png
449 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
450 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
451 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
452 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
453 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
454 %{_datadir}/mythtv/themes/default/mm_checked.png
455 %{_datadir}/mythtv/themes/default/mm_checked_high.png
456 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
457 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
458 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
459 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
460 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
461 %{_datadir}/mythtv/themes/default/mm_rating.png
462 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
463 %{_datadir}/mythtv/themes/default/mm_unchecked.png
464 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
465 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
466 %{_datadir}/mythtv/themes/default/mm_volume_background.png
467 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
468 %{_datadir}/mythtv/themes/default/mm_waiting.png
469 %{_datadir}/mythtv/themes/default/music-sel-bg.png
470 %{_datadir}/mythtv/themes/default/next_button_off.png
471 %{_datadir}/mythtv/themes/default/next_button_on.png
472 %{_datadir}/mythtv/themes/default/next_button_pushed.png
473 %{_datadir}/mythtv/themes/default/pause_button_off.png
474 %{_datadir}/mythtv/themes/default/pause_button_on.png
475 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
476 %{_datadir}/mythtv/themes/default/play_button_off.png
477 %{_datadir}/mythtv/themes/default/play_button_on.png
478 %{_datadir}/mythtv/themes/default/play_button_pushed.png
479 %{_datadir}/mythtv/themes/default/prev_button_off.png
480 %{_datadir}/mythtv/themes/default/prev_button_on.png
481 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
482 %{_datadir}/mythtv/themes/default/rew_button_off.png
483 %{_datadir}/mythtv/themes/default/rew_button_on.png
484 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
485 %{_datadir}/mythtv/themes/default/selectionbar.png
486 %{_datadir}/mythtv/themes/default/stop_button_off.png
487 %{_datadir}/mythtv/themes/default/stop_button_on.png
488 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
489 %{_datadir}/mythtv/themes/default/text_button_off.png
490 %{_datadir}/mythtv/themes/default/text_button_on.png
491 %{_datadir}/mythtv/themes/default/text_button_pushed.png
492 %{_datadir}/mythtv/themes/default/track_info_background.png
493 %endif
494
495 %if %{with mythvideo}
496 %files -n mythvideo -f mythvideo.lang
497 %defattr(644,root,root,755)
498 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
499 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
500 %{_datadir}/mythtv/themes/default/video-ui.xml
501 %{_datadir}/mythtv/themes/default/mv-*.png
502 %{_datadir}/mythtv/themes/default/mv_*.png
503 %{_datadir}/mythtv/video_settings.xml
504 %{_datadir}/mythtv/videomenu.xml
505 %dir %{_datadir}/mythtv/mythvideo
506 %dir %{_datadir}/mythtv/mythvideo/scripts
507 %{_datadir}/mythtv/mythvideo/scripts/README
508 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
509 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
510 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/ofdb.pl
511 /var/lib/mythvideo
512 %endif
513
514 %if %{with mythweather}
515 %files -n mythweather -f mythweather.lang
516 %defattr(644,root,root,755)
517 %doc mythweather/README
518 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
519 %{_datadir}/mythtv/mythweather
520 %{_datadir}/mythtv/themes/default/weather-ui.xml
521 %{_datadir}/mythtv/themes/default/cloudy.png
522 %{_datadir}/mythtv/themes/default/fair.png
523 %{_datadir}/mythtv/themes/default/flurries.png
524 %{_datadir}/mythtv/themes/default/fog.png
525 %{_datadir}/mythtv/themes/default/logo.png
526 %{_datadir}/mythtv/themes/default/lshowers.png
527 %{_datadir}/mythtv/themes/default/mcloudy.png
528 %{_datadir}/mythtv/themes/default/mw-*.png
529 %{_datadir}/mythtv/themes/default/mwmain.png
530 %{_datadir}/mythtv/themes/default/pcloudy.png
531 %{_datadir}/mythtv/themes/default/rainsnow.png
532 %{_datadir}/mythtv/themes/default/showers.png
533 %{_datadir}/mythtv/themes/default/snowshow.png
534 %{_datadir}/mythtv/themes/default/sunny.png
535 %{_datadir}/mythtv/themes/default/thunshowers.png
536 %{_datadir}/mythtv/themes/default/unknown.png
537 %endif
538
539 %if %{with mythgallery}
540 %files -n mythgallery -f mythgallery.lang
541 %defattr(644,root,root,755)
542 %doc mythgallery/README mythgallery/UPGRADING
543 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
544 %{_datadir}/mythtv/themes/default/gallery-ui.xml
545 %{_datadir}/mythtv/themes/default/gallery-*.png
546 # FIXME: this is definately stupid path
547 /var/lib/pictures
548 %endif
549
550 %if %{with mythgame}
551 %files -n mythgame -f mythgame.lang
552 %defattr(644,root,root,755)
553 %doc mythgame/README mythgame/UPGRADING
554 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
555 %{_datadir}/mythtv/games
556 %{_datadir}/mythtv/game_settings.xml
557 %{_datadir}/mythtv/themes/default/game-ui.xml
558 %endif
559
560 %if %{with mythdvd}
561 %files -n mythdvd -f mythdvd.lang
562 %defattr(644,root,root,755)
563 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
564 %attr(755,root,root) %{_bindir}/mtd
565 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
566 %{_datadir}/mythtv/dvd_settings.xml
567 %{_datadir}/mythtv/dvdmenu.xml
568 %{_datadir}/mythtv/themes/default/dvd-ui.xml
569 %{_datadir}/mythtv/themes/default/md_*.png
570 %endif
571
572 %if %{with mythnews}
573 %files -n mythnews -f mythnews.lang
574 %defattr(644,root,root,755)
575 %doc mythnews/README mythnews/AUTHORS
576 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
577 %{_datadir}/mythtv/mythnews
578 %{_datadir}/mythtv/themes/default/news-ui.xml
579 # DUPLICATE WITH MYTHFLIX?
580 %{_datadir}/mythtv/themes/default/news-info-bg.png
581 %endif
582
583 %if %{with mythbrowser}
584 %files -n mythbrowser -f mythbrowser.lang
585 %defattr(644,root,root,755)
586 %doc mythbrowser/README mythbrowser/AUTHORS
587 %attr(755,root,root) %{_bindir}/mythbrowser
588 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
589 %{_datadir}/mythtv/themes/default/webpage.png
590 %endif
591
592 %if %{with mythphone}
593 %files -n mythphone -f mythphone.lang
594 %defattr(644,root,root,755)
595 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
596 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
597 %{_datadir}/mythtv/themes/default/phone-ui.xml
598 %{_datadir}/mythtv/themes/default/webcam-ui.xml
599 %{_datadir}/mythtv/themes/default/mp_*.png
600 %{_datadir}/mythtv/themes/default/phone.png
601 %endif
602
603 %if %{with mythweb}
604 %files -n mythweb
605 %defattr(644,root,root,755)
606 %doc mythweb/{README,TODO} mythweb/languages/*.{pl,txt}
607 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
608 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
609 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
610 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
611 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
612 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
613 %{_datadir}/mythweb
614 %dir %attr(771,root,http) /var/cache/mythweb
615 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
616 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
617 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
618 %endif
619
620 %if %{with mythflix}
621 %files -n mythflix -f mythflix.lang
622 %defattr(644,root,root,755)
623 %doc mythflix/{AUTHORS,ChangeLog,README}
624 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
625 %dir %{_datadir}/mythtv/mythflix
626 %{_datadir}/mythtv/mythflix/netflix-rss.xml
627 %dir %{_datadir}/mythtv/mythflix/scripts
628 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
629 %{_datadir}/mythtv/netflix_menu.xml
630 %{_datadir}/mythtv/themes/default/title_netflix.png
631 %{_datadir}/mythtv/themes/default/netflix-ui.xml
632 # DUPLICATE WITH MYTHNEWS?
633 %{_datadir}/mythtv/themes/default/news-info-bg.png
634 %endif
635
636 %if %{with mythcontrols}
637 %files -n mythcontrols -f mythcontrols.lang
638 %defattr(644,root,root,755)
639 %doc mythcontrols/{AUTHORS,README,TODO}
640 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
641 %{_datadir}/mythtv/themes/default/controls-ui.xml
642 %{_datadir}/mythtv/themes/default/kb-button-off.png
643 %{_datadir}/mythtv/themes/default/kb-button-on.png
644 %endif
This page took 0.153944 seconds and 4 git commands to generate.