]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- a little correction to api definition
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_without  mythvideo       # disable building mythgallery plugin
14 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
15 # not present by default in PLD
16 %bcond_with     mythweather     # building mythgallery plugin disabled by default
17                                 # it looks unusable "due to msnbc webpage structure change
18 %bcond_without  mythweb         # disable building mythgallery plugin
19 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
20
21 %if !%{with binary}
22 %undefine       with_mytharchive
23 %undefine       with_mythbrowser
24 %undefine       with_mythmovies
25 %undefine       with_mythdvd
26 %undefine       with_mythnetvision
27 %undefine       with_mythgallery
28 %undefine       with_mythgame
29 %undefine       with_mythmusic
30 %undefine       with_mythnews
31 %undefine       with_mythvideo
32 %undefine       with_mythweather
33 %endif
34
35 %include        /usr/lib/rpm/macros.perl
36
37 #%define fix     24635
38
39 Summary:        Main MythTV plugins
40 Summary(pl.UTF-8):      Główne wtyczki MythTV
41 Name:           mythplugins
42 Version:        0.23.1
43 #Release:       fix%{fix}.1
44 Release:        2
45 License:        GPL v2
46 Group:          Applications/Multimedia
47 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
48 # Source0-md5:  edd9c5f8a9ae0189b1c8951fa8282c4d
49 Source1:        mythweb.conf
50 Source2:        mythweb_lighttpd.conf
51 Source3:        htdigest.sh
52 Source4:        http_servers_conf_tips.txt
53 #Patch0: %{name}-lib64.patch
54 #Patch1: %{name}-paths.patch
55 Patch2:         mythweb-chdir.patch
56 Patch3:         %{name}-compile_fixes_for_qt_4_7.patch
57 Patch20:        %{name}-mytharchive-INT64.patch
58 #Patch21:       mythmusic_fftw3.patch
59 #Patch100:      mythtv-branch.diff
60 URL:            http://www.mythtv.org/
61 %if %{with binary}
62 %if %{with mythgallery} || %{with myhtmusic}
63 BuildRequires:  OpenGL-devel
64 %endif
65 BuildRequires:  Qt3Support-devel
66 BuildRequires:  QtCore-devel
67 BuildRequires:  QtGui-devel
68 BuildRequires:  QtNetwork-devel
69 BuildRequires:  QtOpenGL-devel
70 BuildRequires:  QtSql-devel
71 BuildRequires:  QtWebKit-devel
72 BuildRequires:  QtXml-devel
73 BuildRequires:  SDL-devel
74 BuildRequires:  a52dec-libs-devel
75 BuildRequires:  cdparanoia-III-devel
76 BuildRequires:  faad2-devel >= 2.0-5.2
77 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
78 BuildRequires:  flac-devel >= 1.0.4
79 BuildRequires:  freetype-devel
80 BuildRequires:  libcdaudio-devel >= 0.99.12p2
81 BuildRequires:  libdvdcss-devel >= 1.2.7
82 BuildRequires:  libdvdread-devel >= 0.9.4
83 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
84 BuildRequires:  libfame-devel >= 0.9.0
85 BuildRequires:  libid3tag-devel
86 BuildRequires:  libmad-devel
87 BuildRequires:  libmyth-devel > 0.21
88 BuildRequires:  libstdc++-devel
89 BuildRequires:  libtiff-devel
90 BuildRequires:  libvorbis-devel >= 1:1.0
91 BuildRequires:  mjpegtools-devel >= 1.6.1
92 BuildRequires:  nasm
93 BuildRequires:  patchutils
94 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
95 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
96 %{?with_mythweather:BuildRequires:      perl-Image-Size}
97 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
98 BuildRequires:  qt4-build
99 BuildRequires:  qt4-qmake
100 BuildRequires:  rpm-perlprov >= 4.1-13
101 BuildRequires:  sed >= 4.0
102 %{?with_mythmusic:BuildRequires:        taglib-devel}
103 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
104 BuildRequires:  xorg-lib-libX11-devel
105 BuildRequires:  xvid-devel >= 1:0.9.1
106 BuildRequires:  zlib-devel
107 %endif
108 %{?with_mytharchive:Requires:   mytharchive}
109 %{?with_mythbrowser:Requires:   mythbrowser}
110 %{?with_mythdvd:Requires:       mythdvd}
111 %{?with_mythnetvision:Requires: mythnetvision}
112 %{?with_mythgallery:Requires:   mythgallery}
113 %{?with_mythgame:Requires:      mythgame}
114 %{?with_mythmysic:Requires:     mythmusic}
115 %{?with_mythnews:Requires:      mythnews}
116 %{?with_mythvideo:Requires:     mythvideo}
117 %{?with_mythweather:Requires:   mythweather}
118 %{?with_mythweb:Requires:       mythweb}
119 ExclusiveArch:  %{ix86} %{x8664} ppc
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
123 %define         _webapps        /etc/webapps
124 %define         _webapp         mythweb
125
126 %description
127 This is a consolidation of all the official MythTV plugins that used
128 to be distributed as separate downloads from mythtv.org.
129
130 %description -l pl.UTF-8
131 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
132 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
133
134 %package -n mytharchive
135 Summary:        A MythTV module to create and burn DVDs
136 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
137 Group:          Applications/Multimedia
138 Requires:       dvdauthor
139 Requires:       mjpegtools
140 Requires:       mythtv-frontend-api = %{myth_api_version}
141 Requires:       python-MySQLdb
142 Requires:       python-PIL
143 Suggests:       dvdrtools-mkisofs
144
145 %description -n mytharchive
146 MythArchive is a MythTV style plugin that uses the Mythburn Script to
147 create and burn DVDs from MythTV recordings, MythVideo files or any
148 video files available on a MythTV system. It can also export
149 recordings to a native archive format that can then be imported back
150 into a MythTV system restoring all the associated metadata.
151
152 %description -n mytharchive -l pl.UTF-8
153 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
154 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
155 innych plików z filmami dostępnych w systemie MythTV. Może także
156 eksportować nagrania do natywnego formatu archiwum, który potem można
157 zaimportować z powrotem do systemu MythTV przywracając wszystkie
158 związane z nimi metadane.
159
160 %package -n mythmusic
161 Summary:        The music player add-on module for MythTV
162 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
163 Group:          Applications/Multimedia
164 BuildRequires:  libvisual-devel
165 Requires:       mythtv-frontend-api = %{myth_api_version}
166
167 %description -n mythmusic
168 Music add-on for MythTV. Support playlists, visualisations, tag editing
169 and plays many popular audio file formats - mp3, flac, wav, ogg etc.
170
171 %description -n mythmusic -l pl.UTF-8
172 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania, wizualizacje,
173 edycję tagów.
174 Potrafi odtwarzać wiele popularnych formatów audio - mp3, flac, wav, ogg
175 itd.
176
177 %package -n mythvideo
178 Summary:        A generic video player frontend module for MythTV
179 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
180 Group:          Applications/Multimedia
181 Requires:       mplayer
182 Requires:       mythtv-frontend-api = %{myth_api_version}
183
184 %description -n mythvideo
185 A generic video and dvd player frontend module for MythTV.
186
187 %description -n mythvideo -l pl.UTF-8
188 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
189
190 %package -n mythweather
191 Summary:        A MythTV module that displays a weather forcast
192 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
193 Group:          Applications/Multimedia
194 Requires:       mythtv-frontend-api = %{myth_api_version}
195
196 %description -n mythweather
197 A MythTV module that displays a weather forcast.
198
199 %description -n mythweather -l pl.UTF-8
200 Moduł MythTV wyświetlający prognozę pogody.
201
202 %package -n mythgallery
203 Summary:        A gallery/slideshow module for MythTV
204 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
205 Group:          Applications/Multimedia
206 Requires:       mythtv-frontend-api = %{myth_api_version}
207
208 %description -n mythgallery
209 A gallery/slideshow module for MythTV.
210
211 %description -n mythgallery -l pl.UTF-8
212 Moduł galerii/pokazu slajdów dla MythTV.
213
214 %package -n mythgame
215 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
216 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
217 Group:          Applications/Multimedia
218 Requires:       mythtv-frontend-api = %{myth_api_version}
219
220 %description -n mythgame
221 A game frontend (xmame, nes, snes, pc) for MythTV.
222
223 %description -n mythgame -l pl.UTF-8
224 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
225
226 %package -n mythdvd
227 Summary:        A DVD ripper module for MythTV
228 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
229 Group:          Applications/Multimedia
230 Requires:       mythtv-frontend-api = %{myth_api_version}
231 Requires:       mythvideo
232 Requires:       transcode >= 0.6.8
233
234 %description -n mythdvd
235 MythDVD is a MythTV module that allows you to rip DVD's and transcode
236 their video and audio content to other (generally smaller) formats.
237 The playing features are simply myth-style wrappers for your favourite
238 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
239 based on and derived from the excellent transcode package.
240
241 %description -n mythdvd -l pl.UTF-8
242 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
243 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
244 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
245 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
246 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
247 pakietu transcode.
248
249 %package -n mythnews
250 Summary:        A RSS News Feed plugin for MythTV
251 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
252 Group:          Applications/Multimedia
253 Requires:       mythtv-frontend-api = %{myth_api_version}
254
255 %description -n mythnews
256 A RSS News Feed plugin for MythTV.
257
258 %description -n mythnews -l pl.UTF-8
259 Wtyczka czytnika nowinek RSS dla MythTV.
260
261 %package -n mythbrowser
262 Summary:        A small web browser module for MythTV
263 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
264 Group:          Applications/Multimedia
265 Requires:       mythtv-frontend-api = %{myth_api_version}
266
267 %description -n mythbrowser
268 MythBrowser is a full fledged web-browser (multiple tabs) to display
269 webpages in full-screen mode. Simple page navigation is possible.
270 Starting with version 0.13 it also has full support for mouse driven
271 navigation (right mouse opens and closes the popup menu).
272
273 MythBrowser also contains a BookmarkManager to manage the website
274 links in a simple mythplugin.
275
276 %description -n mythbrowser -l pl.UTF-8
277 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
278 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
279 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
280 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
281 menu).
282
283 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
284 do stron w prostej wtyczce myth.
285
286 %package -n mythweb
287 Summary:        The web interface to MythTV
288 Summary(pl.UTF-8):      Interfejs WWW do MythTV
289 Group:          Applications/Multimedia
290 Requires:       php(mysql)
291 Requires:       php(posix)
292 Requires:       webapps
293 Requires:       webserver(php) >= 4.3
294 #Suggests:      apache(mod_auth)
295 #Suggests:      apache(mod_env)
296
297 %description -n mythweb
298 The web interface to MythTV.
299
300 %description -n mythweb -l pl.UTF-8
301 Interfejs WWW do MythTV.
302
303 %package -n mythnetvision
304 Summary:        Mythtv extension to watch network movie shows
305 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
306 Group:          Applications/Multimedia
307 Requires:       mythtv-frontend-api = %{myth_api_version}
308 Requires:       mythbrowser
309
310 %description -n mythnetvision
311 Mythtv extension to watch network movie shows (ex. YouTube).
312
313 %description -n mythnetvision -l pl.UTF-8
314 Dodatek do MythTV do oglądania sieciowych transmisji.
315 Na przykład z YouTube.
316
317 %package -n mythmovies
318 Summary:        MythTV cinemas timetable
319 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
320 Group:          Applications/Multimedia
321 Requires:       mythtv-frontend-api = %{myth_api_version}
322
323 %description -n mythmovies
324 MythTV cinemas timetable.
325
326
327 %description -n mythmovies -l pl.UTF-8
328 Moduł MythTV do repertuaru kinowego.
329
330 %package -n mythzoneminder
331 Summary:        MythTV security TV manager
332 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
333 Group:          Applications/Multimedia
334 Requires:       mythtv-frontend-api = %{myth_api_version}
335
336 %description -n mythzoneminder
337 MythTV security TV manager.
338
339
340 %description -n mythzoneminder -l pl.UTF-8
341 Obsługa kamer przemysłowych dla MythTV.
342
343 %prep
344 %setup -q -n %{name}-%{version}
345 #%if %{_lib} != "lib"
346 #%patch0 -p1
347 #%endif
348 #%patch1 -p1
349 %patch2 -p1
350 %patch3 -p1
351 %patch20 -p1
352 #%patch21 -p1
353 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
354
355 # make it visible
356 #mv mythweb/data/{.,}htaccess
357
358 # lib64 fix - enable to update patch
359 %if %{_lib} != "lib" && 0
360 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
361 xargs grep -l /lib/ . | xargs sed -i -e '
362         s,/usr/lib/,/%{_lib}/,g
363         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
364 '
365 exit 1
366 %endif
367
368 %build
369 %if %{with binary}
370 export QTDIR="%{_prefix}"
371 # Not gnu configure
372 %configure \
373         --libdir-name=`basename %{_lib}` \
374         --enable-all \
375         %{!?with_mytharchive:--disable-mytharchive} \
376         %{!?with_mythbrowser:--disable-mythbrowser} \
377         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
378         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
379         %{!?with_mythgame:--disable-mythgame} \
380         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
381         %{!?with_mythnews:--disable-mythnews} \
382         %{!?with_mythvideo:--disable-mythvideo} \
383         %{!?with_mythweather:--disable-mythweather} \
384         %{!?with_mythweb:--disable-mythweb} \
385         %{!?with_mythmovies:--disable-mythmovies} \
386         %{!?with_mythnetvision:--disable-mythnetvision} \
387
388 mv mythconfig.mak mythconfig.mak.old
389 cp mythconfig.mak.old mythconfig.mak
390 cat <<'EOF'>> mythconfig.mak
391 QMAKE_CXX=%{__cxx}
392 QMAKE_CC=%{__cc}
393 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
394 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
395 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
396 EOF
397
398 %{__make}
399 %endif
400
401 %install
402 rm -rf $RPM_BUILD_ROOT
403 %if %{with binary}
404 export QTDIR="%{_prefix}"
405 %{__make} install \
406         INSTALL_ROOT=$RPM_BUILD_ROOT
407
408 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
409 %if %{with mythgame}
410 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
411 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
412 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
413 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
414 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
415 %endif
416 %endif
417
418 %if %{with mythweb}
419 cd mythweb
420 cp -a %{SOURCE3} ./
421 cp -a %{SOURCE4} ./
422 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
423 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
424 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
425 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
426 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
427 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
428 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
429 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
430 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
431 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
432 cd -
433 %endif
434
435 rm -f $RPM_BUILD_ROOT%{_datadir}/data
436 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
437 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
438         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
439                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
440         done > $p.lang
441 done
442
443 %clean
444 rm -rf $RPM_BUILD_ROOT
445
446 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
447 %webapp_register apache %{_webapp}
448
449 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
450 %webapp_unregister apache %{_webapp}
451
452 %triggerin -n mythweb -- apache < 2.2.0, apache-base
453 %webapp_register httpd %{_webapp}
454
455 %triggerin -n mythweb -- lighttpd
456 %webapp_register lighttpd %{_webapp}
457
458 %triggerun -n mythweb -- apache < 2.2.0, apache-base
459 %webapp_unregister httpd %{_webapp}
460
461 %triggerun -n mythweb -- lighttpd
462 %webapp_unregister lighttpd %{_webapp}
463
464 %triggerpostun -n mythweb -- mythweb < 0.19
465 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
466         if [ -f /etc/mythweb/$i.rpmsave ]; then
467                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
468                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
469         fi
470 done
471 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
472
473 # migrate from apache-config macros
474 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
475         if [ -d /etc/apache/webapps.d ]; then
476                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
477                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
478         fi
479
480         if [ -d /etc/httpd/webapps.d ]; then
481                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
482                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
483         fi
484         rm -f /etc/mythweb/apache.conf.rpmsave
485 fi
486
487 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
488         rm -f /etc/apache/conf.d/99_mythplugins.conf
489         /usr/sbin/webapp register apache %{_webapp}
490         %service -q apache reload
491 fi
492 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
493         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
494         /usr/sbin/webapp register httpd %{_webapp}
495         %service -q httpd reload
496 fi
497
498 %post -n mythweb
499 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
500 which packages you can need to run mythweb and how to set it quickly."
501
502 %files
503 %defattr(644,root,root,755)
504
505 %if %{with mytharchive}
506 %files -n mytharchive -f mytharchive.lang
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/mytharchivehelper
509 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
510 %{_datadir}/mythtv/archivemenu.xml
511 %{_datadir}/mythtv/archiveutils.xml
512 %{_datadir}/mythtv/themes/default/ma_*.png
513 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
514 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
515 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
516 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
517 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
518 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
519 %{_datadir}/mythtv/mytharchive
520 %endif
521
522 %if %{with mythmusic}
523 %files -n mythmusic -f mythmusic.lang
524 %defattr(644,root,root,755)
525 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
526 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
527 /var/lib/mythmusic
528 %{_datadir}/mythtv/musicmenu.xml
529 %{_datadir}/mythtv/music_settings.xml
530 %{_datadir}/mythtv/themes/default/music-ui.xml
531 %{_datadir}/mythtv/themes/default/mm-titlelines.png
532 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
533 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
534 %{_datadir}/mythtv/themes/default/ff_button_off.png
535 %{_datadir}/mythtv/themes/default/ff_button_on.png
536 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
537 %{_datadir}/mythtv/themes/default/miniplayer_background.png
538 %{_datadir}/mythtv/themes/default/mm_*.png
539 %{_datadir}/mythtv/themes/default/music-sel-bg.png
540 %{_datadir}/mythtv/themes/default/next_button_off.png
541 %{_datadir}/mythtv/themes/default/next_button_on.png
542 %{_datadir}/mythtv/themes/default/next_button_pushed.png
543 %{_datadir}/mythtv/themes/default/pause_button_off.png
544 %{_datadir}/mythtv/themes/default/pause_button_on.png
545 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
546 %{_datadir}/mythtv/themes/default/play_button_off.png
547 %{_datadir}/mythtv/themes/default/play_button_on.png
548 %{_datadir}/mythtv/themes/default/play_button_pushed.png
549 %{_datadir}/mythtv/themes/default/prev_button_off.png
550 %{_datadir}/mythtv/themes/default/prev_button_on.png
551 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
552 %{_datadir}/mythtv/themes/default/rew_button_off.png
553 %{_datadir}/mythtv/themes/default/rew_button_on.png
554 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
555 %{_datadir}/mythtv/themes/default/selectionbar.png
556 %{_datadir}/mythtv/themes/default/stop_button_off.png
557 %{_datadir}/mythtv/themes/default/stop_button_on.png
558 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
559 %{_datadir}/mythtv/themes/default/track_info_background.png
560 %{_datadir}/mythtv/themes/default-wide/mm_*.png
561 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
562 %endif
563
564 %if %{with mythvideo}
565 %files -n mythvideo -f mythvideo.lang
566 %defattr(644,root,root,755)
567 %doc mythvideo/README mythvideo/videodb
568 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
569 %{_datadir}/mythtv/themes/default/video-ui.xml
570 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
571 %{_datadir}/mythtv/themes/default/mv_*.png
572 %{_datadir}/mythtv/themes/default-wide/mv_*.png
573 %{_datadir}/mythtv/video_settings.xml
574 %{_datadir}/mythtv/videomenu.xml
575 %dir %{_datadir}/mythtv/mythvideo
576 %dir %{_datadir}/mythtv/mythvideo/scripts
577 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
578 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
579 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
580 %{_datadir}/mythtv/mythvideo/scripts/README
581 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
582 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
583 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
584 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
585 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
586 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
587 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Television/*
588 /var/lib/mythvideo
589 %endif
590
591 %if %{with mythweather}
592 %files -n mythweather -f mythweather.lang
593 %defattr(644,root,root,755)
594 %doc mythweather/README
595 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
596 %{_datadir}/mythtv/mythweather
597 %{_datadir}/mythtv/weather_settings.xml
598 %{_datadir}/mythtv/themes/default/weather-ui.xml
599 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
600 %{_datadir}/mythtv/themes/default/cloudy.png
601 %{_datadir}/mythtv/themes/default/fair.png
602 %{_datadir}/mythtv/themes/default/flurries.png
603 %{_datadir}/mythtv/themes/default/fog.png
604 %{_datadir}/mythtv/themes/default/logo.png
605 %{_datadir}/mythtv/themes/default/lshowers.png
606 %{_datadir}/mythtv/themes/default/mcloudy.png
607 %{_datadir}/mythtv/themes/default/mw_*.png
608 %{_datadir}/mythtv/themes/default/mwmain.png
609 %{_datadir}/mythtv/themes/default/pcloudy.png
610 %{_datadir}/mythtv/themes/default/rainsnow.png
611 %{_datadir}/mythtv/themes/default/showers.png
612 %{_datadir}/mythtv/themes/default/snowshow.png
613 %{_datadir}/mythtv/themes/default/sunny.png
614 %{_datadir}/mythtv/themes/default/thunshowers.png
615 %{_datadir}/mythtv/themes/default/unknown.png
616 %{_datadir}/mythtv/themes/default-wide/mw-*.png
617 %endif
618
619 %if %{with mythgallery}
620 %files -n mythgallery -f mythgallery.lang
621 %defattr(644,root,root,755)
622 %doc mythgallery/README
623 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
624 %{_datadir}/mythtv/themes/default/gallery-ui.xml
625 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
626 %{_datadir}/mythtv/themes/default/gallery-*.png
627 # FIXME: this is definately stupid path
628 /var/lib/pictures
629 %endif
630
631 %if %{with mythgame}
632 %files -n mythgame -f mythgame.lang
633 %defattr(644,root,root,755)
634 #%doc mythgame/README
635 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
636 %{_datadir}/mythtv/games
637 %{_datadir}/mythtv/game_settings.xml
638 %{_datadir}/mythtv/themes/default/game-ui.xml
639 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
640 %endif
641
642 %if %{with mythdvd}
643 %files -n mythdvd
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_bindir}/mtd
646 %{_datadir}/mythtv/themes/default/dvd-ui.xml
647 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
648 %{_datadir}/mythtv/themes/default/md_*.png
649 %endif
650
651 %if %{with mythnews}
652 %files -n mythnews -f mythnews.lang
653 %defattr(644,root,root,755)
654 %doc mythnews/README mythnews/AUTHORS
655 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
656 %{_datadir}/mythtv/mythnews
657 %{_datadir}/mythtv/themes/default/news-ui.xml
658 # DUPLICATE WITH MYTHFLIX?
659 %{_datadir}/mythtv/themes/default/news-info-bg.png
660 %{_datadir}/mythtv/themes/default/enclosures.png
661 %{_datadir}/mythtv/themes/default/need-download.png
662 %{_datadir}/mythtv/themes/default/podcast.png
663 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
664 %endif
665
666 %if %{with mythbrowser}
667 %files -n mythbrowser -f mythbrowser.lang
668 %defattr(644,root,root,755)
669 %doc mythbrowser/README mythbrowser/AUTHORS
670 #%attr(755,root,root) %{_bindir}/mythbrowser
671 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
672 %{_datadir}/mythtv/themes/default/mb_progress*.png
673 %{_datadir}/mythtv/themes/default/browser-ui.xml
674 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
675 %endif
676
677 %if %{with mythweb}
678 %files -n mythweb
679 %defattr(644,root,root,755)
680 %doc mythweb/README mythweb/mythweb.conf.lighttpd
681 %doc mythweb/htdigest.sh
682 %doc mythweb/http_servers_conf_tips.txt
683 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
684 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
685 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
686 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
687 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
688 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
689 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
690 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
691 %{_datadir}/mythweb
692 %dir %attr(771,root,http) /var/cache/mythweb
693 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
694 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
695 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
696 %endif
697
698 %if %{with mythnetvision}
699 %files -n mythnetvision -f mythnetvision.lang
700 %defattr(644,root,root,755)
701 %doc mythnetvision/{AUTHORS,ChangeLog,README}
702 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
703 %dir %{_datadir}/mythtv/mythnetvision
704 %{_datadir}/mythtv/netvisionmenu.xml
705 %dir %{_datadir}/mythtv/mythnetvision/scripts
706 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
707 %dir %{_datadir}/mythtv/mythnetvision/icons
708 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
709 %{_datadir}/mythtv/mythnetvision/icons/*.png
710 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
711 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
712 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
713 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
714 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
715 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
716 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
717 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
718 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
719 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
720 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml   
721 %{_datadir}/mythtv/themes/default/netvision-ui.xml
722 %endif
723
724 %if %{with mythmovies}
725 %files -n mythmovies
726 %defattr(644,root,root,755)
727 #-f mythmovies.lang
728 %defattr(644,root,root,755)
729 %doc mythmovies/{README,TODO}
730 %attr(755,root,root) %{_bindir}/ignyte
731 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
732 %{_datadir}/mythtv/themes/default/movies-ui.xml
733 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
734 %{_datadir}/mythtv/i18n/mythmovies_*.qm
735 %endif
736
737 %if %{with mythzoneminder}
738 %files -n mythzoneminder
739 %defattr(644,root,root,755)
740 #-f mythmovies.lang
741 %defattr(644,root,root,755)
742 %doc mythzoneminder/{AUTHORS,README}
743 %attr(755,root,root) %{_bindir}/mythzmserver
744 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
745 %dir %{_datadir}/mythtv/zonemindermenu.xml
746 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
747 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
748 %{_datadir}/mythtv/themes/default/mz_*png
749 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
750 %endif
This page took 0.212636 seconds and 4 git commands to generate.