]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- 0.20.2, builds
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythcontrols    # disable mythcontrols plugin
7 %bcond_without  mythdvd         # disable building mythgallery plugin
8 %bcond_without  mythflix        # disable building mythflix plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_without  mythphone       # disable building mythgallery plugin
14 %bcond_without  mythvideo       # disable building mythgallery plugin
15 %bcond_without  mythweather     # disable building mythgallery plugin
16 %bcond_without  mythweb         # disable building mythgallery plugin
17 #
18 %if !%{with binary}
19 %undefine       with_mytharchive
20 %undefine       with_mythbrowser
21 %undefine       with_mythcontrols
22 %undefine       with_mythdvd
23 %undefine       with_mythflix
24 %undefine       with_mythgallery
25 %undefine       with_mythgame
26 %undefine       with_mythmusic
27 %undefine       with_mythnews
28 %undefine       with_mythphone
29 %undefine       with_mythvideo
30 %undefine       with_mythweather
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34
35 #define _snap 20060905
36 #define _rev 11046
37 %define _rel 0.1
38 Summary:        Main MythTV plugins
39 Summary(pl.UTF-8):      Główne wtyczki MythTV
40 Name:           mythplugins
41 Version:        0.20.2
42 Release:        %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
43 License:        GPL v2
44 Group:          Applications/Multimedia
45 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
46 # Source0-md5:  53fcf62c3d2bac31cde610621a08ef33
47 #Source0:       %{name}-%{_snap}.%{_rev}.tar.bz2
48 Source1:        mythweb.conf
49 Patch0:         %{name}-lib64.patch
50 Patch1:         %{name}-paths.patch
51 Patch2:         mythweb-config.patch
52 Patch100:       mythtv-branch.diff
53 URL:            http://www.mythtv.org/
54 %if %{with binary}
55 %if %{with mythgallery} || %{with myhtmusic}
56 BuildRequires:  OpenGL-devel
57 %endif
58 BuildRequires:  SDL-devel
59 BuildRequires:  XFree86-devel
60 BuildRequires:  a52dec-libs-devel
61 BuildRequires:  cdparanoia-III-devel
62 BuildRequires:  faad2-devel >= 2.0-5.2
63 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
64 BuildRequires:  flac-devel >= 1.0.4
65 BuildRequires:  freetype-devel
66 BuildRequires:  kdelibs-devel
67 BuildRequires:  libcdaudio-devel >= 0.99.12p2
68 BuildRequires:  libdvdcss-devel >= 1.2.7
69 BuildRequires:  libdvdread-devel >= 0.9.4
70 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
71 BuildRequires:  libfame-devel >= 0.9.0
72 BuildRequires:  libid3tag-devel
73 BuildRequires:  libmad-devel
74 BuildRequires:  libmyth-devel >= 0.19
75 BuildRequires:  libstdc++-devel
76 BuildRequires:  libtiff-devel
77 BuildRequires:  libvorbis-devel >= 1:1.0
78 BuildRequires:  mjpegtools-devel >= 1.6.1
79 BuildRequires:  nasm
80 BuildRequires:  patchutils
81 BuildRequires:  rpm-perlprov >= 4.1-13
82 BuildRequires:  sed >= 4.0
83 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
84 BuildRequires:  xvid-devel >= 1:0.9.1
85 BuildRequires:  zlib-devel
86 %endif
87 %{?with_mytharchive:Requires:   mytharchive}
88 %{?with_mythbrowser:Requires:   mythbrowser}
89 %{?with_mythdvd:Requires:       mythdvd}
90 %{?with_mythflix:Requires:      mythflix}
91 %{?with_mythgallery:Requires:   mythgallery}
92 %{?with_mythgame:Requires:      mythgame}
93 %{?with_mythmysic:Requires:     mythmusic}
94 %{?with_mythnews:Requires:      mythnews}
95 %{?with_mythphone:Requires:     mythphone}
96 %{?with_mythvideo:Requires:     mythvideo}
97 %{?with_mythweather:Requires:   mythweather}
98 %{?with_mythweb:Requires:       mythweb}
99 ExclusiveArch:  %{ix86} %{x8664} ppc
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
103 %define         _webapps        /etc/webapps
104 %define         _webapp         mythweb
105
106 %description
107 This is a consolidation of all the official MythTV plugins that used
108 to be distributed as separate downloads from mythtv.org.
109
110 %description -l pl.UTF-8
111 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
112 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
113
114 %package -n mytharchive
115 Summary:        A MythTV module to create and burn DVDs
116 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
117 Group:          Applications/Multimedia
118 Requires:       mythtv-frontend-api = %{myth_api_version}
119
120 %description -n mytharchive
121 MythArchive is a MythTV style plugin that uses the Mythburn Script to
122 create and burn DVDs from MythTV recordings, MythVideo files or any
123 video files available on a MythTV system. It can also export
124 recordings to a native archive format that can then be imported back
125 into a MythTV system restoring all the associated metadata.
126
127 %description -n mytharchive -l pl.UTF-8
128 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
129 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
130 innych plików z filmami dostępnych w systemie MythTV. Może także
131 eksportować nagrania do natywnego formatu archiwum, który potem można
132 zaimportować z powrotem do systemu MythTV przywracając wszystkie
133 związane z nimi metadane.
134
135 %package -n mythmusic
136 Summary:        The music player add-on module for MythTV
137 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
138 Group:          Applications/Multimedia
139 Requires:       mythtv-frontend-api = %{myth_api_version}
140
141 %description -n mythmusic
142 Music add-on for MythTV.
143
144 %description -n mythmusic -l pl.UTF-8
145 Odtwarzacz muzyki dla MythTV.
146
147 %package -n mythvideo
148 Summary:        A generic video player frontend module for MythTV
149 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
150 Group:          Applications/Multimedia
151 Requires:       mplayer
152 Requires:       mythtv-frontend-api = %{myth_api_version}
153
154 %description -n mythvideo
155 A generic video player frontend module for MythTV.
156
157 %description -n mythvideo -l pl.UTF-8
158 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
159
160 %package -n mythweather
161 Summary:        A MythTV module that displays a weather forcast
162 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
163 Group:          Applications/Multimedia
164 Requires:       mythtv-frontend-api = %{myth_api_version}
165
166 %description -n mythweather
167 A MythTV module that displays a weather forcast.
168
169 %description -n mythweather -l pl.UTF-8
170 Moduł MythTV wyświetlający prognozę pogody.
171
172 %package -n mythgallery
173 Summary:        A gallery/slideshow module for MythTV
174 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
175 Group:          Applications/Multimedia
176 Requires:       mythtv-frontend-api = %{myth_api_version}
177
178 %description -n mythgallery
179 A gallery/slideshow module for MythTV.
180
181 %description -n mythgallery -l pl.UTF-8
182 Moduł galerii/pokazu slajdów dla MythTV.
183
184 %package -n mythgame
185 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
186 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
187 Group:          Applications/Multimedia
188 Requires:       mythtv-frontend-api = %{myth_api_version}
189
190 %description -n mythgame
191 A game frontend (xmame, nes, snes, pc) for MythTV.
192
193 %description -n mythgame -l pl.UTF-8
194 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
195
196 %package -n mythdvd
197 Summary:        A DVD player module for MythTV
198 Summary(pl.UTF-8):      Moduł odtwarzacza DVD dla MythTV
199 Group:          Applications/Multimedia
200 Requires:       mythtv-frontend-api = %{myth_api_version}
201 Requires:       transcode >= 0.6.8
202
203 %description -n mythdvd
204 MythDVD is a MythTV module that allows you to play DVDs on a myth-box
205 and (optionally) rip DVD's and transcode their video and audio content
206 to other (generally smaller) formats. The playing features are simply
207 myth-style wrappers for your favourite DVD playing software (mplayer,
208 ogle, xine, etc). The transcoding is based on and derived from the
209 excellent transcode package.
210
211 %description -n mythdvd -l pl.UTF-8
212 MythDVD to moduł MythTV umożliwiający odtwarzanie płyt DVD w MythTV i
213 (opcjonalnie) rippowanie ich oraz przekodowywanie obrazu i dźwięku do
214 innych (zwykle mniej zajmujących) formatów. Możliwości odtwarzania to
215 po prostu obudowanie w stylu myth dla ulubionego oprogramowania do
216 odtwarzania DVD (mplayer, ogle, xine itp.). Przekodowywanie jest
217 oparte i wywodzi się z wspaniałego pakietu transcode.
218
219 %package -n mythnews
220 Summary:        A RSS News Feed plugin for MythTV
221 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
222 Group:          Applications/Multimedia
223 Requires:       mythtv-frontend-api = %{myth_api_version}
224
225 %description -n mythnews
226 A RSS News Feed plugin for MythTV.
227
228 %description -n mythnews -l pl.UTF-8
229 Wtyczka czytnika nowinek RSS dla MythTV.
230
231 %package -n mythbrowser
232 Summary:        A small web browser module for MythTV
233 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
234 Group:          Applications/Multimedia
235 Requires:       mythtv-frontend-api = %{myth_api_version}
236
237 %description -n mythbrowser
238 MythBrowser is a full fledged web-browser (multiple tabs) to display
239 webpages in full-screen mode. Simple page navigation is possible.
240 Starting with version 0.13 it also has full support for mouse driven
241 navigation (right mouse opens and closes the popup menu).
242
243 MythBrowser also contains a BookmarkManager to manage the website
244 links in a simple mythplugin.
245
246 %description -n mythbrowser -l pl.UTF-8
247 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
248 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
249 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
250 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
251 menu).
252
253 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
254 do stron w prostej wtyczce myth.
255
256 %package -n mythphone
257 Summary:        A video conferencing module for MythTV
258 Summary(pl.UTF-8):      Moduł wideokonferencji dla MythTV
259 Group:          Applications/Multimedia
260 Requires:       mythtv-frontend-api = %{myth_api_version}
261
262 %description -n mythphone
263 Mythphone is a phone and videophone capability on Myth using the
264 standard SIP protocol. It is compatible with Microsoft XP Messenger
265 and with SIP Service Providers such as Free World Dialup
266 (fwd.pulver.com).
267
268 %description -n mythphone -l pl.UTF-8
269 Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
270 standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
271 Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
272 (fwd.pulver.com).
273
274 %package -n mythweb
275 Summary:        The web interface to MythTV
276 Summary(pl.UTF-8):      Interfejs WWW do MythTV
277 Group:          Applications/Multimedia
278 Requires:       webapps
279 #Suggests:      apache(mod_auth)
280 #Suggests:      apache(mod_env)
281 Requires:       php(mysql)
282 Requires:       php(posix)
283 Requires:       webserver(php) >= 4.3
284
285 %description -n mythweb
286 The web interface to MythTV.
287
288 %description -n mythweb -l pl.UTF-8
289 Interfejs WWW do MythTV.
290
291 %package -n mythflix
292 Summary:        MythFlix (A NetFlix MythTV)
293 Summary(pl.UTF-8):      MythFlix (NetFlix MythTV)
294 Group:          Applications/Multimedia
295 Requires:       mythtv-frontend-api = %{myth_api_version}
296
297 %description -n mythflix
298 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
299 It currently supports the ability to view your queue and add movies to
300 your queue. The browse feature is based on the Netflix RSS feeds. This
301 plugin is not very mature, which means things might not work right
302 and/or it might break other things.
303
304 %description -n mythflix -l pl.UTF-8
305 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
306 Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
307 Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
308 jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
309 innego.
310
311 %package -n mythcontrols
312 Summary:        MythTV keybindings editor
313 Summary(pl.UTF-8):      Edytor przypisań klawiszy MythTV
314 Group:          Applications/Multimedia
315 Requires:       mythtv-frontend-api = %{myth_api_version}
316
317 %description -n mythcontrols
318 This plugin allows you to configure your keybindings on the frontend
319 without having to use mythweb or edit tables by hand.
320
321 %description -n mythcontrols -l pl.UTF-8
322 Ta wtyczka pozwala konfigurować przypisania klawiszy we frontendzie
323 bez konieczności używania mythweba ani ręcznego modyfikowania tabel.
324
325 %prep
326 %setup -q %{?_snap:-n %{name}}
327 %if %{_lib} != "lib"
328 #%patch0 -p1
329 %endif
330 %patch1 -p1
331 %patch2 -p1
332 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
333
334 # make it visible
335 mv mythweb/{.,}htaccess
336
337 # lib64 fix - enable to update patch
338 %if %{_lib} != "lib" && 0
339 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
340 xargs grep -l /lib/ . | xargs sed -i -e '
341         s,/usr/lib/,/usr/%{_lib}/,g
342         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
343 '
344 exit 1
345 %endif
346
347 %build
348 %if %{with binary}
349 export QTDIR="%{_prefix}"
350 # Not gnu configure
351 %configure \
352         --libdir-name=%{_lib} \
353         --enable-all \
354         %{!?with_mytharchive:--disable-mytharchive} \
355         %{!?with_mythbrowser:--disable-mythbrowser} \
356         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
357         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
358         %{!?with_mythgame:--disable-mythgame} \
359         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
360         %{!?with_mythnews:--disable-mythnews} \
361         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
362         %{!?with_mythvideo:--disable-mythvideo} \
363         %{!?with_mythweather:--disable-mythweather} \
364         %{!?with_mythweb:--disable-mythweb} \
365         %{!?with_mythcontrols:--disable-mythcontrols} \
366         %{!?with_mythflix:--disable-mythflix} \
367
368 mv mythconfig.mak mythconfig.mak.old
369 cp mythconfig.mak.old mythconfig.mak
370 cat <<'EOF'>> mythconfig.mak
371 QMAKE_CXX=%{__cxx}
372 QMAKE_CC=%{__cc}
373 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
374 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
375 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
376 EOF
377
378 %{__make}
379 %endif
380
381 %install
382 rm -rf $RPM_BUILD_ROOT
383
384 %if %{with binary}
385 export QTDIR="%{_prefix}"
386 %{__make} install \
387         INSTALL_ROOT=$RPM_BUILD_ROOT
388
389 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
390 %if %{with mythgame}
391 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
392 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
393 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
394 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
395 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
396 %endif
397 %endif
398
399 %if %{with mythweb}
400 cd mythweb
401 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
402 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
403 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
404 cp -a *.php *.pl data includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
405 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
406 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
407 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
408 cd -
409 %endif
410
411 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
412 rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
413 for p in mytharchive mythbrowser mythcontrols mythdvd mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather; do
414         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
415                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
416         done > $p.lang
417 done
418
419 %clean
420 rm -rf $RPM_BUILD_ROOT
421
422 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
423 %webapp_register apache %{_webapp}
424
425 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
426 %webapp_unregister apache %{_webapp}
427
428 %triggerin -n mythweb -- apache < 2.2.0, apache-base
429 %webapp_register httpd %{_webapp}
430
431 %triggerun -n mythweb -- apache < 2.2.0, apache-base
432 %webapp_unregister httpd %{_webapp}
433
434 %triggerpostun -n mythweb -- mythweb < 0.19
435 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
436         if [ -f /etc/mythweb/$i.rpmsave ]; then
437                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
438                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
439         fi
440 done
441 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
442
443 # migrate from apache-config macros
444 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
445         if [ -d /etc/apache/webapps.d ]; then
446                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
447                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
448         fi
449
450         if [ -d /etc/httpd/webapps.d ]; then
451                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
452                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
453         fi
454         rm -f /etc/mythweb/apache.conf.rpmsave
455 fi
456
457 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
458         rm -f /etc/apache/conf.d/99_mythplugins.conf
459         /usr/sbin/webapp register apache %{_webapp}
460         %service -q apache reload
461 fi
462 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
463         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
464         /usr/sbin/webapp register httpd %{_webapp}
465         %service -q httpd reload
466 fi
467
468 %files
469 %defattr(644,root,root,755)
470
471 %if %{with mytharchive}
472 %files -n mytharchive -f mytharchive.lang
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{_bindir}/mytharchivehelper
475 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
476 %{_datadir}/mythtv/archiveformat.xml
477 %{_datadir}/mythtv/archivemenu.xml
478 %{_datadir}/mythtv/archiveselect.xml
479 %{_datadir}/mythtv/themes/default/ma_*.png
480 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
481 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
482 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
483 %{_datadir}/mythtv/mytharchive
484 %endif
485
486 %if %{with mythmusic}
487 %files -n mythmusic -f mythmusic.lang
488 %defattr(644,root,root,755)
489 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
490 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
491 /var/lib/mythmusic
492 %{_datadir}/mythtv/musicmenu.xml
493 %{_datadir}/mythtv/music_settings.xml
494 %{_datadir}/mythtv/themes/default/music-ui.xml
495 %{_datadir}/mythtv/themes/default/ff_button_off.png
496 %{_datadir}/mythtv/themes/default/ff_button_on.png
497 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
498 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
499 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
500 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
501 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
502 %{_datadir}/mythtv/themes/default/mm_checked.png
503 %{_datadir}/mythtv/themes/default/mm_checked_high.png
504 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
505 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
506 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
507 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
508 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
509 %{_datadir}/mythtv/themes/default/mm_rating.png
510 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
511 %{_datadir}/mythtv/themes/default/mm_unchecked.png
512 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
513 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
514 %{_datadir}/mythtv/themes/default/mm_volume_background.png
515 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
516 %{_datadir}/mythtv/themes/default/mm_waiting.png
517 %{_datadir}/mythtv/themes/default/music-sel-bg.png
518 %{_datadir}/mythtv/themes/default/next_button_off.png
519 %{_datadir}/mythtv/themes/default/next_button_on.png
520 %{_datadir}/mythtv/themes/default/next_button_pushed.png
521 %{_datadir}/mythtv/themes/default/pause_button_off.png
522 %{_datadir}/mythtv/themes/default/pause_button_on.png
523 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
524 %{_datadir}/mythtv/themes/default/play_button_off.png
525 %{_datadir}/mythtv/themes/default/play_button_on.png
526 %{_datadir}/mythtv/themes/default/play_button_pushed.png
527 %{_datadir}/mythtv/themes/default/prev_button_off.png
528 %{_datadir}/mythtv/themes/default/prev_button_on.png
529 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
530 %{_datadir}/mythtv/themes/default/rew_button_off.png
531 %{_datadir}/mythtv/themes/default/rew_button_on.png
532 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
533 %{_datadir}/mythtv/themes/default/selectionbar.png
534 %{_datadir}/mythtv/themes/default/stop_button_off.png
535 %{_datadir}/mythtv/themes/default/stop_button_on.png
536 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
537 %{_datadir}/mythtv/themes/default/text_button_off.png
538 %{_datadir}/mythtv/themes/default/text_button_on.png
539 %{_datadir}/mythtv/themes/default/text_button_pushed.png
540 %{_datadir}/mythtv/themes/default/track_info_background.png
541 %endif
542
543 %if %{with mythvideo}
544 %files -n mythvideo -f mythvideo.lang
545 %defattr(644,root,root,755)
546 %doc mythvideo/README mythvideo/videodb
547 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
548 %{_datadir}/mythtv/themes/default/video-ui.xml
549 %{_datadir}/mythtv/themes/default/mv-*.png
550 %{_datadir}/mythtv/themes/default/mv_*.png
551 %{_datadir}/mythtv/video_settings.xml
552 %{_datadir}/mythtv/videomenu.xml
553 %dir %{_datadir}/mythtv/mythvideo
554 %dir %{_datadir}/mythtv/mythvideo/scripts
555 %{_datadir}/mythtv/mythvideo/scripts/README
556 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
557 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
558 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/ofdb.pl
559 /var/lib/mythvideo
560 %endif
561
562 %if %{with mythweather}
563 %files -n mythweather -f mythweather.lang
564 %defattr(644,root,root,755)
565 %doc mythweather/README
566 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
567 %{_datadir}/mythtv/mythweather
568 %{_datadir}/mythtv/themes/default/weather-ui.xml
569 %{_datadir}/mythtv/themes/default/cloudy.png
570 %{_datadir}/mythtv/themes/default/fair.png
571 %{_datadir}/mythtv/themes/default/flurries.png
572 %{_datadir}/mythtv/themes/default/fog.png
573 %{_datadir}/mythtv/themes/default/logo.png
574 %{_datadir}/mythtv/themes/default/lshowers.png
575 %{_datadir}/mythtv/themes/default/mcloudy.png
576 %{_datadir}/mythtv/themes/default/mw-*.png
577 %{_datadir}/mythtv/themes/default/mwmain.png
578 %{_datadir}/mythtv/themes/default/pcloudy.png
579 %{_datadir}/mythtv/themes/default/rainsnow.png
580 %{_datadir}/mythtv/themes/default/showers.png
581 %{_datadir}/mythtv/themes/default/snowshow.png
582 %{_datadir}/mythtv/themes/default/sunny.png
583 %{_datadir}/mythtv/themes/default/thunshowers.png
584 %{_datadir}/mythtv/themes/default/unknown.png
585 %endif
586
587 %if %{with mythgallery}
588 %files -n mythgallery -f mythgallery.lang
589 %defattr(644,root,root,755)
590 %doc mythgallery/README
591 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
592 %{_datadir}/mythtv/themes/default/gallery-ui.xml
593 %{_datadir}/mythtv/themes/default/gallery-*.png
594 # FIXME: this is definately stupid path
595 /var/lib/pictures
596 %endif
597
598 %if %{with mythgame}
599 %files -n mythgame -f mythgame.lang
600 %defattr(644,root,root,755)
601 %doc mythgame/README
602 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
603 %{_datadir}/mythtv/games
604 %{_datadir}/mythtv/game_settings.xml
605 %{_datadir}/mythtv/themes/default/game-ui.xml
606 %endif
607
608 %if %{with mythdvd}
609 %files -n mythdvd -f mythdvd.lang
610 %defattr(644,root,root,755)
611 %doc mythdvd/README mythdvd/AUTHORS
612 %attr(755,root,root) %{_bindir}/mtd
613 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
614 %{_datadir}/mythtv/dvd_settings.xml
615 %{_datadir}/mythtv/dvdmenu.xml
616 %{_datadir}/mythtv/themes/default/dvd-ui.xml
617 %{_datadir}/mythtv/themes/default/md_*.png
618 %endif
619
620 %if %{with mythnews}
621 %files -n mythnews -f mythnews.lang
622 %defattr(644,root,root,755)
623 %doc mythnews/README mythnews/AUTHORS
624 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
625 %{_datadir}/mythtv/mythnews
626 %{_datadir}/mythtv/themes/default/news-ui.xml
627 # DUPLICATE WITH MYTHFLIX?
628 %{_datadir}/mythtv/themes/default/news-info-bg.png
629 %endif
630
631 %if %{with mythbrowser}
632 %files -n mythbrowser -f mythbrowser.lang
633 %defattr(644,root,root,755)
634 %doc mythbrowser/README mythbrowser/AUTHORS
635 %attr(755,root,root) %{_bindir}/mythbrowser
636 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
637 %{_datadir}/mythtv/themes/default/webpage.png
638 %endif
639
640 %if %{with mythphone}
641 %files -n mythphone -f mythphone.lang
642 %defattr(644,root,root,755)
643 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
644 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
645 %{_datadir}/mythtv/themes/default/phone-ui.xml
646 %{_datadir}/mythtv/themes/default/webcam-ui.xml
647 %{_datadir}/mythtv/themes/default/mp_*.png
648 %{_datadir}/mythtv/themes/default/phone.png
649 %endif
650
651 %if %{with mythweb}
652 %files -n mythweb
653 %defattr(644,root,root,755)
654 %doc mythweb/{README,TODO,htaccess}
655 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
656 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
657 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
658 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
659 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
660 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
661 %{_datadir}/mythweb
662 %dir %attr(771,root,http) /var/cache/mythweb
663 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
664 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
665 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
666 %endif
667
668 %if %{with mythflix}
669 %files -n mythflix -f mythflix.lang
670 %defattr(644,root,root,755)
671 %doc mythflix/{AUTHORS,ChangeLog,README}
672 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
673 %dir %{_datadir}/mythtv/mythflix
674 %{_datadir}/mythtv/mythflix/netflix-rss.xml
675 %dir %{_datadir}/mythtv/mythflix/scripts
676 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
677 %{_datadir}/mythtv/netflix_menu.xml
678 %{_datadir}/mythtv/themes/default/title_netflix.png
679 %{_datadir}/mythtv/themes/default/netflix-ui.xml
680 # DUPLICATE WITH MYTHNEWS?
681 %{_datadir}/mythtv/themes/default/news-info-bg.png
682 %endif
683
684 %if %{with mythcontrols}
685 %files -n mythcontrols -f mythcontrols.lang
686 %defattr(644,root,root,755)
687 %doc mythcontrols/{AUTHORS,README,TODO}
688 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
689 %{_datadir}/mythtv/themes/default/controls-ui.xml
690 %{_datadir}/mythtv/themes/default/kb-button-off.png
691 %{_datadir}/mythtv/themes/default/kb-button-on.png
692 %endif
This page took 0.081391 seconds and 4 git commands to generate.