]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- moved to HEAD
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythflix        # disable building mythflix plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_with     mythphone       # discontnued ??
14 %bcond_without  mythvideo       # disable building mythgallery plugin
15 %bcond_with     mythweather     # building mythgallery plugin disabled by default
16                                 # it looks unusable "due to msnbc webpage structure change
17 %bcond_without  mythweb         # disable building mythgallery plugin
18 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
19
20 %if !%{with binary}
21 %undefine       with_mytharchive
22 %undefine       with_mythbrowser
23 %undefine       with_mythmovies
24 %undefine       with_mythdvd
25 %undefine       with_mythflix
26 %undefine       with_mythgallery
27 %undefine       with_mythgame
28 %undefine       with_mythmusic
29 %undefine       with_mythnews
30 %undefine       with_mythphone
31 %undefine       with_mythvideo
32 %undefine       with_mythweather
33 %endif
34
35 %include        /usr/lib/rpm/macros.perl
36
37 %define snap 20090518
38 #define _rev 11046
39 #%define rel 0.1
40 Summary:        Main MythTV plugins
41 Summary(pl.UTF-8):      Główne wtyczki MythTV
42 Name:           mythplugins
43 Version:        0.22
44 Release:        0.%{snap}.1
45 License:        GPL v2
46 Group:          Applications/Multimedia
47 Source0:        %{name}-%{version}-%{snap}.tar.bz2
48 # Source0-md5:  c489ac9ff8033e41112af2e17fc5d65d
49 Source1:        mythweb.conf
50 #Patch0: %{name}-lib64.patch
51 #Patch1: %{name}-paths.patch
52 Patch2:         mythweb-config.patch
53 Patch20:        %{name}-mytharchive-INT64.patch
54 Patch100:       mythtv-branch.diff
55 URL:            http://www.mythtv.org/
56 %if %{with binary}
57 %if %{with mythgallery} || %{with myhtmusic}
58 BuildRequires:  OpenGL-devel
59 %endif
60 BuildRequires:  Qt3Support-devel
61 BuildRequires:  QtCore-devel
62 BuildRequires:  QtGui-devel
63 BuildRequires:  QtNetwork-devel
64 BuildRequires:  QtOpenGL-devel
65 BuildRequires:  QtSql-devel
66 BuildRequires:  QtWebKit-devel
67 BuildRequires:  QtXml-devel
68 BuildRequires:  SDL-devel
69 BuildRequires:  a52dec-libs-devel
70 BuildRequires:  cdparanoia-III-devel
71 BuildRequires:  faad2-devel >= 2.0-5.2
72 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
73 BuildRequires:  flac-devel >= 1.0.4
74 BuildRequires:  freetype-devel
75 BuildRequires:  libcdaudio-devel >= 0.99.12p2
76 BuildRequires:  libdvdcss-devel >= 1.2.7
77 BuildRequires:  libdvdread-devel >= 0.9.4
78 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
79 BuildRequires:  libfame-devel >= 0.9.0
80 BuildRequires:  libid3tag-devel
81 BuildRequires:  libmad-devel
82 BuildRequires:  libmyth-devel >= 0.19
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtiff-devel
85 BuildRequires:  libvorbis-devel >= 1:1.0
86 BuildRequires:  mjpegtools-devel >= 1.6.1
87 BuildRequires:  nasm
88 BuildRequires:  patchutils
89 BuildRequires:  qt4-build
90 BuildRequires:  qt4-qmake
91 BuildRequires:  rpm-perlprov >= 4.1-13
92 BuildRequires:  sed >= 4.0
93 %{?with_mythmusic:BuildRequires:        taglib-devel}
94 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
95 BuildRequires:  xorg-lib-libX11-devel
96 BuildRequires:  xvid-devel >= 1:0.9.1
97 BuildRequires:  zlib-devel
98 %endif
99 %{?with_mytharchive:Requires:   mytharchive}
100 %{?with_mythbrowser:Requires:   mythbrowser}
101 %{?with_mythdvd:Requires:       mythdvd}
102 %{?with_mythflix:Requires:      mythflix}
103 %{?with_mythgallery:Requires:   mythgallery}
104 %{?with_mythgame:Requires:      mythgame}
105 %{?with_mythmysic:Requires:     mythmusic}
106 %{?with_mythnews:Requires:      mythnews}
107 %{?with_mythphone:Requires:     mythphone}
108 %{?with_mythvideo:Requires:     mythvideo}
109 %{?with_mythweather:Requires:   mythweather}
110 %{?with_mythweb:Requires:       mythweb}
111 ExclusiveArch:  %{ix86} %{x8664} ppc
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
115 %define         _webapps        /etc/webapps
116 %define         _webapp         mythweb
117
118 %description
119 This is a consolidation of all the official MythTV plugins that used
120 to be distributed as separate downloads from mythtv.org.
121
122 %description -l pl.UTF-8
123 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
124 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
125
126 %package -n mytharchive
127 Summary:        A MythTV module to create and burn DVDs
128 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
129 Group:          Applications/Multimedia
130 Requires:       dvdauthor
131 Requires:       mjpegtools
132 Requires:       mythtv-frontend-api = %{myth_api_version}
133 Requires:       python-MySQLdb
134 Requires:       python-PIL
135 Suggests:       dvdrtools-mkisofs
136
137 %description -n mytharchive
138 MythArchive is a MythTV style plugin that uses the Mythburn Script to
139 create and burn DVDs from MythTV recordings, MythVideo files or any
140 video files available on a MythTV system. It can also export
141 recordings to a native archive format that can then be imported back
142 into a MythTV system restoring all the associated metadata.
143
144 %description -n mytharchive -l pl.UTF-8
145 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
146 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
147 innych plików z filmami dostępnych w systemie MythTV. Może także
148 eksportować nagrania do natywnego formatu archiwum, który potem można
149 zaimportować z powrotem do systemu MythTV przywracając wszystkie
150 związane z nimi metadane.
151
152 %package -n mythmusic
153 Summary:        The music player add-on module for MythTV
154 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
155 Group:          Applications/Multimedia
156 Requires:       mythtv-frontend-api = %{myth_api_version}
157
158 %description -n mythmusic
159 Music add-on for MythTV.
160
161 %description -n mythmusic -l pl.UTF-8
162 Odtwarzacz muzyki dla MythTV.
163
164 %package -n mythvideo
165 Summary:        A generic video player frontend module for MythTV
166 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
167 Group:          Applications/Multimedia
168 Requires:       mplayer
169 Requires:       mythtv-frontend-api = %{myth_api_version}
170
171 %description -n mythvideo
172 A generic video and dvd player frontend module for MythTV.
173
174 %description -n mythvideo -l pl.UTF-8
175 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
176
177 %package -n mythweather
178 Summary:        A MythTV module that displays a weather forcast
179 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
180 Group:          Applications/Multimedia
181 Requires:       mythtv-frontend-api = %{myth_api_version}
182
183 %description -n mythweather
184 A MythTV module that displays a weather forcast.
185
186 %description -n mythweather -l pl.UTF-8
187 Moduł MythTV wyświetlający prognozę pogody.
188
189 %package -n mythgallery
190 Summary:        A gallery/slideshow module for MythTV
191 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
192 Group:          Applications/Multimedia
193 Requires:       mythtv-frontend-api = %{myth_api_version}
194
195 %description -n mythgallery
196 A gallery/slideshow module for MythTV.
197
198 %description -n mythgallery -l pl.UTF-8
199 Moduł galerii/pokazu slajdów dla MythTV.
200
201 %package -n mythgame
202 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
203 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
204 Group:          Applications/Multimedia
205 Requires:       mythtv-frontend-api = %{myth_api_version}
206
207 %description -n mythgame
208 A game frontend (xmame, nes, snes, pc) for MythTV.
209
210 %description -n mythgame -l pl.UTF-8
211 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
212
213 %package -n mythdvd
214 Summary:        A DVD ripper module for MythTV
215 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
216 Group:          Applications/Multimedia
217 Requires:       mythtv-frontend-api = %{myth_api_version}
218 Requires:       mythvideo
219 Requires:       transcode >= 0.6.8
220
221 %description -n mythdvd
222 MythDVD is a MythTV module that allows you to rip DVD's and transcode
223 their video and audio content to other (generally smaller) formats.
224 The playing features are simply myth-style wrappers for your favourite
225 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
226 based on and derived from the excellent transcode package.
227
228 %description -n mythdvd -l pl.UTF-8
229 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
230 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
231 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
232 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
233 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
234 pakietu transcode.
235
236 %package -n mythnews
237 Summary:        A RSS News Feed plugin for MythTV
238 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
239 Group:          Applications/Multimedia
240 Requires:       mythtv-frontend-api = %{myth_api_version}
241
242 %description -n mythnews
243 A RSS News Feed plugin for MythTV.
244
245 %description -n mythnews -l pl.UTF-8
246 Wtyczka czytnika nowinek RSS dla MythTV.
247
248 %package -n mythbrowser
249 Summary:        A small web browser module for MythTV
250 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
251 Group:          Applications/Multimedia
252 Requires:       mythtv-frontend-api = %{myth_api_version}
253
254 %description -n mythbrowser
255 MythBrowser is a full fledged web-browser (multiple tabs) to display
256 webpages in full-screen mode. Simple page navigation is possible.
257 Starting with version 0.13 it also has full support for mouse driven
258 navigation (right mouse opens and closes the popup menu).
259
260 MythBrowser also contains a BookmarkManager to manage the website
261 links in a simple mythplugin.
262
263 %description -n mythbrowser -l pl.UTF-8
264 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
265 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
266 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
267 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
268 menu).
269
270 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
271 do stron w prostej wtyczce myth.
272
273 %package -n mythphone
274 Summary:        A video conferencing module for MythTV
275 Summary(pl.UTF-8):      Moduł wideokonferencji dla MythTV
276 Group:          Applications/Multimedia
277 Requires:       mythtv-frontend-api = %{myth_api_version}
278
279 %description -n mythphone
280 Mythphone is a phone and videophone capability on Myth using the
281 standard SIP protocol. It is compatible with Microsoft XP Messenger
282 and with SIP Service Providers such as Free World Dialup
283 (fwd.pulver.com).
284
285 %description -n mythphone -l pl.UTF-8
286 Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
287 standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
288 Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
289 (fwd.pulver.com).
290
291 %package -n mythweb
292 Summary:        The web interface to MythTV
293 Summary(pl.UTF-8):      Interfejs WWW do MythTV
294 Group:          Applications/Multimedia
295 Requires:       php(mysql)
296 Requires:       php(posix)
297 Requires:       webapps
298 Requires:       webserver(php) >= 4.3
299 #Suggests:      apache(mod_auth)
300 #Suggests:      apache(mod_env)
301
302 %description -n mythweb
303 The web interface to MythTV.
304
305 %description -n mythweb -l pl.UTF-8
306 Interfejs WWW do MythTV.
307
308 %package -n mythflix
309 Summary:        MythFlix (A NetFlix MythTV)
310 Summary(pl.UTF-8):      MythFlix (NetFlix MythTV)
311 Group:          Applications/Multimedia
312 Requires:       mythtv-frontend-api = %{myth_api_version}
313
314 %description -n mythflix
315 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
316 It currently supports the ability to view your queue and add movies to
317 your queue. The browse feature is based on the Netflix RSS feeds. This
318 plugin is not very mature, which means things might not work right
319 and/or it might break other things.
320
321 %description -n mythflix -l pl.UTF-8
322 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
323 Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
324 Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
325 jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
326 innego.
327
328 %package -n mythmovies
329 Summary:        MythTV cinemas timetable
330 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
331 Group:          Applications/Multimedia
332 Requires:       mythtv-frontend-api = %{myth_api_version}
333
334 %description -n mythmovies
335 MythTV cinemas timetable.
336
337
338 %description -n mythmovies -l pl.UTF-8
339 Moduł MythTV do repertuaru kinowego.
340
341 %package -n mythzoneminder
342 Summary:        MythTV security TV manager
343 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
344 Group:          Applications/Multimedia
345 Requires:       mythtv-frontend-api = %{myth_api_version}
346
347 %description -n mythzoneminder
348 MythTV security TV manager.
349
350
351 %description -n mythzoneminder -l pl.UTF-8
352 Obsługa kamer przemysłowych dla MythTV.
353
354 %prep
355 #%setup -q %{?_snap:-n %{name}}
356 %setup -q %{SOURCE0}
357 #%if %{_lib} != "lib"
358 #%patch0 -p1
359 #%endif
360 #%patch1 -p1
361 #%patch2 -p1
362 %patch20 -p1
363 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
364
365 # make it visible
366 #mv mythweb/data/{.,}htaccess
367
368 # lib64 fix - enable to update patch
369 %if %{_lib} != "lib" && 0
370 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
371 xargs grep -l /lib/ . | xargs sed -i -e '
372         s,/usr/lib/,/%{_lib}/,g
373         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
374 '
375 exit 1
376 %endif
377
378 %build
379 %if %{with binary}
380 export QTDIR="%{_prefix}"
381 # Not gnu configure
382 %configure \
383         --libdir-name=`basename %{_lib}` \
384         --enable-all \
385         %{!?with_mytharchive:--disable-mytharchive} \
386         %{!?with_mythbrowser:--disable-mythbrowser} \
387         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
388         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
389         %{!?with_mythgame:--disable-mythgame} \
390         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
391         %{!?with_mythnews:--disable-mythnews} \
392         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
393         %{!?with_mythvideo:--disable-mythvideo} \
394         %{!?with_mythweather:--disable-mythweather} \
395         %{!?with_mythweb:--disable-mythweb} \
396         %{!?with_mythmovies:--disable-mythmovies} \
397         %{!?with_mythflix:--disable-mythflix} \
398
399 mv mythconfig.mak mythconfig.mak.old
400 cp mythconfig.mak.old mythconfig.mak
401 cat <<'EOF'>> mythconfig.mak
402 QMAKE_CXX=%{__cxx}
403 QMAKE_CC=%{__cc}
404 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
405 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
406 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
407 EOF
408
409 %{__make}
410 %endif
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414
415 %if %{with binary}
416 export QTDIR="%{_prefix}"
417 %{__make} install \
418         INSTALL_ROOT=$RPM_BUILD_ROOT
419
420 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
421 %if %{with mythgame}
422 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
423 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
424 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
425 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
426 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
427 %endif
428 %endif
429
430 %if %{with mythweb}
431 cd mythweb
432 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
433 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
434 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
435 cp -a *.php *.pl data includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
436 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
437 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
438 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
439 cd -
440 %endif
441
442 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
443 rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
444 for p in mytharchive mythbrowser mythmovies mythdvd mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythzoneminder; do
445         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
446                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
447         done > $p.lang
448 done
449
450 %clean
451 rm -rf $RPM_BUILD_ROOT
452
453 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
454 %webapp_register apache %{_webapp}
455
456 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
457 %webapp_unregister apache %{_webapp}
458
459 %triggerin -n mythweb -- apache < 2.2.0, apache-base
460 %webapp_register httpd %{_webapp}
461
462 %triggerun -n mythweb -- apache < 2.2.0, apache-base
463 %webapp_unregister httpd %{_webapp}
464
465 %triggerpostun -n mythweb -- mythweb < 0.19
466 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
467         if [ -f /etc/mythweb/$i.rpmsave ]; then
468                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
469                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
470         fi
471 done
472 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
473
474 # migrate from apache-config macros
475 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
476         if [ -d /etc/apache/webapps.d ]; then
477                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
478                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
479         fi
480
481         if [ -d /etc/httpd/webapps.d ]; then
482                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
483                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
484         fi
485         rm -f /etc/mythweb/apache.conf.rpmsave
486 fi
487
488 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
489         rm -f /etc/apache/conf.d/99_mythplugins.conf
490         /usr/sbin/webapp register apache %{_webapp}
491         %service -q apache reload
492 fi
493 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
494         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
495         /usr/sbin/webapp register httpd %{_webapp}
496         %service -q httpd reload
497 fi
498
499 %files
500 %defattr(644,root,root,755)
501
502 %if %{with mytharchive}
503 %files -n mytharchive -f mytharchive.lang
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_bindir}/mytharchivehelper
506 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
507 %{_datadir}/mythtv/archivemenu.xml
508 %{_datadir}/mythtv/archiveutils.xml
509 %{_datadir}/mythtv/themes/default/ma_*.png
510 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
511 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
512 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
513 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
514 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
515 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
516 %{_datadir}/mythtv/mytharchive
517 %endif
518
519 %if %{with mythmusic}
520 %files -n mythmusic -f mythmusic.lang
521 %defattr(644,root,root,755)
522 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
523 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
524 /var/lib/mythmusic
525 %{_datadir}/mythtv/musicmenu.xml
526 %{_datadir}/mythtv/music_settings.xml
527 %{_datadir}/mythtv/themes/default/music-ui.xml
528 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
529 %{_datadir}/mythtv/themes/default/ff_button_off.png
530 %{_datadir}/mythtv/themes/default/ff_button_on.png
531 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
532 %{_datadir}/mythtv/themes/default/miniplayer_background.png
533 %{_datadir}/mythtv/themes/default/mm_*.png
534 %{_datadir}/mythtv/themes/default/music-sel-bg.png
535 %{_datadir}/mythtv/themes/default/next_button_off.png
536 %{_datadir}/mythtv/themes/default/next_button_on.png
537 %{_datadir}/mythtv/themes/default/next_button_pushed.png
538 %{_datadir}/mythtv/themes/default/pause_button_off.png
539 %{_datadir}/mythtv/themes/default/pause_button_on.png
540 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
541 %{_datadir}/mythtv/themes/default/play_button_off.png
542 %{_datadir}/mythtv/themes/default/play_button_on.png
543 %{_datadir}/mythtv/themes/default/play_button_pushed.png
544 %{_datadir}/mythtv/themes/default/prev_button_off.png
545 %{_datadir}/mythtv/themes/default/prev_button_on.png
546 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
547 %{_datadir}/mythtv/themes/default/rew_button_off.png
548 %{_datadir}/mythtv/themes/default/rew_button_on.png
549 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
550 %{_datadir}/mythtv/themes/default/selectionbar.png
551 %{_datadir}/mythtv/themes/default/stop_button_off.png
552 %{_datadir}/mythtv/themes/default/stop_button_on.png
553 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
554 %{_datadir}/mythtv/themes/default/track_info_background.png
555 %{_datadir}/mythtv/themes/default-wide/mm_*.png
556 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
557 %endif
558
559 %if %{with mythvideo}
560 %files -n mythvideo -f mythvideo.lang
561 %defattr(644,root,root,755)
562 %doc mythvideo/README mythvideo/videodb
563 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
564 %{_datadir}/mythtv/themes/default/video-ui.xml
565 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
566 %{_datadir}/mythtv/themes/default/mv_*.png
567 %{_datadir}/mythtv/themes/default-wide/mv_*.png
568 %{_datadir}/mythtv/video_settings.xml
569 %{_datadir}/mythtv/videomenu.xml
570 %dir %{_datadir}/mythtv/mythvideo
571 %dir %{_datadir}/mythtv/mythvideo/scripts
572 %{_datadir}/mythtv/mythvideo/scripts/README
573 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
574 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
575 %dir %{_datadir}/mythtv/mythvideo/scripts/MythTV
576 %attr(644,root,root)%{_datadir}/mythtv/mythvideo/scripts/MythTV/MythVideoCommon.pm
577 /var/lib/mythvideo
578 %endif
579
580 %if %{with mythweather}
581 %files -n mythweather -f mythweather.lang
582 %defattr(644,root,root,755)
583 %doc mythweather/README
584 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
585 %{_datadir}/mythtv/mythweather
586 %{_datadir}/mythtv/weather_settings.xml
587 %{_datadir}/mythtv/themes/default/weather-ui.xml
588 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
589 %{_datadir}/mythtv/themes/default/cloudy.png
590 %{_datadir}/mythtv/themes/default/fair.png
591 %{_datadir}/mythtv/themes/default/flurries.png
592 %{_datadir}/mythtv/themes/default/fog.png
593 %{_datadir}/mythtv/themes/default/logo.png
594 %{_datadir}/mythtv/themes/default/lshowers.png
595 %{_datadir}/mythtv/themes/default/mcloudy.png
596 %{_datadir}/mythtv/themes/default/mw_*.png
597 %{_datadir}/mythtv/themes/default/mwmain.png
598 %{_datadir}/mythtv/themes/default/pcloudy.png
599 %{_datadir}/mythtv/themes/default/rainsnow.png
600 %{_datadir}/mythtv/themes/default/showers.png
601 %{_datadir}/mythtv/themes/default/snowshow.png
602 %{_datadir}/mythtv/themes/default/sunny.png
603 %{_datadir}/mythtv/themes/default/thunshowers.png
604 %{_datadir}/mythtv/themes/default/unknown.png
605 %{_datadir}/mythtv/themes/default-wide/mw-*.png
606 %endif
607
608 %if %{with mythgallery}
609 %files -n mythgallery -f mythgallery.lang
610 %defattr(644,root,root,755)
611 %doc mythgallery/README
612 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
613 %{_datadir}/mythtv/themes/default/gallery-ui.xml
614 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
615 %{_datadir}/mythtv/themes/default/gallery-*.png
616 # FIXME: this is definately stupid path
617 /var/lib/pictures
618 %endif
619
620 %if %{with mythgame}
621 %files -n mythgame -f mythgame.lang
622 %defattr(644,root,root,755)
623 #%doc mythgame/README
624 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
625 %{_datadir}/mythtv/games
626 %{_datadir}/mythtv/game_settings.xml
627 %{_datadir}/mythtv/themes/default/game-ui.xml
628 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
629 %endif
630
631 %if %{with mythdvd}
632 %files -n mythdvd
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_bindir}/mtd
635 %{_datadir}/mythtv/themes/default/dvd-ui.xml
636 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
637 %{_datadir}/mythtv/themes/default/md_*.png
638 %endif
639
640 %if %{with mythnews}
641 %files -n mythnews -f mythnews.lang
642 %defattr(644,root,root,755)
643 %doc mythnews/README mythnews/AUTHORS
644 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
645 %{_datadir}/mythtv/mythnews
646 %{_datadir}/mythtv/themes/default/news-ui.xml
647 # DUPLICATE WITH MYTHFLIX?
648 %{_datadir}/mythtv/themes/default/news-info-bg.png
649 %{_datadir}/mythtv/themes/default/enclosures.png
650 %{_datadir}/mythtv/themes/default/need-download.png
651 %{_datadir}/mythtv/themes/default/podcast.png
652 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
653 %endif
654
655 %if %{with mythbrowser}
656 %files -n mythbrowser -f mythbrowser.lang
657 %defattr(644,root,root,755)
658 %doc mythbrowser/README mythbrowser/AUTHORS
659 %attr(755,root,root) %{_bindir}/mythbrowser
660 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
661 %{_datadir}/mythtv/themes/default/mb_progress*.png
662 %{_datadir}/mythtv/themes/default/browser-ui.xml
663 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
664 %endif
665
666 %if %{with mythphone}
667 %files -n mythphone -f mythphone.lang
668 %defattr(644,root,root,755)
669 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
670 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
671 %{_datadir}/mythtv/themes/default/phone-ui.xml
672 %{_datadir}/mythtv/themes/default/webcam-ui.xml
673 %{_datadir}/mythtv/themes/default/mp_*.png
674 %{_datadir}/mythtv/themes/default/phone.png
675 %endif
676
677 %if %{with mythweb}
678 %files -n mythweb
679 %defattr(644,root,root,755)
680 %doc mythweb/README
681 #%doc mythweb/data/htaccess
682 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
683 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
684 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
685 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
686 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
687 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
688 %{_datadir}/mythweb
689 %dir %attr(771,root,http) /var/cache/mythweb
690 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
691 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
692 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
693 %endif
694
695 %if %{with mythflix}
696 %files -n mythflix -f mythflix.lang
697 %defattr(644,root,root,755)
698 %doc mythflix/{AUTHORS,ChangeLog,README}
699 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
700 %dir %{_datadir}/mythtv/mythflix
701 %{_datadir}/mythtv/mythflix/netflix-rss.xml
702 %dir %{_datadir}/mythtv/mythflix/scripts
703 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
704 %{_datadir}/mythtv/netflix_menu.xml
705 %{_datadir}/mythtv/themes/default/title_netflix.png
706 %{_datadir}/mythtv/themes/default/mythflix_background.png
707 %{_datadir}/mythtv/themes/default/netflix-ui.xml
708 %{_datadir}/mythtv/themes/default-wide/netflix-ui.xml
709 %{_datadir}/mythtv/themes/default-wide/netflix-bg.png
710 # DUPLICATE WITH MYTHNEWS?
711 %{_datadir}/mythtv/themes/default/news-info-bg.png
712 %endif
713
714 %if %{with mythmovies}
715 %files -n mythmovies
716 %defattr(644,root,root,755)
717 #-f mythmovies.lang
718 %defattr(644,root,root,755)
719 %doc mythmovies/{README,TODO}
720 %attr(755,root,root) %{_bindir}/ignyte
721 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
722 %{_datadir}/mythtv/themes/default/movies-ui.xml
723 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
724 %endif
725
726 %if %{with mythzoneminder}
727 %files -n mythzoneminder
728 %defattr(644,root,root,755)
729 #-f mythmovies.lang
730 %defattr(644,root,root,755)
731 %doc mythzoneminder/{AUTHORS,README}
732 %attr(755,root,root) %{_bindir}/mythzmserver
733 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
734 %dir %{_datadir}/mythtv/zonemindermenu.xml
735 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
736 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
737 %{_datadir}/mythtv/themes/default/mz_*png
738 %endif
This page took 1.803332 seconds and 4 git commands to generate.