]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- save
[packages/mythplugins.git] / mythplugins.spec
1 Summary:        Main MythTV plugins.
2 Name:           mythplugins
3 Version:        0.18.1
4 Release:        0.112
5 License:        GPL v2
6 Group:          Applications/Multimedia
7 URL:            http://www.mythtv.org/
8 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
9 # Source0-md5:  1d94d19e2a13c24a408ced9b6c4f5b47
10 ###
11 Patch1: mythmusic-0.18-fftw2singleprec.patch
12 #Patch2:        mythmusic-0.12-cdda.patch
13 #Patch10:       mythvideo-0.16-math.patch
14 BuildRequires:  SDL-devel
15 BuildRequires:  X11-OpenGL-devel
16 BuildRequires:  XFree86-devel
17 BuildRequires:  a52dec-libs-devel
18 BuildRequires:  cdparanoia-III-devel
19 BuildRequires:  faad2-devel >= 2.0-5.2
20 BuildRequires:  fftw-devel >= 2.1.3
21 BuildRequires:  flac-devel >= 1.0.4
22 BuildRequires:  freetype-devel
23 BuildRequires:  kdelibs-devel
24 BuildRequires:  libcdaudio-devel
25 BuildRequires:  libdvdcss-devel >= 1.2.7
26 BuildRequires:  libdvdread-devel >= 0.9.4
27 BuildRequires:  libexif-devel
28 BuildRequires:  libfame-devel >= 0.9.0
29 BuildRequires:  libid3tag-devel
30 BuildRequires:  libmad-devel
31 BuildRequires:  libmyth-devel >= 0:%{version}
32 BuildRequires:  libstdc++-devel
33 #BuildRequires: libtermcap-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  libvorbis-devel >= 1.0
36 BuildRequires:  mjpegtools-devel >= 1.6.1
37 BuildRequires:  nasm
38 BuildRequires:  transcode >= 0.6.8
39 BuildRequires:  xvid-devel >= 1:0.9.1
40 BuildRequires:  zlib-devel
41 Requires:       mythbrowser
42 Requires:       mythdvd
43 Requires:       mythgallery
44 Requires:       mythgame
45 Requires:       mythmusic
46 Requires:       mythnews
47 Requires:       mythphone
48 Requires:       mythvideo
49 Requires:       mythweather
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         api_ver %(echo %{version} | cut -d. -f1,2)
53
54 %description
55 This is a consolidation of all the official MythTV plugins that used
56 to be distributed as separate downloads from mythtv.org.
57
58 %package -n mythmusic
59 Summary:        The music player add-on module for MythTV.
60 Group:          Applications/Multimedia
61 Requires:       mythtv-frontend-api = %{api_ver}
62
63 %description -n mythmusic
64 Music add-on for mythtv.
65
66 %package -n mythvideo
67 Summary:        A generic video player frontend module for MythTV.
68 Group:          Applications/Multimedia
69 Requires:       mplayer
70 Requires:       mythtv-frontend-api = %{api_ver}
71
72 %description -n mythvideo
73 A generic video player frontend module for MythTV.
74
75 %package -n mythweather
76 Summary:        A MythTV module that displays a weather forcast.
77 Group:          Applications/Multimedia
78 Requires:       mythtv-frontend-api = %{api_ver}
79
80 %description -n mythweather
81 A MythTV module that displays a weather forcast.
82
83 %package -n mythgallery
84 Summary:        A gallery/slideshow module for MythTV.
85 Group:          Applications/Multimedia
86 Requires:       mythtv-frontend-api = %{api_ver}
87
88 %description -n mythgallery
89 A gallery/slideshow module for MythTV.
90
91 %package -n mythgame
92 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV.
93 Group:          Applications/Multimedia
94 Requires:       mythtv-frontend-api = %{api_ver}
95
96 %description -n mythgame
97 A game frontend (xmame, nes, snes, pc) for MythTV.
98
99 %package -n mythdvd
100 Summary:        A DVD player module for MythTV.
101 Group:          Applications/Multimedia
102 Requires:       mythtv-frontend-api = %{api_ver}
103 Requires:       transcode >= 0.6.8
104
105 %description -n mythdvd
106 MythDVD is a MythTV module that allows you to play DVD's on a myth-box
107 and (optionally) rip DVD's and transcode their video and audio content
108 to other (generally smaller) formats. The playing features are simply
109 myth-style wrappers for your favourite DVD playing software (mplayer,
110 ogle, xine, etc). The transcoding is based on and derived from the
111 excellent transcode package.
112
113 %package -n mythnews
114 Summary:        A RSS News Feed Plugin for MythTV.
115 Group:          Applications/Multimedia
116 Requires:       mythtv-frontend-api = %{api_ver}
117
118 %description -n mythnews
119
120 %package -n mythbrowser
121 Summary:        A small web browser module for MythTV.
122 Group:          Applications/Multimedia
123 Requires:       mythtv-frontend-api = %{api_ver}
124
125 %description -n mythbrowser
126 MythBrowser is a full fledged web-browser (multiple tabs) to display
127 webpages in full-screen mode. Simple page navigation is possible.
128 Starting with version 0.13 it also has full support for mouse driven
129 navigation (right mouse opens and clos es the popup menu).
130
131 MythBrowser also contains a BookmarkManager to manage the website
132 links in a simple mythplugin.
133
134 %package -n mythphone
135 Summary:        A video conferencing module for MythTV.
136 Group:          Applications/Multimedia
137 Requires:       mythtv-frontend-api = %{api_ver}
138
139 %description -n mythphone
140 Mythphone is a phone and videophone capability on MYTH using the
141 standard SIP protocol. It is compatible with Microsoft XP Messenger
142 and with SIP Service Providers such as Free World Dialup
143 (fwd.pulver.com).
144
145 %prep
146 %setup -q
147
148 # lib64 fix
149 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
150         xargs grep -l /lib/ . | xargs sed -i -e 's,/lib/,/%{_lib}/,g'
151
152 #grep -rl %{_prefix}/local . | xargs perl -pi -e's|%{_prefix}/local|'%{_prefix}'|g'
153
154 # include mythtv build settings
155 cp %{_datadir}/mythtv/build/config.mak .
156 sed -i -e '1iinclude(config.mak)'  settings.pro
157 #sed -i -e '1iinclude(%{_datadir}/mythtv/build/settings.pro)'  settings.pro
158 exit 0
159
160 #%ifnarch %{ix86}
161 #cat >> settings.pro << EOF
162 #DEFINES -= HAVE_MMX
163 #EOF
164 #%endif
165
166
167 %patch1 -p0 -b .sfftw
168 cd mythmusic
169 #%patch2 -p0 -b .cdda
170
171
172 # Fix /mnt/store -> /var/lib/mythmusic
173 perl -pi -e's|/mnt/store/music|%{_varlibdir}/mythmusic|' mythmusic/globalsettings.cpp
174
175 cd ..
176 cd mythvideo
177 #%patch10 -p0 -b .math
178
179 #find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
180
181 # Fix /mnt/store -> /var/lib/mythmusic
182 perl -pi -e's|/share/Movies/dvd|%{_varlibdir}/mythvideo|' mythvideo/globalsettings.cpp
183
184 cd ..
185 cd mythweather
186 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
187 cd ..
188 cd mythgallery
189 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
190
191 cd ..
192 cd mythgame
193 #FIXME
194 #patch20 -p1 -b .paths
195 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
196
197 cd ..
198 cd mythdvd
199 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
200
201 cd ..
202 cd mythnews
203 #patch30 -p0 -b .toTime
204 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
205
206 cd ..
207 cd mythbrowser
208 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
209
210 cd ..
211 cd mythphone
212 #patch40 -p0
213 find . -type f -name \*.pro | xargs grep -l /lib$ | xargs perl -pi -e's,/lib$,/%{_lib},'
214
215 cat >> ../settings.pro << EOF
216 INCLUDEPATH += %{_includedir}/mythtv
217 INCLUDEPATH += %{_includedir}/speech_tools
218 EOF
219 cd ..
220
221 %build
222 export QTDIR="%{_prefix}"
223 # not gnu configure
224 %configure \
225         --enable-all \
226         --disable-festival \
227         --disable-mythmusic \
228         --disable-mythphone
229
230 # disable mythmusic,mythphone due to https://bugs.pld-linux.org/?do=details&id=5687
231
232 #       --enable-all             Enable all options
233 #       --enable-opengl          enable OpenGL (Music and Gallery) [default=no]
234 #
235 #       --enable-transcode       enable DVD ripping and transcoding [default=no]
236 #       --enable-vcd             enable VCD playing [default=no]
237 #
238 #       --enable-exif            enable reading of EXIF headers [default=no]
239 #
240 #       --enable-fftw            enable fftw visualizers [default=no]
241 #       --enable-sdl             use SDL for the synaesthesia output [default=no]
242 #       --enable-aac             enable AAC/MP4 audio file decompression [default=no]
243 #
244 #       --enable-festival        enable festival TTS Engine [default=no]
245
246
247 qmake mythplugins.pro
248 %{__make}
249 #cd mythbrowser
250 #qmake mythbrowser.pro
251 #cd ..
252 #make -C mythbrowser
253
254 %install
255 rm -rf $RPM_BUILD_ROOT
256 %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
257 %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT -C mythbrowser
258
259 install -d $RPM_BUILD_ROOT%{_varlibdir}/mythmusic
260 install -d $RPM_BUILD_ROOT%{_varlibdir}/mythvideo
261 install -d $RPM_BUILD_ROOT%{_varlibdir}/pictures
262 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
263 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
264 #mkdir -p %{buildroot}%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
265 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
266 install -d $RPM_BUILD_ROOT%{_datadir}/xmame
267 ln -s %{_datadir}/xmame $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame
268 install -d $RPM_BUILD_ROOT%{_datadir}/xmame/flyers
269 ln -s snap $RPM_BUILD_ROOT%{_datadir}/xmame/screens
270
271 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/
272
273 %clean
274 rm -rf $RPM_BUILD_ROOT
275
276 %files
277 %defattr(644,root,root,755)
278
279 %files -n mythmusic
280 %defattr(644,root,root,755)
281 %doc mythmusic/README mythmusic/UPGRADING mythmusic/COPYING mythmusic/AUTHORS mythmusic/musicdb
282 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
283 %{_varlibdir}/mythmusic
284 %{_datadir}/mythtv/musicmenu.xml
285 %{_datadir}/mythtv/music_settings.xml
286 %{_datadir}/mythtv/i18n/mythmusic_*.qm
287 %{_datadir}/mythtv/themes/default/ff_button_off.png
288 %{_datadir}/mythtv/themes/default/ff_button_on.png
289 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
290 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
291 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
292 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
293 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
294 %{_datadir}/mythtv/themes/default/mm_checked.png
295 %{_datadir}/mythtv/themes/default/mm_checked_high.png
296 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
297 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
298 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
299 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
300 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
301 %{_datadir}/mythtv/themes/default/mm_rating.png
302 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
303 %{_datadir}/mythtv/themes/default/mm_unchecked.png
304 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
305 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
306 %{_datadir}/mythtv/themes/default/mm_volume_background.png
307 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
308 %{_datadir}/mythtv/themes/default/mm_waiting.png
309 %{_datadir}/mythtv/themes/default/music-sel-bg.png
310 %{_datadir}/mythtv/themes/default/music-ui.xml
311 %{_datadir}/mythtv/themes/default/next_button_off.png
312 %{_datadir}/mythtv/themes/default/next_button_on.png
313 %{_datadir}/mythtv/themes/default/next_button_pushed.png
314 %{_datadir}/mythtv/themes/default/pause_button_off.png
315 %{_datadir}/mythtv/themes/default/pause_button_on.png
316 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
317 %{_datadir}/mythtv/themes/default/play_button_off.png
318 %{_datadir}/mythtv/themes/default/play_button_on.png
319 %{_datadir}/mythtv/themes/default/play_button_pushed.png
320 %{_datadir}/mythtv/themes/default/prev_button_off.png
321 %{_datadir}/mythtv/themes/default/prev_button_on.png
322 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
323 %{_datadir}/mythtv/themes/default/rew_button_off.png
324 %{_datadir}/mythtv/themes/default/rew_button_on.png
325 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
326 %{_datadir}/mythtv/themes/default/selectionbar.png
327 %{_datadir}/mythtv/themes/default/stop_button_off.png
328 %{_datadir}/mythtv/themes/default/stop_button_on.png
329 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
330 %{_datadir}/mythtv/themes/default/text_button_off.png
331 %{_datadir}/mythtv/themes/default/text_button_on.png
332 %{_datadir}/mythtv/themes/default/text_button_pushed.png
333 %{_datadir}/mythtv/themes/default/track_info_background.png
334
335 %files -n mythvideo
336 %defattr(644,root,root,755)
337 %doc mythvideo/README mythvideo/UPGRADING mythvideo/COPYING mythvideo/videodb
338 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
339 %{_datadir}/mythtv/i18n/mythvideo_*.qm
340 %{_datadir}/mythtv/themes/default/video-ui.xml
341 %{_datadir}/mythtv/themes/default/mv-*.png
342 %{_datadir}/mythtv/themes/default/mv_*.png
343 %{_datadir}/mythtv/video_settings.xml
344 %{_datadir}/mythtv/videomenu.xml
345 %{_datadir}/mythtv/mythvideo/scripts/README
346 %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
347 %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
348 %{_varlibdir}/mythvideo
349
350 %files -n mythweather
351 %defattr(644,root,root,755)
352 %doc mythweather/README mythweather/COPYING
353 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
354 %{_datadir}/mythtv/i18n/mythweather_*.qm
355 %{_datadir}/mythtv/mythweather
356 %{_datadir}/mythtv/themes/default/weather-ui.xml
357 %{_datadir}/mythtv/themes/default/cloudy.png
358 %{_datadir}/mythtv/themes/default/fair.png
359 %{_datadir}/mythtv/themes/default/flurries.png
360 %{_datadir}/mythtv/themes/default/fog.png
361 %{_datadir}/mythtv/themes/default/logo.png
362 %{_datadir}/mythtv/themes/default/lshowers.png
363 %{_datadir}/mythtv/themes/default/mcloudy.png
364 %{_datadir}/mythtv/themes/default/mw-*.png
365 %{_datadir}/mythtv/themes/default/mwmain.png
366 %{_datadir}/mythtv/themes/default/pcloudy.png
367 %{_datadir}/mythtv/themes/default/rainsnow.png
368 %{_datadir}/mythtv/themes/default/showers.png
369 %{_datadir}/mythtv/themes/default/snowshow.png
370 %{_datadir}/mythtv/themes/default/sunny.png
371 %{_datadir}/mythtv/themes/default/thunshowers.png
372 %{_datadir}/mythtv/themes/default/unknown.png
373
374 %files -n mythgallery
375 %defattr(644,root,root,755)
376 %doc mythgallery/README mythgallery/UPGRADING mythgallery/COPYING
377 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
378 %{_datadir}/mythtv/themes/default/gallery-ui.xml
379 %{_datadir}/mythtv/themes/default/gallery-*.png
380 %{_datadir}/mythtv/i18n/mythgallery_*.qm
381 %{_varlibdir}/pictures
382
383 %files -n mythgame
384 %defattr(644,root,root,755)
385 %doc mythgame/README mythgame/UPGRADING
386 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
387 %{_datadir}/mythtv/games
388 %config %{_datadir}/mythtv/games/PC/gamelist.xml
389 %{_datadir}/xmame/screens
390 %{_datadir}/xmame/flyers
391 %{_datadir}/mythtv/game_settings.xml
392 %{_datadir}/mythtv/themes/default/game-ui.xml
393 %{_datadir}/mythtv/i18n/mythgame_*.qm
394
395 %files -n mythdvd
396 %defattr(644,root,root,755)
397 %doc mythdvd/README mythdvd/UPGRADING mythdvd/COPYING mythdvd/AUTHORS
398 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
399 %{_datadir}/mythtv/dvd_settings.xml
400 %{_datadir}/mythtv/dvdmenu.xml
401 %{_datadir}/mythtv/themes/default/dvd-ui.xml
402 %{_datadir}/mythtv/themes/default/md_*.png
403 %{_datadir}/mythtv/i18n/mythdvd_*.qm
404 %attr(755,root,root) %{_bindir}/mtd
405
406 %files -n mythnews
407 %defattr(644,root,root,755)
408 %doc mythnews/README mythnews/AUTHORS mythnews/COPYING
409 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
410 %{_datadir}/mythtv/mythnews
411 %{_datadir}/mythtv/themes/default/news-ui.xml
412 %{_datadir}/mythtv/themes/default/news-info-bg.png
413 %{_datadir}/mythtv/i18n/mythnews_*.qm
414
415 %files -n mythbrowser
416 %defattr(644,root,root,755)
417 %doc mythbrowser/README mythbrowser/COPYING mythbrowser/AUTHORS
418 %attr(755,root,root) %{_bindir}/mythbrowser
419 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
420 %{_datadir}/mythtv/themes/default/webpage.png
421 %{_datadir}/mythtv/i18n/mythbrowser_*.qm
422
423 %files -n mythphone
424 %defattr(644,root,root,755)
425 %doc mythphone/README mythphone/COPYING mythphone/AUTHORS mythphone/TODO
426 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
427 %{_datadir}/mythtv/themes/default/phone-ui.xml
428 %{_datadir}/mythtv/themes/default/webcam-ui.xml
429 %{_datadir}/mythtv/themes/default/mp_*.png
430 %{_datadir}/mythtv/themes/default/phone.png
431 %{_datadir}/mythtv/i18n/mythphone_*.qm
This page took 0.057455 seconds and 4 git commands to generate.