]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- add branch.diff: release 0.19 fixes up to svn 10051
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mythbrowser     # disable building mythbrowser plugin
5 %bcond_without  mythdvd         # disable building mythgallery plugin
6 %bcond_without  mythgallery     # disable building mythgallery plugin
7 %bcond_without  mythgame        # disable building mythgallery plugin
8 %bcond_without  mythmusic       # disable building mythmusic plugin
9 %bcond_without  mythnews        # disable building mythgallery plugin
10 %bcond_without  mythphone       # disable building mythgallery plugin
11 %bcond_without  mythvideo       # disable building mythgallery plugin
12 %bcond_without  mythweather     # disable building mythgallery plugin
13 %bcond_without  mythweb         # disable building mythgallery plugin
14 %bcond_without  mythflix        # disable building mythflix plugin
15 %bcond_without  mythcontrols    # disable mythcontrols plugin
16 #
17 %if %{without binary}
18 %undefine       with_mythbrowser
19 %undefine       with_mythdvd
20 %undefine       with_mythgallery
21 %undefine       with_mythgame
22 %undefine       with_mythmusic
23 %undefine       with_mythnews
24 %undefine       with_mythphone
25 %undefine       with_mythvideo
26 %undefine       with_mythweather
27 %undefine       with_mythcontrols
28 %undefine       with_mythflix
29 %endif
30
31 %include        /usr/lib/rpm/macros.perl
32
33 Summary:        Main MythTV plugins
34 Summary(pl):    G³ówne wtyczki MythTV
35 Name:           mythplugins
36 Version:        0.19
37 Release:        3.1
38 License:        GPL v2
39 Group:          Applications/Multimedia
40 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
41 # Source0-md5:  201d60d5d60222038d8c97831f7e4288
42 Source1:        mythweb.conf
43 Patch0:         %{name}-lib64.patch
44 Patch1:         %{name}-paths.patch
45 Patch2:         mythweb-config.patch
46 Patch3:         mythtv-branch.diff
47 URL:            http://www.mythtv.org/
48 %if %{with binary}
49 %if %{with mythgallery} || %{with myhtmusic}
50 BuildRequires:  OpenGL-devel
51 %endif
52 BuildRequires:  SDL-devel
53 BuildRequires:  XFree86-devel
54 BuildRequires:  a52dec-libs-devel
55 BuildRequires:  patchutils
56 BuildRequires:  cdparanoia-III-devel
57 BuildRequires:  faad2-devel >= 2.0-5.2
58 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
59 BuildRequires:  flac-devel >= 1.0.4
60 BuildRequires:  freetype-devel
61 BuildRequires:  kdelibs-devel
62 BuildRequires:  libcdaudio-devel >= 0.99.12p2
63 BuildRequires:  libdvdcss-devel >= 1.2.7
64 BuildRequires:  libdvdread-devel >= 0.9.4
65 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
66 BuildRequires:  libfame-devel >= 0.9.0
67 BuildRequires:  libid3tag-devel
68 BuildRequires:  libmad-devel
69 BuildRequires:  libmyth-devel >= 0.19
70 BuildRequires:  libstdc++-devel
71 BuildRequires:  libtiff-devel
72 BuildRequires:  libvorbis-devel >= 1:1.0
73 BuildRequires:  mjpegtools-devel >= 1.6.1
74 BuildRequires:  nasm
75 BuildRequires:  rpm-perlprov >= 4.1-13
76 BuildRequires:  sed >= 4.0
77 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
78 BuildRequires:  xvid-devel >= 1:0.9.1
79 BuildRequires:  zlib-devel
80 %endif
81 %{?with_mythbrowser:Requires:   mythbrowser}
82 %{?with_mythdvd:Requires:       mythdvd}
83 %{?with_mythflix:Requires:      mythflix}
84 %{?with_mythgallery:Requires:   mythgallery}
85 %{?with_mythgame:Requires:      mythgame}
86 %{?with_mythmysic:Requires:     mythmusic}
87 %{?with_mythnews:Requires:      mythnews}
88 %{?with_mythphone:Requires:     mythphone}
89 %{?with_mythvideo:Requires:     mythvideo}
90 %{?with_mythweather:Requires:   mythweather}
91 %{?with_mythweb:Requires:       mythweb}
92 ExclusiveArch:  %{ix86} %{x8664} ppc
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
96 %define         _webapps        /etc/webapps
97 %define         _webapp         mythweb
98
99 %description
100 This is a consolidation of all the official MythTV plugins that used
101 to be distributed as separate downloads from mythtv.org.
102
103 %description -l pl
104 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które by³y
105 wcze¶niej rozpowszechniane jako osobne pakiety na mythtv.org.
106
107 %package -n mythmusic
108 Summary:        The music player add-on module for MythTV
109 Summary(pl):    Modu³ odtwarzacza muzyki dla MythTV
110 Group:          Applications/Multimedia
111 Requires:       mythtv-frontend-api = %{myth_api_version}
112
113 %description -n mythmusic
114 Music add-on for MythTV.
115
116 %description -n mythmusic -l pl
117 Odtwarzacz muzyki dla MythTV.
118
119 %package -n mythvideo
120 Summary:        A generic video player frontend module for MythTV
121 Summary(pl):    Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV
122 Group:          Applications/Multimedia
123 Requires:       mplayer
124 Requires:       mythtv-frontend-api = %{myth_api_version}
125
126 %description -n mythvideo
127 A generic video player frontend module for MythTV.
128
129 %description -n mythvideo -l pl
130 Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV.
131
132 %package -n mythweather
133 Summary:        A MythTV module that displays a weather forcast
134 Summary(pl):    Modu³ MythTV wy¶wietlaj±cy prognozê pogody
135 Group:          Applications/Multimedia
136 Requires:       mythtv-frontend-api = %{myth_api_version}
137
138 %description -n mythweather
139 A MythTV module that displays a weather forcast.
140
141 %description -n mythweather -l pl
142 Modu³ MythTV wy¶wietlaj±cy prognozê pogody.
143
144 %package -n mythgallery
145 Summary:        A gallery/slideshow module for MythTV
146 Summary(pl):    Modu³ galerii/pokazu slajdów dla MythTV
147 Group:          Applications/Multimedia
148 Requires:       mythtv-frontend-api = %{myth_api_version}
149
150 %description -n mythgallery
151 A gallery/slideshow module for MythTV.
152
153 %description -n mythgallery -l pl
154 Modu³ galerii/pokazu slajdów dla MythTV.
155
156 %package -n mythgame
157 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
158 Summary(pl):    Interfejs do gier (xmame, nes, snes, pc) dla MythTV
159 Group:          Applications/Multimedia
160 Requires:       mythtv-frontend-api = %{myth_api_version}
161
162 %description -n mythgame
163 A game frontend (xmame, nes, snes, pc) for MythTV.
164
165 %description -n mythgame -l pl
166 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
167
168 %package -n mythdvd
169 Summary:        A DVD player module for MythTV
170 Summary(pl):    Modu³ odtwarzacza DVD dla MythTV
171 Group:          Applications/Multimedia
172 Requires:       mythtv-frontend-api = %{myth_api_version}
173 Requires:       transcode >= 0.6.8
174
175 %description -n mythdvd
176 MythDVD is a MythTV module that allows you to play DVDs on a myth-box
177 and (optionally) rip DVD's and transcode their video and audio content
178 to other (generally smaller) formats. The playing features are simply
179 myth-style wrappers for your favourite DVD playing software (mplayer,
180 ogle, xine, etc). The transcoding is based on and derived from the
181 excellent transcode package.
182
183 %description -n mythdvd -l pl
184 MythDVD to modu³ MythTV umo¿liwiaj±cy odtwarzanie p³yt DVD w MythTV i
185 (opcjonalnie) rippowanie ich oraz przekodowywanie obrazu i d¼wiêku do
186 innych (zwykle mniej zajmuj±cych) formatów. Mo¿liwo¶ci odtwarzania to
187 po prostu obudowanie w stylu myth dla ulubionego oprogramowania do
188 odtwarzania DVD (mplayer, ogle, xine itp.). Przekodowywanie jest
189 oparte i wywodzi siê z wspania³ego pakietu transcode.
190
191 %package -n mythnews
192 Summary:        A RSS News Feed plugin for MythTV
193 Summary(pl):    Wtyczka czytnika nowinek RSS dla MythTV
194 Group:          Applications/Multimedia
195 Requires:       mythtv-frontend-api = %{myth_api_version}
196
197 %description -n mythnews
198 A RSS News Feed plugin for MythTV.
199
200 %description -n mythnews -l pl
201 Wtyczka czytnika nowinek RSS dla MythTV.
202
203 %package -n mythbrowser
204 Summary:        A small web browser module for MythTV
205 Summary(pl):    Modu³ ma³ej przegl±darki WWW dla MythTV
206 Group:          Applications/Multimedia
207 Requires:       mythtv-frontend-api = %{myth_api_version}
208
209 %description -n mythbrowser
210 MythBrowser is a full fledged web-browser (multiple tabs) to display
211 webpages in full-screen mode. Simple page navigation is possible.
212 Starting with version 0.13 it also has full support for mouse driven
213 navigation (right mouse opens and closes the popup menu).
214
215 MythBrowser also contains a BookmarkManager to manage the website
216 links in a simple mythplugin.
217
218 %description -n mythbrowser -l pl
219 MythBrowser to w pe³ni funkcjonalna przegl±darka WWW (z wieloma
220 zak³adkami) wy¶wietlaj±ca strony WWW w trybie pe³noekranowym. Mo¿liwa
221 jest prosta nawigacja po stronie. Pocz±wszy od wersji 0.13 ma pe³n±
222 obs³ugê nawigacji myszk± (prawy przycisk otwiera i zamywa wyskakuj±ce
223 menu).
224
225 MythBrowser zawiera tak¿e BookmarkManagera do zarz±dzania odno¶nikami
226 do stron w prostej wtyczce myth.
227
228 %package -n mythphone
229 Summary:        A video conferencing module for MythTV
230 Summary(pl):    Modu³ wideokonferencji dla MythTV
231 Group:          Applications/Multimedia
232 Requires:       mythtv-frontend-api = %{myth_api_version}
233
234 %description -n mythphone
235 Mythphone is a phone and videophone capability on Myth using the
236 standard SIP protocol. It is compatible with Microsoft XP Messenger
237 and with SIP Service Providers such as Free World Dialup
238 (fwd.pulver.com).
239
240 %description -n mythphone -l pl
241 Mythphone to funkcjonalno¶æ telefonu i wideofonu w Myth przy u¿yciu
242 standardowego protoko³u SIP. Jest kompatybilny z Microsoft XP
243 Messengerem oraz dostawcami us³ug SIP, takimi jak Free World Dialup
244 (fwd.pulver.com).
245
246 %package -n mythweb
247 Summary:        The web interface to MythTV
248 Summary(pl):    Interfejs WWW do MythTV
249 Group:          Applications/Multimedia
250 Requires:       webapps
251 #Suggests:      apache(mod_auth)
252 #Suggests:      apache(mod_env)
253 Requires:       php >= 3:4.3
254 Requires:       php-mysql
255 Requires:       php-posix
256
257 %description -n mythweb
258 The web interface to MythTV.
259
260 %description -n mythweb -l pl
261 Interfejs WWW do MythTV.
262
263 %package -n mythflix
264 Summary:        MythFlix (A NetFlix MythTV)
265 Summary(pl):    MythFlix (NetFlix MythTV)
266 Group:          Applications/Multimedia
267 Requires:       mythtv-frontend-api = %{myth_api_version}
268
269 %description -n mythflix
270 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
271 It currently supports the ability to view your queue and add movies to
272 your queue. The browse feature is based on the Netflix RSS feeds. This
273 plugin is not very mature, which means things might not work right
274 and/or it might break other things.
275
276 %description -n mythflix -l pl
277 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
278 Aktualnie daje mo¿liwo¶æ ogl±dania kolejki i dodawania do niej filmów.
279 Przegl±danie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
280 jeszcze zbyt dojrza³a, co znaczy, ¿e co¶ mo¿e nie dzia³aæ lub psuæ co¶
281 innego.
282
283 %package -n mythcontrols
284 Summary:        MythTV keybindings editor
285 Summary(pl):    Edytor przypisañ klawiszy MythTV
286 Group:          Applications/Multimedia
287 Requires:       mythtv-frontend-api = %{myth_api_version}
288
289 %description -n mythcontrols
290 This plugin allows you to configure your keybindings on the frontend
291 without having to use mythweb or edit tables by hand.
292
293 %description -n mythcontrols -l pl
294 Ta wtyczka pozwala konfigurowaæ przypisania klawiszy we frontendzie
295 bez konieczno¶ci u¿ywania mythweba ani rêcznego modyfikowania tabel.
296
297 %prep
298 %setup -q %{?_snap:-n %{name}}
299 %if %{_lib} != "lib"
300 %patch0 -p1
301 %endif
302 %patch1 -p1
303 %patch2 -p1
304 filterdiff -i 'mythplugins/*' %{PATCH3} | %{__patch} -p1 -s
305
306 # make it visible
307 mv mythweb/{.,}htaccess
308
309 # lib64 fix - enable to update patch
310 %if %{_lib} != "lib" && 0
311 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
312 xargs grep -l /lib/ . | xargs sed -i -e '
313         s,/usr/lib/,/usr/%{_lib}/,g
314         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
315 '
316 exit 1
317 %endif
318
319 %build
320 %if %{with binary}
321 export QTDIR="%{_prefix}"
322 # Not gnu configure
323 %configure \
324         --enable-all \
325         %{!?with_mythbrowser:--disable-mythbrowser} \
326         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
327         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
328         %{!?with_mythgame:--disable-mythgame} \
329         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
330         %{!?with_mythnews:--disable-mythnews} \
331         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
332         %{!?with_mythvideo:--disable-mythvideo} \
333         %{!?with_mythweather:--disable-mythweather} \
334         %{!?with_mythweb:--disable-mythweb} \
335         %{!?with_mythcontrols:--disable-mythcontrols} \
336         %{!?with_mythflix:--disable-mythflix} \
337
338 mv mythconfig.mak mythconfig.mak.old
339 cp mythconfig.mak.old mythconfig.mak
340 cat <<'EOF'>> mythconfig.mak
341 QMAKE_CXX=%{__cxx}
342 QMAKE_CC=%{__cc}
343 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
344 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
345 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
346 EOF
347
348 %{__make}
349 %endif
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353
354 %if %{with binary}
355 export QTDIR="%{_prefix}"
356 %{__make} install \
357         INSTALL_ROOT=$RPM_BUILD_ROOT
358
359 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
360 %if %{with mythgame}
361 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
362 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
363 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
364 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
365 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
366 %endif
367 %endif
368
369 %if %{with mythweb}
370 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb/{includes,languages}
371 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
372 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
373 cp -a mythweb/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb
374 cp -a mythweb/languages/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/languages
375 cp -a mythweb/includes/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/includes
376 cp -a mythweb/{images,js,skins,modules,themes,templates} $RPM_BUILD_ROOT%{_datadir}/mythweb
377 cp -a mythweb/config/*.{php,dat} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
378 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
379 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
380 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
381 %endif
382
383 for p in mythmusic mythvideo mythweather mythgallery mythgame mythdvd mythnews mythbrowser mythphone mythflix mythcontrols; do
384         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
385                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
386         done > $p.lang
387 done
388
389 %clean
390 rm -rf $RPM_BUILD_ROOT
391
392 %triggerin -n mythweb -- apache1
393 %webapp_register apache %{_webapp}
394
395 %triggerun -n mythweb -- apache1
396 %webapp_unregister apache %{_webapp}
397
398 %triggerin -n mythweb -- apache < 2.2.0, apache-base
399 %webapp_register httpd %{_webapp}
400
401 %triggerun -n mythweb -- apache < 2.2.0, apache-base
402 %webapp_unregister httpd %{_webapp}
403
404 %triggerpostun -n mythweb -- mythweb < 0.19
405 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
406         if [ -f /etc/mythweb/$i.rpmsave ]; then
407                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
408                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
409         fi
410 done
411 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
412
413 # migrate from apache-config macros
414 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
415         if [ -d /etc/apache/webapps.d ]; then
416                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
417                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
418         fi
419
420         if [ -d /etc/httpd/webapps.d ]; then
421                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
422                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
423         fi
424         rm -f /etc/mythweb/apache.conf.rpmsave
425 fi
426
427 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
428         rm -f /etc/apache/conf.d/99_mythplugins.conf
429         /usr/sbin/webapp register apache %{_webapp}
430         %service -q apache reload
431 fi
432 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
433         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
434         /usr/sbin/webapp register httpd %{_webapp}
435         %service -q httpd reload
436 fi
437
438 %files
439 %defattr(644,root,root,755)
440
441 %if %{with mythmusic}
442 %files -n mythmusic -f mythmusic.lang
443 %defattr(644,root,root,755)
444 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
445 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
446 /var/lib/mythmusic
447 %{_datadir}/mythtv/musicmenu.xml
448 %{_datadir}/mythtv/music_settings.xml
449 %{_datadir}/mythtv/themes/default/music-ui.xml
450 %{_datadir}/mythtv/themes/default/ff_button_off.png
451 %{_datadir}/mythtv/themes/default/ff_button_on.png
452 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
453 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
454 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
455 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
456 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
457 %{_datadir}/mythtv/themes/default/mm_checked.png
458 %{_datadir}/mythtv/themes/default/mm_checked_high.png
459 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
460 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
461 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
462 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
463 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
464 %{_datadir}/mythtv/themes/default/mm_rating.png
465 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
466 %{_datadir}/mythtv/themes/default/mm_unchecked.png
467 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
468 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
469 %{_datadir}/mythtv/themes/default/mm_volume_background.png
470 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
471 %{_datadir}/mythtv/themes/default/mm_waiting.png
472 %{_datadir}/mythtv/themes/default/music-sel-bg.png
473 %{_datadir}/mythtv/themes/default/next_button_off.png
474 %{_datadir}/mythtv/themes/default/next_button_on.png
475 %{_datadir}/mythtv/themes/default/next_button_pushed.png
476 %{_datadir}/mythtv/themes/default/pause_button_off.png
477 %{_datadir}/mythtv/themes/default/pause_button_on.png
478 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
479 %{_datadir}/mythtv/themes/default/play_button_off.png
480 %{_datadir}/mythtv/themes/default/play_button_on.png
481 %{_datadir}/mythtv/themes/default/play_button_pushed.png
482 %{_datadir}/mythtv/themes/default/prev_button_off.png
483 %{_datadir}/mythtv/themes/default/prev_button_on.png
484 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
485 %{_datadir}/mythtv/themes/default/rew_button_off.png
486 %{_datadir}/mythtv/themes/default/rew_button_on.png
487 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
488 %{_datadir}/mythtv/themes/default/selectionbar.png
489 %{_datadir}/mythtv/themes/default/stop_button_off.png
490 %{_datadir}/mythtv/themes/default/stop_button_on.png
491 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
492 %{_datadir}/mythtv/themes/default/text_button_off.png
493 %{_datadir}/mythtv/themes/default/text_button_on.png
494 %{_datadir}/mythtv/themes/default/text_button_pushed.png
495 %{_datadir}/mythtv/themes/default/track_info_background.png
496 %endif
497
498 %if %{with mythvideo}
499 %files -n mythvideo -f mythvideo.lang
500 %defattr(644,root,root,755)
501 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
502 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
503 %{_datadir}/mythtv/themes/default/video-ui.xml
504 %{_datadir}/mythtv/themes/default/mv-*.png
505 %{_datadir}/mythtv/themes/default/mv_*.png
506 %{_datadir}/mythtv/video_settings.xml
507 %{_datadir}/mythtv/videomenu.xml
508 %dir %{_datadir}/mythtv/mythvideo
509 %dir %{_datadir}/mythtv/mythvideo/scripts
510 %{_datadir}/mythtv/mythvideo/scripts/README
511 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
512 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
513 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/ofdb.pl
514 /var/lib/mythvideo
515 %endif
516
517 %if %{with mythweather}
518 %files -n mythweather -f mythweather.lang
519 %defattr(644,root,root,755)
520 %doc mythweather/README
521 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
522 %{_datadir}/mythtv/mythweather
523 %{_datadir}/mythtv/themes/default/weather-ui.xml
524 %{_datadir}/mythtv/themes/default/cloudy.png
525 %{_datadir}/mythtv/themes/default/fair.png
526 %{_datadir}/mythtv/themes/default/flurries.png
527 %{_datadir}/mythtv/themes/default/fog.png
528 %{_datadir}/mythtv/themes/default/logo.png
529 %{_datadir}/mythtv/themes/default/lshowers.png
530 %{_datadir}/mythtv/themes/default/mcloudy.png
531 %{_datadir}/mythtv/themes/default/mw-*.png
532 %{_datadir}/mythtv/themes/default/mwmain.png
533 %{_datadir}/mythtv/themes/default/pcloudy.png
534 %{_datadir}/mythtv/themes/default/rainsnow.png
535 %{_datadir}/mythtv/themes/default/showers.png
536 %{_datadir}/mythtv/themes/default/snowshow.png
537 %{_datadir}/mythtv/themes/default/sunny.png
538 %{_datadir}/mythtv/themes/default/thunshowers.png
539 %{_datadir}/mythtv/themes/default/unknown.png
540 %endif
541
542 %if %{with mythgallery}
543 %files -n mythgallery -f mythgallery.lang
544 %defattr(644,root,root,755)
545 %doc mythgallery/README mythgallery/UPGRADING
546 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
547 %{_datadir}/mythtv/themes/default/gallery-ui.xml
548 %{_datadir}/mythtv/themes/default/gallery-*.png
549 # FIXME: this is definately stupid path
550 /var/lib/pictures
551 %endif
552
553 %if %{with mythgame}
554 %files -n mythgame -f mythgame.lang
555 %defattr(644,root,root,755)
556 %doc mythgame/README mythgame/UPGRADING
557 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
558 %{_datadir}/mythtv/games
559 %{_datadir}/mythtv/game_settings.xml
560 %{_datadir}/mythtv/themes/default/game-ui.xml
561 %endif
562
563 %if %{with mythdvd}
564 %files -n mythdvd -f mythdvd.lang
565 %defattr(644,root,root,755)
566 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
567 %attr(755,root,root) %{_bindir}/mtd
568 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
569 %{_datadir}/mythtv/dvd_settings.xml
570 %{_datadir}/mythtv/dvdmenu.xml
571 %{_datadir}/mythtv/themes/default/dvd-ui.xml
572 %{_datadir}/mythtv/themes/default/md_*.png
573 %endif
574
575 %if %{with mythnews}
576 %files -n mythnews -f mythnews.lang
577 %defattr(644,root,root,755)
578 %doc mythnews/README mythnews/AUTHORS
579 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
580 %{_datadir}/mythtv/mythnews
581 %{_datadir}/mythtv/themes/default/news-ui.xml
582 # DUPLICATE WITH MYTHFLIX?
583 %{_datadir}/mythtv/themes/default/news-info-bg.png
584 %endif
585
586 %if %{with mythbrowser}
587 %files -n mythbrowser -f mythbrowser.lang
588 %defattr(644,root,root,755)
589 %doc mythbrowser/README mythbrowser/AUTHORS
590 %attr(755,root,root) %{_bindir}/mythbrowser
591 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
592 %{_datadir}/mythtv/themes/default/webpage.png
593 %endif
594
595 %if %{with mythphone}
596 %files -n mythphone -f mythphone.lang
597 %defattr(644,root,root,755)
598 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
599 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
600 %{_datadir}/mythtv/themes/default/phone-ui.xml
601 %{_datadir}/mythtv/themes/default/webcam-ui.xml
602 %{_datadir}/mythtv/themes/default/mp_*.png
603 %{_datadir}/mythtv/themes/default/phone.png
604 %endif
605
606 %if %{with mythweb}
607 %files -n mythweb
608 %defattr(644,root,root,755)
609 %doc mythweb/{README,TODO} mythweb/languages/*.{pl,txt}
610 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
611 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
612 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
613 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
614 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
615 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
616 %{_datadir}/mythweb
617 %dir %attr(771,root,http) /var/cache/mythweb
618 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
619 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
620 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
621 %endif
622
623 %if %{with mythflix}
624 %files -n mythflix -f mythflix.lang
625 %defattr(644,root,root,755)
626 %doc mythflix/{AUTHORS,ChangeLog,README}
627 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
628 %dir %{_datadir}/mythtv/mythflix
629 %{_datadir}/mythtv/mythflix/netflix-rss.xml
630 %dir %{_datadir}/mythtv/mythflix/scripts
631 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
632 %{_datadir}/mythtv/netflix_menu.xml
633 %{_datadir}/mythtv/themes/default/title_netflix.png
634 %{_datadir}/mythtv/themes/default/netflix-ui.xml
635 # DUPLICATE WITH MYTHNEWS?
636 %{_datadir}/mythtv/themes/default/news-info-bg.png
637 %endif
638
639 %if %{with mythcontrols}
640 %files -n mythcontrols -f mythcontrols.lang
641 %defattr(644,root,root,755)
642 %doc mythcontrols/{AUTHORS,README,TODO}
643 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
644 %{_datadir}/mythtv/themes/default/controls-ui.xml
645 %{_datadir}/mythtv/themes/default/kb-button-off.png
646 %{_datadir}/mythtv/themes/default/kb-button-on.png
647 %endif
This page took 0.066982 seconds and 4 git commands to generate.