]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- 20060905 snap (svn 11046)
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mythbrowser     # disable building mythbrowser plugin
5 %bcond_without  mythdvd         # disable building mythgallery plugin
6 %bcond_without  mythgallery     # disable building mythgallery plugin
7 %bcond_without  mythgame        # disable building mythgallery plugin
8 %bcond_without  mythmusic       # disable building mythmusic plugin
9 %bcond_without  mythnews        # disable building mythgallery plugin
10 %bcond_without  mythphone       # disable building mythgallery plugin
11 %bcond_without  mythvideo       # disable building mythgallery plugin
12 %bcond_without  mythweather     # disable building mythgallery plugin
13 %bcond_without  mythweb         # disable building mythgallery plugin
14 %bcond_without  mythflix        # disable building mythflix plugin
15 %bcond_without  mythcontrols    # disable mythcontrols plugin
16 #
17 %if %{without binary}
18 %undefine       with_mythbrowser
19 %undefine       with_mythdvd
20 %undefine       with_mythgallery
21 %undefine       with_mythgame
22 %undefine       with_mythmusic
23 %undefine       with_mythnews
24 %undefine       with_mythphone
25 %undefine       with_mythvideo
26 %undefine       with_mythweather
27 %undefine       with_mythcontrols
28 %undefine       with_mythflix
29 %endif
30
31 %include        /usr/lib/rpm/macros.perl
32
33 %define _snap 20060905
34 %define _rev 11046
35 %define _rel 0.1
36 Summary:        Main MythTV plugins
37 Summary(pl):    G³ówne wtyczki MythTV
38 Name:           mythplugins
39 Version:        0.19
40 Release:        0.%{_snap}.%{_rev}.%{_rel}
41 License:        GPL v2
42 Group:          Applications/Multimedia
43 #Source0:       http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
44 Source0:        %{name}-%{_snap}.%{_rev}.tar.bz2
45 # Source0-md5:  0d654e21fe60c03fecfafe416b71fe51
46 Source1:        mythweb.conf
47 Patch0:         %{name}-lib64.patch
48 Patch1:         %{name}-paths.patch
49 Patch2:         mythweb-config.patch
50 Patch100:       mythtv-branch.diff
51 URL:            http://www.mythtv.org/
52 %if %{with binary}
53 %if %{with mythgallery} || %{with myhtmusic}
54 BuildRequires:  OpenGL-devel
55 %endif
56 BuildRequires:  SDL-devel
57 BuildRequires:  XFree86-devel
58 BuildRequires:  a52dec-libs-devel
59 BuildRequires:  patchutils
60 BuildRequires:  cdparanoia-III-devel
61 BuildRequires:  faad2-devel >= 2.0-5.2
62 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
63 BuildRequires:  flac-devel >= 1.0.4
64 BuildRequires:  freetype-devel
65 BuildRequires:  kdelibs-devel
66 BuildRequires:  libcdaudio-devel >= 0.99.12p2
67 BuildRequires:  libdvdcss-devel >= 1.2.7
68 BuildRequires:  libdvdread-devel >= 0.9.4
69 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
70 BuildRequires:  libfame-devel >= 0.9.0
71 BuildRequires:  libid3tag-devel
72 BuildRequires:  libmad-devel
73 BuildRequires:  libmyth-devel >= 0.19
74 BuildRequires:  libstdc++-devel
75 BuildRequires:  libtiff-devel
76 BuildRequires:  libvorbis-devel >= 1:1.0
77 BuildRequires:  mjpegtools-devel >= 1.6.1
78 BuildRequires:  nasm
79 BuildRequires:  rpm-perlprov >= 4.1-13
80 BuildRequires:  sed >= 4.0
81 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
82 BuildRequires:  xvid-devel >= 1:0.9.1
83 BuildRequires:  zlib-devel
84 %endif
85 %{?with_mythbrowser:Requires:   mythbrowser}
86 %{?with_mythdvd:Requires:       mythdvd}
87 %{?with_mythflix:Requires:      mythflix}
88 %{?with_mythgallery:Requires:   mythgallery}
89 %{?with_mythgame:Requires:      mythgame}
90 %{?with_mythmysic:Requires:     mythmusic}
91 %{?with_mythnews:Requires:      mythnews}
92 %{?with_mythphone:Requires:     mythphone}
93 %{?with_mythvideo:Requires:     mythvideo}
94 %{?with_mythweather:Requires:   mythweather}
95 %{?with_mythweb:Requires:       mythweb}
96 ExclusiveArch:  %{ix86} %{x8664} ppc
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
100 %define         _webapps        /etc/webapps
101 %define         _webapp         mythweb
102
103 %description
104 This is a consolidation of all the official MythTV plugins that used
105 to be distributed as separate downloads from mythtv.org.
106
107 %description -l pl
108 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które by³y
109 wcze¶niej rozpowszechniane jako osobne pakiety na mythtv.org.
110
111 %package -n mythmusic
112 Summary:        The music player add-on module for MythTV
113 Summary(pl):    Modu³ odtwarzacza muzyki dla MythTV
114 Group:          Applications/Multimedia
115 Requires:       mythtv-frontend-api = %{myth_api_version}
116
117 %description -n mythmusic
118 Music add-on for MythTV.
119
120 %description -n mythmusic -l pl
121 Odtwarzacz muzyki dla MythTV.
122
123 %package -n mythvideo
124 Summary:        A generic video player frontend module for MythTV
125 Summary(pl):    Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV
126 Group:          Applications/Multimedia
127 Requires:       mplayer
128 Requires:       mythtv-frontend-api = %{myth_api_version}
129
130 %description -n mythvideo
131 A generic video player frontend module for MythTV.
132
133 %description -n mythvideo -l pl
134 Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV.
135
136 %package -n mythweather
137 Summary:        A MythTV module that displays a weather forcast
138 Summary(pl):    Modu³ MythTV wy¶wietlaj±cy prognozê pogody
139 Group:          Applications/Multimedia
140 Requires:       mythtv-frontend-api = %{myth_api_version}
141
142 %description -n mythweather
143 A MythTV module that displays a weather forcast.
144
145 %description -n mythweather -l pl
146 Modu³ MythTV wy¶wietlaj±cy prognozê pogody.
147
148 %package -n mythgallery
149 Summary:        A gallery/slideshow module for MythTV
150 Summary(pl):    Modu³ galerii/pokazu slajdów dla MythTV
151 Group:          Applications/Multimedia
152 Requires:       mythtv-frontend-api = %{myth_api_version}
153
154 %description -n mythgallery
155 A gallery/slideshow module for MythTV.
156
157 %description -n mythgallery -l pl
158 Modu³ galerii/pokazu slajdów dla MythTV.
159
160 %package -n mythgame
161 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
162 Summary(pl):    Interfejs do gier (xmame, nes, snes, pc) dla MythTV
163 Group:          Applications/Multimedia
164 Requires:       mythtv-frontend-api = %{myth_api_version}
165
166 %description -n mythgame
167 A game frontend (xmame, nes, snes, pc) for MythTV.
168
169 %description -n mythgame -l pl
170 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
171
172 %package -n mythdvd
173 Summary:        A DVD player module for MythTV
174 Summary(pl):    Modu³ odtwarzacza DVD dla MythTV
175 Group:          Applications/Multimedia
176 Requires:       mythtv-frontend-api = %{myth_api_version}
177 Requires:       transcode >= 0.6.8
178
179 %description -n mythdvd
180 MythDVD is a MythTV module that allows you to play DVDs on a myth-box
181 and (optionally) rip DVD's and transcode their video and audio content
182 to other (generally smaller) formats. The playing features are simply
183 myth-style wrappers for your favourite DVD playing software (mplayer,
184 ogle, xine, etc). The transcoding is based on and derived from the
185 excellent transcode package.
186
187 %description -n mythdvd -l pl
188 MythDVD to modu³ MythTV umo¿liwiaj±cy odtwarzanie p³yt DVD w MythTV i
189 (opcjonalnie) rippowanie ich oraz przekodowywanie obrazu i d¼wiêku do
190 innych (zwykle mniej zajmuj±cych) formatów. Mo¿liwo¶ci odtwarzania to
191 po prostu obudowanie w stylu myth dla ulubionego oprogramowania do
192 odtwarzania DVD (mplayer, ogle, xine itp.). Przekodowywanie jest
193 oparte i wywodzi siê z wspania³ego pakietu transcode.
194
195 %package -n mythnews
196 Summary:        A RSS News Feed plugin for MythTV
197 Summary(pl):    Wtyczka czytnika nowinek RSS dla MythTV
198 Group:          Applications/Multimedia
199 Requires:       mythtv-frontend-api = %{myth_api_version}
200
201 %description -n mythnews
202 A RSS News Feed plugin for MythTV.
203
204 %description -n mythnews -l pl
205 Wtyczka czytnika nowinek RSS dla MythTV.
206
207 %package -n mythbrowser
208 Summary:        A small web browser module for MythTV
209 Summary(pl):    Modu³ ma³ej przegl±darki WWW dla MythTV
210 Group:          Applications/Multimedia
211 Requires:       mythtv-frontend-api = %{myth_api_version}
212
213 %description -n mythbrowser
214 MythBrowser is a full fledged web-browser (multiple tabs) to display
215 webpages in full-screen mode. Simple page navigation is possible.
216 Starting with version 0.13 it also has full support for mouse driven
217 navigation (right mouse opens and closes the popup menu).
218
219 MythBrowser also contains a BookmarkManager to manage the website
220 links in a simple mythplugin.
221
222 %description -n mythbrowser -l pl
223 MythBrowser to w pe³ni funkcjonalna przegl±darka WWW (z wieloma
224 zak³adkami) wy¶wietlaj±ca strony WWW w trybie pe³noekranowym. Mo¿liwa
225 jest prosta nawigacja po stronie. Pocz±wszy od wersji 0.13 ma pe³n±
226 obs³ugê nawigacji myszk± (prawy przycisk otwiera i zamywa wyskakuj±ce
227 menu).
228
229 MythBrowser zawiera tak¿e BookmarkManagera do zarz±dzania odno¶nikami
230 do stron w prostej wtyczce myth.
231
232 %package -n mythphone
233 Summary:        A video conferencing module for MythTV
234 Summary(pl):    Modu³ wideokonferencji dla MythTV
235 Group:          Applications/Multimedia
236 Requires:       mythtv-frontend-api = %{myth_api_version}
237
238 %description -n mythphone
239 Mythphone is a phone and videophone capability on Myth using the
240 standard SIP protocol. It is compatible with Microsoft XP Messenger
241 and with SIP Service Providers such as Free World Dialup
242 (fwd.pulver.com).
243
244 %description -n mythphone -l pl
245 Mythphone to funkcjonalno¶æ telefonu i wideofonu w Myth przy u¿yciu
246 standardowego protoko³u SIP. Jest kompatybilny z Microsoft XP
247 Messengerem oraz dostawcami us³ug SIP, takimi jak Free World Dialup
248 (fwd.pulver.com).
249
250 %package -n mythweb
251 Summary:        The web interface to MythTV
252 Summary(pl):    Interfejs WWW do MythTV
253 Group:          Applications/Multimedia
254 Requires:       webapps
255 #Suggests:      apache(mod_auth)
256 #Suggests:      apache(mod_env)
257 Requires:       php >= 3:4.3
258 Requires:       php-mysql
259 Requires:       php-posix
260
261 %description -n mythweb
262 The web interface to MythTV.
263
264 %description -n mythweb -l pl
265 Interfejs WWW do MythTV.
266
267 %package -n mythflix
268 Summary:        MythFlix (A NetFlix MythTV)
269 Summary(pl):    MythFlix (NetFlix MythTV)
270 Group:          Applications/Multimedia
271 Requires:       mythtv-frontend-api = %{myth_api_version}
272
273 %description -n mythflix
274 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
275 It currently supports the ability to view your queue and add movies to
276 your queue. The browse feature is based on the Netflix RSS feeds. This
277 plugin is not very mature, which means things might not work right
278 and/or it might break other things.
279
280 %description -n mythflix -l pl
281 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
282 Aktualnie daje mo¿liwo¶æ ogl±dania kolejki i dodawania do niej filmów.
283 Przegl±danie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
284 jeszcze zbyt dojrza³a, co znaczy, ¿e co¶ mo¿e nie dzia³aæ lub psuæ co¶
285 innego.
286
287 %package -n mythcontrols
288 Summary:        MythTV keybindings editor
289 Summary(pl):    Edytor przypisañ klawiszy MythTV
290 Group:          Applications/Multimedia
291 Requires:       mythtv-frontend-api = %{myth_api_version}
292
293 %description -n mythcontrols
294 This plugin allows you to configure your keybindings on the frontend
295 without having to use mythweb or edit tables by hand.
296
297 %description -n mythcontrols -l pl
298 Ta wtyczka pozwala konfigurowaæ przypisania klawiszy we frontendzie
299 bez konieczno¶ci u¿ywania mythweba ani rêcznego modyfikowania tabel.
300
301 %prep
302 %setup -q %{?_snap:-n %{name}}
303 %if %{_lib} != "lib"
304 #%patch0 -p1
305 %endif
306 %patch1 -p1
307 %patch2 -p1
308 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
309
310 # make it visible
311 mv mythweb/{.,}htaccess
312
313 # lib64 fix - enable to update patch
314 %if %{_lib} != "lib" && 0
315 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
316 xargs grep -l /lib/ . | xargs sed -i -e '
317         s,/usr/lib/,/usr/%{_lib}/,g
318         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
319 '
320 exit 1
321 %endif
322
323 %build
324 %if %{with binary}
325 export QTDIR="%{_prefix}"
326 # Not gnu configure
327 %configure \
328         --libdir-name=%{_lib} \
329         --enable-all \
330         %{!?with_mythbrowser:--disable-mythbrowser} \
331         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
332         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
333         %{!?with_mythgame:--disable-mythgame} \
334         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
335         %{!?with_mythnews:--disable-mythnews} \
336         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
337         %{!?with_mythvideo:--disable-mythvideo} \
338         %{!?with_mythweather:--disable-mythweather} \
339         %{!?with_mythweb:--disable-mythweb} \
340         %{!?with_mythcontrols:--disable-mythcontrols} \
341         %{!?with_mythflix:--disable-mythflix} \
342
343 mv mythconfig.mak mythconfig.mak.old
344 cp mythconfig.mak.old mythconfig.mak
345 cat <<'EOF'>> mythconfig.mak
346 QMAKE_CXX=%{__cxx}
347 QMAKE_CC=%{__cc}
348 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
349 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
350 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
351 EOF
352
353 %{__make}
354 %endif
355
356 %install
357 rm -rf $RPM_BUILD_ROOT
358
359 %if %{with binary}
360 export QTDIR="%{_prefix}"
361 %{__make} install \
362         INSTALL_ROOT=$RPM_BUILD_ROOT
363
364 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
365 %if %{with mythgame}
366 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
367 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
368 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
369 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
370 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
371 %endif
372 %endif
373
374 %if %{with mythweb}
375 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb/{includes,languages}
376 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
377 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
378 cp -a mythweb/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb
379 cp -a mythweb/languages/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/languages
380 cp -a mythweb/includes/*.php $RPM_BUILD_ROOT%{_datadir}/mythweb/includes
381 cp -a mythweb/{images,js,skins,modules,themes,templates} $RPM_BUILD_ROOT%{_datadir}/mythweb
382 cp -a mythweb/config/*.{php,dat} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
383 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
384 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
385 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
386 %endif
387
388 for p in mythmusic mythvideo mythweather mythgallery mythgame mythdvd mythnews mythbrowser mythphone mythflix mythcontrols; do
389         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
390                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
391         done > $p.lang
392 done
393
394 %clean
395 rm -rf $RPM_BUILD_ROOT
396
397 %triggerin -n mythweb -- apache1
398 %webapp_register apache %{_webapp}
399
400 %triggerun -n mythweb -- apache1
401 %webapp_unregister apache %{_webapp}
402
403 %triggerin -n mythweb -- apache < 2.2.0, apache-base
404 %webapp_register httpd %{_webapp}
405
406 %triggerun -n mythweb -- apache < 2.2.0, apache-base
407 %webapp_unregister httpd %{_webapp}
408
409 %triggerpostun -n mythweb -- mythweb < 0.19
410 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
411         if [ -f /etc/mythweb/$i.rpmsave ]; then
412                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
413                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
414         fi
415 done
416 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
417
418 # migrate from apache-config macros
419 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
420         if [ -d /etc/apache/webapps.d ]; then
421                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
422                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
423         fi
424
425         if [ -d /etc/httpd/webapps.d ]; then
426                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
427                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
428         fi
429         rm -f /etc/mythweb/apache.conf.rpmsave
430 fi
431
432 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
433         rm -f /etc/apache/conf.d/99_mythplugins.conf
434         /usr/sbin/webapp register apache %{_webapp}
435         %service -q apache reload
436 fi
437 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
438         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
439         /usr/sbin/webapp register httpd %{_webapp}
440         %service -q httpd reload
441 fi
442
443 %files
444 %defattr(644,root,root,755)
445
446 %if %{with mythmusic}
447 %files -n mythmusic -f mythmusic.lang
448 %defattr(644,root,root,755)
449 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
450 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
451 /var/lib/mythmusic
452 %{_datadir}/mythtv/musicmenu.xml
453 %{_datadir}/mythtv/music_settings.xml
454 %{_datadir}/mythtv/themes/default/music-ui.xml
455 %{_datadir}/mythtv/themes/default/ff_button_off.png
456 %{_datadir}/mythtv/themes/default/ff_button_on.png
457 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
458 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
459 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
460 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
461 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
462 %{_datadir}/mythtv/themes/default/mm_checked.png
463 %{_datadir}/mythtv/themes/default/mm_checked_high.png
464 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
465 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
466 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
467 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
468 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
469 %{_datadir}/mythtv/themes/default/mm_rating.png
470 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
471 %{_datadir}/mythtv/themes/default/mm_unchecked.png
472 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
473 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
474 %{_datadir}/mythtv/themes/default/mm_volume_background.png
475 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
476 %{_datadir}/mythtv/themes/default/mm_waiting.png
477 %{_datadir}/mythtv/themes/default/music-sel-bg.png
478 %{_datadir}/mythtv/themes/default/next_button_off.png
479 %{_datadir}/mythtv/themes/default/next_button_on.png
480 %{_datadir}/mythtv/themes/default/next_button_pushed.png
481 %{_datadir}/mythtv/themes/default/pause_button_off.png
482 %{_datadir}/mythtv/themes/default/pause_button_on.png
483 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
484 %{_datadir}/mythtv/themes/default/play_button_off.png
485 %{_datadir}/mythtv/themes/default/play_button_on.png
486 %{_datadir}/mythtv/themes/default/play_button_pushed.png
487 %{_datadir}/mythtv/themes/default/prev_button_off.png
488 %{_datadir}/mythtv/themes/default/prev_button_on.png
489 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
490 %{_datadir}/mythtv/themes/default/rew_button_off.png
491 %{_datadir}/mythtv/themes/default/rew_button_on.png
492 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
493 %{_datadir}/mythtv/themes/default/selectionbar.png
494 %{_datadir}/mythtv/themes/default/stop_button_off.png
495 %{_datadir}/mythtv/themes/default/stop_button_on.png
496 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
497 %{_datadir}/mythtv/themes/default/text_button_off.png
498 %{_datadir}/mythtv/themes/default/text_button_on.png
499 %{_datadir}/mythtv/themes/default/text_button_pushed.png
500 %{_datadir}/mythtv/themes/default/track_info_background.png
501 %endif
502
503 %if %{with mythvideo}
504 %files -n mythvideo -f mythvideo.lang
505 %defattr(644,root,root,755)
506 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
507 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
508 %{_datadir}/mythtv/themes/default/video-ui.xml
509 %{_datadir}/mythtv/themes/default/mv-*.png
510 %{_datadir}/mythtv/themes/default/mv_*.png
511 %{_datadir}/mythtv/video_settings.xml
512 %{_datadir}/mythtv/videomenu.xml
513 %dir %{_datadir}/mythtv/mythvideo
514 %dir %{_datadir}/mythtv/mythvideo/scripts
515 %{_datadir}/mythtv/mythvideo/scripts/README
516 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
517 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
518 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/ofdb.pl
519 /var/lib/mythvideo
520 %endif
521
522 %if %{with mythweather}
523 %files -n mythweather -f mythweather.lang
524 %defattr(644,root,root,755)
525 %doc mythweather/README
526 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
527 %{_datadir}/mythtv/mythweather
528 %{_datadir}/mythtv/themes/default/weather-ui.xml
529 %{_datadir}/mythtv/themes/default/cloudy.png
530 %{_datadir}/mythtv/themes/default/fair.png
531 %{_datadir}/mythtv/themes/default/flurries.png
532 %{_datadir}/mythtv/themes/default/fog.png
533 %{_datadir}/mythtv/themes/default/logo.png
534 %{_datadir}/mythtv/themes/default/lshowers.png
535 %{_datadir}/mythtv/themes/default/mcloudy.png
536 %{_datadir}/mythtv/themes/default/mw-*.png
537 %{_datadir}/mythtv/themes/default/mwmain.png
538 %{_datadir}/mythtv/themes/default/pcloudy.png
539 %{_datadir}/mythtv/themes/default/rainsnow.png
540 %{_datadir}/mythtv/themes/default/showers.png
541 %{_datadir}/mythtv/themes/default/snowshow.png
542 %{_datadir}/mythtv/themes/default/sunny.png
543 %{_datadir}/mythtv/themes/default/thunshowers.png
544 %{_datadir}/mythtv/themes/default/unknown.png
545 %endif
546
547 %if %{with mythgallery}
548 %files -n mythgallery -f mythgallery.lang
549 %defattr(644,root,root,755)
550 %doc mythgallery/README mythgallery/UPGRADING
551 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
552 %{_datadir}/mythtv/themes/default/gallery-ui.xml
553 %{_datadir}/mythtv/themes/default/gallery-*.png
554 # FIXME: this is definately stupid path
555 /var/lib/pictures
556 %endif
557
558 %if %{with mythgame}
559 %files -n mythgame -f mythgame.lang
560 %defattr(644,root,root,755)
561 %doc mythgame/README mythgame/UPGRADING
562 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
563 %{_datadir}/mythtv/games
564 %{_datadir}/mythtv/game_settings.xml
565 %{_datadir}/mythtv/themes/default/game-ui.xml
566 %endif
567
568 %if %{with mythdvd}
569 %files -n mythdvd -f mythdvd.lang
570 %defattr(644,root,root,755)
571 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
572 %attr(755,root,root) %{_bindir}/mtd
573 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
574 %{_datadir}/mythtv/dvd_settings.xml
575 %{_datadir}/mythtv/dvdmenu.xml
576 %{_datadir}/mythtv/themes/default/dvd-ui.xml
577 %{_datadir}/mythtv/themes/default/md_*.png
578 %endif
579
580 %if %{with mythnews}
581 %files -n mythnews -f mythnews.lang
582 %defattr(644,root,root,755)
583 %doc mythnews/README mythnews/AUTHORS
584 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
585 %{_datadir}/mythtv/mythnews
586 %{_datadir}/mythtv/themes/default/news-ui.xml
587 # DUPLICATE WITH MYTHFLIX?
588 %{_datadir}/mythtv/themes/default/news-info-bg.png
589 %endif
590
591 %if %{with mythbrowser}
592 %files -n mythbrowser -f mythbrowser.lang
593 %defattr(644,root,root,755)
594 %doc mythbrowser/README mythbrowser/AUTHORS
595 %attr(755,root,root) %{_bindir}/mythbrowser
596 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
597 %{_datadir}/mythtv/themes/default/webpage.png
598 %endif
599
600 %if %{with mythphone}
601 %files -n mythphone -f mythphone.lang
602 %defattr(644,root,root,755)
603 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
604 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
605 %{_datadir}/mythtv/themes/default/phone-ui.xml
606 %{_datadir}/mythtv/themes/default/webcam-ui.xml
607 %{_datadir}/mythtv/themes/default/mp_*.png
608 %{_datadir}/mythtv/themes/default/phone.png
609 %endif
610
611 %if %{with mythweb}
612 %files -n mythweb
613 %defattr(644,root,root,755)
614 %doc mythweb/{README,TODO} mythweb/languages/*.{pl,txt}
615 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
617 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
618 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
619 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
620 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
621 %{_datadir}/mythweb
622 %dir %attr(771,root,http) /var/cache/mythweb
623 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
624 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
625 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
626 %endif
627
628 %if %{with mythflix}
629 %files -n mythflix -f mythflix.lang
630 %defattr(644,root,root,755)
631 %doc mythflix/{AUTHORS,ChangeLog,README}
632 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
633 %dir %{_datadir}/mythtv/mythflix
634 %{_datadir}/mythtv/mythflix/netflix-rss.xml
635 %dir %{_datadir}/mythtv/mythflix/scripts
636 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
637 %{_datadir}/mythtv/netflix_menu.xml
638 %{_datadir}/mythtv/themes/default/title_netflix.png
639 %{_datadir}/mythtv/themes/default/netflix-ui.xml
640 # DUPLICATE WITH MYTHNEWS?
641 %{_datadir}/mythtv/themes/default/news-info-bg.png
642 %endif
643
644 %if %{with mythcontrols}
645 %files -n mythcontrols -f mythcontrols.lang
646 %defattr(644,root,root,755)
647 %doc mythcontrols/{AUTHORS,README,TODO}
648 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
649 %{_datadir}/mythtv/themes/default/controls-ui.xml
650 %{_datadir}/mythtv/themes/default/kb-button-off.png
651 %{_datadir}/mythtv/themes/default/kb-button-on.png
652 %endif
This page took 0.108102 seconds and 4 git commands to generate.