]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- proper permissions for mythweather scripts
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # TODO:
3 #       - fix mytharchive
4 #       - check 64-bit build
5 #
6 # Conditional build:
7 %bcond_without  binary          # skip building binary plugins (build only mythweb)
8 %bcond_with     mytharchive     # enable mytharchive plugin
9 %bcond_without  mythbrowser     # disable building mythbrowser plugin
10 %bcond_without  mythcontrols    # disable mythcontrols plugin
11 %bcond_without  mythflix        # disable building mythflix plugin
12 %bcond_without  mythgallery     # disable building mythgallery plugin
13 %bcond_without  mythgame        # disable building mythgallery plugin
14 %bcond_without  mythmusic       # disable building mythmusic plugin
15 %bcond_without  mythnews        # disable building mythgallery plugin
16 %bcond_without  mythphone       # disable building mythgallery plugin
17 %bcond_without  mythvideo       # disable building mythgallery plugin
18 %bcond_without  mythweather     # disable building mythgallery plugin
19 %bcond_without  mythweb         # disable building mythgallery plugin
20 %bcond_without  mythmovies      # disable building mythmovies plugin
21 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
22 #
23 %if !%{with binary}
24 %undefine       with_mytharchive
25 %undefine       with_mythbrowser
26 %undefine       with_mythcontrols
27 %undefine       with_mythflix
28 %undefine       with_mythgallery
29 %undefine       with_mythgame
30 %undefine       with_mythmusic
31 %undefine       with_mythnews
32 %undefine       with_mythphone
33 %undefine       with_mythvideo
34 %undefine       with_mythweather
35 %undefine       with_mythmovies
36 %undefine       with_mythzoneminder
37 %endif
38
39 %include        /usr/lib/rpm/macros.perl
40
41 #define _snap 20060905
42 #define _rev 11046
43 %define _rel 0.1
44 Summary:        Main MythTV plugins
45 Summary(pl.UTF-8):      Główne wtyczki MythTV
46 Name:           mythplugins
47 Version:        0.21
48 Release:        %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
49 License:        GPL v2
50 Group:          Applications/Multimedia
51 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
52 # Source0-md5:  6c08043227bef1384858deee12b5cdc3
53 #Source0:       %{name}-%{_snap}.%{_rev}.tar.bz2
54 Source1:        mythweb.conf
55 Patch0:         %{name}-paths.patch
56 URL:            http://www.mythtv.org/
57 %if %{with binary}
58 %if %{with mythgallery} || %{with myhtmusic}
59 BuildRequires:  OpenGL-devel
60 %endif
61 BuildRequires:  SDL-devel
62 BuildRequires:  a52dec-libs-devel
63 BuildRequires:  cdparanoia-III-devel
64 BuildRequires:  faad2-devel >= 2.0-5.2
65 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
66 BuildRequires:  flac-devel >= 1.0.4
67 BuildRequires:  freetype-devel
68 BuildRequires:  kdelibs-devel
69 BuildRequires:  libcdaudio-devel >= 0.99.12p2
70 BuildRequires:  libdvdcss-devel >= 1.2.7
71 BuildRequires:  libdvdread-devel >= 0.9.4
72 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
73 BuildRequires:  libfame-devel >= 0.9.0
74 BuildRequires:  libid3tag-devel
75 BuildRequires:  libmad-devel
76 BuildRequires:  libmyth-devel >= 0.21
77 BuildRequires:  libstdc++-devel
78 BuildRequires:  libtiff-devel
79 BuildRequires:  libvorbis-devel >= 1:1.0
80 BuildRequires:  mjpegtools-devel >= 1.6.1
81 BuildRequires:  nasm
82 BuildRequires:  patchutils
83 BuildRequires:  rpm-perlprov >= 4.1-13
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  xvid-devel >= 1:0.9.1
86 BuildRequires:  zlib-devel
87 BuildRequires:  xorg-lib-libXext-devel
88 BuildRequires:  xorg-lib-libXxf86vm-devel
89 %endif
90 %{?with_mytharchive:Requires:   mytharchive}
91 %{?with_mythbrowser:Requires:   mythbrowser}
92 %{?with_mythflix:Requires:      mythflix}
93 %{?with_mythgallery:Requires:   mythgallery}
94 %{?with_mythgame:Requires:      mythgame}
95 %{?with_mythmysic:Requires:     mythmusic}
96 %{?with_mythnews:Requires:      mythnews}
97 %{?with_mythphone:Requires:     mythphone}
98 %{?with_mythvideo:Requires:     mythvideo}
99 %{?with_mythweather:Requires:   mythweather}
100 %{?with_mythweb:Requires:       mythweb}
101 %{?with_mythmovies:Requires:    mythmovies}
102 %{?with_mythzoneminder:Requires:        mythzoneminder}
103 ExclusiveArch:  %{ix86} %{x8664} ppc
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
107 %define         _webapps        /etc/webapps
108 %define         _webapp         mythweb
109
110 %description
111 This is a consolidation of all the official MythTV plugins that used
112 to be distributed as separate downloads from mythtv.org.
113
114 %description -l pl.UTF-8
115 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
116 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
117
118 %package -n mytharchive
119 Summary:        A MythTV module to create and burn DVDs
120 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
121 Group:          Applications/Multimedia
122 Requires:       mythtv-frontend-api = %{myth_api_version}
123
124 %description -n mytharchive
125 MythArchive is a MythTV style plugin that uses the Mythburn Script to
126 create and burn DVDs from MythTV recordings, MythVideo files or any
127 video files available on a MythTV system. It can also export
128 recordings to a native archive format that can then be imported back
129 into a MythTV system restoring all the associated metadata.
130
131 %description -n mytharchive -l pl.UTF-8
132 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
133 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
134 innych plików z filmami dostępnych w systemie MythTV. Może także
135 eksportować nagrania do natywnego formatu archiwum, który potem można
136 zaimportować z powrotem do systemu MythTV przywracając wszystkie
137 związane z nimi metadane.
138
139 %package -n mythmusic
140 Summary:        The music player add-on module for MythTV
141 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
142 Group:          Applications/Multimedia
143 Requires:       mythtv-frontend-api = %{myth_api_version}
144
145 %description -n mythmusic
146 Music add-on for MythTV.
147
148 %description -n mythmusic -l pl.UTF-8
149 Odtwarzacz muzyki dla MythTV.
150
151 %package -n mythvideo
152 Summary:        A generic video player frontend module for MythTV
153 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
154 Group:          Applications/Multimedia
155 Requires:       mplayer
156 Requires:       mythtv-frontend-api = %{myth_api_version}
157
158 %description -n mythvideo
159 A generic video player frontend module for MythTV.
160
161 %description -n mythvideo -l pl.UTF-8
162 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
163
164 %package -n mythweather
165 Summary:        A MythTV module that displays a weather forcast
166 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
167 Group:          Applications/Multimedia
168 Requires:       mythtv-frontend-api = %{myth_api_version}
169
170 %description -n mythweather
171 A MythTV module that displays a weather forcast.
172
173 %description -n mythweather -l pl.UTF-8
174 Moduł MythTV wyświetlający prognozę pogody.
175
176 %package -n mythgallery
177 Summary:        A gallery/slideshow module for MythTV
178 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
179 Group:          Applications/Multimedia
180 Requires:       mythtv-frontend-api = %{myth_api_version}
181
182 %description -n mythgallery
183 A gallery/slideshow module for MythTV.
184
185 %description -n mythgallery -l pl.UTF-8
186 Moduł galerii/pokazu slajdów dla MythTV.
187
188 %package -n mythgame
189 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
190 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
191 Group:          Applications/Multimedia
192 Requires:       mythtv-frontend-api = %{myth_api_version}
193
194 %description -n mythgame
195 A game frontend (xmame, nes, snes, pc) for MythTV.
196
197 %description -n mythgame -l pl.UTF-8
198 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
199
200 %package -n mythnews
201 Summary:        A RSS News Feed plugin for MythTV
202 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
203 Group:          Applications/Multimedia
204 Requires:       mythtv-frontend-api = %{myth_api_version}
205
206 %description -n mythnews
207 A RSS News Feed plugin for MythTV.
208
209 %description -n mythnews -l pl.UTF-8
210 Wtyczka czytnika nowinek RSS dla MythTV.
211
212 %package -n mythbrowser
213 Summary:        A small web browser module for MythTV
214 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
215 Group:          Applications/Multimedia
216 Requires:       mythtv-frontend-api = %{myth_api_version}
217
218 %description -n mythbrowser
219 MythBrowser is a full fledged web-browser (multiple tabs) to display
220 webpages in full-screen mode. Simple page navigation is possible.
221 Starting with version 0.13 it also has full support for mouse driven
222 navigation (right mouse opens and closes the popup menu).
223
224 MythBrowser also contains a BookmarkManager to manage the website
225 links in a simple mythplugin.
226
227 %description -n mythbrowser -l pl.UTF-8
228 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
229 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
230 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
231 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
232 menu).
233
234 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
235 do stron w prostej wtyczce myth.
236
237 %package -n mythphone
238 Summary:        A video conferencing module for MythTV
239 Summary(pl.UTF-8):      Moduł wideokonferencji dla MythTV
240 Group:          Applications/Multimedia
241 Requires:       mythtv-frontend-api = %{myth_api_version}
242
243 %description -n mythphone
244 Mythphone is a phone and videophone capability on Myth using the
245 standard SIP protocol. It is compatible with Microsoft XP Messenger
246 and with SIP Service Providers such as Free World Dialup
247 (fwd.pulver.com).
248
249 %description -n mythphone -l pl.UTF-8
250 Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
251 standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
252 Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
253 (fwd.pulver.com).
254
255 %package -n mythweb
256 Summary:        The web interface to MythTV
257 Summary(pl.UTF-8):      Interfejs WWW do MythTV
258 Group:          Applications/Multimedia
259 Requires:       webapps
260 #Suggests:      apache(mod_auth)
261 #Suggests:      apache(mod_env)
262 Requires:       php(mysql)
263 Requires:       php(posix)
264 Requires:       webserver(php) >= 4.3
265
266 %description -n mythweb
267 The web interface to MythTV.
268
269 %description -n mythweb -l pl.UTF-8
270 Interfejs WWW do MythTV.
271
272 %package -n mythflix
273 Summary:        MythFlix (A NetFlix MythTV)
274 Summary(pl.UTF-8):      MythFlix (NetFlix MythTV)
275 Group:          Applications/Multimedia
276 Requires:       mythtv-frontend-api = %{myth_api_version}
277
278 %description -n mythflix
279 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
280 It currently supports the ability to view your queue and add movies to
281 your queue. The browse feature is based on the Netflix RSS feeds. This
282 plugin is not very mature, which means things might not work right
283 and/or it might break other things.
284
285 %description -n mythflix -l pl.UTF-8
286 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
287 Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
288 Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
289 jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
290 innego.
291
292 %package -n mythcontrols
293 Summary:        MythTV keybindings editor
294 Summary(pl.UTF-8):      Edytor przypisań klawiszy MythTV
295 Group:          Applications/Multimedia
296 Requires:       mythtv-frontend-api = %{myth_api_version}
297
298 %description -n mythcontrols
299 This plugin allows you to configure your keybindings on the frontend
300 without having to use mythweb or edit tables by hand.
301
302 %description -n mythcontrols -l pl.UTF-8
303 Ta wtyczka pozwala konfigurować przypisania klawiszy we frontendzie
304 bez konieczności używania mythweba ani ręcznego modyfikowania tabel.
305
306 %package -n mythmovies
307 Summary:        MythTV plugin for looking up movie showtimes in a given area
308 Group:          Applications/Multimedia
309 Requires:       mythtv-frontend-api = %{myth_api_version}
310
311 %description -n mythmovies
312 MythMovies is a plugin for looking up movie showtimes in a given area. 
313
314 %package -n mythzoneminder
315 Summary:        MythTV plugin to interface ZoneMinder
316 Group:          Applications/Multimedia
317 Requires:       mythtv-frontend-api = %{myth_api_version}
318
319 %description -n mythzoneminder
320 MythZoneMinder is a plugin to interface to some of the features of ZoneMinder.
321 You can use it to view a status window similar to the console window in ZM.
322 Also there are screens to view live camera shots and replay recorded events.
323 Other features may be added at a later time if there is sufficient interest.
324
325 ZoneMinder is a Linux video camera security and surveillance solution .
326
327 %prep
328 %setup -q %{?_snap:-n %{name}}
329 %patch0 -p1
330 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
331
332 # make it visible
333 mv mythweb/{data/.,}htaccess
334
335 # lib64 fix - enable to update patch
336 %if %{_lib} != "lib" && 0
337 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
338 xargs grep -l /lib/ . | xargs sed -i -e '
339         s,/usr/lib/,/usr/%{_lib}/,g
340         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
341 '
342 exit 1
343 %endif
344
345 %build
346 %if %{with binary}
347 export QTDIR="%{_prefix}"
348 # Not gnu configure
349 %configure \
350         --libdir-name=%{_lib} \
351         --enable-all \
352         %{!?with_mytharchive:--disable-mytharchive} \
353         %{!?with_mythbrowser:--disable-mythbrowser} \
354         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
355         %{!?with_mythgame:--disable-mythgame} \
356         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
357         %{!?with_mythnews:--disable-mythnews} \
358         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
359         %{!?with_mythvideo:--disable-mythvideo} \
360         %{!?with_mythweather:--disable-mythweather} \
361         %{!?with_mythweb:--disable-mythweb} \
362         %{!?with_mythcontrols:--disable-mythcontrols} \
363         %{!?with_mythflix:--disable-mythflix} \
364
365 mv mythconfig.mak mythconfig.mak.old
366 cp mythconfig.mak.old mythconfig.mak
367 cat <<'EOF'>> mythconfig.mak
368 QMAKE_CXX=%{__cxx}
369 QMAKE_CC=%{__cc}
370 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
371 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
372 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
373 EOF
374
375 %{__make}
376 %endif
377
378 %install
379 rm -rf $RPM_BUILD_ROOT
380
381 %if %{with binary}
382 export QTDIR="%{_prefix}"
383 %{__make} install \
384         INSTALL_ROOT=$RPM_BUILD_ROOT
385
386 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
387 %if %{with mythgame}
388 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
389 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
390 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
391 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
392 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
393 %endif
394 %endif
395
396 %if %{with mythweb}
397 cd mythweb
398 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
399 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
400 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
401 cp -a *.php *.pl data includes js modules objects skins $RPM_BUILD_ROOT%{_datadir}/mythweb
402 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
403 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
404 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
405 cd -
406 %endif
407
408 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
409 rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
410 for p in mytharchive mythbrowser mythcontrols mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythmovies mythzoneminder; do
411         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
412                 if [ -f "$l" ] ; then
413                         echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
414                 fi
415         done > $p.lang
416 done
417
418 %clean
419 rm -rf $RPM_BUILD_ROOT
420
421 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
422 %webapp_register apache %{_webapp}
423
424 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
425 %webapp_unregister apache %{_webapp}
426
427 %triggerin -n mythweb -- apache < 2.2.0, apache-base
428 %webapp_register httpd %{_webapp}
429
430 %triggerun -n mythweb -- apache < 2.2.0, apache-base
431 %webapp_unregister httpd %{_webapp}
432
433 %triggerpostun -n mythweb -- mythweb < 0.19
434 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
435         if [ -f /etc/mythweb/$i.rpmsave ]; then
436                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
437                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
438         fi
439 done
440 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
441
442 # migrate from apache-config macros
443 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
444         if [ -d /etc/apache/webapps.d ]; then
445                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
446                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
447         fi
448
449         if [ -d /etc/httpd/webapps.d ]; then
450                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
451                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
452         fi
453         rm -f /etc/mythweb/apache.conf.rpmsave
454 fi
455
456 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
457         rm -f /etc/apache/conf.d/99_mythplugins.conf
458         /usr/sbin/webapp register apache %{_webapp}
459         %service -q apache reload
460 fi
461 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
462         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
463         /usr/sbin/webapp register httpd %{_webapp}
464         %service -q httpd reload
465 fi
466
467 %files
468 %defattr(644,root,root,755)
469
470 %if %{with mytharchive}
471 %files -n mytharchive -f mytharchive.lang
472 %defattr(644,root,root,755)
473 %attr(755,root,root) %{_bindir}/mytharchivehelper
474 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
475 %{_datadir}/mythtv/archiveformat.xml
476 %{_datadir}/mythtv/archivemenu.xml
477 %{_datadir}/mythtv/archiveselect.xml
478 %{_datadir}/mythtv/themes/default/ma_*.png
479 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
480 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
481 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
482 %{_datadir}/mythtv/mytharchive
483 %endif
484
485 %if %{with mythmusic}
486 %files -n mythmusic -f mythmusic.lang
487 %defattr(644,root,root,755)
488 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
489 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
490 /var/lib/mythmusic
491 %{_datadir}/mythtv/musicmenu.xml
492 %{_datadir}/mythtv/music_settings.xml
493 %{_datadir}/mythtv/themes/default/music-ui.xml
494 %{_datadir}/mythtv/themes/default/ff_button_off.png
495 %{_datadir}/mythtv/themes/default/ff_button_on.png
496 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
497 %{_datadir}/mythtv/themes/default/mm_*.png
498 %{_datadir}/mythtv/themes/default/music-sel-bg.png
499 %{_datadir}/mythtv/themes/default/next_button_off.png
500 %{_datadir}/mythtv/themes/default/next_button_on.png
501 %{_datadir}/mythtv/themes/default/next_button_pushed.png
502 %{_datadir}/mythtv/themes/default/pause_button_off.png
503 %{_datadir}/mythtv/themes/default/pause_button_on.png
504 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
505 %{_datadir}/mythtv/themes/default/play_button_off.png
506 %{_datadir}/mythtv/themes/default/play_button_on.png
507 %{_datadir}/mythtv/themes/default/play_button_pushed.png
508 %{_datadir}/mythtv/themes/default/prev_button_off.png
509 %{_datadir}/mythtv/themes/default/prev_button_on.png
510 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
511 %{_datadir}/mythtv/themes/default/rew_button_off.png
512 %{_datadir}/mythtv/themes/default/rew_button_on.png
513 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
514 %{_datadir}/mythtv/themes/default/selectionbar.png
515 %{_datadir}/mythtv/themes/default/stop_button_off.png
516 %{_datadir}/mythtv/themes/default/stop_button_on.png
517 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
518 %{_datadir}/mythtv/themes/default/track_info_background.png
519 %{_datadir}/mythtv/themes/default/miniplayer*.png
520 %endif
521
522 %if %{with mythvideo}
523 %files -n mythvideo -f mythvideo.lang
524 %defattr(644,root,root,755)
525 %doc mythvideo/README mythvideo/videodb
526 %attr(755,root,root) %{_bindir}/mtd
527 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
528 %{_datadir}/mythtv/themes/default/dvd-ui.xml
529 %{_datadir}/mythtv/themes/default/video-ui.xml
530 %{_datadir}/mythtv/themes/default/mv-*.png
531 %{_datadir}/mythtv/themes/default/mv_*.png
532 %{_datadir}/mythtv/themes/default/md_*.png
533 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
534 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
535 %{_datadir}/mythtv/themes/default-wide/mv-*.png
536 %{_datadir}/mythtv/themes/default-wide/mv_*.png
537 %{_datadir}/mythtv/video_settings.xml
538 %{_datadir}/mythtv/videomenu.xml
539 %dir %{_datadir}/mythtv/mythvideo
540 %dir %{_datadir}/mythtv/mythvideo/scripts
541 %{_datadir}/mythtv/mythvideo/scripts/README
542 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
543 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
544 /var/lib/mythvideo
545 %endif
546
547 %if %{with mythweather}
548 %files -n mythweather -f mythweather.lang
549 %defattr(644,root,root,755)
550 %doc mythweather/README
551 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
552 %dir %{_datadir}/mythtv/mythweather
553 %dir %{_datadir}/mythtv/mythweather/scripts
554 %{_datadir}/mythtv/mythweather/scripts/README
555 %dir %{_datadir}/mythtv/mythweather/scripts/ca_envcan
556 %attr(755,root,root) %{_datadir}/mythtv/mythweather/scripts/ca_envcan/*.pl
557 %{_datadir}/mythtv/mythweather/scripts/ca_envcan/*.pm
558 %{_datadir}/mythtv/mythweather/scripts/ca_envcan/*.xml
559 %{_datadir}/mythtv/mythweather/scripts/ca_envcan/ENVCAN_icons
560 %dir %{_datadir}/mythtv/mythweather/scripts/uk_bbc
561 %attr(755,root,root) %{_datadir}/mythtv/mythweather/scripts/uk_bbc/*.pl
562 %{_datadir}/mythtv/mythweather/scripts/uk_bbc/*.pm
563 %dir %{_datadir}/mythtv/mythweather/scripts/us_nws
564 %attr(755,root,root) %{_datadir}/mythtv/mythweather/scripts/us_nws/*.pl
565 %{_datadir}/mythtv/mythweather/scripts/us_nws/*.pm
566 %{_datadir}/mythtv/mythweather/scripts/us_nws/*.xml
567 %{_datadir}/mythtv/mythweather/scripts/us_nws/*.dbx
568 %{_datadir}/mythtv/mythweather/scripts/us_nws/icons
569 %{_datadir}/mythtv/mythweather/scripts/us_nws/maps
570 %{_datadir}/mythtv/mythweather/scripts/us_nws/weather_types
571 %{_datadir}/mythtv/mythweather/weather-screens.xml
572 %{_datadir}/mythtv/themes/default/weather-ui.xml
573 %{_datadir}/mythtv/themes/default/cloudy.png
574 %{_datadir}/mythtv/themes/default/fair.png
575 %{_datadir}/mythtv/themes/default/flurries.png
576 %{_datadir}/mythtv/themes/default/fog.png
577 %{_datadir}/mythtv/themes/default/logo.png
578 %{_datadir}/mythtv/themes/default/lshowers.png
579 %{_datadir}/mythtv/themes/default/mcloudy.png
580 %{_datadir}/mythtv/themes/default/mw_*.png
581 %{_datadir}/mythtv/themes/default/mwmain.png
582 %{_datadir}/mythtv/themes/default/pcloudy.png
583 %{_datadir}/mythtv/themes/default/rainsnow.png
584 %{_datadir}/mythtv/themes/default/showers.png
585 %{_datadir}/mythtv/themes/default/snowshow.png
586 %{_datadir}/mythtv/themes/default/sunny.png
587 %{_datadir}/mythtv/themes/default/thunshowers.png
588 %{_datadir}/mythtv/themes/default/unknown.png
589 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
590 %{_datadir}/mythtv/themes/default-wide/mw-*.png
591 %{_datadir}/mythtv/weather_settings.xml
592 %endif
593
594 %if %{with mythgallery}
595 %files -n mythgallery -f mythgallery.lang
596 %defattr(644,root,root,755)
597 %doc mythgallery/README
598 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
599 %{_datadir}/mythtv/themes/default/gallery-ui.xml
600 %{_datadir}/mythtv/themes/default/gallery-*.png
601 # FIXME: this is definately stupid path
602 /var/lib/pictures
603 %endif
604
605 %if %{with mythgame}
606 %files -n mythgame -f mythgame.lang
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
609 %{_datadir}/mythtv/games
610 %{_datadir}/mythtv/game_settings.xml
611 %{_datadir}/mythtv/themes/default/game-ui.xml
612 %endif
613
614 %if %{with mythnews}
615 %files -n mythnews -f mythnews.lang
616 %defattr(644,root,root,755)
617 %doc mythnews/README mythnews/AUTHORS
618 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
619 %{_datadir}/mythtv/mythnews
620 %{_datadir}/mythtv/themes/default/news-ui.xml
621 %{_datadir}/mythtv/themes/default/enclosures.png
622 %{_datadir}/mythtv/themes/default/need-download.png
623 # DUPLICATE WITH MYTHFLIX?
624 %{_datadir}/mythtv/themes/default/news-info-bg.png
625 %endif
626
627 %if %{with mythbrowser}
628 %files -n mythbrowser -f mythbrowser.lang
629 %defattr(644,root,root,755)
630 %doc mythbrowser/README mythbrowser/AUTHORS
631 %attr(755,root,root) %{_bindir}/mythbrowser
632 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
633 %{_datadir}/mythtv/themes/default/webpage.png
634 %endif
635
636 %if %{with mythphone}
637 %files -n mythphone -f mythphone.lang
638 %defattr(644,root,root,755)
639 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
640 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
641 %{_datadir}/mythtv/themes/default/phone-ui.xml
642 %{_datadir}/mythtv/themes/default/webcam-ui.xml
643 %{_datadir}/mythtv/themes/default/mp_*.png
644 %{_datadir}/mythtv/themes/default/phone.png
645 %endif
646
647 %if %{with mythweb}
648 %files -n mythweb
649 %defattr(644,root,root,755)
650 %doc mythweb/{README,INSTALL,data,htaccess,mythweb.conf.*}
651 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
652 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
654 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
655 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
656 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
657 %{_datadir}/mythweb
658 %dir %attr(771,root,http) /var/cache/mythweb
659 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
660 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
661 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
662 %endif
663
664 %if %{with mythflix}
665 %files -n mythflix -f mythflix.lang
666 %defattr(644,root,root,755)
667 %doc mythflix/{AUTHORS,ChangeLog,README}
668 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
669 %dir %{_datadir}/mythtv/mythflix
670 %{_datadir}/mythtv/mythflix/netflix-rss.xml
671 %dir %{_datadir}/mythtv/mythflix/scripts
672 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
673 %{_datadir}/mythtv/netflix_menu.xml
674 %{_datadir}/mythtv/themes/default/title_netflix.png
675 %{_datadir}/mythtv/themes/default/netflix-ui.xml
676 # DUPLICATE WITH MYTHNEWS?
677 %{_datadir}/mythtv/themes/default/news-info-bg.png
678 %endif
679
680 %if %{with mythcontrols}
681 %files -n mythcontrols -f mythcontrols.lang
682 %defattr(644,root,root,755)
683 %doc mythcontrols/{AUTHORS,README,TODO}
684 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
685 %{_datadir}/mythtv/themes/default/controls-ui.xml
686 %{_datadir}/mythtv/themes/default/kb-button-off.png
687 %{_datadir}/mythtv/themes/default/kb-button-on.png
688 %endif
689
690 %if %{with mythmovies}
691 %files -n mythmovies -f mythmovies.lang
692 %defattr(644,root,root,755)
693 %doc mythmovies/{README,TODO}
694 %attr(755,root,root) %{_bindir}/ignyte
695 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
696 %{_datadir}/mythtv/themes/default/movies-ui.xml
697 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
698 %endif
699
700 %if %{with mythzoneminder}
701 %files -n mythzoneminder -f mythzoneminder.lang
702 %defattr(644,root,root,755)
703 %doc mythzoneminder/{README,AUTHORS}
704 %attr(755,root,root) %{_bindir}/mythzmserver
705 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
706 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
707 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
708 %{_datadir}/mythtv/themes/default/mz_*.png
709 %{_datadir}/mythtv/zonemindermenu.xml
710 %endif
This page took 0.101554 seconds and 4 git commands to generate.