]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
Version: 0.24.3
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 %bcond_without  mythvideo       # disable building mythvideo plugin
12 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
13 # not present by default in PLD
14 %bcond_with     mythweather     # enable building mythweather plugin
15 %bcond_without  mythweb         # disable building mythweb plugin
16 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
17
18 %if %{without binary}
19 %undefine       with_mytharchive
20 %undefine       with_mythbrowser
21 %undefine       with_mythnetvision
22 %undefine       with_mythgallery
23 %undefine       with_mythgame
24 %undefine       with_mythmusic
25 %undefine       with_mythnews
26 %undefine       with_mythvideo
27 %undefine       with_mythweather
28 %endif
29
30 %include        /usr/lib/rpm/macros.perl
31
32 Summary:        Main MythTV plugins
33 Summary(pl.UTF-8):      Główne wtyczki MythTV
34 Name:           mythplugins
35 Version:        0.24.3
36 Release:        0.1
37 License:        GPL v2
38 Group:          Applications/Multimedia
39 Source0:        ftp://ftp.osuosl.org/pub/mythtv/old_releases/%{name}-%{version}.tar.bz2
40 # Source0-md5:  8483036df0a9fa4e821e0066ed35b544
41 Source1:        mythweb.conf
42 Source2:        mythweb_lighttpd.conf
43 Source3:        htdigest.sh
44 Source4:        http_servers_conf_tips.txt
45 Patch0:         mythweb-chdir.patch
46 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
47 Patch20:        %{name}-mytharchive-INT64.patch
48 URL:            http://www.mythtv.org/
49 %if %{with binary}
50 %if %{with mythgallery} || %{with myhtmusic}
51 BuildRequires:  OpenGL-devel
52 %endif
53 BuildRequires:  Qt3Support-devel
54 BuildRequires:  QtCore-devel
55 BuildRequires:  QtGui-devel
56 BuildRequires:  QtNetwork-devel
57 BuildRequires:  QtOpenGL-devel
58 BuildRequires:  QtSql-devel
59 BuildRequires:  QtWebKit-devel
60 BuildRequires:  QtXml-devel
61 BuildRequires:  SDL-devel
62 BuildRequires:  a52dec-libs-devel
63 BuildRequires:  cdparanoia-III-devel
64 BuildRequires:  faad2-devel >= 2.0-5.2
65 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
66 BuildRequires:  flac-devel >= 1.0.4
67 BuildRequires:  freetype-devel
68 BuildRequires:  libcdaudio-devel >= 0.99.12p2
69 BuildRequires:  libdvdcss-devel >= 1.2.7
70 BuildRequires:  libdvdread-devel >= 0.9.4
71 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
72 BuildRequires:  libfame-devel >= 0.9.0
73 BuildRequires:  libid3tag-devel
74 BuildRequires:  libmad-devel
75 BuildRequires:  libmyth-devel > 0.21
76 BuildRequires:  libstdc++-devel
77 BuildRequires:  libtiff-devel
78 BuildRequires:  libvisual-devel
79 BuildRequires:  libvorbis-devel >= 1:1.0
80 BuildRequires:  mjpegtools-devel >= 1.6.1
81 BuildRequires:  nasm
82 BuildRequires:  patchutils
83 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
84 %{?with_mythweather:BuildRequires:      perl-Image-Size}
85 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
86 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
87 %{?with_mythnetvision:BuildRequires:    python-MythTV}
88 %{?with_mythnetvision:BuildRequires:    python-oauth}
89 BuildRequires:  qt4-build
90 BuildRequires:  qt4-qmake
91 BuildRequires:  rpm-perlprov >= 4.1-13
92 BuildRequires:  sed >= 4.0
93 %{?with_mythmusic:BuildRequires:        taglib-devel}
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xvid-devel >= 1:0.9.1
96 BuildRequires:  zlib-devel
97 %endif
98 %{?with_mytharchive:Requires:   mytharchive}
99 %{?with_mythbrowser:Requires:   mythbrowser}
100 %{?with_mythgallery:Requires:   mythgallery}
101 %{?with_mythgame:Requires:      mythgame}
102 %{?with_mythmysic:Requires:     mythmusic}
103 %{?with_mythnetvision:Requires: mythnetvision}
104 %{?with_mythnews:Requires:      mythnews}
105 %{?with_mythvideo:Requires:     mythvideo}
106 %{?with_mythweather:Requires:   mythweather}
107 %{?with_mythweb:Requires:       mythweb}
108 ExclusiveArch:  %{ix86} %{x8664} ppc
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
112 %define         _webapps        /etc/webapps
113 %define         _webapp         mythweb
114
115 %description
116 This is a consolidation of all the official MythTV plugins that used
117 to be distributed as separate downloads from mythtv.org.
118
119 %description -l pl.UTF-8
120 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
121 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
122
123 %package -n mytharchive
124 Summary:        A MythTV module to create and burn DVDs
125 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
126 Group:          Applications/Multimedia
127 Requires:       dvdauthor
128 Requires:       mjpegtools
129 Requires:       mythtv-frontend-api = %{myth_api_version}
130 Requires:       python-MySQLdb
131 Requires:       python-PIL
132 Suggests:       dvdrtools-mkisofs
133
134 %description -n mytharchive
135 MythArchive is a MythTV style plugin that uses the Mythburn Script to
136 create and burn DVDs from MythTV recordings, MythVideo files or any
137 video files available on a MythTV system. It can also export
138 recordings to a native archive format that can then be imported back
139 into a MythTV system restoring all the associated metadata.
140
141 %description -n mytharchive -l pl.UTF-8
142 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
143 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
144 innych plików z filmami dostępnych w systemie MythTV. Może także
145 eksportować nagrania do natywnego formatu archiwum, który potem można
146 zaimportować z powrotem do systemu MythTV przywracając wszystkie
147 związane z nimi metadane.
148
149 %package -n mythmusic
150 Summary:        The music player add-on module for MythTV
151 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
152 Group:          Applications/Multimedia
153 Requires:       mythtv-frontend-api = %{myth_api_version}
154
155 %description -n mythmusic
156 Music add-on for MythTV. Support playlists, visualisations, tag
157 editing and plays many popular audio file formats - mp3, flac, wav,
158 ogg etc.
159
160 %description -n mythmusic -l pl.UTF-8
161 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
162 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
163 formatów audio - mp3, flac, wav, ogg itd.
164
165 %package -n mythvideo
166 Summary:        A generic video player frontend module for MythTV
167 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
168 Group:          Applications/Multimedia
169 Requires:       mplayer
170 Requires:       mythtv-frontend-api = %{myth_api_version}
171
172 %description -n mythvideo
173 A generic video and dvd player frontend module for MythTV.
174
175 %description -n mythvideo -l pl.UTF-8
176 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
177
178 %package -n mythweather
179 Summary:        A MythTV module that displays a weather forcast
180 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
181 Group:          Applications/Multimedia
182 Requires:       mythtv-frontend-api = %{myth_api_version}
183
184 %description -n mythweather
185 A MythTV module that displays a weather forcast.
186
187 %description -n mythweather -l pl.UTF-8
188 Moduł MythTV wyświetlający prognozę pogody.
189
190 %package -n mythgallery
191 Summary:        A gallery/slideshow module for MythTV
192 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
193 Group:          Applications/Multimedia
194 Requires:       mythtv-frontend-api = %{myth_api_version}
195
196 %description -n mythgallery
197 A gallery/slideshow module for MythTV.
198
199 %description -n mythgallery -l pl.UTF-8
200 Moduł galerii/pokazu slajdów dla MythTV.
201
202 %package -n mythgame
203 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
204 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
205 Group:          Applications/Multimedia
206 Requires:       mythtv-frontend-api = %{myth_api_version}
207
208 %description -n mythgame
209 A game frontend (xmame, nes, snes, pc) for MythTV.
210
211 %description -n mythgame -l pl.UTF-8
212 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
213
214 %package -n mythnews
215 Summary:        A RSS News Feed plugin for MythTV
216 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
217 Group:          Applications/Multimedia
218 Requires:       mythtv-frontend-api = %{myth_api_version}
219
220 %description -n mythnews
221 A RSS News Feed plugin for MythTV.
222
223 %description -n mythnews -l pl.UTF-8
224 Wtyczka czytnika nowinek RSS dla MythTV.
225
226 %package -n mythbrowser
227 Summary:        A small web browser module for MythTV
228 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
229 Group:          Applications/Multimedia
230 Requires:       mythtv-frontend-api = %{myth_api_version}
231
232 %description -n mythbrowser
233 MythBrowser is a full fledged web-browser (multiple tabs) to display
234 webpages in full-screen mode. Simple page navigation is possible.
235 Starting with version 0.13 it also has full support for mouse driven
236 navigation (right mouse opens and closes the popup menu).
237
238 MythBrowser also contains a BookmarkManager to manage the website
239 links in a simple mythplugin.
240
241 %description -n mythbrowser -l pl.UTF-8
242 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
243 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
244 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
245 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
246 menu).
247
248 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
249 do stron w prostej wtyczce myth.
250
251 %package -n mythweb
252 Summary:        The web interface to MythTV
253 Summary(pl.UTF-8):      Interfejs WWW do MythTV
254 Group:          Applications/Multimedia
255 Requires:       php(mysql)
256 Requires:       php(posix)
257 Requires:       webapps
258 Requires:       webserver(php) >= 4.3
259
260 %description -n mythweb
261 The web interface to MythTV.
262
263 %description -n mythweb -l pl.UTF-8
264 Interfejs WWW do MythTV.
265
266 %package -n mythnetvision
267 Summary:        Mythtv extension to watch network movie shows
268 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
269 Group:          Applications/Multimedia
270 Requires:       mythbrowser
271 Requires:       mythtv-frontend-api = %{myth_api_version}
272 Requires:       python-MythTV
273 Requires:       python-oauth
274
275 %description -n mythnetvision
276 Mythtv extension to watch network movie shows (ex. YouTube).
277
278 %description -n mythnetvision -l pl.UTF-8
279 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
280 YouTube.
281
282 %package -n mythzoneminder
283 Summary:        MythTV security TV manager
284 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
285 Group:          Applications/Multimedia
286 Requires:       mythtv-frontend-api = %{myth_api_version}
287
288 %description -n mythzoneminder
289 MythTV security TV manager.
290
291
292 %description -n mythzoneminder -l pl.UTF-8
293 Obsługa kamer przemysłowych dla MythTV.
294
295 %prep
296 %setup -q
297 %patch0 -p1
298 #%patch10 -p1
299 %patch20 -p1
300
301 # lib64 fix - enable to update patch
302 %if %{_lib} != "lib" && 0
303 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
304 xargs grep -l /lib/ . | xargs sed -i -e '
305 s,%{_prefix}/lib/,/%{_lib}/,g
306         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
307 '
308 exit 1
309 %endif
310
311 %build
312 %if %{with binary}
313 export QTDIR="%{_prefix}"
314 # Not gnu configure
315 %configure \
316         --libdir-name=`basename %{_lib}` \
317         --enable-all \
318         %{!?with_mytharchive:--disable-mytharchive} \
319         %{!?with_mythbrowser:--disable-mythbrowser} \
320         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
321         %{!?with_mythgame:--disable-mythgame} \
322         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
323         %{!?with_mythnews:--disable-mythnews} \
324         %{!?with_mythvideo:--disable-mythvideo} \
325         %{!?with_mythweather:--disable-mythweather} \
326         %{!?with_mythweb:--disable-mythweb} \
327         %{!?with_mythnetvision:--disable-mythnetvision} \
328
329 mv mythconfig.mak mythconfig.mak.old
330 cp mythconfig.mak.old mythconfig.mak
331 cat <<'EOF'>> mythconfig.mak
332 QMAKE_CXX=%{__cxx}
333 QMAKE_CC=%{__cc}
334 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
335 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
336 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
337 EOF
338
339 %{__make}
340 %endif
341
342 %install
343 rm -rf $RPM_BUILD_ROOT
344 %if %{with binary}
345 export QTDIR="%{_prefix}"
346 %{__make} install \
347         INSTALL_ROOT=$RPM_BUILD_ROOT
348
349 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
350 %if %{with mythgame}
351 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
352 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
353 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
354 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
355 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
356 %endif
357 %endif
358
359 %if %{with mythweb}
360 cd mythweb
361 cp -a %{SOURCE3} ./
362 cp -a %{SOURCE4} ./
363 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
364 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
365 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
366 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
367 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
368 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
369 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
370 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
371 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
372 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
373 cd -
374 %endif
375
376 rm -f $RPM_BUILD_ROOT%{_datadir}/data
377 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
378 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythvideo mythweather mythzoneminder; do
379         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
380                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
381         done > $p.lang
382 done
383
384 %clean
385 rm -rf $RPM_BUILD_ROOT
386
387 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
388 %webapp_register apache %{_webapp}
389
390 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
391 %webapp_unregister apache %{_webapp}
392
393 %triggerin -n mythweb -- apache < 2.2.0, apache-base
394 %webapp_register httpd %{_webapp}
395
396 %triggerin -n mythweb -- lighttpd
397 %webapp_register lighttpd %{_webapp}
398
399 %triggerun -n mythweb -- apache < 2.2.0, apache-base
400 %webapp_unregister httpd %{_webapp}
401
402 %triggerun -n mythweb -- lighttpd
403 %webapp_unregister lighttpd %{_webapp}
404
405 %triggerpostun -n mythweb -- mythweb < 0.19
406 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
407         if [ -f /etc/mythweb/$i.rpmsave ]; then
408                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
409                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
410         fi
411 done
412 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
413
414 # migrate from apache-config macros
415 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
416         if [ -d /etc/apache/webapps.d ]; then
417                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
418                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
419         fi
420
421         if [ -d /etc/httpd/webapps.d ]; then
422                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
423                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
424         fi
425         rm -f /etc/mythweb/apache.conf.rpmsave
426 fi
427
428 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
429         rm -f /etc/apache/conf.d/99_mythplugins.conf
430         /usr/sbin/webapp register apache %{_webapp}
431         %service -q apache reload
432 fi
433 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
434         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
435         /usr/sbin/webapp register httpd %{_webapp}
436         %service -q httpd reload
437 fi
438
439 %post -n mythweb
440 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
441 which packages you can need to run mythweb and how to set it quickly."
442
443 %files
444 %defattr(644,root,root,755)
445
446 %if %{with mytharchive}
447 %files -n mytharchive -f mytharchive.lang
448 %defattr(644,root,root,755)
449 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
450 %attr(755,root,root) %{_bindir}/mytharchivehelper
451 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
452 %{_datadir}/mythtv/archivemenu.xml
453 %{_datadir}/mythtv/archiveutils.xml
454 %{_datadir}/mythtv/themes/default/ma_*.png
455 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
456 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
457 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
458 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
459 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
460 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
461 %{_datadir}/mythtv/mytharchive
462 %endif
463
464 %if %{with mythmusic}
465 %files -n mythmusic -f mythmusic.lang
466 %defattr(644,root,root,755)
467 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
468 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
469 /var/lib/mythmusic
470 %{_datadir}/mythtv/musicmenu.xml
471 %{_datadir}/mythtv/music_settings.xml
472 %{_datadir}/mythtv/themes/default/music-ui.xml
473 %{_datadir}/mythtv/themes/default/mm-titlelines.png
474 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
475 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
476 %{_datadir}/mythtv/themes/default/ff_button_off.png
477 %{_datadir}/mythtv/themes/default/ff_button_on.png
478 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
479 %{_datadir}/mythtv/themes/default/miniplayer_background.png
480 %{_datadir}/mythtv/themes/default/mm_*.png
481 %{_datadir}/mythtv/themes/default/music-sel-bg.png
482 %{_datadir}/mythtv/themes/default/next_button_off.png
483 %{_datadir}/mythtv/themes/default/next_button_on.png
484 %{_datadir}/mythtv/themes/default/next_button_pushed.png
485 %{_datadir}/mythtv/themes/default/pause_button_off.png
486 %{_datadir}/mythtv/themes/default/pause_button_on.png
487 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
488 %{_datadir}/mythtv/themes/default/play_button_off.png
489 %{_datadir}/mythtv/themes/default/play_button_on.png
490 %{_datadir}/mythtv/themes/default/play_button_pushed.png
491 %{_datadir}/mythtv/themes/default/prev_button_off.png
492 %{_datadir}/mythtv/themes/default/prev_button_on.png
493 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
494 %{_datadir}/mythtv/themes/default/rew_button_off.png
495 %{_datadir}/mythtv/themes/default/rew_button_on.png
496 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
497 %{_datadir}/mythtv/themes/default/selectionbar.png
498 %{_datadir}/mythtv/themes/default/stop_button_off.png
499 %{_datadir}/mythtv/themes/default/stop_button_on.png
500 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
501 %{_datadir}/mythtv/themes/default/track_info_background.png
502 %{_datadir}/mythtv/themes/default-wide/mm_*.png
503 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
504 %endif
505
506 %if %{with mythvideo}
507 %files -n mythvideo -f mythvideo.lang
508 %defattr(644,root,root,755)
509 %doc mythvideo/README* mythvideo/videodb mythvideo/contrib
510 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
511 %{_datadir}/mythtv/themes/default/video-ui.xml
512 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
513 %{_datadir}/mythtv/themes/default/mv_*.png
514 %{_datadir}/mythtv/themes/default-wide/mv_*.png
515 %{_datadir}/mythtv/themes/default/md_*.png
516 %{_datadir}/mythtv/video_settings.xml
517 %{_datadir}/mythtv/videomenu.xml
518 %dir %{_datadir}/mythtv/mythvideo
519 %dir %{_datadir}/mythtv/mythvideo/scripts
520 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
521 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
522 %{_datadir}/mythtv/mythvideo/scripts/README
523 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
524 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
525 %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
526 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
527 /var/lib/mythvideo
528 %endif
529
530 %if %{with mythweather}
531 %files -n mythweather -f mythweather.lang
532 %defattr(644,root,root,755)
533 %doc mythweather/AUTHORS mythweather/README
534 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
535 %{_datadir}/mythtv/mythweather
536 %{_datadir}/mythtv/weather_settings.xml
537 %{_datadir}/mythtv/themes/default/weather-ui.xml
538 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
539 %{_datadir}/mythtv/themes/default/cloudy.png
540 %{_datadir}/mythtv/themes/default/fair.png
541 %{_datadir}/mythtv/themes/default/flurries.png
542 %{_datadir}/mythtv/themes/default/fog.png
543 %{_datadir}/mythtv/themes/default/logo.png
544 %{_datadir}/mythtv/themes/default/lshowers.png
545 %{_datadir}/mythtv/themes/default/mcloudy.png
546 %{_datadir}/mythtv/themes/default/mw_*.png
547 %{_datadir}/mythtv/themes/default/mwmain.png
548 %{_datadir}/mythtv/themes/default/pcloudy.png
549 %{_datadir}/mythtv/themes/default/rainsnow.png
550 %{_datadir}/mythtv/themes/default/showers.png
551 %{_datadir}/mythtv/themes/default/snowshow.png
552 %{_datadir}/mythtv/themes/default/sunny.png
553 %{_datadir}/mythtv/themes/default/thunshowers.png
554 %{_datadir}/mythtv/themes/default/unknown.png
555 %{_datadir}/mythtv/themes/default-wide/mw-*.png
556 %endif
557
558 %if %{with mythgallery}
559 %files -n mythgallery -f mythgallery.lang
560 %defattr(644,root,root,755)
561 %doc mythgallery/AUTHORS mythgallery/README
562 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
563 %{_datadir}/mythtv/themes/default/gallery-ui.xml
564 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
565 %{_datadir}/mythtv/themes/default/gallery-*.png
566 /var/lib/pictures
567 %endif
568
569 %if %{with mythgame}
570 %files -n mythgame -f mythgame.lang
571 %defattr(644,root,root,755)
572 %doc mythgame/contrib
573 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
574 %{_datadir}/mythtv/games
575 %{_datadir}/mythtv/game_settings.xml
576 %{_datadir}/mythtv/themes/default/game-ui.xml
577 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
578 %dir %{_datadir}/mythtv/metadata/Game
579 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
580 %{_datadir}/mythtv/metadata/Game/giantbomb
581 %endif
582
583 %if %{with mythnews}
584 %files -n mythnews -f mythnews.lang
585 %defattr(644,root,root,755)
586 %doc mythnews/README mythnews/AUTHORS
587 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
588 %{_datadir}/mythtv/mythnews
589 %{_datadir}/mythtv/themes/default/news-ui.xml
590 %{_datadir}/mythtv/themes/default/news-info-bg.png
591 %{_datadir}/mythtv/themes/default/enclosures.png
592 %{_datadir}/mythtv/themes/default/need-download.png
593 %{_datadir}/mythtv/themes/default/podcast.png
594 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
595 %endif
596
597 %if %{with mythbrowser}
598 %files -n mythbrowser -f mythbrowser.lang
599 %defattr(644,root,root,755)
600 %doc mythbrowser/README mythbrowser/AUTHORS
601 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
602 %{_datadir}/mythtv/themes/default/mb_progress*.png
603 %{_datadir}/mythtv/themes/default/browser-ui.xml
604 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
605 %endif
606
607 %if %{with mythweb}
608 %files -n mythweb
609 %defattr(644,root,root,755)
610 %doc mythweb/README mythweb/mythweb.conf.lighttpd
611 %doc mythweb/htdigest.sh
612 %doc mythweb/http_servers_conf_tips.txt
613 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
615 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
616 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
617 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
618 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
619 %{_datadir}/mythweb
620 %dir %attr(771,root,http) /var/cache/mythweb
621 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
622 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
623 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
624 %endif
625
626 %if %{with mythnetvision}
627 %files -n mythnetvision -f mythnetvision.lang
628 %defattr(644,root,root,755)
629 %doc mythnetvision/{AUTHORS,ChangeLog,README}
630 %attr(755,root,root) %{_bindir}/mythfillnetvision
631 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
632 %dir %{_datadir}/mythtv/mythnetvision
633 %{_datadir}/mythtv/netvisionmenu.xml
634 %dir %{_datadir}/mythtv/mythnetvision/icons
635 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
636 %{_datadir}/mythtv/mythnetvision/icons/*.png
637 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
638 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
639 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
640 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
641 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
642 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
643 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
644 %{_datadir}/mythtv/themes/default/netvision-ui.xml
645 %endif
646
647 %if %{with mythzoneminder}
648 %files -n mythzoneminder
649 %defattr(644,root,root,755)
650 %defattr(644,root,root,755)
651 %doc mythzoneminder/{AUTHORS,README}
652 %attr(755,root,root) %{_bindir}/mythzmserver
653 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
654 %dir %{_datadir}/mythtv/zonemindermenu.xml
655 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
656 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
657 %{_datadir}/mythtv/themes/default/mz_*png
658 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
659 %endif
This page took 0.083688 seconds and 4 git commands to generate.