]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- pl
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # disable mythmusic,mythphone due to https://bugs.pld-linux.org/?do=details&id=5687
3 %bcond_without  mythmusic
4 %bcond_without  mythphone
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Main MythTV plugins
8 Summary(pl):    G³ówne wtyczki MythTV
9 Name:           mythplugins
10 Version:        0.18.1
11 Release:        0.112.9
12 License:        GPL v2
13 Group:          Applications/Multimedia
14 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
15 # Source0-md5:  1d94d19e2a13c24a408ced9b6c4f5b47
16 Patch0:         %{name}-configure.patch
17 URL:            http://www.mythtv.org/
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  SDL-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  a52dec-libs-devel
22 BuildRequires:  cdparanoia-III-devel
23 BuildRequires:  faad2-devel >= 2.0-5.2
24 BuildRequires:  fftw-devel >= 2.1.3
25 BuildRequires:  flac-devel >= 1.0.4
26 BuildRequires:  freetype-devel
27 BuildRequires:  kdelibs-devel
28 BuildRequires:  libcdaudio-devel
29 BuildRequires:  libdvdcss-devel >= 1.2.7
30 BuildRequires:  libdvdread-devel >= 0.9.4
31 BuildRequires:  libexif-devel
32 BuildRequires:  libfame-devel >= 0.9.0
33 BuildRequires:  libid3tag-devel
34 BuildRequires:  libmad-devel
35 BuildRequires:  libmyth-devel >= 0.18.1-0.21
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtiff-devel
38 BuildRequires:  libvorbis-devel >= 1.0
39 BuildRequires:  mjpegtools-devel >= 1.6.1
40 BuildRequires:  nasm
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  transcode >= 0.6.8
44 BuildRequires:  xvid-devel >= 1:0.9.1
45 BuildRequires:  zlib-devel
46 Requires:       mythbrowser
47 Requires:       mythdvd
48 Requires:       mythgallery
49 Requires:       mythgame
50 %{?with_mythmusic:Requires:     mythmusic}
51 Requires:       mythnews
52 %{?with_mythphone:Requires:     mythphone}
53 Requires:       mythvideo
54 Requires:       mythweather
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         api_ver %(echo %{version} | cut -d. -f1,2)
58
59 %description
60 This is a consolidation of all the official MythTV plugins that used
61 to be distributed as separate downloads from mythtv.org.
62
63 %description -l pl
64 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które by³y
65 wcze¶niej rozpowszechniane jako osobne pakiety na mythtv.org.
66
67 %package -n mythmusic
68 Summary:        The music player add-on module for MythTV
69 Summary(pl):    Modu³ odtwarzacza muzyki dla MythTV
70 Group:          Applications/Multimedia
71 Requires:       mythtv-frontend-api = %{api_ver}
72
73 %description -n mythmusic
74 Music add-on for MythTV.
75
76 %description -n mythmusic -l pl
77 Odtwarzacz muzyki dla MythTV.
78
79 %package -n mythvideo
80 Summary:        A generic video player frontend module for MythTV
81 Summary(pl):    Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV
82 Group:          Applications/Multimedia
83 Requires:       mplayer
84 Requires:       mythtv-frontend-api = %{api_ver}
85
86 %description -n mythvideo
87 A generic video player frontend module for MythTV.
88
89 %description -n mythvideo -l pl
90 Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV.
91
92 %package -n mythweather
93 Summary:        A MythTV module that displays a weather forcast
94 Summary(pl):    Modu³ MythTV wy¶wietlaj±cy prognozê pogody
95 Group:          Applications/Multimedia
96 Requires:       mythtv-frontend-api = %{api_ver}
97
98 %description -n mythweather
99 A MythTV module that displays a weather forcast.
100
101 %description -n mythweather -l pl
102 Modu³ MythTV wy¶wietlaj±cy prognozê pogody.
103
104 %package -n mythgallery
105 Summary:        A gallery/slideshow module for MythTV
106 Summary(pl):    Modu³ galerii/pokazu slajdów dla MythTV
107 Group:          Applications/Multimedia
108 Requires:       mythtv-frontend-api = %{api_ver}
109
110 %description -n mythgallery
111 A gallery/slideshow module for MythTV.
112
113 %description -n mythgallery -l pl
114 Modu³ galerii/pokazu slajdów dla MythTV.
115
116 %package -n mythgame
117 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
118 Summary(pl):    Interfejs do gier (xmame, nes, snes, pc) dla MythTV
119 Group:          Applications/Multimedia
120 Requires:       mythtv-frontend-api = %{api_ver}
121
122 %description -n mythgame
123 A game frontend (xmame, nes, snes, pc) for MythTV.
124
125 %description -n mythgame -l pl
126 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
127
128 %package -n mythdvd
129 Summary:        A DVD player module for MythTV
130 Summary(pl):    Modu³ odtwarzacza DVD dla MythTV
131 Group:          Applications/Multimedia
132 Requires:       mythtv-frontend-api = %{api_ver}
133 Requires:       transcode >= 0.6.8
134
135 %description -n mythdvd
136 MythDVD is a MythTV module that allows you to play DVDs on a myth-box
137 and (optionally) rip DVD's and transcode their video and audio content
138 to other (generally smaller) formats. The playing features are simply
139 myth-style wrappers for your favourite DVD playing software (mplayer,
140 ogle, xine, etc). The transcoding is based on and derived from the
141 excellent transcode package.
142
143 %description -n mythdvd -l pl
144 MythDVD to modu³ MythTV umo¿liwiaj±cy odtwarzanie p³yt DVD w MythTV i
145 (opcjonalnie) rippowanie ich oraz przekodowywanie obrazu i d¼wiêku do
146 innych (zwykle mniej zajmuj±cych) formatów. Mo¿liwo¶ci odtwarzania to
147 po prostu obudowanie w stylu myth dla ulubionego oprogramowania do
148 odtwarzania DVD (mplayer, ogle, xine itp.). Przekodowywanie jest
149 oparte i wywodzi siê z wspania³ego pakietu transcode.
150
151 %package -n mythnews
152 Summary:        A RSS News Feed plugin for MythTV
153 Summary(pl):    Wtyczka czytnika nowinek RSS dla MythTV
154 Group:          Applications/Multimedia
155 Requires:       mythtv-frontend-api = %{api_ver}
156
157 %description -n mythnews
158 A RSS News Feed plugin for MythTV.
159
160 %description -n mythnews -l pl
161 Wtyczka czytnika nowinek RSS dla MythTV.
162
163 %package -n mythbrowser
164 Summary:        A small web browser module for MythTV
165 Summary(pl):    Modu³ ma³ej przegl±darki WWW dla MythTV
166 Group:          Applications/Multimedia
167 Requires:       mythtv-frontend-api = %{api_ver}
168
169 %description -n mythbrowser
170 MythBrowser is a full fledged web-browser (multiple tabs) to display
171 webpages in full-screen mode. Simple page navigation is possible.
172 Starting with version 0.13 it also has full support for mouse driven
173 navigation (right mouse opens and closes the popup menu).
174
175 MythBrowser also contains a BookmarkManager to manage the website
176 links in a simple mythplugin.
177
178 %description -n mythbrowser -l pl
179 MythBrowser to w pe³ni funkcjonalna przegl±darka WWW (z wieloma
180 zak³adkami) wy¶wietlaj±ca strony WWW w trybie pe³noekranowym. Mo¿liwa
181 jest prosta nawigacja po stronie. Pocz±wszy od wersji 0.13 ma pe³n±
182 obs³ugê nawigacji myszk± (prawy przycisk otwiera i zamywa wyskakuj±ce
183 menu).
184
185 MythBrowser zawiera tak¿e BookmarkManagera do zarz±dzania odno¶nikami
186 do stron w prostej wtyczce myth.
187
188 %package -n mythphone
189 Summary:        A video conferencing module for MythTV
190 Summary(pl):    Modu³ wideokonferencji dla MythTV
191 Group:          Applications/Multimedia
192 Requires:       mythtv-frontend-api = %{api_ver}
193
194 %description -n mythphone
195 Mythphone is a phone and videophone capability on Myth using the
196 standard SIP protocol. It is compatible with Microsoft XP Messenger
197 and with SIP Service Providers such as Free World Dialup
198 (fwd.pulver.com).
199
200 %description -n mythphone -l pl
201 Mythphone to funkcjonalno¶æ telefonu i wideofonu w Myth przy u¿yciu
202 standardowego protoko³u SIP. Jest kompatybilny z Microsoft XP
203 Messengerem oraz dostawcami us³ug SIP, takimi jak Free World Dialup
204 (fwd.pulver.com).
205
206 %prep
207 %setup -q
208 %patch0 -p1
209
210 # lib64 fix
211 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
212 xargs grep -l /lib/ . | xargs sed -i -e '
213         s,/usr/lib/,/usr/%{_lib}/,g
214         s,{PREFIX}/lib,{PREFIX}/%{_lib}/,g
215 '
216
217 sed -i -e 's|/mnt/store/music|/var/lib/mythmusic|' mythmusic/mythmusic/globalsettings.cpp
218 sed -i -e 's|/share/Movies/dvd|/var/lib/mythvideo|' mythvideo/mythvideo/globalsettings.cpp
219 sed -i -e 's|/mnt/cdrom:/mnt/camera|/media/cdrom:/mnt/camera|' mythgallery/mythgallery/gallerysettings.cpp
220
221 # include mythtv build settings
222 cp %{_datadir}/mythtv/build/config.mak .
223 sed -i -e '1iinclude(config.mak)'  settings.pro
224
225 %ifarch %{x8664}
226         # mmx asm isn't x86_64 compatible in mythmusic
227         echo 'DEFINES -= HAVE_MMX' >> settings.pro
228 %endif
229
230 %build
231 export QTDIR="%{_prefix}"
232 # Not gnu configure
233 %configure \
234         --enable-all \
235         --disable-festival \
236         %{!?with_mythmusic:--disable-mythmusic} \
237         %{!?with_mythphone:--disable-mythphone}
238
239 #       --enable-opengl          enable OpenGL (Music and Gallery) [default=no]
240 #       --enable-transcode       enable DVD ripping and transcoding [default=no]
241 #       --enable-vcd             enable VCD playing [default=no]
242 #       --enable-exif            enable reading of EXIF headers [default=no]
243 #       --enable-fftw            enable fftw visualizers [default=no]
244 #       --enable-sdl             use SDL for the synaesthesia output [default=no]
245 #       --enable-aac             enable AAC/MP4 audio file decompression [default=no]
246 #       --enable-festival        enable festival TTS Engine [default=no]
247
248 qmake mythplugins.pro
249 %{__make}
250
251 %install
252 rm -rf $RPM_BUILD_ROOT
253
254 export QTDIR="%{_prefix}"
255 %{__make} install \
256         INSTALL_ROOT=$RPM_BUILD_ROOT
257
258 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
259 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
260 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
261 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
262 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
263 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %files
269 %defattr(644,root,root,755)
270
271 %if %{with mythmusic}
272 %files -n mythmusic
273 %defattr(644,root,root,755)
274 %doc mythmusic/README mythmusic/UPGRADING mythmusic/AUTHORS mythmusic/musicdb
275 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
276 /var/lib/mythmusic
277 %{_datadir}/mythtv/musicmenu.xml
278 %{_datadir}/mythtv/music_settings.xml
279 %{_datadir}/mythtv/i18n/mythmusic_*.qm
280 %{_datadir}/mythtv/themes/default/ff_button_off.png
281 %{_datadir}/mythtv/themes/default/ff_button_on.png
282 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
283 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
284 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
285 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
286 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
287 %{_datadir}/mythtv/themes/default/mm_checked.png
288 %{_datadir}/mythtv/themes/default/mm_checked_high.png
289 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
290 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
291 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
292 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
293 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
294 %{_datadir}/mythtv/themes/default/mm_rating.png
295 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
296 %{_datadir}/mythtv/themes/default/mm_unchecked.png
297 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
298 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
299 %{_datadir}/mythtv/themes/default/mm_volume_background.png
300 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
301 %{_datadir}/mythtv/themes/default/mm_waiting.png
302 %{_datadir}/mythtv/themes/default/music-sel-bg.png
303 %{_datadir}/mythtv/themes/default/music-ui.xml
304 %{_datadir}/mythtv/themes/default/next_button_off.png
305 %{_datadir}/mythtv/themes/default/next_button_on.png
306 %{_datadir}/mythtv/themes/default/next_button_pushed.png
307 %{_datadir}/mythtv/themes/default/pause_button_off.png
308 %{_datadir}/mythtv/themes/default/pause_button_on.png
309 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
310 %{_datadir}/mythtv/themes/default/play_button_off.png
311 %{_datadir}/mythtv/themes/default/play_button_on.png
312 %{_datadir}/mythtv/themes/default/play_button_pushed.png
313 %{_datadir}/mythtv/themes/default/prev_button_off.png
314 %{_datadir}/mythtv/themes/default/prev_button_on.png
315 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
316 %{_datadir}/mythtv/themes/default/rew_button_off.png
317 %{_datadir}/mythtv/themes/default/rew_button_on.png
318 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
319 %{_datadir}/mythtv/themes/default/selectionbar.png
320 %{_datadir}/mythtv/themes/default/stop_button_off.png
321 %{_datadir}/mythtv/themes/default/stop_button_on.png
322 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
323 %{_datadir}/mythtv/themes/default/text_button_off.png
324 %{_datadir}/mythtv/themes/default/text_button_on.png
325 %{_datadir}/mythtv/themes/default/text_button_pushed.png
326 %{_datadir}/mythtv/themes/default/track_info_background.png
327 %endif
328
329 %files -n mythvideo
330 %defattr(644,root,root,755)
331 %doc mythvideo/README mythvideo/UPGRADING mythvideo/videodb
332 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
333 %{_datadir}/mythtv/i18n/mythvideo_*.qm
334 %{_datadir}/mythtv/themes/default/video-ui.xml
335 %{_datadir}/mythtv/themes/default/mv-*.png
336 %{_datadir}/mythtv/themes/default/mv_*.png
337 %{_datadir}/mythtv/video_settings.xml
338 %{_datadir}/mythtv/videomenu.xml
339 %dir %{_datadir}/mythtv/mythvideo
340 %dir %{_datadir}/mythtv/mythvideo/scripts
341 %{_datadir}/mythtv/mythvideo/scripts/README
342 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
343 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
344 /var/lib/mythvideo
345
346 %files -n mythweather
347 %defattr(644,root,root,755)
348 %doc mythweather/README
349 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
350 %{_datadir}/mythtv/i18n/mythweather_*.qm
351 %{_datadir}/mythtv/mythweather
352 %{_datadir}/mythtv/themes/default/weather-ui.xml
353 %{_datadir}/mythtv/themes/default/cloudy.png
354 %{_datadir}/mythtv/themes/default/fair.png
355 %{_datadir}/mythtv/themes/default/flurries.png
356 %{_datadir}/mythtv/themes/default/fog.png
357 %{_datadir}/mythtv/themes/default/logo.png
358 %{_datadir}/mythtv/themes/default/lshowers.png
359 %{_datadir}/mythtv/themes/default/mcloudy.png
360 %{_datadir}/mythtv/themes/default/mw-*.png
361 %{_datadir}/mythtv/themes/default/mwmain.png
362 %{_datadir}/mythtv/themes/default/pcloudy.png
363 %{_datadir}/mythtv/themes/default/rainsnow.png
364 %{_datadir}/mythtv/themes/default/showers.png
365 %{_datadir}/mythtv/themes/default/snowshow.png
366 %{_datadir}/mythtv/themes/default/sunny.png
367 %{_datadir}/mythtv/themes/default/thunshowers.png
368 %{_datadir}/mythtv/themes/default/unknown.png
369
370 %files -n mythgallery
371 %defattr(644,root,root,755)
372 %doc mythgallery/README mythgallery/UPGRADING
373 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
374 %{_datadir}/mythtv/themes/default/gallery-ui.xml
375 %{_datadir}/mythtv/themes/default/gallery-*.png
376 %{_datadir}/mythtv/i18n/mythgallery_*.qm
377 /var/lib/pictures
378
379 %files -n mythgame
380 %defattr(644,root,root,755)
381 %doc mythgame/README mythgame/UPGRADING
382 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
383 %{_datadir}/mythtv/games
384 #%config %{_datadir}/mythtv/games/PC/gamelist.xml
385 #%{_datadir}/xmame/screens
386 #%{_datadir}/xmame/flyers
387 %{_datadir}/mythtv/game_settings.xml
388 %{_datadir}/mythtv/themes/default/game-ui.xml
389 %{_datadir}/mythtv/i18n/mythgame_*.qm
390
391 %files -n mythdvd
392 %defattr(644,root,root,755)
393 %doc mythdvd/README mythdvd/UPGRADING mythdvd/AUTHORS
394 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
395 %{_datadir}/mythtv/dvd_settings.xml
396 %{_datadir}/mythtv/dvdmenu.xml
397 %{_datadir}/mythtv/themes/default/dvd-ui.xml
398 %{_datadir}/mythtv/themes/default/md_*.png
399 %{_datadir}/mythtv/i18n/mythdvd_*.qm
400 %attr(755,root,root) %{_bindir}/mtd
401
402 %files -n mythnews
403 %defattr(644,root,root,755)
404 %doc mythnews/README mythnews/AUTHORS
405 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
406 %{_datadir}/mythtv/mythnews
407 %{_datadir}/mythtv/themes/default/news-ui.xml
408 %{_datadir}/mythtv/themes/default/news-info-bg.png
409 %{_datadir}/mythtv/i18n/mythnews_*.qm
410
411 %files -n mythbrowser
412 %defattr(644,root,root,755)
413 %doc mythbrowser/README mythbrowser/AUTHORS
414 %attr(755,root,root) %{_bindir}/mythbrowser
415 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
416 %{_datadir}/mythtv/themes/default/webpage.png
417 %{_datadir}/mythtv/i18n/mythbrowser_*.qm
418
419 %if %{with mythphone}
420 %files -n mythphone
421 %defattr(644,root,root,755)
422 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
423 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
424 %{_datadir}/mythtv/themes/default/phone-ui.xml
425 %{_datadir}/mythtv/themes/default/webcam-ui.xml
426 %{_datadir}/mythtv/themes/default/mp_*.png
427 %{_datadir}/mythtv/themes/default/phone.png
428 %{_datadir}/mythtv/i18n/mythphone_*.qm
429 %endif
This page took 0.07303 seconds and 4 git commands to generate.