]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- updated to 0.26.0
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 %bcond_without  mythvideo       # disable building mythvideo plugin
12 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
13 # not present by default in PLD
14 %bcond_with     mythweather     # enable building mythweather plugin
15 %bcond_without  mythweb         # disable building mythweb plugin
16 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
17
18 %if %{without binary}
19 %undefine       with_mytharchive
20 %undefine       with_mythbrowser
21 %undefine       with_mythnetvision
22 %undefine       with_mythgallery
23 %undefine       with_mythgame
24 %undefine       with_mythmusic
25 %undefine       with_mythnews
26 %undefine       with_mythvideo
27 %undefine       with_mythweather
28 %endif
29
30 %include        /usr/lib/rpm/macros.perl
31
32 Summary:        Main MythTV plugins
33 Summary(pl.UTF-8):      Główne wtyczki MythTV
34 Name:           mythplugins
35 Version:        0.26.0
36 Release:        0.1
37 License:        GPL v2
38 Group:          Applications/Multimedia
39 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
40 # Source0-md5:  15bd7b2f4173488966f3d761e0eacffa
41 Source1:        mythweb.conf
42 Source2:        mythweb_lighttpd.conf
43 Source3:        htdigest.sh
44 Source4:        http_servers_conf_tips.txt
45 Patch0:         mythweb-chdir.patch
46 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
47 Patch20:        %{name}-mytharchive-INT64.patch
48 URL:            http://www.mythtv.org/
49 %if %{with binary}
50 %if %{with mythgallery} || %{with myhtmusic}
51 BuildRequires:  OpenGL-devel
52 %endif
53 BuildRequires:  Qt3Support-devel
54 BuildRequires:  QtCore-devel
55 BuildRequires:  QtGui-devel
56 BuildRequires:  QtNetwork-devel
57 BuildRequires:  QtOpenGL-devel
58 BuildRequires:  QtSql-devel
59 BuildRequires:  QtWebKit-devel
60 BuildRequires:  QtXml-devel
61 BuildRequires:  SDL-devel
62 BuildRequires:  a52dec-libs-devel
63 BuildRequires:  cdparanoia-III-devel
64 BuildRequires:  faad2-devel >= 2.0-5.2
65 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
66 BuildRequires:  flac-devel >= 1.0.4
67 BuildRequires:  freetype-devel
68 BuildRequires:  libcdaudio-devel >= 0.99.12p2
69 BuildRequires:  libdvdcss-devel >= 1.2.7
70 BuildRequires:  libdvdread-devel >= 0.9.4
71 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
72 BuildRequires:  libfame-devel >= 0.9.0
73 BuildRequires:  libid3tag-devel
74 BuildRequires:  libmad-devel
75 BuildRequires:  libmyth-devel > 0.26
76 BuildRequires:  libstdc++-devel
77 BuildRequires:  libtiff-devel
78 BuildRequires:  libvisual-devel
79 BuildRequires:  libvorbis-devel >= 1:1.0
80 BuildRequires:  mjpegtools-devel >= 1.6.1
81 BuildRequires:  nasm
82 BuildRequires:  patchutils
83 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
84 %{?with_mythweather:BuildRequires:      perl-Image-Size}
85 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
86 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
87 %{?with_mythnetvision:BuildRequires:    python-MythTV}
88 %{?with_mythnetvision:BuildRequires:    python-oauth}
89 BuildRequires:  qt4-build
90 BuildRequires:  qt4-qmake
91 BuildRequires:  rpm-perlprov >= 4.1-13
92 BuildRequires:  sed >= 4.0
93 %{?with_mythmusic:BuildRequires:        taglib-devel}
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xvid-devel >= 1:0.9.1
96 BuildRequires:  zlib-devel
97 %endif
98 Obsoletes:      mythdvd < %{version}-%{release}
99 Obsoletes:      mythmovies < %{version}-%{release}
100 %{?with_mytharchive:Requires:   mytharchive}
101 %{?with_mythbrowser:Requires:   mythbrowser}
102 %{?with_mythgallery:Requires:   mythgallery}
103 %{?with_mythgame:Requires:      mythgame}
104 %{?with_mythmysic:Requires:     mythmusic}
105 %{?with_mythnetvision:Requires: mythnetvision}
106 %{?with_mythnews:Requires:      mythnews}
107 %{?with_mythvideo:Requires:     mythvideo}
108 %{?with_mythweather:Requires:   mythweather}
109 %{?with_mythweb:Requires:       mythweb}
110 ExclusiveArch:  %{ix86} %{x8664} ppc
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
114 %define         _webapps        /etc/webapps
115 %define         _webapp         mythweb
116
117 %description
118 This is a consolidation of all the official MythTV plugins that used
119 to be distributed as separate downloads from mythtv.org.
120
121 %description -l pl.UTF-8
122 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
123 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
124
125 %package -n mytharchive
126 Summary:        A MythTV module to create and burn DVDs
127 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
128 Group:          Applications/Multimedia
129 Requires:       dvdauthor
130 Requires:       mjpegtools
131 Requires:       mythtv-frontend-api = %{myth_api_version}
132 Requires:       python-MySQLdb
133 Requires:       python-PIL
134 Suggests:       dvdrtools-mkisofs
135
136 %description -n mytharchive
137 MythArchive is a MythTV style plugin that uses the Mythburn Script to
138 create and burn DVDs from MythTV recordings, MythVideo files or any
139 video files available on a MythTV system. It can also export
140 recordings to a native archive format that can then be imported back
141 into a MythTV system restoring all the associated metadata.
142
143 %description -n mytharchive -l pl.UTF-8
144 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
145 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
146 innych plików z filmami dostępnych w systemie MythTV. Może także
147 eksportować nagrania do natywnego formatu archiwum, który potem można
148 zaimportować z powrotem do systemu MythTV przywracając wszystkie
149 związane z nimi metadane.
150
151 %package -n mythmusic
152 Summary:        The music player add-on module for MythTV
153 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
154 Group:          Applications/Multimedia
155 Requires:       mythtv-frontend-api = %{myth_api_version}
156
157 %description -n mythmusic
158 Music add-on for MythTV. Support playlists, visualisations, tag
159 editing and plays many popular audio file formats - mp3, flac, wav,
160 ogg etc.
161
162 %description -n mythmusic -l pl.UTF-8
163 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
164 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
165 formatów audio - mp3, flac, wav, ogg itd.
166
167 %package -n mythvideo
168 Summary:        A generic video player frontend module for MythTV
169 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
170 Group:          Applications/Multimedia
171 Requires:       mplayer
172 Requires:       mythtv-frontend-api = %{myth_api_version}
173
174 %description -n mythvideo
175 A generic video and dvd player frontend module for MythTV.
176
177 %description -n mythvideo -l pl.UTF-8
178 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
179
180 %package -n mythweather
181 Summary:        A MythTV module that displays a weather forcast
182 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
183 Group:          Applications/Multimedia
184 Requires:       mythtv-frontend-api = %{myth_api_version}
185
186 %description -n mythweather
187 A MythTV module that displays a weather forcast.
188
189 %description -n mythweather -l pl.UTF-8
190 Moduł MythTV wyświetlający prognozę pogody.
191
192 %package -n mythgallery
193 Summary:        A gallery/slideshow module for MythTV
194 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
195 Group:          Applications/Multimedia
196 Requires:       mythtv-frontend-api = %{myth_api_version}
197
198 %description -n mythgallery
199 A gallery/slideshow module for MythTV.
200
201 %description -n mythgallery -l pl.UTF-8
202 Moduł galerii/pokazu slajdów dla MythTV.
203
204 %package -n mythgame
205 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
206 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
207 Group:          Applications/Multimedia
208 Requires:       mythtv-frontend-api = %{myth_api_version}
209
210 %description -n mythgame
211 A game frontend (xmame, nes, snes, pc) for MythTV.
212
213 %description -n mythgame -l pl.UTF-8
214 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
215
216 %package -n mythnews
217 Summary:        A RSS News Feed plugin for MythTV
218 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
219 Group:          Applications/Multimedia
220 Requires:       mythtv-frontend-api = %{myth_api_version}
221
222 %description -n mythnews
223 A RSS News Feed plugin for MythTV.
224
225 %description -n mythnews -l pl.UTF-8
226 Wtyczka czytnika nowinek RSS dla MythTV.
227
228 %package -n mythbrowser
229 Summary:        A small web browser module for MythTV
230 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
231 Group:          Applications/Multimedia
232 Requires:       mythtv-frontend-api = %{myth_api_version}
233
234 %description -n mythbrowser
235 MythBrowser is a full fledged web-browser (multiple tabs) to display
236 webpages in full-screen mode. Simple page navigation is possible.
237 Starting with version 0.13 it also has full support for mouse driven
238 navigation (right mouse opens and closes the popup menu).
239
240 MythBrowser also contains a BookmarkManager to manage the website
241 links in a simple mythplugin.
242
243 %description -n mythbrowser -l pl.UTF-8
244 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
245 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
246 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
247 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
248 menu).
249
250 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
251 do stron w prostej wtyczce myth.
252
253 %package -n mythweb
254 Summary:        The web interface to MythTV
255 Summary(pl.UTF-8):      Interfejs WWW do MythTV
256 Group:          Applications/Multimedia
257 Requires:       php(mysql)
258 Requires:       php(posix)
259 Requires:       webapps
260 Requires:       webserver(php) >= 4.3
261
262 %description -n mythweb
263 The web interface to MythTV.
264
265 %description -n mythweb -l pl.UTF-8
266 Interfejs WWW do MythTV.
267
268 %package -n mythnetvision
269 Summary:        Mythtv extension to watch network movie shows
270 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
271 Group:          Applications/Multimedia
272 Requires:       mythbrowser
273 Requires:       mythtv-frontend-api = %{myth_api_version}
274 Requires:       python-MythTV
275 Requires:       python-oauth
276
277 %description -n mythnetvision
278 Mythtv extension to watch network movie shows (ex. YouTube).
279
280 %description -n mythnetvision -l pl.UTF-8
281 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
282 YouTube.
283
284 %package -n mythzoneminder
285 Summary:        MythTV security TV manager
286 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
287 Group:          Applications/Multimedia
288 Requires:       mythtv-frontend-api = %{myth_api_version}
289
290 %description -n mythzoneminder
291 MythTV security TV manager.
292
293
294 %description -n mythzoneminder -l pl.UTF-8
295 Obsługa kamer przemysłowych dla MythTV.
296
297 %prep
298 %setup -q
299 %patch0 -p1
300 #%patch10 -p1
301 %patch20 -p1
302
303 # lib64 fix - enable to update patch
304 %if %{_lib} != "lib" && 0
305 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
306 xargs grep -l /lib/ . | xargs sed -i -e '
307 s,%{_prefix}/lib/,/%{_lib}/,g
308         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
309 '
310 exit 1
311 %endif
312
313 %build
314 %if %{with binary}
315 export QTDIR="%{_prefix}"
316 # Not gnu configure
317 %configure \
318         --libdir-name=`basename %{_lib}` \
319         --enable-all \
320         %{!?with_mytharchive:--disable-mytharchive} \
321         %{!?with_mythbrowser:--disable-mythbrowser} \
322         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
323         %{!?with_mythgame:--disable-mythgame} \
324         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
325         %{!?with_mythnews:--disable-mythnews} \
326         %{!?with_mythvideo:--disable-mythvideo} \
327         %{!?with_mythweather:--disable-mythweather} \
328         %{!?with_mythweb:--disable-mythweb} \
329         %{!?with_mythnetvision:--disable-mythnetvision} \
330
331 mv mythconfig.mak mythconfig.mak.old
332 cp mythconfig.mak.old mythconfig.mak
333 cat <<'EOF'>> mythconfig.mak
334 QMAKE_CXX=%{__cxx}
335 QMAKE_CC=%{__cc}
336 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
337 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
338 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
339 EOF
340
341 %{__make}
342 %endif
343
344 %install
345 rm -rf $RPM_BUILD_ROOT
346 %if %{with binary}
347 export QTDIR="%{_prefix}"
348 %{__make} install \
349         INSTALL_ROOT=$RPM_BUILD_ROOT
350
351 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
352 %if %{with mythgame}
353 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
354 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
355 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
356 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
357 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
358 %endif
359 %endif
360
361 %if %{with mythweb}
362 cd mythweb
363 cp -a %{SOURCE3} ./
364 cp -a %{SOURCE4} ./
365 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
366 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
367 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
368 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
369 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
370 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
371 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
372 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
373 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
374 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
375 cd -
376 %endif
377
378 rm -f $RPM_BUILD_ROOT%{_datadir}/data
379 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
380 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythvideo mythweather mythzoneminder; do
381         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
382                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
383         done > $p.lang
384 done
385
386 %clean
387 rm -rf $RPM_BUILD_ROOT
388
389 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
390 %webapp_register apache %{_webapp}
391
392 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
393 %webapp_unregister apache %{_webapp}
394
395 %triggerin -n mythweb -- apache < 2.2.0, apache-base
396 %webapp_register httpd %{_webapp}
397
398 %triggerin -n mythweb -- lighttpd
399 %webapp_register lighttpd %{_webapp}
400
401 %triggerun -n mythweb -- apache < 2.2.0, apache-base
402 %webapp_unregister httpd %{_webapp}
403
404 %triggerun -n mythweb -- lighttpd
405 %webapp_unregister lighttpd %{_webapp}
406
407 %triggerpostun -n mythweb -- mythweb < 0.19
408 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
409         if [ -f /etc/mythweb/$i.rpmsave ]; then
410                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
411                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
412         fi
413 done
414 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
415
416 # migrate from apache-config macros
417 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
418         if [ -d /etc/apache/webapps.d ]; then
419                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
420                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
421         fi
422
423         if [ -d /etc/httpd/webapps.d ]; then
424                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
425                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
426         fi
427         rm -f /etc/mythweb/apache.conf.rpmsave
428 fi
429
430 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
431         rm -f /etc/apache/conf.d/99_mythplugins.conf
432         /usr/sbin/webapp register apache %{_webapp}
433         %service -q apache reload
434 fi
435 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
436         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
437         /usr/sbin/webapp register httpd %{_webapp}
438         %service -q httpd reload
439 fi
440
441 %post -n mythweb
442 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
443 which packages you can need to run mythweb and how to set it quickly."
444
445 %files
446 %defattr(644,root,root,755)
447
448 %if %{with mytharchive}
449 %files -n mytharchive -f mytharchive.lang
450 %defattr(644,root,root,755)
451 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
452 %attr(755,root,root) %{_bindir}/mytharchivehelper
453 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
454 %{_datadir}/mythtv/archivemenu.xml
455 %{_datadir}/mythtv/archiveutils.xml
456 %{_datadir}/mythtv/themes/default/ma_*.png
457 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
458 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
459 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
460 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
461 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
462 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
463 %{_datadir}/mythtv/mytharchive
464 %endif
465
466 %if %{with mythmusic}
467 %files -n mythmusic -f mythmusic.lang
468 %defattr(644,root,root,755)
469 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
470 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
471 /var/lib/mythmusic
472 %{_datadir}/mythtv/musicmenu.xml
473 %{_datadir}/mythtv/music_settings.xml
474 %{_datadir}/mythtv/themes/default/music-ui.xml
475 %{_datadir}/mythtv/themes/default/mm-titlelines.png
476 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
477 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
478 %{_datadir}/mythtv/themes/default/ff_button_off.png
479 %{_datadir}/mythtv/themes/default/ff_button_on.png
480 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
481 %{_datadir}/mythtv/themes/default/miniplayer_background.png
482 %{_datadir}/mythtv/themes/default/mm_*.png
483 %{_datadir}/mythtv/themes/default/music-sel-bg.png
484 %{_datadir}/mythtv/themes/default/next_button_off.png
485 %{_datadir}/mythtv/themes/default/next_button_on.png
486 %{_datadir}/mythtv/themes/default/next_button_pushed.png
487 %{_datadir}/mythtv/themes/default/pause_button_off.png
488 %{_datadir}/mythtv/themes/default/pause_button_on.png
489 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
490 %{_datadir}/mythtv/themes/default/play_button_off.png
491 %{_datadir}/mythtv/themes/default/play_button_on.png
492 %{_datadir}/mythtv/themes/default/play_button_pushed.png
493 %{_datadir}/mythtv/themes/default/prev_button_off.png
494 %{_datadir}/mythtv/themes/default/prev_button_on.png
495 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
496 %{_datadir}/mythtv/themes/default/rew_button_off.png
497 %{_datadir}/mythtv/themes/default/rew_button_on.png
498 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
499 %{_datadir}/mythtv/themes/default/selectionbar.png
500 %{_datadir}/mythtv/themes/default/stop_button_off.png
501 %{_datadir}/mythtv/themes/default/stop_button_on.png
502 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
503 %{_datadir}/mythtv/themes/default/track_info_background.png
504 %{_datadir}/mythtv/themes/default-wide/mm_*.png
505 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
506 %endif
507
508 %if %{with mythvideo}
509 %files -n mythvideo -f mythvideo.lang
510 %defattr(644,root,root,755)
511 %doc mythvideo/README* mythvideo/videodb mythvideo/contrib
512 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
513 %{_datadir}/mythtv/themes/default/video-ui.xml
514 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
515 %{_datadir}/mythtv/themes/default/mv_*.png
516 %{_datadir}/mythtv/themes/default-wide/mv_*.png
517 %{_datadir}/mythtv/themes/default/md_*.png
518 %{_datadir}/mythtv/video_settings.xml
519 %{_datadir}/mythtv/videomenu.xml
520 %dir %{_datadir}/mythtv/mythvideo
521 %dir %{_datadir}/mythtv/mythvideo/scripts
522 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
523 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
524 %{_datadir}/mythtv/mythvideo/scripts/README
525 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
526 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
527 %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
528 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
529 /var/lib/mythvideo
530 %endif
531
532 %if %{with mythweather}
533 %files -n mythweather -f mythweather.lang
534 %defattr(644,root,root,755)
535 %doc mythweather/AUTHORS mythweather/README
536 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
537 %{_datadir}/mythtv/mythweather
538 %{_datadir}/mythtv/weather_settings.xml
539 %{_datadir}/mythtv/themes/default/weather-ui.xml
540 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
541 %{_datadir}/mythtv/themes/default/cloudy.png
542 %{_datadir}/mythtv/themes/default/fair.png
543 %{_datadir}/mythtv/themes/default/flurries.png
544 %{_datadir}/mythtv/themes/default/fog.png
545 %{_datadir}/mythtv/themes/default/logo.png
546 %{_datadir}/mythtv/themes/default/lshowers.png
547 %{_datadir}/mythtv/themes/default/mcloudy.png
548 %{_datadir}/mythtv/themes/default/mw_*.png
549 %{_datadir}/mythtv/themes/default/mwmain.png
550 %{_datadir}/mythtv/themes/default/pcloudy.png
551 %{_datadir}/mythtv/themes/default/rainsnow.png
552 %{_datadir}/mythtv/themes/default/showers.png
553 %{_datadir}/mythtv/themes/default/snowshow.png
554 %{_datadir}/mythtv/themes/default/sunny.png
555 %{_datadir}/mythtv/themes/default/thunshowers.png
556 %{_datadir}/mythtv/themes/default/unknown.png
557 %{_datadir}/mythtv/themes/default-wide/mw-*.png
558 %endif
559
560 %if %{with mythgallery}
561 %files -n mythgallery -f mythgallery.lang
562 %defattr(644,root,root,755)
563 %doc mythgallery/AUTHORS mythgallery/README
564 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
565 %{_datadir}/mythtv/themes/default/gallery-ui.xml
566 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
567 %{_datadir}/mythtv/themes/default/gallery-*.png
568 /var/lib/pictures
569 %endif
570
571 %if %{with mythgame}
572 %files -n mythgame -f mythgame.lang
573 %defattr(644,root,root,755)
574 %doc mythgame/contrib
575 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
576 %{_datadir}/mythtv/games
577 %{_datadir}/mythtv/game_settings.xml
578 %{_datadir}/mythtv/themes/default/game-ui.xml
579 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
580 %dir %{_datadir}/mythtv/metadata/Game
581 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
582 %{_datadir}/mythtv/metadata/Game/giantbomb
583 %endif
584
585 %if %{with mythnews}
586 %files -n mythnews -f mythnews.lang
587 %defattr(644,root,root,755)
588 %doc mythnews/README mythnews/AUTHORS
589 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
590 %{_datadir}/mythtv/mythnews
591 %{_datadir}/mythtv/themes/default/news-ui.xml
592 %{_datadir}/mythtv/themes/default/news-info-bg.png
593 %{_datadir}/mythtv/themes/default/enclosures.png
594 %{_datadir}/mythtv/themes/default/need-download.png
595 %{_datadir}/mythtv/themes/default/podcast.png
596 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
597 %endif
598
599 %if %{with mythbrowser}
600 %files -n mythbrowser -f mythbrowser.lang
601 %defattr(644,root,root,755)
602 %doc mythbrowser/README mythbrowser/AUTHORS
603 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
604 %{_datadir}/mythtv/themes/default/mb_progress*.png
605 %{_datadir}/mythtv/themes/default/browser-ui.xml
606 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
607 %endif
608
609 %if %{with mythweb}
610 %files -n mythweb
611 %defattr(644,root,root,755)
612 %doc mythweb/README mythweb/mythweb.conf.lighttpd
613 %doc mythweb/htdigest.sh
614 %doc mythweb/http_servers_conf_tips.txt
615 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
617 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
618 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
619 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
620 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
621 %{_datadir}/mythweb
622 %dir %attr(771,root,http) /var/cache/mythweb
623 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
624 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
625 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
626 %endif
627
628 %if %{with mythnetvision}
629 %files -n mythnetvision -f mythnetvision.lang
630 %defattr(644,root,root,755)
631 %doc mythnetvision/{AUTHORS,ChangeLog,README}
632 %attr(755,root,root) %{_bindir}/mythfillnetvision
633 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
634 %dir %{_datadir}/mythtv/mythnetvision
635 %{_datadir}/mythtv/netvisionmenu.xml
636 %dir %{_datadir}/mythtv/mythnetvision/icons
637 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
638 %{_datadir}/mythtv/mythnetvision/icons/*.png
639 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
640 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
641 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
642 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
643 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
644 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
645 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
646 %{_datadir}/mythtv/themes/default/netvision-ui.xml
647 %endif
648
649 %if %{with mythzoneminder}
650 %files -n mythzoneminder
651 %defattr(644,root,root,755)
652 %defattr(644,root,root,755)
653 %doc mythzoneminder/{AUTHORS,README}
654 %attr(755,root,root) %{_bindir}/mythzmserver
655 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
656 %dir %{_datadir}/mythtv/zonemindermenu.xml
657 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
658 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
659 %{_datadir}/mythtv/themes/default/mz_*png
660 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
661 %endif
This page took 0.104676 seconds and 3 git commands to generate.