]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- reeanbled patch against fftw3
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythflix        # disable building mythflix plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_with     mythphone       # discontnued ??
14 %bcond_without  mythvideo       # disable building mythgallery plugin
15 %bcond_with     mythweather     # building mythgallery plugin disabled by default
16                                 # it looks unusable "due to msnbc webpage structure change
17 %bcond_without  mythweb         # disable building mythgallery plugin
18 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
19
20 %if !%{with binary}
21 %undefine       with_mytharchive
22 %undefine       with_mythbrowser
23 %undefine       with_mythmovies
24 %undefine       with_mythdvd
25 %undefine       with_mythflix
26 %undefine       with_mythgallery
27 %undefine       with_mythgame
28 %undefine       with_mythmusic
29 %undefine       with_mythnews
30 %undefine       with_mythphone
31 %undefine       with_mythvideo
32 %undefine       with_mythweather
33 %endif
34
35 %include        /usr/lib/rpm/macros.perl
36
37 %define snap rc1
38 #define _rev 11046
39 #%define rel 0.1
40 Summary:        Main MythTV plugins
41 Summary(pl.UTF-8):      Główne wtyczki MythTV
42 Name:           mythplugins
43 Version:        0.22
44 Release:        0.%{snap}.1
45 License:        GPL v2
46 Group:          Applications/Multimedia
47 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}%{snap}.tar.bz2
48 # Source0-md5: 1c03d3f4ccedcd9de1c0ac2226e0031c 
49 Source1:        mythweb.conf
50 #Patch0: %{name}-lib64.patch
51 #Patch1: %{name}-paths.patch
52 Patch2:         mythweb-config.patch
53 Patch20:        %{name}-mytharchive-INT64.patch
54 Patch21:        mythmusic_fftw3.patch
55 #Patch100:      mythtv-branch.diff
56 URL:            http://www.mythtv.org/
57 %if %{with binary}
58 %if %{with mythgallery} || %{with myhtmusic}
59 BuildRequires:  OpenGL-devel
60 %endif
61 BuildRequires:  Qt3Support-devel
62 BuildRequires:  QtCore-devel
63 BuildRequires:  QtGui-devel
64 BuildRequires:  QtNetwork-devel
65 BuildRequires:  QtOpenGL-devel
66 BuildRequires:  QtSql-devel
67 BuildRequires:  QtWebKit-devel
68 BuildRequires:  QtXml-devel
69 BuildRequires:  SDL-devel
70 BuildRequires:  a52dec-libs-devel
71 BuildRequires:  cdparanoia-III-devel
72 BuildRequires:  faad2-devel >= 2.0-5.2
73 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
74 BuildRequires:  flac-devel >= 1.0.4
75 BuildRequires:  freetype-devel
76 BuildRequires:  libcdaudio-devel >= 0.99.12p2
77 BuildRequires:  libdvdcss-devel >= 1.2.7
78 BuildRequires:  libdvdread-devel >= 0.9.4
79 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
80 BuildRequires:  libfame-devel >= 0.9.0
81 BuildRequires:  libid3tag-devel
82 BuildRequires:  libmad-devel
83 BuildRequires:  libmyth-devel > 0.21
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  libtiff-devel
86 BuildRequires:  libvorbis-devel >= 1:1.0
87 BuildRequires:  mjpegtools-devel >= 1.6.1
88 BuildRequires:  nasm
89 BuildRequires:  patchutils
90 BuildRequires:  qt4-build
91 BuildRequires:  qt4-qmake
92 BuildRequires:  rpm-perlprov >= 4.1-13
93 BuildRequires:  sed >= 4.0
94 %{?with_mythmusic:BuildRequires:        taglib-devel}
95 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xvid-devel >= 1:0.9.1
98 BuildRequires:  zlib-devel
99 %endif
100 %{?with_mytharchive:Requires:   mytharchive}
101 %{?with_mythbrowser:Requires:   mythbrowser}
102 %{?with_mythdvd:Requires:       mythdvd}
103 %{?with_mythflix:Requires:      mythflix}
104 %{?with_mythgallery:Requires:   mythgallery}
105 %{?with_mythgame:Requires:      mythgame}
106 %{?with_mythmysic:Requires:     mythmusic}
107 %{?with_mythnews:Requires:      mythnews}
108 %{?with_mythphone:Requires:     mythphone}
109 %{?with_mythvideo:Requires:     mythvideo}
110 %{?with_mythweather:Requires:   mythweather}
111 %{?with_mythweb:Requires:       mythweb}
112 ExclusiveArch:  %{ix86} %{x8664} ppc
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
116 %define         _webapps        /etc/webapps
117 %define         _webapp         mythweb
118
119 %description
120 This is a consolidation of all the official MythTV plugins that used
121 to be distributed as separate downloads from mythtv.org.
122
123 %description -l pl.UTF-8
124 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
125 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
126
127 %package -n mytharchive
128 Summary:        A MythTV module to create and burn DVDs
129 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
130 Group:          Applications/Multimedia
131 Requires:       dvdauthor
132 Requires:       mjpegtools
133 Requires:       mythtv-frontend-api = %{myth_api_version}
134 Requires:       python-MySQLdb
135 Requires:       python-PIL
136 Suggests:       dvdrtools-mkisofs
137
138 %description -n mytharchive
139 MythArchive is a MythTV style plugin that uses the Mythburn Script to
140 create and burn DVDs from MythTV recordings, MythVideo files or any
141 video files available on a MythTV system. It can also export
142 recordings to a native archive format that can then be imported back
143 into a MythTV system restoring all the associated metadata.
144
145 %description -n mytharchive -l pl.UTF-8
146 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
147 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
148 innych plików z filmami dostępnych w systemie MythTV. Może także
149 eksportować nagrania do natywnego formatu archiwum, który potem można
150 zaimportować z powrotem do systemu MythTV przywracając wszystkie
151 związane z nimi metadane.
152
153 %package -n mythmusic
154 Summary:        The music player add-on module for MythTV
155 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
156 Group:          Applications/Multimedia
157 BuildRequires:  libvisual-devel
158 Requires:       mythtv-frontend-api = %{myth_api_version}
159
160 %description -n mythmusic
161 Music add-on for MythTV.
162
163 %description -n mythmusic -l pl.UTF-8
164 Odtwarzacz muzyki dla MythTV.
165
166 %package -n mythvideo
167 Summary:        A generic video player frontend module for MythTV
168 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
169 Group:          Applications/Multimedia
170 Requires:       mplayer
171 Requires:       mythtv-frontend-api = %{myth_api_version}
172
173 %description -n mythvideo
174 A generic video and dvd player frontend module for MythTV.
175
176 %description -n mythvideo -l pl.UTF-8
177 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
178
179 %package -n mythweather
180 Summary:        A MythTV module that displays a weather forcast
181 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
182 Group:          Applications/Multimedia
183 Requires:       mythtv-frontend-api = %{myth_api_version}
184
185 %description -n mythweather
186 A MythTV module that displays a weather forcast.
187
188 %description -n mythweather -l pl.UTF-8
189 Moduł MythTV wyświetlający prognozę pogody.
190
191 %package -n mythgallery
192 Summary:        A gallery/slideshow module for MythTV
193 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
194 Group:          Applications/Multimedia
195 Requires:       mythtv-frontend-api = %{myth_api_version}
196
197 %description -n mythgallery
198 A gallery/slideshow module for MythTV.
199
200 %description -n mythgallery -l pl.UTF-8
201 Moduł galerii/pokazu slajdów dla MythTV.
202
203 %package -n mythgame
204 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
205 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
206 Group:          Applications/Multimedia
207 Requires:       mythtv-frontend-api = %{myth_api_version}
208
209 %description -n mythgame
210 A game frontend (xmame, nes, snes, pc) for MythTV.
211
212 %description -n mythgame -l pl.UTF-8
213 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
214
215 %package -n mythdvd
216 Summary:        A DVD ripper module for MythTV
217 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
218 Group:          Applications/Multimedia
219 Requires:       mythtv-frontend-api = %{myth_api_version}
220 Requires:       mythvideo
221 Requires:       transcode >= 0.6.8
222
223 %description -n mythdvd
224 MythDVD is a MythTV module that allows you to rip DVD's and transcode
225 their video and audio content to other (generally smaller) formats.
226 The playing features are simply myth-style wrappers for your favourite
227 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
228 based on and derived from the excellent transcode package.
229
230 %description -n mythdvd -l pl.UTF-8
231 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
232 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
233 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
234 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
235 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
236 pakietu transcode.
237
238 %package -n mythnews
239 Summary:        A RSS News Feed plugin for MythTV
240 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
241 Group:          Applications/Multimedia
242 Requires:       mythtv-frontend-api = %{myth_api_version}
243
244 %description -n mythnews
245 A RSS News Feed plugin for MythTV.
246
247 %description -n mythnews -l pl.UTF-8
248 Wtyczka czytnika nowinek RSS dla MythTV.
249
250 %package -n mythbrowser
251 Summary:        A small web browser module for MythTV
252 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
253 Group:          Applications/Multimedia
254 Requires:       mythtv-frontend-api = %{myth_api_version}
255
256 %description -n mythbrowser
257 MythBrowser is a full fledged web-browser (multiple tabs) to display
258 webpages in full-screen mode. Simple page navigation is possible.
259 Starting with version 0.13 it also has full support for mouse driven
260 navigation (right mouse opens and closes the popup menu).
261
262 MythBrowser also contains a BookmarkManager to manage the website
263 links in a simple mythplugin.
264
265 %description -n mythbrowser -l pl.UTF-8
266 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
267 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
268 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
269 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
270 menu).
271
272 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
273 do stron w prostej wtyczce myth.
274
275 %package -n mythphone
276 Summary:        A video conferencing module for MythTV
277 Summary(pl.UTF-8):      Moduł wideokonferencji dla MythTV
278 Group:          Applications/Multimedia
279 Requires:       mythtv-frontend-api = %{myth_api_version}
280
281 %description -n mythphone
282 Mythphone is a phone and videophone capability on Myth using the
283 standard SIP protocol. It is compatible with Microsoft XP Messenger
284 and with SIP Service Providers such as Free World Dialup
285 (fwd.pulver.com).
286
287 %description -n mythphone -l pl.UTF-8
288 Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
289 standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
290 Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
291 (fwd.pulver.com).
292
293 %package -n mythweb
294 Summary:        The web interface to MythTV
295 Summary(pl.UTF-8):      Interfejs WWW do MythTV
296 Group:          Applications/Multimedia
297 Requires:       php(mysql)
298 Requires:       php(posix)
299 Requires:       webapps
300 Requires:       webserver(php) >= 4.3
301 #Suggests:      apache(mod_auth)
302 #Suggests:      apache(mod_env)
303
304 %description -n mythweb
305 The web interface to MythTV.
306
307 %description -n mythweb -l pl.UTF-8
308 Interfejs WWW do MythTV.
309
310 %package -n mythflix
311 Summary:        MythFlix (A NetFlix MythTV)
312 Summary(pl.UTF-8):      MythFlix (NetFlix MythTV)
313 Group:          Applications/Multimedia
314 Requires:       mythtv-frontend-api = %{myth_api_version}
315
316 %description -n mythflix
317 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
318 It currently supports the ability to view your queue and add movies to
319 your queue. The browse feature is based on the Netflix RSS feeds. This
320 plugin is not very mature, which means things might not work right
321 and/or it might break other things.
322
323 %description -n mythflix -l pl.UTF-8
324 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
325 Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
326 Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
327 jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
328 innego.
329
330 %package -n mythmovies
331 Summary:        MythTV cinemas timetable
332 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
333 Group:          Applications/Multimedia
334 Requires:       mythtv-frontend-api = %{myth_api_version}
335
336 %description -n mythmovies
337 MythTV cinemas timetable.
338
339
340 %description -n mythmovies -l pl.UTF-8
341 Moduł MythTV do repertuaru kinowego.
342
343 %package -n mythzoneminder
344 Summary:        MythTV security TV manager
345 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
346 Group:          Applications/Multimedia
347 Requires:       mythtv-frontend-api = %{myth_api_version}
348
349 %description -n mythzoneminder
350 MythTV security TV manager.
351
352
353 %description -n mythzoneminder -l pl.UTF-8
354 Obsługa kamer przemysłowych dla MythTV.
355
356 %prep
357 #%setup -q %{?_snap:-n %{name}}
358 %setup -q -n %{name}-%{version}%{snap}
359 #%if %{_lib} != "lib"
360 #%patch0 -p1
361 #%endif
362 #%patch1 -p1
363 #%patch2 -p1
364 %patch20 -p1
365 %patch21 -p1
366 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
367
368 # make it visible
369 #mv mythweb/data/{.,}htaccess
370
371 # lib64 fix - enable to update patch
372 %if %{_lib} != "lib" && 0
373 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
374 xargs grep -l /lib/ . | xargs sed -i -e '
375         s,/usr/lib/,/%{_lib}/,g
376         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
377 '
378 exit 1
379 %endif
380
381 %build
382 %if %{with binary}
383 export QTDIR="%{_prefix}"
384 # Not gnu configure
385 %configure \
386         --libdir-name=`basename %{_lib}` \
387         --enable-all \
388         %{!?with_mytharchive:--disable-mytharchive} \
389         %{!?with_mythbrowser:--disable-mythbrowser} \
390         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
391         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
392         %{!?with_mythgame:--disable-mythgame} \
393         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
394         %{!?with_mythnews:--disable-mythnews} \
395         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
396         %{!?with_mythvideo:--disable-mythvideo} \
397         %{!?with_mythweather:--disable-mythweather} \
398         %{!?with_mythweb:--disable-mythweb} \
399         %{!?with_mythmovies:--disable-mythmovies} \
400         %{!?with_mythflix:--disable-mythflix} \
401
402 mv mythconfig.mak mythconfig.mak.old
403 cp mythconfig.mak.old mythconfig.mak
404 cat <<'EOF'>> mythconfig.mak
405 QMAKE_CXX=%{__cxx}
406 QMAKE_CC=%{__cc}
407 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
408 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
409 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
410 EOF
411
412 %{__make}
413 %endif
414
415 %install
416 rm -rf $RPM_BUILD_ROOT
417
418 %if %{with binary}
419 export QTDIR="%{_prefix}"
420 %{__make} install \
421         INSTALL_ROOT=$RPM_BUILD_ROOT
422
423 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
424 %if %{with mythgame}
425 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
426 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
427 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
428 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
429 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
430 %endif
431 %endif
432
433 %if %{with mythweb}
434 cd mythweb
435 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
436 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
437 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
438 cp -a *.php *.pl data includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
439 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
440 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
441 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
442 cd -
443 %endif
444
445 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
446 rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
447 for p in mytharchive mythbrowser mythmovies mythdvd mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythzoneminder; do
448         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
449                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
450         done > $p.lang
451 done
452
453 %clean
454 rm -rf $RPM_BUILD_ROOT
455
456 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
457 %webapp_register apache %{_webapp}
458
459 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
460 %webapp_unregister apache %{_webapp}
461
462 %triggerin -n mythweb -- apache < 2.2.0, apache-base
463 %webapp_register httpd %{_webapp}
464
465 %triggerun -n mythweb -- apache < 2.2.0, apache-base
466 %webapp_unregister httpd %{_webapp}
467
468 %triggerpostun -n mythweb -- mythweb < 0.19
469 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
470         if [ -f /etc/mythweb/$i.rpmsave ]; then
471                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
472                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
473         fi
474 done
475 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
476
477 # migrate from apache-config macros
478 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
479         if [ -d /etc/apache/webapps.d ]; then
480                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
481                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
482         fi
483
484         if [ -d /etc/httpd/webapps.d ]; then
485                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
486                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
487         fi
488         rm -f /etc/mythweb/apache.conf.rpmsave
489 fi
490
491 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
492         rm -f /etc/apache/conf.d/99_mythplugins.conf
493         /usr/sbin/webapp register apache %{_webapp}
494         %service -q apache reload
495 fi
496 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
497         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
498         /usr/sbin/webapp register httpd %{_webapp}
499         %service -q httpd reload
500 fi
501
502 %files
503 %defattr(644,root,root,755)
504
505 %if %{with mytharchive}
506 %files -n mytharchive -f mytharchive.lang
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/mytharchivehelper
509 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
510 %{_datadir}/mythtv/archivemenu.xml
511 %{_datadir}/mythtv/archiveutils.xml
512 %{_datadir}/mythtv/themes/default/ma_*.png
513 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
514 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
515 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
516 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
517 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
518 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
519 %{_datadir}/mythtv/mytharchive
520 %endif
521
522 %if %{with mythmusic}
523 %files -n mythmusic -f mythmusic.lang
524 %defattr(644,root,root,755)
525 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
526 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
527 /var/lib/mythmusic
528 %{_datadir}/mythtv/musicmenu.xml
529 %{_datadir}/mythtv/music_settings.xml
530 %{_datadir}/mythtv/themes/default/music-ui.xml
531 %{_datadir}/mythtv/themes/default/mm-titlelines.png
532 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
533 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
534 %{_datadir}/mythtv/themes/default/ff_button_off.png
535 %{_datadir}/mythtv/themes/default/ff_button_on.png
536 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
537 %{_datadir}/mythtv/themes/default/miniplayer_background.png
538 %{_datadir}/mythtv/themes/default/mm_*.png
539 %{_datadir}/mythtv/themes/default/music-sel-bg.png
540 %{_datadir}/mythtv/themes/default/next_button_off.png
541 %{_datadir}/mythtv/themes/default/next_button_on.png
542 %{_datadir}/mythtv/themes/default/next_button_pushed.png
543 %{_datadir}/mythtv/themes/default/pause_button_off.png
544 %{_datadir}/mythtv/themes/default/pause_button_on.png
545 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
546 %{_datadir}/mythtv/themes/default/play_button_off.png
547 %{_datadir}/mythtv/themes/default/play_button_on.png
548 %{_datadir}/mythtv/themes/default/play_button_pushed.png
549 %{_datadir}/mythtv/themes/default/prev_button_off.png
550 %{_datadir}/mythtv/themes/default/prev_button_on.png
551 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
552 %{_datadir}/mythtv/themes/default/rew_button_off.png
553 %{_datadir}/mythtv/themes/default/rew_button_on.png
554 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
555 %{_datadir}/mythtv/themes/default/selectionbar.png
556 %{_datadir}/mythtv/themes/default/stop_button_off.png
557 %{_datadir}/mythtv/themes/default/stop_button_on.png
558 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
559 %{_datadir}/mythtv/themes/default/track_info_background.png
560 %{_datadir}/mythtv/themes/default-wide/mm_*.png
561 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
562 %endif
563
564 %if %{with mythvideo}
565 %files -n mythvideo -f mythvideo.lang
566 %defattr(644,root,root,755)
567 %doc mythvideo/README mythvideo/videodb
568 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
569 %{_datadir}/mythtv/themes/default/video-ui.xml
570 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
571 %{_datadir}/mythtv/themes/default/mv_*.png
572 %{_datadir}/mythtv/themes/default-wide/mv_*.png
573 %{_datadir}/mythtv/video_settings.xml
574 %{_datadir}/mythtv/videomenu.xml
575 %dir %{_datadir}/mythtv/mythvideo
576 %dir %{_datadir}/mythtv/mythvideo/scripts
577 %dir %{_datadir}/mythtv/mythvideo/scripts/ttvdb
578 %{_datadir}/mythtv/mythvideo/scripts/README
579 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
580 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
581 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
582 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
583 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/ttvdb/*
584
585 %dir %{_datadir}/mythtv/mythvideo/scripts/MythTV
586 %attr(644,root,root)%{_datadir}/mythtv/mythvideo/scripts/MythTV/MythVideoCommon.pm
587 /var/lib/mythvideo
588 %endif
589
590 %if %{with mythweather}
591 %files -n mythweather -f mythweather.lang
592 %defattr(644,root,root,755)
593 %doc mythweather/README
594 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
595 %{_datadir}/mythtv/mythweather
596 %{_datadir}/mythtv/weather_settings.xml
597 %{_datadir}/mythtv/themes/default/weather-ui.xml
598 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
599 %{_datadir}/mythtv/themes/default/cloudy.png
600 %{_datadir}/mythtv/themes/default/fair.png
601 %{_datadir}/mythtv/themes/default/flurries.png
602 %{_datadir}/mythtv/themes/default/fog.png
603 %{_datadir}/mythtv/themes/default/logo.png
604 %{_datadir}/mythtv/themes/default/lshowers.png
605 %{_datadir}/mythtv/themes/default/mcloudy.png
606 %{_datadir}/mythtv/themes/default/mw_*.png
607 %{_datadir}/mythtv/themes/default/mwmain.png
608 %{_datadir}/mythtv/themes/default/pcloudy.png
609 %{_datadir}/mythtv/themes/default/rainsnow.png
610 %{_datadir}/mythtv/themes/default/showers.png
611 %{_datadir}/mythtv/themes/default/snowshow.png
612 %{_datadir}/mythtv/themes/default/sunny.png
613 %{_datadir}/mythtv/themes/default/thunshowers.png
614 %{_datadir}/mythtv/themes/default/unknown.png
615 %{_datadir}/mythtv/themes/default-wide/mw-*.png
616 %endif
617
618 %if %{with mythgallery}
619 %files -n mythgallery -f mythgallery.lang
620 %defattr(644,root,root,755)
621 %doc mythgallery/README
622 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
623 %{_datadir}/mythtv/themes/default/gallery-ui.xml
624 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
625 %{_datadir}/mythtv/themes/default/gallery-*.png
626 # FIXME: this is definately stupid path
627 /var/lib/pictures
628 %endif
629
630 %if %{with mythgame}
631 %files -n mythgame -f mythgame.lang
632 %defattr(644,root,root,755)
633 #%doc mythgame/README
634 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
635 %{_datadir}/mythtv/games
636 %{_datadir}/mythtv/game_settings.xml
637 %{_datadir}/mythtv/themes/default/game-ui.xml
638 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
639 %endif
640
641 %if %{with mythdvd}
642 %files -n mythdvd
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_bindir}/mtd
645 %{_datadir}/mythtv/themes/default/dvd-ui.xml
646 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
647 %{_datadir}/mythtv/themes/default/md_*.png
648 %endif
649
650 %if %{with mythnews}
651 %files -n mythnews -f mythnews.lang
652 %defattr(644,root,root,755)
653 %doc mythnews/README mythnews/AUTHORS
654 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
655 %{_datadir}/mythtv/mythnews
656 %{_datadir}/mythtv/themes/default/news-ui.xml
657 # DUPLICATE WITH MYTHFLIX?
658 %{_datadir}/mythtv/themes/default/news-info-bg.png
659 %{_datadir}/mythtv/themes/default/enclosures.png
660 %{_datadir}/mythtv/themes/default/need-download.png
661 %{_datadir}/mythtv/themes/default/podcast.png
662 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
663 %endif
664
665 %if %{with mythbrowser}
666 %files -n mythbrowser -f mythbrowser.lang
667 %defattr(644,root,root,755)
668 %doc mythbrowser/README mythbrowser/AUTHORS
669 #%attr(755,root,root) %{_bindir}/mythbrowser
670 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
671 %{_datadir}/mythtv/themes/default/mb_progress*.png
672 %{_datadir}/mythtv/themes/default/browser-ui.xml
673 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
674 %endif
675
676 %if %{with mythphone}
677 %files -n mythphone -f mythphone.lang
678 %defattr(644,root,root,755)
679 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
680 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
681 %{_datadir}/mythtv/themes/default/phone-ui.xml
682 %{_datadir}/mythtv/themes/default/webcam-ui.xml
683 %{_datadir}/mythtv/themes/default/mp_*.png
684 %{_datadir}/mythtv/themes/default/phone.png
685 %endif
686
687 %if %{with mythweb}
688 %files -n mythweb
689 %defattr(644,root,root,755)
690 %doc mythweb/README
691 #%doc mythweb/data/htaccess
692 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
693 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
694 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
695 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
696 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
697 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
698 %{_datadir}/mythweb
699 %dir %attr(771,root,http) /var/cache/mythweb
700 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
701 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
702 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
703 %endif
704
705 %if %{with mythflix}
706 %files -n mythflix -f mythflix.lang
707 %defattr(644,root,root,755)
708 %doc mythflix/{AUTHORS,ChangeLog,README}
709 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
710 %dir %{_datadir}/mythtv/mythflix
711 %{_datadir}/mythtv/mythflix/netflix-rss.xml
712 %dir %{_datadir}/mythtv/mythflix/scripts
713 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
714 %{_datadir}/mythtv/netflix_menu.xml
715 %{_datadir}/mythtv/themes/default/title_netflix.png
716 %{_datadir}/mythtv/themes/default/mythflix_background.png
717 %{_datadir}/mythtv/themes/default/netflix-ui.xml
718 %{_datadir}/mythtv/themes/default-wide/netflix-ui.xml
719 %{_datadir}/mythtv/themes/default-wide/netflix-bg.png
720 # DUPLICATE WITH MYTHNEWS?
721 %{_datadir}/mythtv/themes/default/news-info-bg.png
722 %endif
723
724 %if %{with mythmovies}
725 %files -n mythmovies
726 %defattr(644,root,root,755)
727 #-f mythmovies.lang
728 %defattr(644,root,root,755)
729 %doc mythmovies/{README,TODO}
730 %attr(755,root,root) %{_bindir}/ignyte
731 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
732 %{_datadir}/mythtv/themes/default/movies-ui.xml
733 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
734 %{_datadir}/mythtv/i18n/mythmovies_*.qm
735 %endif
736
737 %if %{with mythzoneminder}
738 %files -n mythzoneminder
739 %defattr(644,root,root,755)
740 #-f mythmovies.lang
741 %defattr(644,root,root,755)
742 %doc mythzoneminder/{AUTHORS,README}
743 %attr(755,root,root) %{_bindir}/mythzmserver
744 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
745 %dir %{_datadir}/mythtv/zonemindermenu.xml
746 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
747 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
748 %{_datadir}/mythtv/themes/default/mz_*png
749 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
750 %endif
This page took 0.153103 seconds and 3 git commands to generate.