]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- corrected instalation of mythweb/lighttpd configs
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_without  mythvideo       # disable building mythgallery plugin
14 %bcond_without  mythweather     # building mythgallery plugin disabled by default
15                                 # it looks unusable "due to msnbc webpage structure change
16 %bcond_without  mythweb         # disable building mythgallery plugin
17 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
18
19 %if !%{with binary}
20 %undefine       with_mytharchive
21 %undefine       with_mythbrowser
22 %undefine       with_mythmovies
23 %undefine       with_mythdvd
24 %undefine       with_mythnetvision
25 %undefine       with_mythgallery
26 %undefine       with_mythgame
27 %undefine       with_mythmusic
28 %undefine       with_mythnews
29 %undefine       with_mythvideo
30 %undefine       with_mythweather
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34
35 #%define fix     24635
36
37 Summary:        Main MythTV plugins
38 Summary(pl.UTF-8):      Główne wtyczki MythTV
39 Name:           mythplugins
40 Version:        0.23
41 #Release:       fix%{fix}.1
42 Release:        0.2
43 License:        GPL v2
44 Group:          Applications/Multimedia
45 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
46 # Source0-md5:  be44db841f9e03d0d17ab449545b38aa
47 Source1:        mythweb.conf
48 Source2:        mythweb_lighttpd.conf
49 Source3:        htdigest.sh
50 Source4:        http_servers_conf_tips.txt
51 #Patch0: %{name}-lib64.patch
52 #Patch1: %{name}-paths.patch
53 Patch2:         mythweb-chdir.patch
54 Patch20:        %{name}-mytharchive-INT64.patch
55 #Patch21:       mythmusic_fftw3.patch
56 #Patch100:      mythtv-branch.diff
57 URL:            http://www.mythtv.org/
58 %if %{with binary}
59 %if %{with mythgallery} || %{with myhtmusic}
60 BuildRequires:  OpenGL-devel
61 %endif
62 BuildRequires:  Qt3Support-devel
63 BuildRequires:  QtCore-devel
64 BuildRequires:  QtGui-devel
65 BuildRequires:  QtNetwork-devel
66 BuildRequires:  QtOpenGL-devel
67 BuildRequires:  QtSql-devel
68 BuildRequires:  QtWebKit-devel
69 BuildRequires:  QtXml-devel
70 BuildRequires:  SDL-devel
71 BuildRequires:  a52dec-libs-devel
72 BuildRequires:  cdparanoia-III-devel
73 BuildRequires:  faad2-devel >= 2.0-5.2
74 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
75 BuildRequires:  flac-devel >= 1.0.4
76 BuildRequires:  freetype-devel
77 BuildRequires:  libcdaudio-devel >= 0.99.12p2
78 BuildRequires:  libdvdcss-devel >= 1.2.7
79 BuildRequires:  libdvdread-devel >= 0.9.4
80 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
81 BuildRequires:  libfame-devel >= 0.9.0
82 BuildRequires:  libid3tag-devel
83 BuildRequires:  libmad-devel
84 BuildRequires:  libmyth-devel > 0.21
85 BuildRequires:  libstdc++-devel
86 BuildRequires:  libtiff-devel
87 BuildRequires:  libvorbis-devel >= 1:1.0
88 BuildRequires:  mjpegtools-devel >= 1.6.1
89 BuildRequires:  nasm
90 BuildRequires:  patchutils
91 BuildRequires:  qt4-build
92 BuildRequires:  qt4-qmake
93 BuildRequires:  rpm-perlprov >= 4.1-13
94 BuildRequires:  sed >= 4.0
95 %{?with_mythmusic:BuildRequires:        taglib-devel}
96 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
97 BuildRequires:  xorg-lib-libX11-devel
98 BuildRequires:  xvid-devel >= 1:0.9.1
99 BuildRequires:  zlib-devel
100 %endif
101 %{?with_mytharchive:Requires:   mytharchive}
102 %{?with_mythbrowser:Requires:   mythbrowser}
103 %{?with_mythdvd:Requires:       mythdvd}
104 %{?with_mythnetvision:Requires: mythnetvision}
105 %{?with_mythgallery:Requires:   mythgallery}
106 %{?with_mythgame:Requires:      mythgame}
107 %{?with_mythmysic:Requires:     mythmusic}
108 %{?with_mythnews:Requires:      mythnews}
109 %{?with_mythvideo:Requires:     mythvideo}
110 %{?with_mythweather:Requires:   mythweather}
111 %{?with_mythweb:Requires:       mythweb}
112 ExclusiveArch:  %{ix86} %{x8664} ppc
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
116 %define         _webapps        /etc/webapps
117 %define         _webapp         mythweb
118
119 %description
120 This is a consolidation of all the official MythTV plugins that used
121 to be distributed as separate downloads from mythtv.org.
122
123 %description -l pl.UTF-8
124 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
125 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
126
127 %package -n mytharchive
128 Summary:        A MythTV module to create and burn DVDs
129 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
130 Group:          Applications/Multimedia
131 Requires:       dvdauthor
132 Requires:       mjpegtools
133 Requires:       mythtv-frontend-api = %{myth_api_version}
134 Requires:       python-MySQLdb
135 Requires:       python-PIL
136 Suggests:       dvdrtools-mkisofs
137
138 %description -n mytharchive
139 MythArchive is a MythTV style plugin that uses the Mythburn Script to
140 create and burn DVDs from MythTV recordings, MythVideo files or any
141 video files available on a MythTV system. It can also export
142 recordings to a native archive format that can then be imported back
143 into a MythTV system restoring all the associated metadata.
144
145 %description -n mytharchive -l pl.UTF-8
146 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
147 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
148 innych plików z filmami dostępnych w systemie MythTV. Może także
149 eksportować nagrania do natywnego formatu archiwum, który potem można
150 zaimportować z powrotem do systemu MythTV przywracając wszystkie
151 związane z nimi metadane.
152
153 %package -n mythmusic
154 Summary:        The music player add-on module for MythTV
155 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
156 Group:          Applications/Multimedia
157 BuildRequires:  libvisual-devel
158 Requires:       mythtv-frontend-api = %{myth_api_version}
159
160 %description -n mythmusic
161 Music add-on for MythTV. Support playlists, visualisations, tag editing
162 and plays many popular audio file formats - mp3, flac, wav, ogg etc.
163
164 %description -n mythmusic -l pl.UTF-8
165 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania, wizualizacje,
166 edycję tagów.
167 Potrafi odtwarzać wiele popularnych formatów audio - mp3, flac, wav, ogg
168 itd.
169
170 %package -n mythvideo
171 Summary:        A generic video player frontend module for MythTV
172 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
173 Group:          Applications/Multimedia
174 Requires:       mplayer
175 Requires:       mythtv-frontend-api = %{myth_api_version}
176
177 %description -n mythvideo
178 A generic video and dvd player frontend module for MythTV.
179
180 %description -n mythvideo -l pl.UTF-8
181 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
182
183 %package -n mythweather
184 Summary:        A MythTV module that displays a weather forcast
185 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
186 Group:          Applications/Multimedia
187 Requires:       mythtv-frontend-api = %{myth_api_version}
188
189 %description -n mythweather
190 A MythTV module that displays a weather forcast.
191
192 %description -n mythweather -l pl.UTF-8
193 Moduł MythTV wyświetlający prognozę pogody.
194
195 %package -n mythgallery
196 Summary:        A gallery/slideshow module for MythTV
197 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
198 Group:          Applications/Multimedia
199 Requires:       mythtv-frontend-api = %{myth_api_version}
200
201 %description -n mythgallery
202 A gallery/slideshow module for MythTV.
203
204 %description -n mythgallery -l pl.UTF-8
205 Moduł galerii/pokazu slajdów dla MythTV.
206
207 %package -n mythgame
208 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
209 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
210 Group:          Applications/Multimedia
211 Requires:       mythtv-frontend-api = %{myth_api_version}
212
213 %description -n mythgame
214 A game frontend (xmame, nes, snes, pc) for MythTV.
215
216 %description -n mythgame -l pl.UTF-8
217 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
218
219 %package -n mythdvd
220 Summary:        A DVD ripper module for MythTV
221 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
222 Group:          Applications/Multimedia
223 Requires:       mythtv-frontend-api = %{myth_api_version}
224 Requires:       mythvideo
225 Requires:       transcode >= 0.6.8
226
227 %description -n mythdvd
228 MythDVD is a MythTV module that allows you to rip DVD's and transcode
229 their video and audio content to other (generally smaller) formats.
230 The playing features are simply myth-style wrappers for your favourite
231 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
232 based on and derived from the excellent transcode package.
233
234 %description -n mythdvd -l pl.UTF-8
235 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
236 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
237 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
238 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
239 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
240 pakietu transcode.
241
242 %package -n mythnews
243 Summary:        A RSS News Feed plugin for MythTV
244 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
245 Group:          Applications/Multimedia
246 Requires:       mythtv-frontend-api = %{myth_api_version}
247
248 %description -n mythnews
249 A RSS News Feed plugin for MythTV.
250
251 %description -n mythnews -l pl.UTF-8
252 Wtyczka czytnika nowinek RSS dla MythTV.
253
254 %package -n mythbrowser
255 Summary:        A small web browser module for MythTV
256 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
257 Group:          Applications/Multimedia
258 Requires:       mythtv-frontend-api = %{myth_api_version}
259
260 %description -n mythbrowser
261 MythBrowser is a full fledged web-browser (multiple tabs) to display
262 webpages in full-screen mode. Simple page navigation is possible.
263 Starting with version 0.13 it also has full support for mouse driven
264 navigation (right mouse opens and closes the popup menu).
265
266 MythBrowser also contains a BookmarkManager to manage the website
267 links in a simple mythplugin.
268
269 %description -n mythbrowser -l pl.UTF-8
270 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
271 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
272 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
273 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
274 menu).
275
276 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
277 do stron w prostej wtyczce myth.
278
279 %package -n mythweb
280 Summary:        The web interface to MythTV
281 Summary(pl.UTF-8):      Interfejs WWW do MythTV
282 Group:          Applications/Multimedia
283 Requires:       php(mysql)
284 Requires:       php(posix)
285 Requires:       webapps
286 Requires:       webserver(php) >= 4.3
287 #Suggests:      apache(mod_auth)
288 #Suggests:      apache(mod_env)
289
290 %description -n mythweb
291 The web interface to MythTV.
292
293 %description -n mythweb -l pl.UTF-8
294 Interfejs WWW do MythTV.
295
296 %package -n mythnetvision
297 Summary:        Mythtv extension to watch network movie shows
298 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
299 Group:          Applications/Multimedia
300 Requires:       mythtv-frontend-api = %{myth_api_version}
301 Requires:       mythbrowser
302
303 %description -n mythnetvision
304 Mythtv extension to watch network movie shows (ex. YouTube).
305
306 %description -n mythnetvision -l pl.UTF-8
307 Dodatek do MythTV do oglądania sieciowych transmisji.
308 Na przykład z YouTube.
309
310 %package -n mythmovies
311 Summary:        MythTV cinemas timetable
312 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
313 Group:          Applications/Multimedia
314 Requires:       mythtv-frontend-api = %{myth_api_version}
315
316 %description -n mythmovies
317 MythTV cinemas timetable.
318
319
320 %description -n mythmovies -l pl.UTF-8
321 Moduł MythTV do repertuaru kinowego.
322
323 %package -n mythzoneminder
324 Summary:        MythTV security TV manager
325 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
326 Group:          Applications/Multimedia
327 Requires:       mythtv-frontend-api = %{myth_api_version}
328
329 %description -n mythzoneminder
330 MythTV security TV manager.
331
332
333 %description -n mythzoneminder -l pl.UTF-8
334 Obsługa kamer przemysłowych dla MythTV.
335
336 %prep
337 %setup -q -n %{name}-%{version}
338 #%if %{_lib} != "lib"
339 #%patch0 -p1
340 #%endif
341 #%patch1 -p1
342 %patch2 -p1
343 %patch20 -p1
344 #%patch21 -p1
345 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
346
347 # make it visible
348 #mv mythweb/data/{.,}htaccess
349
350 # lib64 fix - enable to update patch
351 %if %{_lib} != "lib" && 0
352 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
353 xargs grep -l /lib/ . | xargs sed -i -e '
354         s,/usr/lib/,/%{_lib}/,g
355         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
356 '
357 exit 1
358 %endif
359
360 %build
361 %if %{with binary}
362 export QTDIR="%{_prefix}"
363 # Not gnu configure
364 %configure \
365         --libdir-name=`basename %{_lib}` \
366         --enable-all \
367         %{!?with_mytharchive:--disable-mytharchive} \
368         %{!?with_mythbrowser:--disable-mythbrowser} \
369         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
370         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
371         %{!?with_mythgame:--disable-mythgame} \
372         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
373         %{!?with_mythnews:--disable-mythnews} \
374         %{!?with_mythvideo:--disable-mythvideo} \
375         %{!?with_mythweather:--disable-mythweather} \
376         %{!?with_mythweb:--disable-mythweb} \
377         %{!?with_mythmovies:--disable-mythmovies} \
378         %{!?with_mythnetvision:--disable-mythnetvision} \
379
380 mv mythconfig.mak mythconfig.mak.old
381 cp mythconfig.mak.old mythconfig.mak
382 cat <<'EOF'>> mythconfig.mak
383 QMAKE_CXX=%{__cxx}
384 QMAKE_CC=%{__cc}
385 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
386 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
387 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
388 EOF
389
390 %{__make}
391 %endif
392
393 %install
394 rm -rf $RPM_BUILD_ROOT
395 %if %{with binary}
396 export QTDIR="%{_prefix}"
397 %{__make} install \
398         INSTALL_ROOT=$RPM_BUILD_ROOT
399
400 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
401 %if %{with mythgame}
402 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
403 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
404 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
405 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
406 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
407 %endif
408 %endif
409
410 %if %{with mythweb}
411 cd mythweb
412 cp -a %{SOURCE3} ./
413 cp -a %{SOURCE4} ./
414 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
415 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
416 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
417 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
418 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
419 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
420 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
421 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
422 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
423 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
424 cd -
425 %endif
426
427 rm -f $RPM_BUILD_ROOT%{_datadir}/data
428 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
429 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
430         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
431                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
432         done > $p.lang
433 done
434
435 %clean
436 rm -rf $RPM_BUILD_ROOT
437
438 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
439 %webapp_register apache %{_webapp}
440
441 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
442 %webapp_unregister apache %{_webapp}
443
444 %triggerin -n mythweb -- apache < 2.2.0, apache-base
445 %webapp_register httpd %{_webapp}
446
447 %triggerin -n mythweb -- lighttpd
448 %webapp_register lighttpd %{_webapp}
449
450 %triggerun -n mythweb -- apache < 2.2.0, apache-base
451 %webapp_unregister httpd %{_webapp}
452
453 %triggerun -n mythweb -- lighttpd
454 %webapp_unregister lighttpd %{_webapp}
455
456 %triggerpostun -n mythweb -- mythweb < 0.19
457 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
458         if [ -f /etc/mythweb/$i.rpmsave ]; then
459                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
460                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
461         fi
462 done
463 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
464
465 # migrate from apache-config macros
466 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
467         if [ -d /etc/apache/webapps.d ]; then
468                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
469                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
470         fi
471
472         if [ -d /etc/httpd/webapps.d ]; then
473                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
474                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
475         fi
476         rm -f /etc/mythweb/apache.conf.rpmsave
477 fi
478
479 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
480         rm -f /etc/apache/conf.d/99_mythplugins.conf
481         /usr/sbin/webapp register apache %{_webapp}
482         %service -q apache reload
483 fi
484 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
485         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
486         /usr/sbin/webapp register httpd %{_webapp}
487         %service -q httpd reload
488 fi
489
490 %post -n mythweb
491 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
492 which packages you can need to run mythweb and how to set it quickly."
493
494 %files
495 %defattr(644,root,root,755)
496
497 %if %{with mytharchive}
498 %files -n mytharchive -f mytharchive.lang
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_bindir}/mytharchivehelper
501 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
502 %{_datadir}/mythtv/archivemenu.xml
503 %{_datadir}/mythtv/archiveutils.xml
504 %{_datadir}/mythtv/themes/default/ma_*.png
505 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
506 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
507 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
508 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
509 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
510 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
511 %{_datadir}/mythtv/mytharchive
512 %endif
513
514 %if %{with mythmusic}
515 %files -n mythmusic -f mythmusic.lang
516 %defattr(644,root,root,755)
517 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
518 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
519 /var/lib/mythmusic
520 %{_datadir}/mythtv/musicmenu.xml
521 %{_datadir}/mythtv/music_settings.xml
522 %{_datadir}/mythtv/themes/default/music-ui.xml
523 %{_datadir}/mythtv/themes/default/mm-titlelines.png
524 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
525 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
526 %{_datadir}/mythtv/themes/default/ff_button_off.png
527 %{_datadir}/mythtv/themes/default/ff_button_on.png
528 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
529 %{_datadir}/mythtv/themes/default/miniplayer_background.png
530 %{_datadir}/mythtv/themes/default/mm_*.png
531 %{_datadir}/mythtv/themes/default/music-sel-bg.png
532 %{_datadir}/mythtv/themes/default/next_button_off.png
533 %{_datadir}/mythtv/themes/default/next_button_on.png
534 %{_datadir}/mythtv/themes/default/next_button_pushed.png
535 %{_datadir}/mythtv/themes/default/pause_button_off.png
536 %{_datadir}/mythtv/themes/default/pause_button_on.png
537 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
538 %{_datadir}/mythtv/themes/default/play_button_off.png
539 %{_datadir}/mythtv/themes/default/play_button_on.png
540 %{_datadir}/mythtv/themes/default/play_button_pushed.png
541 %{_datadir}/mythtv/themes/default/prev_button_off.png
542 %{_datadir}/mythtv/themes/default/prev_button_on.png
543 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
544 %{_datadir}/mythtv/themes/default/rew_button_off.png
545 %{_datadir}/mythtv/themes/default/rew_button_on.png
546 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
547 %{_datadir}/mythtv/themes/default/selectionbar.png
548 %{_datadir}/mythtv/themes/default/stop_button_off.png
549 %{_datadir}/mythtv/themes/default/stop_button_on.png
550 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
551 %{_datadir}/mythtv/themes/default/track_info_background.png
552 %{_datadir}/mythtv/themes/default-wide/mm_*.png
553 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
554 %endif
555
556 %if %{with mythvideo}
557 %files -n mythvideo -f mythvideo.lang
558 %defattr(644,root,root,755)
559 %doc mythvideo/README mythvideo/videodb
560 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
561 %{_datadir}/mythtv/themes/default/video-ui.xml
562 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
563 %{_datadir}/mythtv/themes/default/mv_*.png
564 %{_datadir}/mythtv/themes/default-wide/mv_*.png
565 %{_datadir}/mythtv/video_settings.xml
566 %{_datadir}/mythtv/videomenu.xml
567 %dir %{_datadir}/mythtv/mythvideo
568 %dir %{_datadir}/mythtv/mythvideo/scripts
569 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
570 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
571 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
572 %{_datadir}/mythtv/mythvideo/scripts/README
573 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
574 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
575 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
576 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
577 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
578 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
579 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Television/*
580 /var/lib/mythvideo
581 %endif
582
583 %if %{with mythweather}
584 %files -n mythweather -f mythweather.lang
585 %defattr(644,root,root,755)
586 %doc mythweather/README
587 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
588 %{_datadir}/mythtv/mythweather
589 %{_datadir}/mythtv/weather_settings.xml
590 %{_datadir}/mythtv/themes/default/weather-ui.xml
591 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
592 %{_datadir}/mythtv/themes/default/cloudy.png
593 %{_datadir}/mythtv/themes/default/fair.png
594 %{_datadir}/mythtv/themes/default/flurries.png
595 %{_datadir}/mythtv/themes/default/fog.png
596 %{_datadir}/mythtv/themes/default/logo.png
597 %{_datadir}/mythtv/themes/default/lshowers.png
598 %{_datadir}/mythtv/themes/default/mcloudy.png
599 %{_datadir}/mythtv/themes/default/mw_*.png
600 %{_datadir}/mythtv/themes/default/mwmain.png
601 %{_datadir}/mythtv/themes/default/pcloudy.png
602 %{_datadir}/mythtv/themes/default/rainsnow.png
603 %{_datadir}/mythtv/themes/default/showers.png
604 %{_datadir}/mythtv/themes/default/snowshow.png
605 %{_datadir}/mythtv/themes/default/sunny.png
606 %{_datadir}/mythtv/themes/default/thunshowers.png
607 %{_datadir}/mythtv/themes/default/unknown.png
608 %{_datadir}/mythtv/themes/default-wide/mw-*.png
609 %endif
610
611 %if %{with mythgallery}
612 %files -n mythgallery -f mythgallery.lang
613 %defattr(644,root,root,755)
614 %doc mythgallery/README
615 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
616 %{_datadir}/mythtv/themes/default/gallery-ui.xml
617 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
618 %{_datadir}/mythtv/themes/default/gallery-*.png
619 # FIXME: this is definately stupid path
620 /var/lib/pictures
621 %endif
622
623 %if %{with mythgame}
624 %files -n mythgame -f mythgame.lang
625 %defattr(644,root,root,755)
626 #%doc mythgame/README
627 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
628 %{_datadir}/mythtv/games
629 %{_datadir}/mythtv/game_settings.xml
630 %{_datadir}/mythtv/themes/default/game-ui.xml
631 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
632 %endif
633
634 %if %{with mythdvd}
635 %files -n mythdvd
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/mtd
638 %{_datadir}/mythtv/themes/default/dvd-ui.xml
639 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
640 %{_datadir}/mythtv/themes/default/md_*.png
641 %endif
642
643 %if %{with mythnews}
644 %files -n mythnews -f mythnews.lang
645 %defattr(644,root,root,755)
646 %doc mythnews/README mythnews/AUTHORS
647 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
648 %{_datadir}/mythtv/mythnews
649 %{_datadir}/mythtv/themes/default/news-ui.xml
650 # DUPLICATE WITH MYTHFLIX?
651 %{_datadir}/mythtv/themes/default/news-info-bg.png
652 %{_datadir}/mythtv/themes/default/enclosures.png
653 %{_datadir}/mythtv/themes/default/need-download.png
654 %{_datadir}/mythtv/themes/default/podcast.png
655 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
656 %endif
657
658 %if %{with mythbrowser}
659 %files -n mythbrowser -f mythbrowser.lang
660 %defattr(644,root,root,755)
661 %doc mythbrowser/README mythbrowser/AUTHORS
662 #%attr(755,root,root) %{_bindir}/mythbrowser
663 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
664 %{_datadir}/mythtv/themes/default/mb_progress*.png
665 %{_datadir}/mythtv/themes/default/browser-ui.xml
666 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
667 %endif
668
669 %if %{with mythweb}
670 %files -n mythweb
671 %defattr(644,root,root,755)
672 %doc mythweb/README mythweb/mythweb.conf.lighttpd
673 %doc mythweb/htdigest.sh
674 %doc mythweb/http_servers_conf_tips.txt
675 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
676 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
677 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
678 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
679 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
680 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
681 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
682 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
683 %{_datadir}/mythweb
684 %dir %attr(771,root,http) /var/cache/mythweb
685 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
686 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
687 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
688 %endif
689
690 %if %{with mythnetvision}
691 %files -n mythnetvision -f mythnetvision.lang
692 %defattr(644,root,root,755)
693 %doc mythnetvision/{AUTHORS,ChangeLog,README}
694 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
695 %dir %{_datadir}/mythtv/mythnetvision
696 %{_datadir}/mythtv/netvisionmenu.xml
697 %dir %{_datadir}/mythtv/mythnetvision/scripts
698 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
699 %dir %{_datadir}/mythtv/mythnetvision/icons
700 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
701 %{_datadir}/mythtv/mythnetvision/icons/*.png
702 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
703 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
704 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
705 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
706 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
707 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
708 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
709 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
710 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
711 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
712 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml   
713 %{_datadir}/mythtv/themes/default/netvision-ui.xml
714 %endif
715
716 %if %{with mythmovies}
717 %files -n mythmovies
718 %defattr(644,root,root,755)
719 #-f mythmovies.lang
720 %defattr(644,root,root,755)
721 %doc mythmovies/{README,TODO}
722 %attr(755,root,root) %{_bindir}/ignyte
723 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
724 %{_datadir}/mythtv/themes/default/movies-ui.xml
725 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
726 %{_datadir}/mythtv/i18n/mythmovies_*.qm
727 %endif
728
729 %if %{with mythzoneminder}
730 %files -n mythzoneminder
731 %defattr(644,root,root,755)
732 #-f mythmovies.lang
733 %defattr(644,root,root,755)
734 %doc mythzoneminder/{AUTHORS,README}
735 %attr(755,root,root) %{_bindir}/mythzmserver
736 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
737 %dir %{_datadir}/mythtv/zonemindermenu.xml
738 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
739 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
740 %{_datadir}/mythtv/themes/default/mz_*png
741 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
742 %endif
This page took 0.15716 seconds and 3 git commands to generate.