]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
4df93d39ad153ceb8c5eb61eb590291be3f7427e
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # TODO:
3 #       - fix mytharchive
4 #       - check 64-bit build
5 #
6 # Conditional build:
7 %bcond_without  binary          # skip building binary plugins (build only mythweb)
8 %bcond_with     mytharchive     # enable mytharchive plugin
9 %bcond_without  mythbrowser     # disable building mythbrowser plugin
10 %bcond_without  mythcontrols    # disable mythcontrols plugin
11 %bcond_without  mythflix        # disable building mythflix plugin
12 %bcond_without  mythgallery     # disable building mythgallery plugin
13 %bcond_without  mythgame        # disable building mythgallery plugin
14 %bcond_without  mythmusic       # disable building mythmusic plugin
15 %bcond_without  mythnews        # disable building mythgallery plugin
16 %bcond_without  mythphone       # disable building mythgallery plugin
17 %bcond_without  mythvideo       # disable building mythgallery plugin
18 %bcond_without  mythweather     # disable building mythgallery plugin
19 %bcond_without  mythweb         # disable building mythgallery plugin
20 %bcond_without  mythmovies      # disable building mythmovies plugin
21 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
22 #
23 %if !%{with binary}
24 %undefine       with_mytharchive
25 %undefine       with_mythbrowser
26 %undefine       with_mythcontrols
27 %undefine       with_mythflix
28 %undefine       with_mythgallery
29 %undefine       with_mythgame
30 %undefine       with_mythmusic
31 %undefine       with_mythnews
32 %undefine       with_mythphone
33 %undefine       with_mythvideo
34 %undefine       with_mythweather
35 %undefine       with_mythmovies
36 %undefine       with_mythzoneminder
37 %endif
38
39 %include        /usr/lib/rpm/macros.perl
40
41 #define _snap 20060905
42 #define _rev 11046
43 %define _rel 0.1
44 Summary:        Main MythTV plugins
45 Summary(pl.UTF-8):      Główne wtyczki MythTV
46 Name:           mythplugins
47 Version:        0.21
48 Release:        %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
49 License:        GPL v2
50 Group:          Applications/Multimedia
51 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
52 # Source0-md5:  6c08043227bef1384858deee12b5cdc3
53 #Source0:       %{name}-%{_snap}.%{_rev}.tar.bz2
54 Source1:        mythweb.conf
55 Patch0:         %{name}-lib64.patch
56 Patch1:         %{name}-paths.patch
57 URL:            http://www.mythtv.org/
58 %if %{with binary}
59 %if %{with mythgallery} || %{with myhtmusic}
60 BuildRequires:  OpenGL-devel
61 %endif
62 BuildRequires:  SDL-devel
63 BuildRequires:  a52dec-libs-devel
64 BuildRequires:  cdparanoia-III-devel
65 BuildRequires:  faad2-devel >= 2.0-5.2
66 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
67 BuildRequires:  flac-devel >= 1.0.4
68 BuildRequires:  freetype-devel
69 BuildRequires:  kdelibs-devel
70 BuildRequires:  libcdaudio-devel >= 0.99.12p2
71 BuildRequires:  libdvdcss-devel >= 1.2.7
72 BuildRequires:  libdvdread-devel >= 0.9.4
73 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
74 BuildRequires:  libfame-devel >= 0.9.0
75 BuildRequires:  libid3tag-devel
76 BuildRequires:  libmad-devel
77 BuildRequires:  libmyth-devel >= 0.21
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  libtiff-devel
80 BuildRequires:  libvorbis-devel >= 1:1.0
81 BuildRequires:  mjpegtools-devel >= 1.6.1
82 BuildRequires:  nasm
83 BuildRequires:  patchutils
84 BuildRequires:  rpm-perlprov >= 4.1-13
85 BuildRequires:  sed >= 4.0
86 BuildRequires:  xvid-devel >= 1:0.9.1
87 BuildRequires:  zlib-devel
88 BuildRequires:  xorg-lib-libXext-devel
89 BuildRequires:  xorg-lib-libXxf86vm-devel
90 %endif
91 %{?with_mytharchive:Requires:   mytharchive}
92 %{?with_mythbrowser:Requires:   mythbrowser}
93 %{?with_mythflix:Requires:      mythflix}
94 %{?with_mythgallery:Requires:   mythgallery}
95 %{?with_mythgame:Requires:      mythgame}
96 %{?with_mythmysic:Requires:     mythmusic}
97 %{?with_mythnews:Requires:      mythnews}
98 %{?with_mythphone:Requires:     mythphone}
99 %{?with_mythvideo:Requires:     mythvideo}
100 %{?with_mythweather:Requires:   mythweather}
101 %{?with_mythweb:Requires:       mythweb}
102 %{?with_mythmovies:Requires:    mythmovies}
103 %{?with_mythzoneminder:Requires:        mythzoneminder}
104 ExclusiveArch:  %{ix86} %{x8664} ppc
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
108 %define         _webapps        /etc/webapps
109 %define         _webapp         mythweb
110
111 %description
112 This is a consolidation of all the official MythTV plugins that used
113 to be distributed as separate downloads from mythtv.org.
114
115 %description -l pl.UTF-8
116 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
117 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
118
119 %package -n mytharchive
120 Summary:        A MythTV module to create and burn DVDs
121 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
122 Group:          Applications/Multimedia
123 Requires:       mythtv-frontend-api = %{myth_api_version}
124
125 %description -n mytharchive
126 MythArchive is a MythTV style plugin that uses the Mythburn Script to
127 create and burn DVDs from MythTV recordings, MythVideo files or any
128 video files available on a MythTV system. It can also export
129 recordings to a native archive format that can then be imported back
130 into a MythTV system restoring all the associated metadata.
131
132 %description -n mytharchive -l pl.UTF-8
133 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
134 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
135 innych plików z filmami dostępnych w systemie MythTV. Może także
136 eksportować nagrania do natywnego formatu archiwum, który potem można
137 zaimportować z powrotem do systemu MythTV przywracając wszystkie
138 związane z nimi metadane.
139
140 %package -n mythmusic
141 Summary:        The music player add-on module for MythTV
142 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
143 Group:          Applications/Multimedia
144 Requires:       mythtv-frontend-api = %{myth_api_version}
145
146 %description -n mythmusic
147 Music add-on for MythTV.
148
149 %description -n mythmusic -l pl.UTF-8
150 Odtwarzacz muzyki dla MythTV.
151
152 %package -n mythvideo
153 Summary:        A generic video player frontend module for MythTV
154 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
155 Group:          Applications/Multimedia
156 Requires:       mplayer
157 Requires:       mythtv-frontend-api = %{myth_api_version}
158
159 %description -n mythvideo
160 A generic video player frontend module for MythTV.
161
162 %description -n mythvideo -l pl.UTF-8
163 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
164
165 %package -n mythweather
166 Summary:        A MythTV module that displays a weather forcast
167 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
168 Group:          Applications/Multimedia
169 Requires:       mythtv-frontend-api = %{myth_api_version}
170
171 %description -n mythweather
172 A MythTV module that displays a weather forcast.
173
174 %description -n mythweather -l pl.UTF-8
175 Moduł MythTV wyświetlający prognozę pogody.
176
177 %package -n mythgallery
178 Summary:        A gallery/slideshow module for MythTV
179 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
180 Group:          Applications/Multimedia
181 Requires:       mythtv-frontend-api = %{myth_api_version}
182
183 %description -n mythgallery
184 A gallery/slideshow module for MythTV.
185
186 %description -n mythgallery -l pl.UTF-8
187 Moduł galerii/pokazu slajdów dla MythTV.
188
189 %package -n mythgame
190 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
191 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
192 Group:          Applications/Multimedia
193 Requires:       mythtv-frontend-api = %{myth_api_version}
194
195 %description -n mythgame
196 A game frontend (xmame, nes, snes, pc) for MythTV.
197
198 %description -n mythgame -l pl.UTF-8
199 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
200
201 %package -n mythnews
202 Summary:        A RSS News Feed plugin for MythTV
203 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
204 Group:          Applications/Multimedia
205 Requires:       mythtv-frontend-api = %{myth_api_version}
206
207 %description -n mythnews
208 A RSS News Feed plugin for MythTV.
209
210 %description -n mythnews -l pl.UTF-8
211 Wtyczka czytnika nowinek RSS dla MythTV.
212
213 %package -n mythbrowser
214 Summary:        A small web browser module for MythTV
215 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
216 Group:          Applications/Multimedia
217 Requires:       mythtv-frontend-api = %{myth_api_version}
218
219 %description -n mythbrowser
220 MythBrowser is a full fledged web-browser (multiple tabs) to display
221 webpages in full-screen mode. Simple page navigation is possible.
222 Starting with version 0.13 it also has full support for mouse driven
223 navigation (right mouse opens and closes the popup menu).
224
225 MythBrowser also contains a BookmarkManager to manage the website
226 links in a simple mythplugin.
227
228 %description -n mythbrowser -l pl.UTF-8
229 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
230 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
231 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
232 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
233 menu).
234
235 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
236 do stron w prostej wtyczce myth.
237
238 %package -n mythphone
239 Summary:        A video conferencing module for MythTV
240 Summary(pl.UTF-8):      Moduł wideokonferencji dla MythTV
241 Group:          Applications/Multimedia
242 Requires:       mythtv-frontend-api = %{myth_api_version}
243
244 %description -n mythphone
245 Mythphone is a phone and videophone capability on Myth using the
246 standard SIP protocol. It is compatible with Microsoft XP Messenger
247 and with SIP Service Providers such as Free World Dialup
248 (fwd.pulver.com).
249
250 %description -n mythphone -l pl.UTF-8
251 Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
252 standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
253 Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
254 (fwd.pulver.com).
255
256 %package -n mythweb
257 Summary:        The web interface to MythTV
258 Summary(pl.UTF-8):      Interfejs WWW do MythTV
259 Group:          Applications/Multimedia
260 Requires:       webapps
261 #Suggests:      apache(mod_auth)
262 #Suggests:      apache(mod_env)
263 Requires:       php(mysql)
264 Requires:       php(posix)
265 Requires:       webserver(php) >= 4.3
266
267 %description -n mythweb
268 The web interface to MythTV.
269
270 %description -n mythweb -l pl.UTF-8
271 Interfejs WWW do MythTV.
272
273 %package -n mythflix
274 Summary:        MythFlix (A NetFlix MythTV)
275 Summary(pl.UTF-8):      MythFlix (NetFlix MythTV)
276 Group:          Applications/Multimedia
277 Requires:       mythtv-frontend-api = %{myth_api_version}
278
279 %description -n mythflix
280 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
281 It currently supports the ability to view your queue and add movies to
282 your queue. The browse feature is based on the Netflix RSS feeds. This
283 plugin is not very mature, which means things might not work right
284 and/or it might break other things.
285
286 %description -n mythflix -l pl.UTF-8
287 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
288 Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
289 Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
290 jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
291 innego.
292
293 %package -n mythcontrols
294 Summary:        MythTV keybindings editor
295 Summary(pl.UTF-8):      Edytor przypisań klawiszy MythTV
296 Group:          Applications/Multimedia
297 Requires:       mythtv-frontend-api = %{myth_api_version}
298
299 %description -n mythcontrols
300 This plugin allows you to configure your keybindings on the frontend
301 without having to use mythweb or edit tables by hand.
302
303 %description -n mythcontrols -l pl.UTF-8
304 Ta wtyczka pozwala konfigurować przypisania klawiszy we frontendzie
305 bez konieczności używania mythweba ani ręcznego modyfikowania tabel.
306
307 %package -n mythmovies
308 Summary:        MythTV plugin for looking up movie showtimes in a given area
309 Group:          Applications/Multimedia
310 Requires:       mythtv-frontend-api = %{myth_api_version}
311
312 %description -n mythmovies
313 MythMovies is a plugin for looking up movie showtimes in a given area. 
314
315 %package -n mythzoneminder
316 Summary:        MythTV plugin to interface ZoneMinder
317 Group:          Applications/Multimedia
318 Requires:       mythtv-frontend-api = %{myth_api_version}
319
320 %description -n mythzoneminder
321 MythZoneMinder is a plugin to interface to some of the features of ZoneMinder.
322 You can use it to view a status window similar to the console window in ZM.
323 Also there are screens to view live camera shots and replay recorded events.
324 Other features may be added at a later time if there is sufficient interest.
325
326 ZoneMinder is a Linux video camera security and surveillance solution .
327
328 %prep
329 %setup -q %{?_snap:-n %{name}}
330 %if %{_lib} != "lib"
331 #%patch0 -p1
332 %endif
333 %patch1 -p1
334 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
335
336 # make it visible
337 mv mythweb/{data/.,}htaccess
338
339 # lib64 fix - enable to update patch
340 %if %{_lib} != "lib" && 0
341 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
342 xargs grep -l /lib/ . | xargs sed -i -e '
343         s,/usr/lib/,/usr/%{_lib}/,g
344         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
345 '
346 exit 1
347 %endif
348
349 %build
350 %if %{with binary}
351 export QTDIR="%{_prefix}"
352 # Not gnu configure
353 %configure \
354         --libdir-name=%{_lib} \
355         --enable-all \
356         %{!?with_mytharchive:--disable-mytharchive} \
357         %{!?with_mythbrowser:--disable-mythbrowser} \
358         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
359         %{!?with_mythgame:--disable-mythgame} \
360         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
361         %{!?with_mythnews:--disable-mythnews} \
362         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
363         %{!?with_mythvideo:--disable-mythvideo} \
364         %{!?with_mythweather:--disable-mythweather} \
365         %{!?with_mythweb:--disable-mythweb} \
366         %{!?with_mythcontrols:--disable-mythcontrols} \
367         %{!?with_mythflix:--disable-mythflix} \
368
369 mv mythconfig.mak mythconfig.mak.old
370 cp mythconfig.mak.old mythconfig.mak
371 cat <<'EOF'>> mythconfig.mak
372 QMAKE_CXX=%{__cxx}
373 QMAKE_CC=%{__cc}
374 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
375 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
376 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
377 EOF
378
379 %{__make}
380 %endif
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384
385 %if %{with binary}
386 export QTDIR="%{_prefix}"
387 %{__make} install \
388         INSTALL_ROOT=$RPM_BUILD_ROOT
389
390 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
391 %if %{with mythgame}
392 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
393 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
394 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
395 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
396 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
397 %endif
398 %endif
399
400 %if %{with mythweb}
401 cd mythweb
402 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
403 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
404 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
405 cp -a *.php *.pl data includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
406 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
407 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
408 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
409 cd -
410 %endif
411
412 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
413 rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
414 for p in mytharchive mythbrowser mythcontrols mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythmovies mythzoneminder; do
415         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
416                 if [ -f "$l" ] ; then
417                         echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
418                 fi
419         done > $p.lang
420 done
421
422 %clean
423 rm -rf $RPM_BUILD_ROOT
424
425 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
426 %webapp_register apache %{_webapp}
427
428 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
429 %webapp_unregister apache %{_webapp}
430
431 %triggerin -n mythweb -- apache < 2.2.0, apache-base
432 %webapp_register httpd %{_webapp}
433
434 %triggerun -n mythweb -- apache < 2.2.0, apache-base
435 %webapp_unregister httpd %{_webapp}
436
437 %triggerpostun -n mythweb -- mythweb < 0.19
438 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
439         if [ -f /etc/mythweb/$i.rpmsave ]; then
440                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
441                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
442         fi
443 done
444 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
445
446 # migrate from apache-config macros
447 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
448         if [ -d /etc/apache/webapps.d ]; then
449                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
450                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
451         fi
452
453         if [ -d /etc/httpd/webapps.d ]; then
454                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
455                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
456         fi
457         rm -f /etc/mythweb/apache.conf.rpmsave
458 fi
459
460 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
461         rm -f /etc/apache/conf.d/99_mythplugins.conf
462         /usr/sbin/webapp register apache %{_webapp}
463         %service -q apache reload
464 fi
465 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
466         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
467         /usr/sbin/webapp register httpd %{_webapp}
468         %service -q httpd reload
469 fi
470
471 %files
472 %defattr(644,root,root,755)
473
474 %if %{with mytharchive}
475 %files -n mytharchive -f mytharchive.lang
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_bindir}/mytharchivehelper
478 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
479 %{_datadir}/mythtv/archiveformat.xml
480 %{_datadir}/mythtv/archivemenu.xml
481 %{_datadir}/mythtv/archiveselect.xml
482 %{_datadir}/mythtv/themes/default/ma_*.png
483 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
484 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
485 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
486 %{_datadir}/mythtv/mytharchive
487 %endif
488
489 %if %{with mythmusic}
490 %files -n mythmusic -f mythmusic.lang
491 %defattr(644,root,root,755)
492 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
493 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
494 /var/lib/mythmusic
495 %{_datadir}/mythtv/musicmenu.xml
496 %{_datadir}/mythtv/music_settings.xml
497 %{_datadir}/mythtv/themes/default/music-ui.xml
498 %{_datadir}/mythtv/themes/default/ff_button_off.png
499 %{_datadir}/mythtv/themes/default/ff_button_on.png
500 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
501 %{_datadir}/mythtv/themes/default/mm_*.png
502 %{_datadir}/mythtv/themes/default/music-sel-bg.png
503 %{_datadir}/mythtv/themes/default/next_button_off.png
504 %{_datadir}/mythtv/themes/default/next_button_on.png
505 %{_datadir}/mythtv/themes/default/next_button_pushed.png
506 %{_datadir}/mythtv/themes/default/pause_button_off.png
507 %{_datadir}/mythtv/themes/default/pause_button_on.png
508 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
509 %{_datadir}/mythtv/themes/default/play_button_off.png
510 %{_datadir}/mythtv/themes/default/play_button_on.png
511 %{_datadir}/mythtv/themes/default/play_button_pushed.png
512 %{_datadir}/mythtv/themes/default/prev_button_off.png
513 %{_datadir}/mythtv/themes/default/prev_button_on.png
514 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
515 %{_datadir}/mythtv/themes/default/rew_button_off.png
516 %{_datadir}/mythtv/themes/default/rew_button_on.png
517 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
518 %{_datadir}/mythtv/themes/default/selectionbar.png
519 %{_datadir}/mythtv/themes/default/stop_button_off.png
520 %{_datadir}/mythtv/themes/default/stop_button_on.png
521 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
522 %{_datadir}/mythtv/themes/default/track_info_background.png
523 %{_datadir}/mythtv/themes/default/miniplayer*.png
524 %endif
525
526 %if %{with mythvideo}
527 %files -n mythvideo -f mythvideo.lang
528 %defattr(644,root,root,755)
529 %doc mythvideo/README mythvideo/videodb
530 %attr(755,root,root) %{_bindir}/mtd
531 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
532 %{_datadir}/mythtv/themes/default/dvd-ui.xml
533 %{_datadir}/mythtv/themes/default/video-ui.xml
534 %{_datadir}/mythtv/themes/default/mv-*.png
535 %{_datadir}/mythtv/themes/default/mv_*.png
536 %{_datadir}/mythtv/themes/default/md_*.png
537 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
538 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
539 %{_datadir}/mythtv/themes/default-wide/mv-*.png
540 %{_datadir}/mythtv/themes/default-wide/mv_*.png
541 %{_datadir}/mythtv/video_settings.xml
542 %{_datadir}/mythtv/videomenu.xml
543 %dir %{_datadir}/mythtv/mythvideo
544 %dir %{_datadir}/mythtv/mythvideo/scripts
545 %{_datadir}/mythtv/mythvideo/scripts/README
546 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
547 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
548 /var/lib/mythvideo
549 %endif
550
551 %if %{with mythweather}
552 %files -n mythweather -f mythweather.lang
553 %defattr(644,root,root,755)
554 %doc mythweather/README
555 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
556 %{_datadir}/mythtv/mythweather
557 %{_datadir}/mythtv/themes/default/weather-ui.xml
558 %{_datadir}/mythtv/themes/default/cloudy.png
559 %{_datadir}/mythtv/themes/default/fair.png
560 %{_datadir}/mythtv/themes/default/flurries.png
561 %{_datadir}/mythtv/themes/default/fog.png
562 %{_datadir}/mythtv/themes/default/logo.png
563 %{_datadir}/mythtv/themes/default/lshowers.png
564 %{_datadir}/mythtv/themes/default/mcloudy.png
565 %{_datadir}/mythtv/themes/default/mw_*.png
566 %{_datadir}/mythtv/themes/default/mwmain.png
567 %{_datadir}/mythtv/themes/default/pcloudy.png
568 %{_datadir}/mythtv/themes/default/rainsnow.png
569 %{_datadir}/mythtv/themes/default/showers.png
570 %{_datadir}/mythtv/themes/default/snowshow.png
571 %{_datadir}/mythtv/themes/default/sunny.png
572 %{_datadir}/mythtv/themes/default/thunshowers.png
573 %{_datadir}/mythtv/themes/default/unknown.png
574 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
575 %{_datadir}/mythtv/themes/default-wide/mw-*.png
576 %{_datadir}/mythtv/weather_settings.xml
577 %endif
578
579 %if %{with mythgallery}
580 %files -n mythgallery -f mythgallery.lang
581 %defattr(644,root,root,755)
582 %doc mythgallery/README
583 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
584 %{_datadir}/mythtv/themes/default/gallery-ui.xml
585 %{_datadir}/mythtv/themes/default/gallery-*.png
586 # FIXME: this is definately stupid path
587 /var/lib/pictures
588 %endif
589
590 %if %{with mythgame}
591 %files -n mythgame -f mythgame.lang
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
594 %{_datadir}/mythtv/games
595 %{_datadir}/mythtv/game_settings.xml
596 %{_datadir}/mythtv/themes/default/game-ui.xml
597 %endif
598
599 %if %{with mythnews}
600 %files -n mythnews -f mythnews.lang
601 %defattr(644,root,root,755)
602 %doc mythnews/README mythnews/AUTHORS
603 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
604 %{_datadir}/mythtv/mythnews
605 %{_datadir}/mythtv/themes/default/news-ui.xml
606 %{_datadir}/mythtv/themes/default/enclosures.png
607 %{_datadir}/mythtv/themes/default/need-download.png
608 # DUPLICATE WITH MYTHFLIX?
609 %{_datadir}/mythtv/themes/default/news-info-bg.png
610 %endif
611
612 %if %{with mythbrowser}
613 %files -n mythbrowser -f mythbrowser.lang
614 %defattr(644,root,root,755)
615 %doc mythbrowser/README mythbrowser/AUTHORS
616 %attr(755,root,root) %{_bindir}/mythbrowser
617 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
618 %{_datadir}/mythtv/themes/default/webpage.png
619 %endif
620
621 %if %{with mythphone}
622 %files -n mythphone -f mythphone.lang
623 %defattr(644,root,root,755)
624 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
625 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
626 %{_datadir}/mythtv/themes/default/phone-ui.xml
627 %{_datadir}/mythtv/themes/default/webcam-ui.xml
628 %{_datadir}/mythtv/themes/default/mp_*.png
629 %{_datadir}/mythtv/themes/default/phone.png
630 %endif
631
632 %if %{with mythweb}
633 %files -n mythweb
634 %defattr(644,root,root,755)
635 %doc mythweb/{README,INSTALL,data,htaccess,mythweb.conf.*}
636 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
637 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
638 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
639 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
640 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
641 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
642 %{_datadir}/mythweb
643 %dir %attr(771,root,http) /var/cache/mythweb
644 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
645 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
646 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
647 %endif
648
649 %if %{with mythflix}
650 %files -n mythflix -f mythflix.lang
651 %defattr(644,root,root,755)
652 %doc mythflix/{AUTHORS,ChangeLog,README}
653 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
654 %dir %{_datadir}/mythtv/mythflix
655 %{_datadir}/mythtv/mythflix/netflix-rss.xml
656 %dir %{_datadir}/mythtv/mythflix/scripts
657 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
658 %{_datadir}/mythtv/netflix_menu.xml
659 %{_datadir}/mythtv/themes/default/title_netflix.png
660 %{_datadir}/mythtv/themes/default/netflix-ui.xml
661 # DUPLICATE WITH MYTHNEWS?
662 %{_datadir}/mythtv/themes/default/news-info-bg.png
663 %endif
664
665 %if %{with mythcontrols}
666 %files -n mythcontrols -f mythcontrols.lang
667 %defattr(644,root,root,755)
668 %doc mythcontrols/{AUTHORS,README,TODO}
669 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
670 %{_datadir}/mythtv/themes/default/controls-ui.xml
671 %{_datadir}/mythtv/themes/default/kb-button-off.png
672 %{_datadir}/mythtv/themes/default/kb-button-on.png
673 %endif
674
675 %if %{with mythmovies}
676 %files -n mythmovies -f mythmovies.lang
677 %defattr(644,root,root,755)
678 %doc mythmovies/{README,TODO}
679 %attr(755,root,root) %{_bindir}/ignyte
680 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
681 %{_datadir}/mythtv/themes/default/movies-ui.xml
682 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
683 %endif
684
685 %if %{with mythzoneminder}
686 %files -n mythzoneminder -f mythzoneminder.lang
687 %defattr(644,root,root,755)
688 %doc mythzoneminder/{README,AUTHORS}
689 %attr(755,root,root) %{_bindir}/mythzmserver
690 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
691 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
692 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
693 %{_datadir}/mythtv/themes/default/mz_*.png
694 %{_datadir}/mythtv/zonemindermenu.xml
695 %endif
This page took 0.89201 seconds and 2 git commands to generate.