]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- up to 0.22 svn version
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythflix        # disable building mythflix plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_with     mythphone       # discontnued ??
14 %bcond_without  mythvideo       # disable building mythgallery plugin
15 %bcond_without  mythweather     # disable building mythgallery plugin
16 %bcond_without  mythweb         # disable building mythgallery plugin
17 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
18
19 %if !%{with binary}
20 %undefine       with_mytharchive
21 %undefine       with_mythbrowser
22 %undefine       with_mythmovies
23 %undefine       with_mythdvd
24 %undefine       with_mythflix
25 %undefine       with_mythgallery
26 %undefine       with_mythgame
27 %undefine       with_mythmusic
28 %undefine       with_mythnews
29 %undefine       with_mythphone
30 %undefine       with_mythvideo
31 %undefine       with_mythweather
32 %endif
33
34 %include        /usr/lib/rpm/macros.perl
35
36 %define snap 20090302
37 #define _rev 11046
38 #%define rel 0.1
39 Summary:        Main MythTV plugins
40 Summary(pl.UTF-8):      Główne wtyczki MythTV
41 Name:           mythplugins
42 Version:        0.22
43 Release:        0.%{snap}.1
44 License:        GPL v2
45 Group:          Applications/Multimedia
46 Source0:        %{name}-%{version}-%{snap}.tar.bz2
47 # Source0-md5: 
48 Source1:        mythweb.conf
49 #Patch0:                %{name}-lib64.patch
50 #Patch1:                %{name}-paths.patch
51 Patch2:         mythweb-config.patch
52 Patch20:        mytharchive-INT64.patch
53 Patch100:       mythtv-branch.diff
54 URL:            http://www.mythtv.org/
55 %if %{with binary}
56 %if %{with mythgallery} || %{with myhtmusic}
57 BuildRequires:  OpenGL-devel
58 %endif
59 BuildRequires:  SDL-devel
60 BuildRequires:  xorg-lib-libX11-devel   
61 BuildRequires:  a52dec-libs-devel
62 BuildRequires:  cdparanoia-III-devel
63 BuildRequires:  faad2-devel >= 2.0-5.2
64 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
65 %{?with_mythmusic:BuildRequires:        taglib-devel}
66 BuildRequires:  flac-devel >= 1.0.4
67 BuildRequires:  freetype-devel
68 BuildRequires:  qt4-qmake
69 BuildRequires:  Qt3Support-devel
70 BuildRequires:  QtOpenGL-devel
71 BuildRequires:  QtXml-devel
72 BuildRequires:  qt4-build
73 BuildRequires:  QtNetwork-devel
74 BuildRequires:  QtGui-devel
75 BuildRequires:  QtSql-devel
76 BuildRequires:  QtCore-devel
77 BuildRequires:  QtWebKit-devel
78 BuildRequires:  libcdaudio-devel >= 0.99.12p2
79 BuildRequires:  libdvdcss-devel >= 1.2.7
80 BuildRequires:  libdvdread-devel >= 0.9.4
81 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
82 BuildRequires:  libfame-devel >= 0.9.0
83 BuildRequires:  libid3tag-devel
84 BuildRequires:  libmad-devel
85 BuildRequires:  libmyth-devel >= 0.19
86 BuildRequires:  libstdc++-devel
87 BuildRequires:  libtiff-devel
88 BuildRequires:  libvorbis-devel >= 1:1.0
89 BuildRequires:  mjpegtools-devel >= 1.6.1
90 BuildRequires:  nasm
91 BuildRequires:  patchutils
92 BuildRequires:  rpm-perlprov >= 4.1-13
93 BuildRequires:  sed >= 4.0
94 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
95 BuildRequires:  xvid-devel >= 1:0.9.1
96 BuildRequires:  zlib-devel
97 %endif
98 %{?with_mytharchive:Requires:   mytharchive}
99 %{?with_mythbrowser:Requires:   mythbrowser}
100 %{?with_mythdvd:Requires:       mythdvd}
101 %{?with_mythflix:Requires:      mythflix}
102 %{?with_mythgallery:Requires:   mythgallery}
103 %{?with_mythgame:Requires:      mythgame}
104 %{?with_mythmysic:Requires:     mythmusic}
105 %{?with_mythnews:Requires:      mythnews}
106 %{?with_mythphone:Requires:     mythphone}
107 %{?with_mythvideo:Requires:     mythvideo}
108 %{?with_mythweather:Requires:   mythweather}
109 %{?with_mythweb:Requires:       mythweb}
110 ExclusiveArch:  %{ix86} %{x8664} ppc
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
114 %define         _webapps        /etc/webapps
115 %define         _webapp         mythweb
116
117 %description
118 This is a consolidation of all the official MythTV plugins that used
119 to be distributed as separate downloads from mythtv.org.
120
121 %description -l pl.UTF-8
122 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
123 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
124
125 %package -n mytharchive
126 Summary:        A MythTV module to create and burn DVDs
127 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
128 Group:          Applications/Multimedia
129 Requires:       mythtv-frontend-api = %{myth_api_version}
130 Requires:       python-PIL
131 Requires:       python-MySQLdb
132 Requires:       mjpegtools
133 Requires:       dvdauthor
134 Suggests:       dvdrtools-mkisofs
135
136 %description -n mytharchive
137 MythArchive is a MythTV style plugin that uses the Mythburn Script to
138 create and burn DVDs from MythTV recordings, MythVideo files or any
139 video files available on a MythTV system. It can also export
140 recordings to a native archive format that can then be imported back
141 into a MythTV system restoring all the associated metadata.
142
143 %description -n mytharchive -l pl.UTF-8
144 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
145 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
146 innych plików z filmami dostępnych w systemie MythTV. Może także
147 eksportować nagrania do natywnego formatu archiwum, który potem można
148 zaimportować z powrotem do systemu MythTV przywracając wszystkie
149 związane z nimi metadane.
150
151 %package -n mythmusic
152 Summary:        The music player add-on module for MythTV
153 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
154 Group:          Applications/Multimedia
155 Requires:       mythtv-frontend-api = %{myth_api_version}
156
157 %description -n mythmusic
158 Music add-on for MythTV.
159
160 %description -n mythmusic -l pl.UTF-8
161 Odtwarzacz muzyki dla MythTV.
162
163 %package -n mythvideo
164 Summary:        A generic video player frontend module for MythTV
165 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
166 Group:          Applications/Multimedia
167 Requires:       mplayer
168 Requires:       mythtv-frontend-api = %{myth_api_version}
169
170 %description -n mythvideo
171 A generic video and dvd player frontend module for MythTV.
172
173 %description -n mythvideo -l pl.UTF-8
174 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
175
176 %package -n mythweather
177 Summary:        A MythTV module that displays a weather forcast
178 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
179 Group:          Applications/Multimedia
180 Requires:       mythtv-frontend-api = %{myth_api_version}
181
182 %description -n mythweather
183 A MythTV module that displays a weather forcast.
184
185 %description -n mythweather -l pl.UTF-8
186 Moduł MythTV wyświetlający prognozę pogody.
187
188 %package -n mythgallery
189 Summary:        A gallery/slideshow module for MythTV
190 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
191 Group:          Applications/Multimedia
192 Requires:       mythtv-frontend-api = %{myth_api_version}
193
194 %description -n mythgallery
195 A gallery/slideshow module for MythTV.
196
197 %description -n mythgallery -l pl.UTF-8
198 Moduł galerii/pokazu slajdów dla MythTV.
199
200 %package -n mythgame
201 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
202 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
203 Group:          Applications/Multimedia
204 Requires:       mythtv-frontend-api = %{myth_api_version}
205
206 %description -n mythgame
207 A game frontend (xmame, nes, snes, pc) for MythTV.
208
209 %description -n mythgame -l pl.UTF-8
210 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
211
212 %package -n mythdvd
213 Summary:        A DVD ripper module for MythTV
214 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
215 Group:          Applications/Multimedia
216 Requires:       mythtv-frontend-api = %{myth_api_version}
217 Requires:       transcode >= 0.6.8
218 Requires:       mythvideo
219
220 %description -n mythdvd
221 MythDVD is a MythTV module that allows you to rip DVD's and transcode 
222 their video and audio content to other (generally smaller) formats. 
223 The playing features are simply myth-style wrappers for your 
224 favourite DVD playing software (mplayer, ogle, xine, etc). 
225 The transcoding is based on and derived from the excellent transcode 
226 package.
227
228 %description -n mythdvd -l pl.UTF-8
229 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz 
230 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących) 
231 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth 
232 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine 
233 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego 
234 pakietu transcode.
235
236 %package -n mythnews
237 Summary:        A RSS News Feed plugin for MythTV
238 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
239 Group:          Applications/Multimedia
240 Requires:       mythtv-frontend-api = %{myth_api_version}
241
242 %description -n mythnews
243 A RSS News Feed plugin for MythTV.
244
245 %description -n mythnews -l pl.UTF-8
246 Wtyczka czytnika nowinek RSS dla MythTV.
247
248 %package -n mythbrowser
249 Summary:        A small web browser module for MythTV
250 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
251 Group:          Applications/Multimedia
252 Requires:       mythtv-frontend-api = %{myth_api_version}
253
254 %description -n mythbrowser
255 MythBrowser is a full fledged web-browser (multiple tabs) to display
256 webpages in full-screen mode. Simple page navigation is possible.
257 Starting with version 0.13 it also has full support for mouse driven
258 navigation (right mouse opens and closes the popup menu).
259
260 MythBrowser also contains a BookmarkManager to manage the website
261 links in a simple mythplugin.
262
263 %description -n mythbrowser -l pl.UTF-8
264 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
265 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
266 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
267 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
268 menu).
269
270 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
271 do stron w prostej wtyczce myth.
272
273 %package -n mythphone
274 Summary:        A video conferencing module for MythTV
275 Summary(pl.UTF-8):      Moduł wideokonferencji dla MythTV
276 Group:          Applications/Multimedia
277 Requires:       mythtv-frontend-api = %{myth_api_version}
278
279 %description -n mythphone
280 Mythphone is a phone and videophone capability on Myth using the
281 standard SIP protocol. It is compatible with Microsoft XP Messenger
282 and with SIP Service Providers such as Free World Dialup
283 (fwd.pulver.com).
284
285 %description -n mythphone -l pl.UTF-8
286 Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
287 standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
288 Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
289 (fwd.pulver.com).
290
291 %package -n mythweb
292 Summary:        The web interface to MythTV
293 Summary(pl.UTF-8):      Interfejs WWW do MythTV
294 Group:          Applications/Multimedia
295 Requires:       webapps
296 #Suggests:      apache(mod_auth)
297 #Suggests:      apache(mod_env)
298 Requires:       php(mysql)
299 Requires:       php(posix)
300 Requires:       webserver(php) >= 4.3
301
302 %description -n mythweb
303 The web interface to MythTV.
304
305 %description -n mythweb -l pl.UTF-8
306 Interfejs WWW do MythTV.
307
308 %package -n mythflix
309 Summary:        MythFlix (A NetFlix MythTV)
310 Summary(pl.UTF-8):      MythFlix (NetFlix MythTV)
311 Group:          Applications/Multimedia
312 Requires:       mythtv-frontend-api = %{myth_api_version}
313
314 %description -n mythflix
315 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
316 It currently supports the ability to view your queue and add movies to
317 your queue. The browse feature is based on the Netflix RSS feeds. This
318 plugin is not very mature, which means things might not work right
319 and/or it might break other things.
320
321 %description -n mythflix -l pl.UTF-8
322 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
323 Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
324 Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
325 jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
326 innego.
327
328 %package -n mythmovies
329 Summary:        MythTV cinemas timetable
330 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
331 Group:          Applications/Multimedia
332 Requires:       mythtv-frontend-api = %{myth_api_version}
333
334 %description -n mythmovies
335 MythTV cinemas timetable.
336
337
338 %description -n mythmovies -l pl.UTF-8
339 Moduł MythTV do repertuaru kinowego.
340
341 %package -n mythzoneminder
342 Summary:        MythTV security TV manager
343 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
344 Group:          Applications/Multimedia
345 BuildRequires:  mysql-devel
346 Requires:       mythtv-frontend-api = %{myth_api_version}
347
348 %description -n mythzoneminder
349 MythTV security TV manager.
350
351
352 %description -n mythzoneminder -l pl.UTF-8
353 Obsługa kamer przemysłowych dla MythTV.
354
355 %prep
356 #%setup -q %{?_snap:-n %{name}}
357 %setup -q %{SOURCE0}
358 #%if %{_lib} != "lib"
359 #%patch0 -p1
360 #%endif
361 #%patch1 -p1
362 #%patch2 -p1
363 %patch20 -p1
364 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
365
366 # make it visible
367 #mv mythweb/data/{.,}htaccess
368
369 # lib64 fix - enable to update patch
370 %if %{_lib} != "lib" && 0
371 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
372 xargs grep -l /lib/ . | xargs sed -i -e '
373         s,/usr/lib/,/%{_lib}/,g
374         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
375 '
376 exit 1
377 %endif
378
379 %build
380 %if %{with binary}
381 export QTDIR="%{_prefix}"
382 # Not gnu configure
383 %configure \
384         --libdir-name=`basename %{_lib}` \
385         --enable-all \
386         %{!?with_mytharchive:--disable-mytharchive} \
387         %{!?with_mythbrowser:--disable-mythbrowser} \
388         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
389         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
390         %{!?with_mythgame:--disable-mythgame} \
391         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
392         %{!?with_mythnews:--disable-mythnews} \
393         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
394         %{!?with_mythvideo:--disable-mythvideo} \
395         %{!?with_mythweather:--disable-mythweather} \
396         %{!?with_mythweb:--disable-mythweb} \
397         %{!?with_mythmovies:--disable-mythmovies} \
398         %{!?with_mythflix:--disable-mythflix} \
399
400 mv mythconfig.mak mythconfig.mak.old
401 cp mythconfig.mak.old mythconfig.mak
402 cat <<'EOF'>> mythconfig.mak
403 QMAKE_CXX=%{__cxx}
404 QMAKE_CC=%{__cc}
405 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
406 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
407 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
408 EOF
409
410 %{__make}
411 %endif
412
413 %install
414 rm -rf $RPM_BUILD_ROOT
415
416 %if %{with binary}
417 export QTDIR="%{_prefix}"
418 %{__make} install \
419         INSTALL_ROOT=$RPM_BUILD_ROOT
420
421 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
422 %if %{with mythgame}
423 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
424 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
425 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
426 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
427 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
428 %endif
429 %endif
430
431 %if %{with mythweb}
432 cd mythweb
433 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
434 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
435 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
436 cp -a *.php *.pl data includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
437 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
438 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
439 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
440 cd -
441 %endif
442
443 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
444 rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
445 for p in mytharchive mythbrowser mythmovies mythdvd mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythzoneminder; do
446         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
447                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
448         done > $p.lang
449 done
450
451 %clean
452 rm -rf $RPM_BUILD_ROOT
453
454 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
455 %webapp_register apache %{_webapp}
456
457 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
458 %webapp_unregister apache %{_webapp}
459
460 %triggerin -n mythweb -- apache < 2.2.0, apache-base
461 %webapp_register httpd %{_webapp}
462
463 %triggerun -n mythweb -- apache < 2.2.0, apache-base
464 %webapp_unregister httpd %{_webapp}
465
466 %triggerpostun -n mythweb -- mythweb < 0.19
467 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
468         if [ -f /etc/mythweb/$i.rpmsave ]; then
469                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
470                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
471         fi
472 done
473 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
474
475 # migrate from apache-config macros
476 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
477         if [ -d /etc/apache/webapps.d ]; then
478                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
479                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
480         fi
481
482         if [ -d /etc/httpd/webapps.d ]; then
483                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
484                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
485         fi
486         rm -f /etc/mythweb/apache.conf.rpmsave
487 fi
488
489 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
490         rm -f /etc/apache/conf.d/99_mythplugins.conf
491         /usr/sbin/webapp register apache %{_webapp}
492         %service -q apache reload
493 fi
494 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
495         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
496         /usr/sbin/webapp register httpd %{_webapp}
497         %service -q httpd reload
498 fi
499
500 %files
501 %defattr(644,root,root,755)
502
503 %if %{with mytharchive}
504 %files -n mytharchive -f mytharchive.lang
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_bindir}/mytharchivehelper
507 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
508 %{_datadir}/mythtv/archivemenu.xml
509 %{_datadir}/mythtv/archiveutils.xml
510 %{_datadir}/mythtv/themes/default/ma_*.png
511 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
512 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
513 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
514 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
515 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
516 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
517 %{_datadir}/mythtv/mytharchive
518 %endif
519
520 %if %{with mythmusic}
521 %files -n mythmusic -f mythmusic.lang
522 %defattr(644,root,root,755)
523 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
524 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
525 /var/lib/mythmusic
526 %{_datadir}/mythtv/musicmenu.xml
527 %{_datadir}/mythtv/music_settings.xml
528 %{_datadir}/mythtv/themes/default/music-ui.xml
529 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
530 %{_datadir}/mythtv/themes/default/ff_button_off.png
531 %{_datadir}/mythtv/themes/default/ff_button_on.png
532 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
533 %{_datadir}/mythtv/themes/default/miniplayer_background.png
534 %{_datadir}/mythtv/themes/default/mm_*.png
535 %{_datadir}/mythtv/themes/default/music-sel-bg.png
536 %{_datadir}/mythtv/themes/default/next_button_off.png
537 %{_datadir}/mythtv/themes/default/next_button_on.png
538 %{_datadir}/mythtv/themes/default/next_button_pushed.png
539 %{_datadir}/mythtv/themes/default/pause_button_off.png
540 %{_datadir}/mythtv/themes/default/pause_button_on.png
541 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
542 %{_datadir}/mythtv/themes/default/play_button_off.png
543 %{_datadir}/mythtv/themes/default/play_button_on.png
544 %{_datadir}/mythtv/themes/default/play_button_pushed.png
545 %{_datadir}/mythtv/themes/default/prev_button_off.png
546 %{_datadir}/mythtv/themes/default/prev_button_on.png
547 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
548 %{_datadir}/mythtv/themes/default/rew_button_off.png
549 %{_datadir}/mythtv/themes/default/rew_button_on.png
550 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
551 %{_datadir}/mythtv/themes/default/selectionbar.png
552 %{_datadir}/mythtv/themes/default/stop_button_off.png
553 %{_datadir}/mythtv/themes/default/stop_button_on.png
554 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
555 %{_datadir}/mythtv/themes/default/track_info_background.png
556 %{_datadir}/mythtv/themes/default-wide/mm_*.png
557 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
558 %endif
559
560 %if %{with mythvideo}
561 %files -n mythvideo -f mythvideo.lang
562 %defattr(644,root,root,755)
563 %doc mythvideo/README mythvideo/videodb
564 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
565 %{_datadir}/mythtv/themes/default/video-ui.xml
566 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
567 %{_datadir}/mythtv/themes/default/mv_*.png
568 %{_datadir}/mythtv/themes/default-wide/mv_*.png
569 %{_datadir}/mythtv/video_settings.xml
570 %{_datadir}/mythtv/videomenu.xml
571 %dir %{_datadir}/mythtv/mythvideo
572 %dir %{_datadir}/mythtv/mythvideo/scripts
573 %{_datadir}/mythtv/mythvideo/scripts/README
574 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
575 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
576 %dir %{_datadir}/mythtv/mythvideo/scripts/MythTV
577 %attr(644,root,root)%{_datadir}/mythtv/mythvideo/scripts/MythTV/MythVideoCommon.pm
578 /var/lib/mythvideo
579 %endif
580
581 %if %{with mythweather}
582 %files -n mythweather -f mythweather.lang
583 %defattr(644,root,root,755)
584 %doc mythweather/README
585 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
586 %{_datadir}/mythtv/mythweather
587 %{_datadir}/mythtv/weather_settings.xml
588 %{_datadir}/mythtv/themes/default/weather-ui.xml
589 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
590 %{_datadir}/mythtv/themes/default/cloudy.png
591 %{_datadir}/mythtv/themes/default/fair.png
592 %{_datadir}/mythtv/themes/default/flurries.png
593 %{_datadir}/mythtv/themes/default/fog.png
594 %{_datadir}/mythtv/themes/default/logo.png
595 %{_datadir}/mythtv/themes/default/lshowers.png
596 %{_datadir}/mythtv/themes/default/mcloudy.png
597 %{_datadir}/mythtv/themes/default/mw_*.png
598 %{_datadir}/mythtv/themes/default/mwmain.png
599 %{_datadir}/mythtv/themes/default/pcloudy.png
600 %{_datadir}/mythtv/themes/default/rainsnow.png
601 %{_datadir}/mythtv/themes/default/showers.png
602 %{_datadir}/mythtv/themes/default/snowshow.png
603 %{_datadir}/mythtv/themes/default/sunny.png
604 %{_datadir}/mythtv/themes/default/thunshowers.png
605 %{_datadir}/mythtv/themes/default/unknown.png
606 %{_datadir}/mythtv/themes/default-wide/mw-*.png
607 %endif
608
609 %if %{with mythgallery}
610 %files -n mythgallery -f mythgallery.lang
611 %defattr(644,root,root,755)
612 %doc mythgallery/README
613 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
614 %{_datadir}/mythtv/themes/default/gallery-ui.xml
615 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
616 %{_datadir}/mythtv/themes/default/gallery-*.png
617 # FIXME: this is definately stupid path
618 /var/lib/pictures
619 %endif
620
621 %if %{with mythgame}
622 %files -n mythgame -f mythgame.lang
623 %defattr(644,root,root,755)
624 #%doc mythgame/README
625 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
626 %{_datadir}/mythtv/games
627 %{_datadir}/mythtv/game_settings.xml
628 %{_datadir}/mythtv/themes/default/game-ui.xml
629 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
630 %endif
631
632 %if %{with mythdvd}
633 %files -n mythdvd
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_bindir}/mtd
636 %{_datadir}/mythtv/themes/default/dvd-ui.xml
637 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
638 %{_datadir}/mythtv/themes/default/md_*.png
639 %endif
640
641 %if %{with mythnews}
642 %files -n mythnews -f mythnews.lang
643 %defattr(644,root,root,755)
644 %doc mythnews/README mythnews/AUTHORS
645 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
646 %{_datadir}/mythtv/mythnews
647 %{_datadir}/mythtv/themes/default/news-ui.xml
648 # DUPLICATE WITH MYTHFLIX?
649 %{_datadir}/mythtv/themes/default/news-info-bg.png
650 %{_datadir}/mythtv/themes/default/enclosures.png
651 %{_datadir}/mythtv/themes/default/need-download.png
652 %{_datadir}/mythtv/themes/default/podcast.png
653 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
654 %endif
655
656 %if %{with mythbrowser}
657 %files -n mythbrowser -f mythbrowser.lang
658 %defattr(644,root,root,755)
659 %doc mythbrowser/README mythbrowser/AUTHORS
660 %attr(755,root,root) %{_bindir}/mythbrowser
661 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
662 %{_datadir}/mythtv/themes/default/mb_progress*.png
663 %{_datadir}/mythtv/themes/default/browser-ui.xml
664 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
665 %endif
666
667 %if %{with mythphone}
668 %files -n mythphone -f mythphone.lang
669 %defattr(644,root,root,755)
670 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
671 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
672 %{_datadir}/mythtv/themes/default/phone-ui.xml
673 %{_datadir}/mythtv/themes/default/webcam-ui.xml
674 %{_datadir}/mythtv/themes/default/mp_*.png
675 %{_datadir}/mythtv/themes/default/phone.png
676 %endif
677
678 %if %{with mythweb}
679 %files -n mythweb
680 %defattr(644,root,root,755)
681 %doc mythweb/README
682 #%doc mythweb/data/htaccess
683 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
684 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
685 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
686 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
687 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
688 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
689 %{_datadir}/mythweb
690 %dir %attr(771,root,http) /var/cache/mythweb
691 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
692 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
693 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
694 %endif
695
696 %if %{with mythflix}
697 %files -n mythflix -f mythflix.lang
698 %defattr(644,root,root,755)
699 %doc mythflix/{AUTHORS,ChangeLog,README}
700 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
701 %dir %{_datadir}/mythtv/mythflix
702 %{_datadir}/mythtv/mythflix/netflix-rss.xml
703 %dir %{_datadir}/mythtv/mythflix/scripts
704 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
705 %{_datadir}/mythtv/netflix_menu.xml
706 %{_datadir}/mythtv/themes/default/title_netflix.png
707 %{_datadir}/mythtv/themes/default/mythflix_background.png
708 %{_datadir}/mythtv/themes/default/netflix-ui.xml
709 %{_datadir}/mythtv/themes/default-wide/netflix-ui.xml
710 %{_datadir}/mythtv/themes/default-wide/netflix-bg.png
711 # DUPLICATE WITH MYTHNEWS?
712 %{_datadir}/mythtv/themes/default/news-info-bg.png
713 %endif
714
715 %if %{with mythmovies}
716 %files -n mythmovies
717 #-f mythmovies.lang
718 %defattr(644,root,root,755)
719 %doc mythmovies/{README,TODO}
720 %attr(755,root,root) %{_bindir}/ignyte
721 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
722 %{_datadir}/mythtv/themes/default/movies-ui.xml
723 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
724 %endif
725
726 %if %{with mythzoneminder}
727 %files -n mythzoneminder
728 #-f mythmovies.lang
729 %defattr(644,root,root,755)
730 %doc mythzoneminder/{AUTHORS,README}
731 %attr(755,root,root) %{_bindir}/mythzmserver
732 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
733 %dir %{_datadir}/mythtv/zonemindermenu.xml
734 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
735 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
736 %{_datadir}/mythtv/themes/default/mz_*png
737 %endif
This page took 0.178921 seconds and 3 git commands to generate.