]> git.pld-linux.org Git - packages/mutter.git/commitdiff
- upstream update for cogl 1.17
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 3 Mar 2014 19:15:16 +0000 (20:15 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 3 Mar 2014 19:15:16 +0000 (20:15 +0100)
cogl-1.17.patch [new file with mode: 0644]
mutter.spec

diff --git a/cogl-1.17.patch b/cogl-1.17.patch
new file mode 100644 (file)
index 0000000..4926c7e
--- /dev/null
@@ -0,0 +1,134 @@
+diff --git a/src/compositor/meta-texture-rectangle.c b/src/compositor/meta-texture-rectangle.c
+index cd585b5..3fc9430 100644
+--- a/src/compositor/meta-texture-rectangle.c
++++ b/src/compositor/meta-texture-rectangle.c
+@@ -26,41 +26,6 @@
+ #include <clutter/clutter.h>
+ #include "meta-texture-rectangle.h"
+-CoglTexture *
+-meta_texture_rectangle_new (unsigned int width,
+-                            unsigned int height,
+-                            CoglPixelFormat format,
+-                            CoglPixelFormat internal_format,
+-                            unsigned int rowstride,
+-                            const guint8 *data,
+-                            GError **error)
+-{
+-  ClutterBackend *backend =
+-    clutter_get_default_backend ();
+-  CoglContext *context =
+-    clutter_backend_get_cogl_context (backend);
+-  CoglTextureRectangle *tex_rect;
+-
+-  tex_rect = cogl_texture_rectangle_new_with_size (context,
+-                                                   width, height,
+-                                                   internal_format,
+-                                                   error);
+-  if (tex_rect == NULL)
+-    return NULL;
+-
+-  if (data)
+-    cogl_texture_set_region (COGL_TEXTURE (tex_rect),
+-                             0, 0, /* src_x/y */
+-                             0, 0, /* dst_x/y */
+-                             width, height, /* dst_width/height */
+-                             width, height, /* width/height */
+-                             format,
+-                             rowstride,
+-                             data);
+-
+-  return COGL_TEXTURE (tex_rect);
+-}
+-
+ static void
+ texture_rectangle_check_cb (CoglTexture *sub_texture,
+                             const float *sub_texture_coords,
+diff --git a/src/compositor/meta-texture-rectangle.h b/src/compositor/meta-texture-rectangle.h
+index ba2624f..30f60d3 100644
+--- a/src/compositor/meta-texture-rectangle.h
++++ b/src/compositor/meta-texture-rectangle.h
+@@ -28,15 +28,6 @@
+ G_BEGIN_DECLS
+-CoglTexture *
+-meta_texture_rectangle_new (unsigned int width,
+-                            unsigned int height,
+-                            CoglPixelFormat format,
+-                            CoglPixelFormat internal_format,
+-                            unsigned int rowstride,
+-                            const guint8 *data,
+-                            GError **error);
+-
+ gboolean
+ meta_texture_rectangle_check (CoglTexture *texture);
+diff --git a/src/compositor/meta-texture-tower.c b/src/compositor/meta-texture-tower.c
+index 5d82add..9a30de0 100644
+--- a/src/compositor/meta-texture-tower.c
++++ b/src/compositor/meta-texture-tower.c
+@@ -359,18 +359,10 @@ texture_tower_create_texture (MetaTextureTower *tower,
+   if ((!is_power_of_two (width) || !is_power_of_two (height)) &&
+       meta_texture_rectangle_check (tower->textures[level - 1]))
+     {
+-      tower->textures[level] =
+-        meta_texture_rectangle_new (width, height,
+-                                    /* data format */
+-                                    TEXTURE_FORMAT,
+-                                    /* internal cogl format */
+-                                    TEXTURE_FORMAT,
+-                                    /* rowstride */
+-                                    width * 4,
+-                                    /* data */
+-                                    NULL,
+-                                    /* error */
+-                                    NULL);
++      ClutterBackend *backend = clutter_get_default_backend ();
++      CoglContext *context = clutter_backend_get_cogl_context (backend);
++
++      tower->textures[level] = cogl_texture_rectangle_new_with_size (context, width, height);
+     }
+   else
+     {
+diff --git a/src/compositor/meta-window-actor.c b/src/compositor/meta-window-actor.c
+index b9473d2..a2c05ca 100644
+--- a/src/compositor/meta-window-actor.c
++++ b/src/compositor/meta-window-actor.c
+@@ -2165,12 +2165,18 @@ build_and_scan_frame_mask (MetaWindowActor       *self,
+   if (meta_texture_rectangle_check (paint_tex))
+     {
+-      mask_texture = meta_texture_rectangle_new (tex_width, tex_height,
+-                                                 COGL_PIXEL_FORMAT_A_8,
+-                                                 COGL_PIXEL_FORMAT_A_8,
+-                                                 stride,
+-                                                 mask_data,
+-                                                 NULL /* error */);
++      ClutterBackend *backend = clutter_get_default_backend ();
++      CoglContext *context = clutter_backend_get_cogl_context (backend);
++
++      mask_texture = COGL_TEXTURE (cogl_texture_rectangle_new_with_size (context, tex_width, tex_height));
++      cogl_texture_set_components (mask_texture, COGL_TEXTURE_COMPONENTS_A);
++      cogl_texture_set_region (mask_texture,
++                               0, 0, /* src_x/y */
++                               0, 0, /* dst_x/y */
++                               tex_width, tex_height, /* dst_width/height */
++                               tex_width, tex_height, /* width/height */
++                               COGL_PIXEL_FORMAT_A_8,
++                               stride, mask_data);
+     }
+   else
+     {
+diff --git a/src/core/meta-cursor-tracker.c b/src/core/meta-cursor-tracker.c
+index 84f3185..d1b365e 100644
+--- a/src/core/meta-cursor-tracker.c
++++ b/src/core/meta-cursor-tracker.c
+@@ -307,7 +307,6 @@ ensure_xfixes_cursor (MetaCursorTracker *tracker)
+                                           cursor_image->width,
+                                           cursor_image->height,
+                                           CLUTTER_CAIRO_FORMAT_ARGB32,
+-                                          COGL_PIXEL_FORMAT_ANY,
+                                           cursor_image->width * 4, /* stride */
+                                           cursor_data,
+                                           NULL);
index f8e7aa649c72b061573a8bfe2178634597725dcc..d3b9659e0fcad845092943ec23e3dfe4fbf19b28 100644 (file)
@@ -11,6 +11,7 @@ License:      GPL v2+
 Group:         X11/Window Managers
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/mutter/3.10/%{name}-%{version}.tar.xz
 # Source0-md5: e25602e010097aa44611da102c514c7c
+Patch0:                cogl-1.17.patch
 URL:           http://git.gnome.org/cgit/mutter
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.11
@@ -129,6 +130,7 @@ Dokumentacja API Mutter (Meta).
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__intltoolize}
This page took 0.045899 seconds and 4 git commands to generate.