]> git.pld-linux.org Git - packages/musescore.git/commitdiff
- more work inspired by opensuse;
authorKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Mon, 5 Jun 2023 18:59:42 +0000 (18:59 +0000)
committerKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Mon, 5 Jun 2023 18:59:42 +0000 (18:59 +0000)
- added fonts subpackage

musescore.spec

index 4f629abb6350112c08d89d725e769625ca4007e7..74b6dc1470e3dc0c68e2ac2aebb2b45927a1882e 100644 (file)
@@ -27,15 +27,12 @@ BuildRequires:      Qt5NetworkAuth-devel >= %{min_qt_version}
 BuildRequires: Qt5OpenGL-devel >= %{min_qt_version}
 BuildRequires: Qt5PrintSupport-devel >= %{min_qt_version}
 BuildRequires: Qt5Qml-devel >= %{min_qt_version}
+BuildRequires: Qt5Quick-controls2-devel
 BuildRequires: Qt5Quick-devel >= %{min_qt_version}
 BuildRequires: Qt5Sql-devel >= %{min_qt_version}
 BuildRequires: Qt5Svg-devel >= %{min_qt_version}
 BuildRequires: Qt5Test-devel >= %{min_qt_version}
 BuildRequires: Qt5UiTools-devel >= %{min_qt_version}
-#%ifnarch x32
-#BuildRequires:        Qt5WebEngine-devel >= %{min_qt_version}
-#%endif
-BuildRequires: Qt5Quick-controls2-devel
 BuildRequires: Qt5Widgets-devel >= %{min_qt_version}
 BuildRequires: Qt5Xml-devel >= %{min_qt_version}
 BuildRequires: Qt5XmlPatterns-devel >= %{min_qt_version}
@@ -54,13 +51,9 @@ BuildRequires:       qt5-linguist
 BuildRequires: qt5-qmake
 BuildRequires: texlive-latex
 Requires:      Qt5Quick-graphicaleffects
+Suggests:      %{name}-fonts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# broken:
-#  extracting debug info from /home/users/jajcus/tmp/musescore-3.0.4-root-jajcus/usr/bin/mscore
-#  /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
-#%define       _enable_debug_packages  0
-
 %description
 MuseScore is an open source and free music notation software.
 
@@ -77,6 +70,23 @@ Features:
 - integrated sequencer and software synthesizer to play the score
 - print or create pdf files
 
+%description -l pl.UTF-8
+MuseScore to otwarte i darmowe oprogramowanie do notacji muzycznej.
+
+Cechy:
+- edytor WYSIWYG, nuty są wprowadzane na "wirtualny papier nutowy"
+- czcionki TrueType do drukowania i wyświetlania umożliwiają wysokiej
+  jakości skalowanie do wszystkich rozmiarów
+- łatwe i szybkie wprowadzanie nut
+- wiele funkcji edycyjnych
+- import/eksport MusicXML
+- import/eksport Midi (SMF).
+- import MuseData
+- wejście Midi do wprowadzania nut
+- zintegrowany sekwencer i syntezator programowy do odtwarzania
+  partytury
+- możliwość tworzenia i drukowania plików pdf
+
 %package fonts
 Summary:       MuseScore fonts
 Summary(pl.UTF-8):     Czcionki MuseScore
@@ -87,6 +97,10 @@ BuildArch:   noarch
 %description fonts
 Additional fonts for use by the MuseScore music notation program.
 
+%description fonts -l pl.UTF-8
+Dodatkowe czcionki do użytku w oprogramowaniu do notacji muzycznej
+MuseScore.
+
 %prep
 %setup -q -n MuseScore-%{version}
 %patch0 -p1
@@ -95,15 +109,25 @@ Additional fonts for use by the MuseScore music notation program.
 %patch3 -p1
 %patch4 -p1
 
+# fix EOL encoding
+sed 's/\r$//' fonts/bravura/OFL-FAQ.txt > tmpfile
+touch -r fonts/bravura/OFL-FAQ.txt tmpfile
+mv -f tmpfile fonts/bravura/OFL-FAQ.txt
+
+sed 's/\r$//' thirdparty/rtf2html/README > tmpfile
+touch -r thirdparty/rtf2html/README tmpfile
+mv -f tmpfile thirdparty/rtf2html/README
+
+sed 's/\r$//' thirdparty/rtf2html/README.ru > tmpfile
+touch -r thirdparty/rtf2html/README.ru tmpfile
+mv -f tmpfile thirdparty/rtf2html/README.ru
+
 %build
 
 # note: 'build' directory is already there, for something else
 install -d build.release
 cd build.release
 
-# cmake flags taken from the main Makefile
-#CFLAGS="%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG -fPIC" \
-#CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG -fPIC" \
 %cmake  \
        -DCMAKE_BUILD_TYPE=RelWithDebInfo \
        -DMUSESCORE_BUILD_CONFIG=release \
@@ -140,17 +164,18 @@ rm -r $RPM_BUILD_ROOT%{_includedir}/opus
 rm $RPM_BUILD_ROOT%{_mandir}/man1/musescore.1.gz
 echo ".so mscore.1" > $RPM_BUILD_ROOT%{_mandir}/man1/musescore.1
 
+cd ..
 # install fonts
-install -d $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/*.ttf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/*/*.ttf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/bravura/BravuraText.otf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/campania/Campania.otf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/edwin/*.otf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/gootville/GootvilleText.otf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/leland/LelandText.otf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/musejazz/MuseJazzText.otf $RPM_BUILD_ROOT%{fontdir}
-install -p fonts/petaluma/PetalumaText.otf $RPM_BUILD_ROOT%{fontdir}
+install -d $RPM_BUILD_ROOT%{_datadir}/fonts/{OTF,TTF}
+install -p fonts/*.ttf $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
+install -p fonts/*/*.ttf $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
+install -p fonts/bravura/BravuraText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
+install -p fonts/campania/Campania.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
+install -p fonts/edwin/*.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
+install -p fonts/gootville/GootvilleText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
+install -p fonts/leland/LelandText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
+install -p fonts/musejazz/MuseJazzText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
+install -p fonts/petaluma/PetalumaText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
 
 # unique names for font docs
 mv fonts/edwin/README.md         fonts/edwin/README.md.edwin
@@ -158,6 +183,28 @@ mv fonts/edwin/LICENSE.txt       fonts/edwin/LICENSE.txt.edwin
 mv fonts/leland/README.md        fonts/leland/README.md.leland
 mv fonts/leland/LICENSE.txt      fonts/leland/LICENSE.txt.leland
 
+# collect doc files
+mkdir tmp_doc
+install -p thirdparty/beatroot/COPYING         tmp_doc/COPYING.beatroot
+install -p thirdparty/beatroot/README.txt      tmp_doc/README.txt.beatroot
+install -p thirdparty/dtl/COPYING              tmp_doc/COPYING.BSD.dtl
+install -p thirdparty/freetype/README          tmp_doc/README.freetype
+install -p thirdparty/intervaltree/README      tmp_doc/README.intervaltree
+install -p thirdparty/rtf2html/ChangeLog       tmp_doc/ChangeLog.rtf2html
+install -p thirdparty/rtf2html/COPYING.LESSER  tmp_doc/COPYING.LESSER.rtf2html
+install -p thirdparty/rtf2html/README          tmp_doc/README.rtf2html
+install -p thirdparty/rtf2html/README.mscore   tmp_doc/README.mscore.rtf2html
+install -p thirdparty/rtf2html/README.ru       tmp_doc/README.ru.rtf2html
+install -p thirdparty/singleapp/LGPL_EXCEPTION.txt tmp_doc/LGPL_EXCEPTION.txt.singleapp
+install -p thirdparty/singleapp/LICENSE.GPL3   tmp_doc/LICENSE.GPL3.singleapp
+install -p thirdparty/singleapp/LICENSE.LGPL   tmp_doc/LICENSE.LGPL.singleapp
+install -p thirdparty/singleapp/README.TXT     tmp_doc/README.TXT.singleapp
+install -p tools/bww2mxml/COPYING              tmp_doc/COPYING.bww2mxml
+install -p tools/bww2mxml/README               tmp_doc/README.bww2mxml
+install -p share/sound/README.md               tmp_doc/README.md.sound
+install -p share/instruments/README.md         tmp_doc/README.md.instruments
+install -p share/wallpapers/COPYRIGHT          tmp_doc/COPYING.wallpaper
+
 %post
 %update_desktop_database
 %update_icon_cache hicolor
@@ -168,12 +215,20 @@ mv fonts/leland/LICENSE.txt      fonts/leland/LICENSE.txt.leland
 %update_icon_cache hicolor
 %update_mime_database
 
+%post fonts
+fontpostinst OTF
+fontpostinst TTF
+
+%postun fonts
+fontpostinst OTF
+fontpostinst TTF
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md Compatibility
+%doc README.md Compatibility LICENSE.GPL tmp_doc/*
 %attr(755,root,root) %{_bindir}/mscore
 %{_datadir}/mscore-4.0
 %{_desktopdir}/org.musescore.MuseScore.desktop
@@ -183,3 +238,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/musescore.1*
 %{_datadir}/mime/packages/musescore.xml
 %{_datadir}/metainfo/org.musescore.MuseScore.appdata.xml
+
+%files fonts
+%defattr(644,root,root,755)
+%{_datadir}/fonts/TTF/*.ttf
+%{_datadir}/fonts/OTF/*.otf
+%doc fonts/README.md
+%doc fonts/bravura/bravura-text.md
+%doc fonts/bravura/OFL-FAQ.txt
+%doc fonts/bravura/OFL.txt
+%doc fonts/gootville/readme.txt fonts/campania/LICENSE
+# see section 'unique names for font docs' above
+%doc fonts/edwin/README.md.edwin fonts/edwin/LICENSE.txt.edwin
+%doc fonts/leland/README.md.leland fonts/leland/LICENSE.txt.leland
This page took 0.176336 seconds and 4 git commands to generate.