]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
- up to 0.7.1
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.7.1
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  8112478d360135b2c78ea08dac3b9b22
9 Source1:        %{name}.conf
10 Patch0:         %{name}-lua.patch
11 URL:            http://mpv.io/
12 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
13 BuildRequires:  OpenAL-devel >= 1.13
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  SDL-devel
16 BuildRequires:  alsa-lib-devel
17 BuildRequires:  enca-devel
18 BuildRequires:  ffmpeg-devel >= 2.1.4
19 BuildRequires:  jack-audio-connection-kit-devel
20 BuildRequires:  ladspa-devel
21 BuildRequires:  lcms2-devel >= 2.6
22 BuildRequires:  libass-devel
23 %ifarch i386 i486
24 BuildRequires:  libatomic-devel
25 %endif
26 BuildRequires:  libbluray-devel >= 0.2.1
27 BuildRequires:  libbs2b-devel
28 BuildRequires:  libcaca-devel >= 0.99
29 BuildRequires:  libcdio-paranoia-devel
30 BuildRequires:  libdvdnav-devel >= 4.2.0
31 BuildRequires:  libdvdread-devel >= 4.1.0
32 BuildRequires:  libguess-devel
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libmpg123-devel >= 1.14.0
35 BuildRequires:  libsmbclient-devel
36 BuildRequires:  libv4l-devel
37 BuildRequires:  libva-devel >= 1.2.0
38 BuildRequires:  libva-glx-devel >= 1.2.0
39 BuildRequires:  libvdpau-devel >= 0.2
40 BuildRequires:  lirc-devel
41 BuildRequires:  lua51-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  portaudio-devel >= 19
44 BuildRequires:  pulseaudio-devel >= 0.9
45 BuildRequires:  rpmbuild(macros) >= 1.336
46 BuildRequires:  waf >= 1.8.1
47 BuildRequires:  wayland-devel >= 1.3.0
48 BuildRequires:  xorg-lib-libX11-devel
49 BuildRequires:  xorg-lib-libXScrnSaver-devel
50 BuildRequires:  xorg-lib-libXdamage-devel
51 BuildRequires:  xorg-lib-libXext-devel
52 BuildRequires:  xorg-lib-libXinerama-devel
53 BuildRequires:  xorg-lib-libXv-devel
54 BuildRequires:  xorg-lib-libXxf86vm-devel
55 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
56 BuildRequires:  xorg-proto-xproto-devel
57 Requires:       OpenGL
58 Suggests:       youtube-dl >= 2:20141109
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
62
63 %define         zshdir %{_datadir}/zsh/site-functions
64
65 %description
66 Movie player based on MPlayer and mplayer2.
67
68 %package client-libs
69 Summary:        Client library for controlling mpv
70 Group:          Development/Libraries
71
72 %description client-libs
73 Client library for controlling mpv.
74
75 %package client-devel
76 Summary:        Development files for mpv client library
77 Group:          Development/Libraries
78 Requires:       %{name}-client-libs = %{version}-%{release}
79
80 %description client-devel
81 Development files for mpv client library.
82
83 %package -n zsh-completion-mpv
84 Summary:        zsh-completion for mpv
85 Group:          Applications/Shells
86 Requires:       %{name} = %{version}-%{release}
87
88 %description -n zsh-completion-mpv
89 zsh-completion for mpv.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 %waf configure \
97                 --prefix=%{_prefix} \
98                 --bindir=%{_bindir} \
99                 --confdir=%{_sysconfdir}/mpv \
100                 --libdir=%{_libdir} \
101                 --datadir=%{_datadir} \
102                 --mandir=%{_mandir} \
103                 --disable-debug-build \
104                 --enable-alsa \
105                 --enable-audio-input \
106                 --enable-caca \
107                 --enable-cdda \
108                 --enable-dvb \
109                 --enable-dvbin \
110                 --enable-dvdnav \
111                 --enable-dvdread \
112                 --enable-enca \
113                 --enable-encoding \
114                 --enable-gl-wayland \
115                 --enable-gl-x11 \
116                 --enable-iconv \
117                 --enable-jack \
118                 --enable-joystick \
119                 --enable-jpeg \
120                 --enable-ladspa \
121                 --enable-lcms2 \
122                 --enable-libass \
123                 --enable-libass-osd \
124                 --enable-libavdevice \
125                 --enable-libavfilter \
126                 --enable-libavresample \
127                 --enable-libbluray \
128                 --enable-libbs2b \
129                 --enable-libguess \
130                 --enable-libmpv-shared \
131                 --enable-libpostproc \
132                 --enable-libsmbclient \
133                 --enable-libv4l2 \
134                 --enable-lirc \
135                 --enable-mpg123 \
136                 --enable-openal \
137                 --enable-oss-audio \
138                 --enable-portaudio \
139                 --enable-pulse \
140                 --enable-pvr \
141                 --enable-sdl1 \
142                 --enable-shm \
143                 --enable-tv \
144                 --enable-tv-v4l2 \
145                 --enable-vaapi \
146                 --enable-vaapi-glx \
147                 --enable-vaapi-hwaccel \
148                 --enable-vaapi-vpp \
149                 --enable-vdpau \
150                 --enable-vdpau-gl-x11 \
151                 --enable-vdpau-hwaccel \
152                 --enable-wayland \
153                 --enable-x11 \
154                 --enable-xext \
155                 --enable-xinerama \
156                 --enable-xss \
157                 --enable-xv \
158                 --enable-zsh-comp \
159                 --lua=51pld \
160                 --zshdir=%{zshdir}
161
162 %waf build -v
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %waf install --destdir=$RPM_BUILD_ROOT
168
169 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
170 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
171
172 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %files
178 %defattr(644,root,root,755)
179 %doc README.md RELEASE_NOTES etc/example.conf etc/input.conf etc/mplayer-input.conf etc/restore-old-bindings.conf
180 %dir %{_sysconfdir}/mpv
181 %{_sysconfdir}/mpv/encoding-profiles.conf
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
183 %attr(755,root,root) %{_bindir}/%{name}
184 %{_desktopdir}/mpv.desktop
185 %{_iconsdir}/hicolor/*/apps/mpv.png
186 %{_mandir}/man1/mpv.1*
187
188 %files client-libs
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
192
193 %files client-devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libmpv.so
196 %{_includedir}/mpv
197 %{_pkgconfigdir}/mpv.pc
198
199 %files -n zsh-completion-mpv
200 %defattr(644,root,root,755)
201 %{zshdir}/_mpv
This page took 0.0402 seconds and 3 git commands to generate.