]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
25f69e3152d022d49f61395e9c520e5de2a90903
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.22.0
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  aa56677b11c1b634a83c56f1c1c39c57
9 Source1:        %{name}.conf
10 Patch0:         %{name}-lua.patch
11 URL:            http://mpv.io/
12 BuildRequires:  Mesa-libEGL-devel >= 9.0.0
13 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
14 BuildRequires:  OpenAL-devel >= 1.13
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  SDL-devel
17 BuildRequires:  alsa-lib-devel
18 BuildRequires:  docutils
19 BuildRequires:  enca-devel
20 BuildRequires:  ffmpeg-devel >= 2.4.0
21 BuildRequires:  jack-audio-connection-kit-devel
22 BuildRequires:  lcms2-devel >= 2.6
23 BuildRequires:  libass-devel >= 0.12.1
24 %ifarch i386 i486
25 BuildRequires:  libatomic-devel
26 %endif
27 BuildRequires:  libbluray-devel >= 0.3.0
28 BuildRequires:  libcaca-devel >= 0.99
29 BuildRequires:  libcdio-paranoia-devel
30 BuildRequires:  libdvdnav-devel >= 4.2.0
31 BuildRequires:  libdvdread-devel >= 4.1.0
32 BuildRequires:  libguess-devel
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libsmbclient-devel
35 BuildRequires:  libv4l-devel
36 BuildRequires:  libva-devel >= 1.2.0
37 BuildRequires:  libva-glx-devel >= 1.2.0
38 BuildRequires:  libvdpau-devel >= 0.2
39 BuildRequires:  lua51-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  pulseaudio-devel >= 0.9
42 BuildRequires:  rpmbuild(macros) >= 1.336
43 BuildRequires:  waf >= 1.8.12
44 BuildRequires:  wayland-devel >= 1.3.0
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xorg-lib-libXScrnSaver-devel
47 BuildRequires:  xorg-lib-libXdamage-devel
48 BuildRequires:  xorg-lib-libXext-devel
49 BuildRequires:  xorg-lib-libXinerama-devel
50 BuildRequires:  xorg-lib-libXv-devel
51 BuildRequires:  xorg-lib-libXxf86vm-devel
52 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
53 BuildRequires:  xorg-proto-xproto-devel
54 Requires:       Mesa-libwayland-egl >= 9.0.0
55 Requires:       OpenAL >= 1.13
56 Requires:       OpenGL
57 %requires_eq    ffmpeg-libs
58 Requires:       lcms2 >= 2.6
59 Requires:       libass >= 0.12.1
60 Requires:       libbluray >= 0.3.0
61 Requires:       libcaca >= 0.99
62 Requires:       libdvdnav >= 4.2.0
63 Requires:       libdvdread >= 4.1.0
64 Requires:       libva >= 1.2.0
65 Requires:       libva-glx >= 1.2.0
66 Requires:       libvdpau >= 0.2
67 Requires:       pulseaudio-libs >= 1.0
68 Requires:       wayland >= 1.6.0
69 Requires:       xorg-lib-libxkbcommon >= 0.3.0
70 Suggests:       youtube-dl >= 2:20150223
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
74
75 %define         zshdir %{_datadir}/zsh/site-functions
76
77 %description
78 Movie player based on MPlayer and mplayer2.
79
80 %package client-libs
81 Summary:        Client library for controlling mpv
82 Group:          Development/Libraries
83
84 %description client-libs
85 Client library for controlling mpv.
86
87 %package client-devel
88 Summary:        Development files for mpv client library
89 Group:          Development/Libraries
90 Requires:       %{name}-client-libs = %{version}-%{release}
91
92 %description client-devel
93 Development files for mpv client library.
94
95 %package -n zsh-completion-mpv
96 Summary:        zsh-completion for mpv
97 Group:          Applications/Shells
98 Requires:       %{name} = %{version}-%{release}
99
100 %description -n zsh-completion-mpv
101 zsh-completion for mpv.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 %build
108 %waf configure \
109                 --prefix=%{_prefix} \
110                 --bindir=%{_bindir} \
111                 --confdir=%{_sysconfdir}/mpv \
112                 --libdir=%{_libdir} \
113                 --datadir=%{_datadir} \
114                 --mandir=%{_mandir} \
115                 --disable-debug-build \
116                 --enable-alsa \
117                 --enable-audio-input \
118                 --enable-caca \
119                 --enable-cdda \
120                 --enable-dvb \
121                 --enable-dvbin \
122                 --enable-dvdnav \
123                 --enable-dvdread \
124                 --enable-enca \
125                 --enable-encoding \
126                 --enable-gl-wayland \
127                 --enable-gl-x11 \
128                 --enable-iconv \
129                 --enable-jack \
130                 --enable-jpeg \
131                 --enable-lcms2 \
132                 --enable-libass \
133                 --enable-libass-osd \
134                 --enable-libavdevice \
135                 --enable-libbluray \
136                 --enable-libguess \
137                 --enable-libmpv-shared \
138                 --enable-libsmbclient \
139                 --enable-libswresample \
140                 --enable-libv4l2 \
141                 --enable-openal \
142                 --enable-oss-audio \
143                 --enable-pulse \
144                 --enable-sdl1 \
145                 --enable-shm \
146                 --enable-tv \
147                 --enable-tv-v4l2 \
148                 --enable-vaapi \
149                 --enable-vaapi-glx \
150                 --enable-vaapi-hwaccel \
151                 --enable-vdpau \
152                 --enable-vdpau-gl-x11 \
153                 --enable-vdpau-hwaccel \
154                 --enable-wayland \
155                 --enable-x11 \
156                 --enable-xext \
157                 --enable-xinerama \
158                 --enable-xss \
159                 --enable-xv \
160                 --enable-zsh-comp \
161                 --lua=51pld \
162                 --zshdir=%{zshdir}
163
164 %waf build -v
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168
169 %waf install --destdir=$RPM_BUILD_ROOT
170
171 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
172 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
173
174 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   client-libs -p /sbin/ldconfig
180 %postun client-libs -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc README.md RELEASE_NOTES etc/input.conf etc/mplayer-input.conf etc/mpv.conf etc/restore-old-bindings.conf
185 %dir %{_sysconfdir}/mpv
186 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/encoding-profiles.conf
187 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
188 %attr(755,root,root) %{_bindir}/%{name}
189 %{_desktopdir}/mpv.desktop
190 %{_iconsdir}/hicolor/*/apps/mpv.png
191 %{_iconsdir}/hicolor/scalable/apps/mpv.svg
192 %{_iconsdir}/hicolor/symbolic/apps/mpv-symbolic.svg
193 %{_mandir}/man1/mpv.1*
194
195 %files client-libs
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
198 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
199
200 %files client-devel
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libmpv.so
203 %{_includedir}/mpv
204 %{_pkgconfigdir}/mpv.pc
205
206 %files -n zsh-completion-mpv
207 %defattr(644,root,root,755)
208 %{zshdir}/_mpv
This page took 0.055766 seconds and 2 git commands to generate.