]> git.pld-linux.org Git - packages/mplayer2.git/commitdiff
- fix format string errors
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 29 Aug 2013 12:03:31 +0000 (14:03 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 29 Aug 2013 12:03:31 +0000 (14:03 +0200)
- disable live555 support

format-security.patch [new file with mode: 0644]
mplayer2.spec

diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..1071d8a
--- /dev/null
@@ -0,0 +1,20 @@
+--- mplayer2-build-2.0/ffmpeg-mt/libavcodec/srtdec.c.orig      2013-08-29 13:55:20.253846192 +0200
++++ mplayer2-build-2.0/ffmpeg-mt/libavcodec/srtdec.c   2013-08-29 13:55:41.680766150 +0200
+@@ -109,7 +109,7 @@
+                                 if (stack[sptr-1].param[i][0])
+                                     for (j=sptr-2; j>=0; j--)
+                                         if (stack[j].param[i][0]) {
+-                                            out += snprintf(out, out_end-out,
++                                            out += snprintf(out, out_end-out, "%s",
+                                                             stack[j].param[i]);
+                                             break;
+                                         }
+@@ -145,7 +145,7 @@
+                             }
+                             for (i=0; i<PARAM_NUMBER; i++)
+                                 if (stack[sptr].param[i][0])
+-                                    out += snprintf(out, out_end-out,
++                                    out += snprintf(out, out_end-out, "%s",
+                                                     stack[sptr].param[i]);
+                         }
+                     } else if (!buffer[1] && strspn(buffer, "bisu") == 1) {
index 36de8fa41a82bb50cd46d035e2990bc3dd73f0b7..a3ae0dca998df3c68b5d136dd71805eedddb5638 100644 (file)
@@ -24,7 +24,7 @@
 %bcond_without libdts          # disable libdts support
 %bcond_without libdv           # disable libdv en/decoding support
 %bcond_without lirc            # without lirc support
-%bcond_without live            # without LIVE555 libraries
+%bcond_with    live            # without LIVE555 libraries
 %bcond_without lzo             # with LZO support (requires lzo 2.x)
 %bcond_without mad             # without mad (audio MPEG) support
 %bcond_without pulseaudio      # without pulseaudio output
@@ -68,6 +68,7 @@ License:      GPL
 Group:         Applications/Multimedia
 Source0:       http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}.tar.xz
 # Source0-md5: 05b93784de995235e2758f182de15f73
+Patch0:                format-security.patch
 URL:           http://www.mplayer2.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
@@ -221,6 +222,7 @@ escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
 
 %prep
 %setup -q -n %{name}-build-%{version}
+%patch0 -p1
 
 # set ffmpeg options:
 echo " --arch=%{_target_base_arch}" >>ffmpeg_options
This page took 0.125204 seconds and 4 git commands to generate.