]> git.pld-linux.org Git - packages/mplayer2.git/blob - mplayer2.spec
- build options for ffmpeg, x264 does not work
[packages/mplayer2.git] / mplayer2.spec
1 #
2 %bcond_with     directfb        # with DirectFB video output
3 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
4 %bcond_with     ggi             # with ggi video output
5 %bcond_with     nas             # with NAS audio output
6 %bcond_with     svga            # with svgalib video output
7 %bcond_without  osd             # with osd menu support
8 %bcond_without  altivec         # without altivec support
9 %bcond_without  x264            # without x264 support
10 %bcond_with     xmms            # with XMMS inputplugin support
11 %bcond_without  aalib           # without aalib video output
12 %bcond_without  jack            # without JACKD support
13 %bcond_without  alsa            # without ALSA audio output
14 %bcond_with     arts            # with arts audio output
15 %bcond_without  caca            # without libcaca video output
16 %bcond_without  cdparanoia      # without cdparanoia support
17 %bcond_without  dvdnav          # without dvdnav support
18 %bcond_without  enca            # disable using ENCA charset oracle library
19 %bcond_with     esd             # enable EsounD sound support
20 %bcond_without  faad            # disable FAAD2 (AAC) support
21 %bcond_without  gif             # disable GIF support
22 %bcond_without  gui             # without GTK+ GUI
23 %bcond_without  joystick        # disable joystick support
24 %bcond_without  libdts          # disable libdts support
25 %bcond_without  libdv           # disable libdv en/decoding support
26 %bcond_without  lirc            # without lirc support
27 %bcond_without  live            # without LIVE555 libraries
28 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
29 %bcond_without  mad             # without mad (audio MPEG) support
30 %bcond_without  pulseaudio      # without pulseaudio output
31 %bcond_without  quicktime       # without binary quicktime dll support
32 %bcond_without  real            # without Real* 8/9 codecs support
33 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
34                                 #  in compile time (advertised by mplayer authors as working faster); in this case
35                                 #  mplayer may not work on machine other then where it was compiled
36 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
37 %bcond_without  smb             # disable Samba (SMB) input support
38 %bcond_without  theora          # without theora support
39 %bcond_without  win32           # without win32 codecs support
40 %bcond_without  vdpau           # disable vdpau
41 %bcond_without  vidix           # disable vidix
42 %bcond_without  vorbis          # without Ogg-Vorbis audio support
43 %bcond_with     system_vorbis   # use system libvorbis instead of internal tremor
44 %bcond_without  xvid            # disable XviD codec
45 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
46 %bcond_without  sdl             # disable SDL
47 %bcond_without  doc             # don't build docs (slow)
48 %bcond_with     shared          # experimental libmplayer.so support
49 %bcond_without  amr             # enable Adaptive Multi Rate (AMR) speech codec support
50 %bcond_without  gnomess         # disable controling gnome screensaver
51 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
52 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
53 %bcond_with     on2             # with patches from On2 Flix Engine for Linux
54
55 %bcond_with     nonfree         # non free options of package
56 %bcond_without  va              # VAAPI (Video Acceleration API)
57 %bcond_without  vpx             # VP8, a high-quality video codec
58
59 %if %{_lib} == "lib64"
60 %define         _suf    64
61 %else
62 %define         _suf    32
63 %endif
64
65 %define         subver  rc2
66 %define         rel     1
67 Summary:        MPlayer - THE Movie Player for UN*X
68 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
69 Summary(es.UTF-8):      Otro reproductor de películas
70 Summary(ko.UTF-8):      리눅스용 미디어플레이어
71 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
72 Summary(pt_BR.UTF-8):   Reprodutor de filmes
73 Name:           mplayer2
74 Version:        2.0
75 Release:        0.%{subver}.%{rel}
76 License:        GPL
77 Group:          Applications/Multimedia
78 Source0:        http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}-%{subver}.tar.xz
79 # Source0-md5:  92793d629181e059384c43972fa9a701
80 URL:            http://www.mplayer2.org/
81 BuildRequires:  OpenAL-devel
82 BuildRequires:  OpenGL-devel
83 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
84 %{?with_aalib:BuildRequires:    aalib-devel}
85 %{?with_alsa:BuildRequires:     alsa-lib-devel}
86 %{?with_arts:BuildRequires:     artsc-devel}
87 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
88 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
89 BuildRequires:  dirac-devel
90 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
91 %{?with_doc:BuildRequires:      docbook-style-xsl}
92 %{?with_dxr3:BuildRequires:     em8300-devel}
93 %{?with_enca:BuildRequires:     enca-devel}
94 %{?with_esd:BuildRequires:      esound-devel}
95 BuildRequires:  faac-devel
96 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
97 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
98 BuildRequires:  freetype-devel >= 2.0.9
99 BuildRequires:  fribidi-devel
100 BuildRequires:  tar >= 1:1.22
101 %{?with_vidix:BuildRequires:    vidix-devel}
102 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
103 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
104 %{?with_gif:BuildRequires:      giflib-devel}
105 %{?with_gui:BuildRequires:      gtk+2-devel}
106 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
107 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
108 BuildRequires:  lame-libs-devel
109 %{?with_caca:BuildRequires:     libcaca-devel}
110 %{?with_libdts:BuildRequires:   libdts-devel}
111 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
112 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
113 %{?with_ggi:BuildRequires:      libggi-devel}
114 BuildRequires:  libjpeg-devel
115 %{?with_mad:BuildRequires:      libmad-devel}
116 BuildRequires:  libmng-devel
117 BuildRequires:  libmpcdec-devel >= 1.2.1
118 BuildRequires:  libpng-devel
119 %{?with_smb:BuildRequires:      libsmbclient-devel}
120 %{?with_theora:BuildRequires:   libtheora-devel}
121 %{?with_vdpau:BuildRequires:    libvdpau-devel}
122 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
123 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
124 BuildRequires:  libxslt-progs
125 %{?with_lirc:BuildRequires:     lirc-devel}
126 %{?with_live:BuildRequires:     live-devel}
127 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
128 %{?with_nas:BuildRequires:      nas-devel}
129 BuildRequires:  ncurses-devel
130 %{?with_amr:BuildRequires:      opencore-amr-devel}
131 BuildRequires:  pkgconfig
132 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
133 BuildRequires:  rpm >= 4.4.9-56
134 BuildRequires:  rpmbuild(macros) >= 1.527
135 BuildRequires:  schroedinger-devel
136 BuildRequires:  speex-devel >= 1.1
137 %{?with_svga:BuildRequires:     svgalib-devel}
138 BuildRequires:  twolame-devel
139 %{?with_xmms:BuildRequires:     xmms-devel}
140 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
141 %ifarch %{ix86} %{x8664}
142 BuildRequires:  yasm
143 %endif
144 BuildRequires:  zlib-devel
145 BuildRequires:  xorg-lib-libX11-devel
146 BuildRequires:  xorg-lib-libXScrnSaver-devel
147 BuildRequires:  xorg-lib-libXext-devel
148 BuildRequires:  xorg-lib-libXinerama-devel
149 BuildRequires:  xorg-lib-libXv-devel
150 BuildRequires:  xorg-lib-libXvMC-devel
151 BuildRequires:  xorg-lib-libXxf86dga-devel
152 BuildRequires:  xorg-lib-libXxf86vm-devel
153 Requires:       OpenGL
154 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
155
156 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
157 %define         specflags_ia32  -fomit-frame-pointer
158 %if %{with altivec}
159 %define         specflags_ppc   -maltivec
160 %endif
161
162 %description
163 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
164 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
165 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
166 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
167 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
168 optionally with SHM extension, X11 using overlays with the Xvideo
169 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
170 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
171
172 If you want to use win32 codecs install w32codec package.
173
174 %description -l de.UTF-8
175 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
176 Kennzeichnend ist die herausragende Format- und
177 Plattform-Kompatibilität.
178
179 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
180 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
181 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
182 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
183 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
184 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
185 installierte Codecs nicht mit MPlayer kollidieren können.
186
187 %description -l es.UTF-8
188 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
189 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
190 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
191 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
192 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
193 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
194 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
195 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
196 v1.1.7 etc.
197
198 Si quiere usar codecs Win32, instale el paquete w32codec.
199
200 %description -l ko.UTF-8
201 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
202 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
203 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
204 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
205 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
206 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
207 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
208 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
209 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
210
211 %description -l pl.UTF-8
212 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
213 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
214 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
215 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
216 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
217 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
218 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
219
220 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
221
222 %description -l pt_BR.UTF-8
223 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
224 áudio. Diferentes mecanismos de reprodução podem também ser
225 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
226
227 %prep
228 %setup -q -n %{name}
229
230 # set ffmpeg options:
231 echo "  --arch=%{_target_base_arch}" >>ffmpeg_options
232 #echo " --prefix=%{_prefix}" >>ffmpeg_options
233 #echo " --libdir=%{_libdir}" >>ffmpeg_options
234 #echo " --shlibdir=%{_libdir}" >>ffmpeg_options
235 #echo " --mandir=%{_mandir}" >>ffmpeg_options
236 echo "  --cc="%{__cc}"" >>ffmpeg_options
237 echo "  --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}"" >>ffmpeg_options
238 echo "  --extra-ldflags="%{rpmcflags} %{rpmldflags}"" >>ffmpeg_options
239 echo "  --disable-debug" >>ffmpeg_options
240 echo "  --disable-optimizations" >>ffmpeg_options
241 echo "  --disable-stripping" >>ffmpeg_options
242 echo "  --enable-avfilter" >>ffmpeg_options
243 echo "  --enable-gpl" >>ffmpeg_options
244 echo "  --enable-version3" >>ffmpeg_options
245 echo "  --enable-libdc1394" >>ffmpeg_options
246 echo "  --enable-libdirac" >>ffmpeg_options
247 #echo " --enable-libfaad" >>ffmpeg_options
248 #echo " --enable-libfaadbin" >>ffmpeg_options
249 # no libgsm-devel
250 #echo " --enable-libgsm" >>ffmpeg_options 
251 echo "  --enable-libmp3lame" >>ffmpeg_options
252 echo "  --enable-libschroedinger" >>ffmpeg_options
253 echo "  --enable-libspeex" >>ffmpeg_options
254 echo "  --enable-libtheora" >>ffmpeg_options
255 echo "  --enable-libvorbis" >>ffmpeg_options
256 echo "  %{?with_vpx:--enable-libvpx}" >>ffmpeg_options
257 # x264 >= 0.99
258 #echo " --enable-libx264" >>ffmpeg_options
259 echo "  --enable-libxvid" >>ffmpeg_options
260 echo "  --enable-libopencore-amrnb" >>ffmpeg_options
261 echo "  --enable-libopencore-amrwb" >>ffmpeg_options
262 echo "  --enable-libopenjpeg" >>ffmpeg_options
263 echo "  --enable-postproc" >>ffmpeg_options
264 echo "  --enable-pthreads" >>ffmpeg_options
265 echo "  --enable-swscale" >>ffmpeg_options
266 echo "  --enable-vdpau" >>ffmpeg_options
267 echo "  --enable-x11grab" >>ffmpeg_options
268 %ifnarch %{ix86} %{x8664}
269 echo "  --disable-mmx" >>ffmpeg_options
270 %endif
271 %ifarch i386 i486
272 echo "  --disable-mmx" >>ffmpeg_options
273 %endif
274 %if %{with nonfree}
275 echo "  --enable-nonfree" >>ffmpeg_options
276 echo "  --enable-libfaac" >>ffmpeg_options
277 %endif
278 echo "  --enable-runtime-cpudetect" >>ffmpeg_options
279
280 # set mplayer options:
281 echo "  --prefix=%{_prefix}" >>mplayer_options
282 echo "  --confdir=%{_sysconfdir}/mplayer" >>mplayer_options
283 echo "  --cc="%{__cc}"" >>mplayer_options
284 echo "  --extra-cflags="$CFLAGS"" >>mplayer_options
285 #echo " --real-ldflags="%{rpmldflags}"" >>mplayer_options
286 echo "  --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}"" >>mplayer_options
287 %if %{with system_ffmpeg}
288 echo "  --disable-libavutil_a" >>mplayer_options
289 echo "  --disable-libavcodec_a" >>mplayer_options
290 echo "  --disable-libavformat_a" >>mplayer_options
291 echo "  --disable-libpostproc_a" >>mplayer_options
292 echo "  --enable-libavutil_so" >>mplayer_options
293 echo "  --enable-libavcodec_so" >>mplayer_options
294 echo "  --enable-libavformat_so" >>mplayer_options
295 echo "  --enable-libpostproc_so" >>mplayer_options
296 %endif
297 %ifnarch %{ix86} %{x8664}
298 echo "  --disable-mmx" >>mplayer_options
299 echo "  --disable-mmxext" >>mplayer_options
300 echo "  --disable-3dnow" >>mplayer_options
301 echo "  --disable-3dnowext" >>mplayer_options
302 echo "  --disable-sse" >>mplayer_options
303 echo "  --disable-sse2" >>mplayer_options
304 echo "  --disable-fastmemcpy" >>mplayer_options
305 %endif
306 echo "  %{__disable ssse3}" >>mplayer_options
307 #echo " %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb}" >>mplayer_options
308 echo "  %{__enable_disable directfb}" >>mplayer_options
309 echo "  %{__disable dxr3}" >>mplayer_options
310 echo "  %{__disable ggi}" >>mplayer_options
311 echo "  %{__disable live}" >>mplayer_options
312 echo "  %{__disable lzo liblzo}" >>mplayer_options
313 echo "  %{__disable nas}" >>mplayer_options
314 echo "  %{__disable svga}" >>mplayer_options
315 echo "  %{__disable aalib aa}" >>mplayer_options
316 echo "  %{__disable jack}" >>mplayer_options
317 echo "  %{__enable_disable alsa}" >>mplayer_options
318 echo "  %{__disable arts}" >>mplayer_options
319 echo "  %{__disable caca}" >>mplayer_options
320 echo "  %{__disable cdparanoia}" >>mplayer_options
321 echo "  %{__disable enca}" >>mplayer_options
322 echo "  %{__disable esd}" >>mplayer_options
323 echo "  %{__disable faad}" >>mplayer_options
324 echo "  %{__disable gif}" >>mplayer_options
325 echo "  %{__enable joystick}" >>mplayer_options
326 echo "  %{__disable libdv}" >>mplayer_options
327 echo "  %{__disable libdts libdca}" >>mplayer_options
328 echo "  %{__enable_disable lirc}" >>mplayer_options
329 echo "  %{__disable mad}" >>mplayer_options
330 echo "  %{__disable pulseaudio pulse}" >>mplayer_options
331 echo "  %{__disable quicktime qtx}" >>mplayer_options
332 echo "  %{__disable real}" >>mplayer_options
333 echo "  %{__enable_disable runtime runtime-cpudetection}" >>mplayer_options
334 echo "  %{__disable select}" >>mplayer_options
335 echo "  %{__disable smb}" >>mplayer_options
336 echo "  %{__disable win32 win32dll}" >>mplayer_options
337 echo "  %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis}" >>mplayer_options
338 echo "  %{__disable_if system_vorbis tremor-internal}" >>mplayer_options
339 echo "  %{__enable osd menu}" >>mplayer_options
340 echo "  %{__disable theora}" >>mplayer_options
341 echo "  %{__disable x264}" >>mplayer_options
342 echo "  %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}}" >>mplayer_options
343 echo "  %{__disable xvid}" >>mplayer_options
344 echo "  %{__disable vidix}" >>mplayer_options
345 echo "  %{__disable vdpau}" >>mplayer_options
346 echo "  %{__disable mencoder}" >>mplayer_options
347 echo "  --enable-dga1" >>mplayer_options
348 echo "  --enable-dga2" >>mplayer_options
349 echo "  %{__enable_disable dvdnav}" >>mplayer_options
350 echo "  --enable-fbdev" >>mplayer_options
351 echo "  --enable-gl" >>mplayer_options
352 echo "  --enable-mga" >>mplayer_options
353 echo "  --enable-radio" >>mplayer_options
354 echo "  --enable-radio-capture" >>mplayer_options
355 echo "  %{__enable_disable sdl}" >>mplayer_options
356 echo "  --enable-tdfxfb" >>mplayer_options
357 echo "  --enable-vm" >>mplayer_options
358 echo "  --enable-x11" >>mplayer_options
359 echo "  --enable-xmga" >>mplayer_options
360 echo "  --enable-xv" >>mplayer_options
361 echo "  --enable-xvmc" >>mplayer_options
362 echo "  --with-xvmclib=XvMCW" >>mplayer_options
363 #echo " --enable-zr" >>mplayer_options
364 echo "  --enable-unrarexec" >>mplayer_options
365 echo "  --enable-dynamic-plugins" >>mplayer_options
366 echo "  --enable-largefiles" >>mplayer_options
367 echo "  --language=all" >>mplayer_options
368 echo "  --codecsdir=%{_libdir}/codecs" >>mplayer_options
369
370 cat mplayer/etc/example.conf > mplayer/etc/mplayer.conf
371 cat <<'CONFIGADD' >> mplayer/etc/mplayer.conf
372
373 ######################
374 # PLD Linux Defaults #
375 ######################
376 [default]
377
378 # alternate solution for CP1250-encoded subtitles
379 fontconfig = yes
380 subcp = cp1250
381
382 # ...or if you prefer native bitmap fonts shipped with mplayer
383 #fontconfig = no
384 #subcp = iso-8859-1
385
386 # Standard location
387 unrarexec = "%{_bindir}/unrar"
388
389 CONFIGADD
390
391 %build
392 %{__make}
393
394 %install
395 rm -rf $RPM_BUILD_ROOT
396 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} 
397
398 %{__make} install DESTDIR=$RPM_BUILD_ROOT
399
400 mv -f $RPM_BUILD_ROOT%{_bindir}/{mplayer,%{name}}
401 # default config files
402 #install mplayer/etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
403
404 # fonts
405 #cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
406 #ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
407
408 #install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
409 #install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
410
411 %clean
412 rm -rf $RPM_BUILD_ROOT
413
414 %files
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.111127 seconds and 4 git commands to generate.