]> git.pld-linux.org Git - packages/mpich.git/commitdiff
- rel 3 auto/th/mpich-1_2_7p1-3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 4 Apr 2012 12:01:20 +0000 (12:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix building with current g++/gfortran

Changed files:
    mpich-c++.patch -> 1.1
    mpich.spec -> 1.17

mpich-c++.patch [new file with mode: 0644]
mpich.spec

diff --git a/mpich-c++.patch b/mpich-c++.patch
new file mode 100644 (file)
index 0000000..b271575
--- /dev/null
@@ -0,0 +1,52 @@
+--- mpich-1.2.7p1/configure.in~        2012-04-04 13:02:28.073692580 +0200
++++ mpich-1.2.7p1/configure.in 2012-04-04 13:55:29.800502795 +0200
+@@ -1804,7 +1804,7 @@
+             # (the autoconf tests are too GNU-centric)
+           if test -n "$GXXTRIAL" ; then 
+                 cat > conftest.cc <<EOF
+-#include <iostream.h>
++#include <iostream>
+ EOF
+               rm -f conftest.out
+               if $GXXTRIAL $CXXFLAGS -c conftest.cc >conftest.out 2>&1 ; then
+@@ -1845,10 +1845,10 @@
+     # used above is used only to *find* a compiler; if the user selected
+     # a compiler that doesn't work, we still need the test.
+     if test -n "$CPP_COMPILER" ; then 
+-        AC_MSG_CHECKING([whether selected C++ compiler can compile iostream.h])
++        AC_MSG_CHECKING([whether selected C++ compiler can compile iostream])
+         rm -f conftest*
+         cat > conftest.cc <<EOF
+-#include <iostream.h> 
++#include <iostream>   
+ EOF
+         if $CPP_COMPILER $CXXFLAGS -c conftest.cc>conftest.out 2>&1 ; then 
+             AC_MSG_RESULT(yes)
+--- mpich-1.2.7p1/configure~   2012-04-04 13:56:35.643839099 +0200
++++ mpich-1.2.7p1/configure    2012-04-04 13:57:10.133840656 +0200
+@@ -2748,7 +2748,7 @@
+             # (the autoconf tests are too GNU-centric)
+           if test -n "$GXXTRIAL" ; then 
+                 cat > conftest.cc <<EOF
+-#include <iostream.h>
++#include <iostream>
+ EOF
+               rm -f conftest.out
+               if $GXXTRIAL $CXXFLAGS -c conftest.cc >conftest.out 2>&1 ; then
+@@ -2844,13 +2844,13 @@
+ fi
+ if test -z "$ac_echo_test" -a 1 = 1 ; then
+-echo $ac_n "checking whether selected C++ compiler can compile iostream.h""... $ac_c"
++echo $ac_n "checking whether selected C++ compiler can compile iostream""... $ac_c"
+ else
+-echo $ac_n "checking whether selected C++ compiler can compile iostream.h""... $ac_c" 1>&1
++echo $ac_n "checking whether selected C++ compiler can compile iostream""... $ac_c" 1>&1
+ fi
+         rm -f conftest*
+         cat > conftest.cc <<EOF
+-#include <iostream.h> 
++#include <iostream>
+ EOF
+         if $CPP_COMPILER $CXXFLAGS -c conftest.cc>conftest.out 2>&1 ; then 
+             if test -z "$ac_echo_test" -a 1 = 1 ; then
index 387646b5bd2edf70d380b5de672e483f2e533979..15096ed535e3feabb9f55c776e3a8c924ddbaa6b 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Portable MPI Model Implementation
 Summary(pl.UTF-8):     Przenośna implementacja standardu MPI
 Name:          mpich
 Version:       1.2.7p1
-Release:       2
+Release:       3
 License:       Open source (MPICH), BSD-like (MPI-2-C++)
 Group:         Development/Libraries
 Source0:       ftp://ftp.mcs.anl.gov/pub/mpi/%{name}-%{version}.tar.bz2
@@ -10,6 +10,7 @@ Source0:      ftp://ftp.mcs.anl.gov/pub/mpi/%{name}-%{version}.tar.bz2
 Patch0:                %{name}-fuckssh.patch
 Patch1:                %{name}-opt.patch
 Patch2:                http://squishy.monkeysoft.net/mpich/%{name}-1.2.5-oM.patch
+Patch3:                mpich-c++.patch
 URL:           http://www-unix.mcs.anl.gov/mpi/
 BuildRequires: gcc-g77
 BuildRequires: libstdc++-devel
@@ -33,6 +34,7 @@ części wersji MPI-2, szczególnie w zakresie równoległej komunikacji.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 sed -i -e 's|RCPCOMMAND-rcp|RCPCOMMAND-scp|' mpid/ch_p4/mpirun.ch_p4.in
 
@@ -55,7 +57,8 @@ messagecat_dir=%{_libdir} \
        --sbindir=%{_sbindir} \
        --mandir=%{_mandir} \
        --docdir=%{_docdir} \
-       -opt="%{rpmcflags} -fPIC"
+       -opt="%{rpmcflags} -fPIC -DPIC" \
+       -fc=gfortran
 
 %{__make}
 
This page took 0.156359 seconds and 4 git commands to generate.