]> git.pld-linux.org Git - packages/mpich.git/blob - mpich.spec
- removed broken symlinks
[packages/mpich.git] / mpich.spec
1 Summary:        Portable MPI Model Implementation
2 Summary(pl.UTF-8):      Przenośna implementacja standardu MPI
3 Name:           mpich
4 Version:        1.2.7p1
5 Release:        1
6 License:        Open source (MPICH), BSD-like (MPI-2-C++)
7 Group:          Development/Libraries
8 Source0:        ftp://ftp.mcs.anl.gov/pub/mpi/%{name}-%{version}.tar.bz2
9 # Source0-md5:  4fc0f20bddfbd5061a11047cf2d17d31
10 Patch0:         %{name}-fuckssh.patch
11 Patch1:         %{name}-opt.patch
12 Patch2:         http://squishy.monkeysoft.net/mpich/%{name}-1.2.5-oM.patch
13 URL:            http://www-unix.mcs.anl.gov/mpi/
14 BuildRequires:  gcc-g77
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  sed >= 4.0
17 Provides:       mpi
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 MPICH is an open-source, portable implementation of the
22 Message-Passing Interface Standard. It contains a complete
23 implementation of version 1.2 of the MPI Standard and also significant
24 parts of MPI-2, particularly in the area of parallel I/O.
25
26 %description -l pl.UTF-8
27 MPICH jest wolnodostępną implementacją standardu MPI (Message-Passing
28 Interface). Zawiera pełną implementację wersji MPI 1.2 oraz znaczne
29 części wersji MPI-2, szczególnie w zakresie równoległej komunikacji.
30
31 %prep
32 %setup -q
33 %patch0 -p1
34 %patch1 -p1
35 %patch2 -p1
36
37 sed -i -e 's|RCPCOMMAND-rcp|RCPCOMMAND-scp|' mpid/ch_p4/mpirun.ch_p4.in
38
39 %build
40 RSHCOMMAND=/usr/bin/ssh ; export RSHCOMMAND
41 RCPCOMMAND=/usr/bin/scp ; export RCPCOMMAND
42 # note: can't run autoconf - we must patch configure not only configure.in
43 # also, don't change it to %%configure - it won't work
44 # no configure options for sysconfdir and messagecat_dir :/
45 sysconfdir=%{_sysconfdir} \
46 messagecat_dir=%{_libdir} \
47 ./configure \
48         --prefix=%{_prefix} \
49         --exec_prefix=%{_prefix} \
50         --includedir=%{_includedir} \
51         --sharedlib=%{_libdir} \
52         --libdir=%{_libdir} \
53         --datadir=%{_datadir}/%{name} \
54         --bindir=%{_bindir} \
55         --sbindir=%{_sbindir} \
56         --mandir=%{_mandir} \
57         --docdir=%{_docdir} \
58         -opt="%{rpmcflags}"
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 # really awful
66 DESTDIR=$RPM_BUILD_ROOT ; export DESTDIR
67 %{__make} install
68
69 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70 mv -f $RPM_BUILD_ROOT%{_prefix}/examples/* \
71         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 (cd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74 rm -f mpirun MPI-2-C++/mpirun
75 ln -sf %{_bindir}/mpirun mpirun
76 ln -sf %{_bindir}/mpirun MPI-2-C++/mpirun
77 )
78
79 # argh... where came that 4 from???
80 for f in $RPM_BUILD_ROOT%{_mandir}/man4/*.4 ; do
81         mv -f "$f" $RPM_BUILD_ROOT%{_mandir}/man3/`basename "$f" .4`.3
82 done
83
84 for f in HISTORY LICENSE README TODO ; do
85         mv -f MPI-2-C++/$f $f.MPI-2-C++
86 done
87
88 rm -rf $RPM_BUILD_ROOT%{_prefix}/{doc,logfiles,www}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc doc/*.ps* COPYRIGHT README KnownBugs
99 %attr(755,root,root) %{_bindir}/*
100 %attr(755,root,root) %{_sbindir}/*
101 %attr(755,root,root) %{_libdir}/lib*.so*
102 %{_libdir}/lib*.a
103 %{_libdir}/mpe_prof.o
104 %{_sysconfdir}/mpichversion.c
105 %{_sysconfdir}/mpichconf.h.dat
106 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpi*.conf
107 %{_includedir}/*.h
108 %{_includedir}/mpi2c++
109 %{_mandir}/man1/*
110 %{_mandir}/man3/*
111 %{_datadir}/mpich
112 %{_examplesdir}/%{name}-%{version}
This page took 0.093674 seconds and 4 git commands to generate.