]> git.pld-linux.org Git - packages/mpich.git/blob - mpich.spec
9382d3a6c784860cc8cdbc3c213167179e0cfd5a
[packages/mpich.git] / mpich.spec
1 Summary:        Portable MPI Model Implementation
2 Summary(pl):    Przeno¶na implementacja standardu MPI
3 Name:           mpich
4 Version:        1.2.5
5 %define pver    1a
6 Release:        %{pver}.2
7 License:        Open source (MPICH), BSD-like (MPI-2-C++)
8 Group:          Development/Libraries
9 Source0:        ftp://ftp.mcs.anl.gov/pub/mpi/%{name}-%{version}-%{pver}.tar.gz
10 # Source0-md5:  b4557d284e41a2a5a682cd69128cac89
11 Patch0:         %{name}-fuckssh.patch
12 Patch1:         %{name}-opt.patch
13 Patch2:         http://squishy.monkeysoft.net/%{name}/%{name}-%{version}-oM.patch
14 URL:            http://www-unix.mcs.anl.gov/mpi/
15 BuildRequires:  gcc-g77
16 BuildRequires:  libstdc++-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 MPICH is an open-source, portable implementation of the
21 Message-Passing Interface Standard. It contains a complete
22 implementation of version 1.2 of the MPI Standard and also significant
23 parts of MPI-2, particularly in the area of parallel I/O.
24
25 %description -l pl
26 MPICH jest wolnodostêpn± implementacj± standardu MPI (Message-Passing
27 Interface). Zawiera pe³n± implementacjê wersji MPI 1.2 oraz znaczne
28 czê¶ci wersji MPI-2, szczególnie w zakresie równoleg³ej komunikacji.
29
30 %prep
31 %setup -q
32 %patch0 -p1
33 %patch1 -p1
34 %patch2 -p1
35
36 %build
37 # note: can't run autoconf - we must patch configure not only configure.in
38 # also, don't change it to %%configure - it won't work
39 # no configure options for sysconfdir and messagecat_dir :/
40 sysconfdir=%{_sysconfdir} messagecat_dir=%{_libdir} \
41 ./configure \
42         --prefix=%{_prefix} --exec_prefix=%{_prefix} \
43         --includedir=%{_includedir} --sharedlib=%{_libdir} \
44         --libdir=%{_libdir} --datadir=%{_datadir}/%{name} \
45         --bindir=%{_bindir} --sbindir=%{_sbindir} \
46         --mandir=%{_mandir} --docdir=%{_docdir} \
47         -opt="%{rpmcflags}"
48
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # really awful
55 DESTDIR=$RPM_BUILD_ROOT ; export DESTDIR
56 %{__make} install
57
58 # fix symlinks
59 (cd $RPM_BUILD_ROOT%{_libdir}
60 rm -f libfmpich.so libmpich.so libpmpich.so
61 ln -sf libfmpich.so.*.* libfmpich.so
62 ln -sf libmpich.so.*.* libmpich.so
63 ln -sf libpmpich.so.*.* libpmpich.so
64 )
65
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67 mv -f $RPM_BUILD_ROOT%{_prefix}/examples/* \
68         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 (cd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71 rm -f mpirun MPI-2-C++/mpirun
72 ln -sf %{_bindir}/mpirun mpirun
73 ln -sf %{_bindir}/mpirun MPI-2-C++/mpirun
74 )
75
76 # argh... where came that 4 from???
77 for f in $RPM_BUILD_ROOT%{_mandir}/man4/*.4 ; do
78         mv -f "$f" $RPM_BUILD_ROOT%{_mandir}/man3/`basename "$f" .4`.3
79 done
80
81 for f in HISTORY LICENSE README TODO ; do
82         mv -f MPI-2-C++/$f $f.MPI-2-C++
83 done
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc doc/*.ps* COPYRIGHT README KnownBugs
94 %attr(755,root,root) %{_bindir}/*
95 %attr(755,root,root) %{_sbindir}/*
96 %attr(755,root,root) %{_libdir}/lib*.so*
97 %{_libdir}/lib*.a
98 %{_sysconfdir}/*
99 %{_includedir}/*
100 %{_mandir}/man1/*
101 %{_mandir}/man3/*
102 %{_datadir}/mpich
103 %{_examplesdir}/%{name}-%{version}
This page took 0.184096 seconds and 2 git commands to generate.