]> git.pld-linux.org Git - packages/mpfr.git/blob - mpfr.spec
- updated to 3.1.6
[packages/mpfr.git] / mpfr.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make check
4 #
5 Summary:        Multiple-precision floating-point computations library
6 Summary(pl.UTF-8):      Biblioteka obliczeń zmiennoprzecinkowych wielokrotnej precyzji
7 Name:           mpfr
8 Version:        3.1.6
9 Release:        1
10 License:        LGPL v3+
11 Group:          Libraries
12 Source0:        http://www.mpfr.org/mpfr-current/%{name}-%{version}.tar.xz
13 # Source0-md5:  51bfdbf81553966c8d43808122cc81b3
14 Patch0:         %{name}-info.patch
15 URL:            http://www.mpfr.org/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.13
18 BuildRequires:  gmp-devel >= 4.1.0
19 BuildRequires:  libtool
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  texinfo
22 BuildRequires:  xz
23 Requires:       gmp >= 4.1.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The MPFR library is a C library for multiple-precision floating-point
28 computations with exact rounding (also called correct rounding). It is
29 based on the GMP multiple-precision library. The main goal of MPFR is
30 to provide a library for multiple-precision floating-point computation
31 which is both efficient and has a well-defined semantics. It copies
32 the good ideas from the ANSI/IEEE-754 standard for double-precision
33 floating-point arithmetic (53-bit mantissa).
34
35 %description -l pl.UTF-8
36 Biblioteka MPFR to biblioteka C do obliczeń zmiennoprzecinkowych z
37 wielokrotną precyzją i dokładnym zaokrąglaniem (zwanym także poprawnym
38 zaokrąglaniem). Jest oparta na bibliotece GMP wielokrotnej precyzji.
39 Głównym celem MPFR jest dostarczenie biblioteki do obliczeń
40 zmiennoprzecinkowych wielokrotnej precyzji, która jest wydajna i ma
41 dobrze zdefiniowaną semantykę. Powiela dobre idee ze standardu
42 ANSI/IEEE-754 dla arytmetyki zmiennoprzecinkowej podwójnej precyzji (z
43 53-bitową mantysą).
44
45 %package devel
46 Summary:        Header files for MPFR library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MPFR
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       gmp-devel >= 4.1.0
51 Obsoletes:      libmpfr-devel
52
53 %description devel
54 Header files for MPFR library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki MPFR.
58
59 %package static
60 Summary:        Static MPFR library
61 Summary(pl.UTF-8):      Statyczna biblioteka MPFR
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static MPFR library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka MPFR.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 # triggers bug in gold (as of binutils-2.21.53.0.2-1.i686)
76 mkdir my-ld
77 if [ -x /usr/bin/ld.bfd ]; then
78         ln -s /usr/bin/ld.bfd my-ld/ld
79 fi
80
81 %build
82 export PATH=$PWD/my-ld:$PATH
83 %{__libtoolize}
84 %{__aclocal} -I m4
85 %{__autoconf}
86 %{__automake}
87 %configure \
88         --enable-shared
89
90 # make -j4 creates truncated .lo files
91 %{__make} -j1 all
92
93 %if %{with tests}
94 %{__make} check
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %post   devel -p /sbin/postshell
112 -/usr/sbin/fix-info-dir -c %{_infodir}
113
114 %postun devel -p /sbin/postshell
115 -/usr/sbin/fix-info-dir -c %{_infodir}
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS BUGS ChangeLog NEWS README TODO doc/FAQ.html
120 %attr(755,root,root) %{_libdir}/libmpfr.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libmpfr.so.4
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libmpfr.so
126 %{_libdir}/libmpfr.la
127 %{_includedir}/mpfr.h
128 %{_includedir}/mpf2mpfr.h
129 %{_infodir}/mpfr.info*
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libmpfr.a
This page took 0.080669 seconds and 3 git commands to generate.