]> git.pld-linux.org Git - packages/mpd.git/commitdiff
- added -ffmpeg_sigsegv.patch fixing "mpd[11147]: segfault at...libavformat.so..... auto/ti/mpd-0_16_3-3
authorKrzysztof Krakowiak <evil@pld-linux.org>
Fri, 15 Jul 2011 09:55:29 +0000 (09:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mpd-ffmpeg_sigsegv.patch -> 1.1
    mpd.spec -> 1.68

mpd-ffmpeg_sigsegv.patch [new file with mode: 0644]
mpd.spec

diff --git a/mpd-ffmpeg_sigsegv.patch b/mpd-ffmpeg_sigsegv.patch
new file mode 100644 (file)
index 0000000..a945a0a
--- /dev/null
@@ -0,0 +1,21 @@
+diff -ur mpd-0.16.3.orig/src/decoder/ffmpeg_decoder_plugin.c mpd-0.16.3/src/decoder/ffmpeg_decoder_plugin.c
+--- mpd-0.16.3.orig/src/decoder/ffmpeg_decoder_plugin.c        2011-06-04 17:36:33.000000000 +0300
++++ mpd-0.16.3/src/decoder/ffmpeg_decoder_plugin.c     2011-06-24 18:18:51.840218251 +0300
+@@ -321,7 +321,7 @@
+       }
+       //ffmpeg works with ours "fileops" helper
+-      AVFormatContext *format_context;
++      AVFormatContext *format_context = NULL;
+       if (av_open_input_stream(&format_context, stream->io, input->uri,
+                                input_format, NULL) != 0) {
+               g_warning("Open failed\n");
+@@ -470,7 +470,7 @@
+       if (stream == NULL)
+               return NULL;
+-      AVFormatContext *f;
++      AVFormatContext *f = NULL;
+       if (av_open_input_stream(&f, stream->io, is->uri,
+                                input_format, NULL) != 0) {
+               mpd_ffmpeg_stream_close(stream);
index 41df4cf37cedf58fca1ffd2a91e141efdd325c62..ca9396e2dfbe9888943eea2182f353f94f41892b 100644 (file)
--- a/mpd.spec
+++ b/mpd.spec
@@ -10,7 +10,7 @@ Summary(hu.UTF-8):    Music Player Daemon
 Summary(pl.UTF-8):     Music Player Daemon - demon odtwarzajÄ…cy muzykÄ™
 Name:          mpd
 Version:       0.16.3
-Release:       2
+Release:       3
 License:       GPL v2+
 Group:         Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/musicpd/%{name}-%{version}.tar.bz2
@@ -19,6 +19,7 @@ Source1:      %{name}.conf
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
 URL:           http://www.musicpd.org/
+Patch0:                %{name}-ffmpeg_sigsegv.patch
 BuildRequires: OpenAL-devel
 BuildRequires: alsa-lib-devel >= 0.9.0
 BuildRequires: audiofile-devel >= 0.1.7
@@ -117,6 +118,7 @@ Dokumentacja do Music Player Daemon (MPD).
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 # ac_cv_* hacks to avoid unwanted linking
This page took 0.142634 seconds and 4 git commands to generate.