]> git.pld-linux.org Git - packages/mpd.git/blob - mpd.spec
- rel 2
[packages/mpd.git] / mpd.spec
1 # TODO:
2 # - add logrotate
3 #
4 # Conditional build:
5 %bcond_without  mod             # enable MOD support
6 %bcond_without  pulse           # disable PulseAudio support
7 #
8 Summary:        Music Player Daemon
9 Summary(hu.UTF-8):      Music Player Daemon
10 Summary(pl.UTF-8):      Music Player Daemon - demon odtwarzający muzykę
11 Name:           mpd
12 Version:        0.15.9
13 Release:        2
14 License:        GPL v2+
15 Group:          Applications/Multimedia
16 Source0:        http://downloads.sourceforge.net/musicpd/%{name}-%{version}.tar.bz2
17 # Source0-md5:  88f7bc0b17eac81d03b24929d12b8aa1
18 Source1:        %{name}.conf
19 Source2:        %{name}.init
20 URL:            http://www.musicpd.org/
21 BuildRequires:  alsa-lib-devel >= 0.9.0
22 BuildRequires:  audiofile-devel >= 0.1.7
23 BuildRequires:  avahi-glib-devel
24 BuildRequires:  bzip2-devel
25 BuildRequires:  curl-devel
26 BuildRequires:  doxygen
27 BuildRequires:  faad2-devel >= 2.6.1-5
28 BuildRequires:  ffmpeg-devel
29 BuildRequires:  flac-devel >= 1.1.0
30 BuildRequires:  fluidsynth-devel
31 BuildRequires:  glib2-devel
32 BuildRequires:  jack-audio-connection-kit-devel >= 0.4
33 BuildRequires:  lame-libs-devel
34 BuildRequires:  libao-devel >= 0.8.3
35 BuildRequires:  libcdio-devel
36 BuildRequires:  libcue-devel
37 BuildRequires:  libid3tag-devel
38 BuildRequires:  libmad-devel
39 %{?with_mod:BuildRequires:      libmikmod-devel >= 3.1.7}
40 BuildRequires:  libmms-devel
41 BuildRequires:  libmodplug-devel
42 BuildRequires:  libmpcdec-devel
43 BuildRequires:  libogg-devel
44 BuildRequires:  libsamplerate-devel >= 0.0.15
45 BuildRequires:  libshout-devel
46 BuildRequires:  libvorbis-devel
47 BuildRequires:  pkgconfig >= 1:0.9.0
48 %{?with_pulse:BuildRequires:    pulseaudio-devel}
49 BuildRequires:  sqlite3-devel
50 BuildRequires:  wavpack-devel
51 BuildRequires:  wildmidi-devel
52 BuildRequires:  xmlto
53 BuildRequires:  zlib-devel
54 BuildRequires:  zziplib-devel
55 Provides:       group(mpd)
56 Provides:       user(mpd)
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Music Player Daemon (MPD) allows remote access for playing music (MP3,
61 Ogg Vorbis, FLAC, AAC, Mod, and wave files) and managing playlists.
62 MPD is designed for integrating a computer into a stereo system that
63 provides control for music playback over a local network. It is also
64 makes a great desktop music player, especially if you are a console
65 junkie, like frontend options, or restart X often.
66
67 %description -l hu.UTF-8
68 Music Player Daemon (MPD)-vel lehetővé válik távoli zenelejátszás
69 (MP3, Ogg Vorbis, FLAC, AAC, Mod és wav fájlok) és lejátszási listák
70 menedzselése. Az MPD a számítógépben egy zenelejátszó, amelyet
71 irányíthatsz helyi hálózaton keresztül. Egyben egy zseniális desktop
72 zenelejátszó is, különösen a konzol-mániásoknak, vagy azoknak, akik
73 sűrűn indítják újra az X-et.
74
75 %description -l pl.UTF-8
76 Music Player Daemon (MPD) pozwala na zdalny dostęp do odtwarzania
77 muzyki (plików MP3, Ogg Vorbis, FLAC, AAC, Mod i wave) oraz
78 zarządzania playlistami. MPD jest zaprojektowany do integrowania
79 komputera w system stereo umożliwiający sterowanie odtwarzaniem muzyki
80 w sieci lokalnej. Służy także za dobry odtwarzacz muzyki dla
81 komputerów biurkowych, zwłaszcza dla miłośników konsoli, różnych opcji
82 frontendów albo często restartujących X.
83
84 %prep
85 %setup -q
86
87 %build
88 # ac_cv_* hacks to avoid unwanted linking
89 %configure \
90         ac_cv_lib_iconv_main=no \
91         ac_cv_lib_nsl_gethostbyname=no \
92         %{!?with_pulse:--disable-pulse} \
93         %{?with_mod:--enable-mikmod} \
94         --disable-sidplay \
95         --enable-alsa \
96         --enable-ao \
97         --enable-bzip2 \
98         --enable-cue \
99         --enable-curl \
100         --enable-documentation \
101         --enable-ffmpeg \
102         --enable-fluidsynth \
103         --enable-httpd-output \
104         --enable-iso9660 \
105         --enable-jack \
106         --enable-lame-encoder \
107         --enable-lastfm \
108         --enable-lsr \
109         --enable-mad \
110         --enable-mms \
111         --enable-modplug \
112         --enable-mvp \
113         --enable-shout \
114         --enable-sqlite \
115         --enable-vorbis-encoder \
116         --enable-wavpack \
117         --enable-wildmidi \
118         --enable-zip \
119         --with-zeroconf=avahi \
120         --without-tremor
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d} \
126         $RPM_BUILD_ROOT{/var/lib/mpd/playlists,/var/log/mpd,/var/run/mpd}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
132 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mpd
133
134 touch $RPM_BUILD_ROOT/var/lib/mpd/mpd.db
135 touch $RPM_BUILD_ROOT/var/log/mpd/mpd.error
136 touch $RPM_BUILD_ROOT/var/log/mpd/mpd.log
137 touch $RPM_BUILD_ROOT/var/run/mpd/mpdstate
138
139 rm -rf $RPM_BUILD_ROOT/usr/share/doc/mpd
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %pre
145 %groupadd -g 204 mpd
146 %useradd -u 204 -r -d /home/services/mpd -s /bin/false -c "Music Player Daemon (MPD) user" -g audio -G mpd mpd
147
148 %post
149 for f in mpd.log mpd.error; do
150         if [ ! -f /var/log/%{name}/$f ]; then
151                 touch /var/log/%{name}/$f
152                 chown mpd:mpd /var/log/%{name}/$f
153                 chmod 644 /var/log/%{name}/$f
154         fi
155 done
156 /sbin/chkconfig --add mpd
157
158 %preun
159 if [ "$1" = "0" ]; then
160         %service mpd stop
161         /sbin/chkconfig --del mpd
162 fi
163
164 %postun
165 if [ "$1" = "0" ]; then
166         %userremove mpd
167         %groupremove mpd
168 fi
169
170 %files
171 %defattr(644,root,root,755)
172 %doc AUTHORS NEWS README doc/mpdconf.example UPGRADING doc/api doc/developer doc/protocol doc/sticker doc/user
173 %attr(755,root,root) %{_bindir}/*
174 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpd.conf
175 %attr(754,root,root) /etc/rc.d/init.d/mpd
176 %dir %attr(770,root,mpd) /var/lib/%{name}
177 %dir %attr(770,root,mpd) /var/lib/%{name}/playlists
178 %dir %attr(751,root,root) /var/log/%{name}
179 %dir %attr(770,root,mpd) /var/run/%{name}
180 %attr(644,mpd,mpd) %ghost /var/lib/%{name}/mpd.db
181 %attr(644,mpd,mpd) %ghost /var/log/%{name}/mpd.error
182 %attr(644,mpd,mpd) %ghost /var/log/%{name}/mpd.log
183 %attr(644,mpd,mpd) %ghost /var/run/%{name}/mpdstate
184 %{_mandir}/man1/mpd.1*
185 %{_mandir}/man5/mpd.conf.5*
This page took 0.265976 seconds and 4 git commands to generate.