]> git.pld-linux.org Git - packages/mp4v2.git/commitdiff
- added export patch: really export Base64ToBinary(), as indicated in header auto/th/mp4v2-2.0.0-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 7 Dec 2012 21:11:22 +0000 (22:11 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 7 Dec 2012 21:11:22 +0000 (22:11 +0100)
- release 2

mp4v2-export.patch [new file with mode: 0644]
mp4v2.spec

diff --git a/mp4v2-export.patch b/mp4v2-export.patch
new file mode 100644 (file)
index 0000000..dd24b28
--- /dev/null
@@ -0,0 +1,39 @@
+--- mp4v2-2.0.0/src/mp4util.cpp.orig   2012-05-21 00:11:53.000000000 +0200
++++ mp4v2-2.0.0/src/mp4util.cpp        2012-12-07 19:20:16.380127762 +0100
+@@ -195,6 +195,9 @@
+     return true;
+ }
++}} // namespace mp4v2::impl
++
++extern "C"
+ uint8_t *Base64ToBinary (const char *pData, uint32_t decodeSize, uint32_t *pDataSize)
+ {
+     uint8_t *ret;
+@@ -208,7 +211,7 @@
+     }
+     size = (decodeSize * 3) / 4;
+     groups = decodeSize / 4;
+-    ret = (uint8_t *)MP4Calloc(size);
++    ret = (uint8_t *)mp4v2::impl::MP4Calloc(size);
+     if (ret == NULL) return NULL;
+     for (ix = 0; ix < groups; ix++) {
+         uint8_t value[4];
+@@ -220,7 +223,7 @@
+                 }
+                 size--;
+                 value[jx] = 0;
+-            } else if (convertBase64(pData[jx], &value[jx]) == false) {
++            } else if (mp4v2::impl::convertBase64(pData[jx], &value[jx]) == false) {
+                 free(ret);
+                 return NULL;
+             }
+@@ -234,6 +237,8 @@
+     return ret;
+ }
++namespace mp4v2 { namespace impl {
++
+ // log2 of value, rounded up
+ static uint8_t ilog2(uint64_t value)
+ {
index 25428fe5df8d1b0fed9ef539377de859d8a1fb4b..424ca14ebd3bacd97212d9f3af92930f3886f257 100644 (file)
@@ -4,12 +4,13 @@ Summary:      MP4v2 library provides API for creation and modification of MP4 files
 Summary(pl.UTF-8):     Biblioteka MP4v2 - API do tworzenia i modyfikowania plików MP4
 Name:          mp4v2
 Version:       2.0.0
-Release:       1
+Release:       2
 License:       MPL v1.1
 Group:         Applications/Multimedia
 #Source0Download: http://code.google.com/p/mp4v2/downloads/list
 Source0:       http://mp4v2.googlecode.com/files/%{name}-%{version}.tar.bz2
 # Source0-md5: c91f06711225b34b4c192c9114887b14
+Patch0:                %{name}-export.patch
 URL:           http://code.google.com/p/mp4v2/
 BuildRequires: help2man
 BuildRequires: libstdc++-devel
@@ -73,6 +74,7 @@ Ten pakiet zawiera statyczną wersję biblioteki MP4v2.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure
This page took 0.12201 seconds and 4 git commands to generate.