]> git.pld-linux.org Git - packages/mozjs52.git/commitdiff
Add patch to fix build on x32. Release 2
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Wed, 11 Oct 2017 19:13:19 +0000 (21:13 +0200)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Wed, 11 Oct 2017 19:13:19 +0000 (21:13 +0200)
mozjs52-x32.patch [new file with mode: 0644]
mozjs52.spec

diff --git a/mozjs52-x32.patch b/mozjs52-x32.patch
new file mode 100644 (file)
index 0000000..ba0990f
--- /dev/null
@@ -0,0 +1,22 @@
+--- mozilla-esr38/js/src/jstypes.h.x32fix      2017-03-21 08:17:52.446161040 +0100
++++ mozilla-esr38/js/src/jstypes.h     2017-03-21 08:18:23.531014466 +0100
+@@ -142,7 +142,7 @@
+ # endif
+ #elif defined(__GNUC__)
+ /* Additional GCC defines are when running on Solaris, AIX, and HPUX */
+-# if defined(__x86_64__) || defined(__sparcv9) || \
++# if (defined(__x86_64__) && !defined(__ILP32__)) || defined(__sparcv9) || \
+         defined(__64BIT__) || defined(__LP64__)
+ #  define JS_64BIT
+ # endif
+--- firefox-52.4.0esr/build/moz.configure/init.configure.x32   2017-10-09 21:07:08.378262900 +0200
++++ firefox-52.4.0esr/build/moz.configure/init.configure       2017-10-09 21:07:52.781784556 +0200
+@@ -386,7 +386,7 @@ def split_triplet(triplet):
+     return namespace(
+         alias=triplet,
+         cpu=CPU(canonical_cpu),
+-        bitness=CPU_bitness[canonical_cpu],
++        bitness=32,
+         kernel=Kernel(canonical_kernel),
+         os=OS(canonical_os),
+         endianness=Endianness(endianness),
index c5be051cb3fdc7091d7920c37c0c875a83c8caf5..10c20abb3698f5b65f3f422a4315a832bf19bb04 100644 (file)
@@ -2,7 +2,7 @@ Summary:        SpiderMonkey 52 - JavaScript implementation
 Summary(pl.UTF-8):     SpiderMonkey 52 - implementacja języka JavaScript
 Name:          mozjs52
 Version:       52.4.0
-Release:       1
+Release:       2
 License:       MPL v2.0
 Group:         Libraries
 Source0:       https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.xz
@@ -11,6 +11,7 @@ Patch0:               copy-headers.patch
 Patch1:                disable-mozglue.patch
 Patch2:                system-virtualenv.patch
 Patch3:                include-configure-script.patch
+Patch4:                %{name}-x32.patch
 URL:           https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
 BuildRequires: autoconf2_13
 BuildRequires: libstdc++-devel >= 6:4.4
@@ -61,6 +62,9 @@ Pliki nagłówkowe do biblioteki JavaScript.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%ifarch x32
+%patch4 -p1
+%endif
 
 cd js/src
 
This page took 0.173037 seconds and 4 git commands to generate.