]> git.pld-linux.org Git - packages/mozilla-firefox.git/commitdiff
- based on mozilla-install.patch, for forefox3
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 5 Mar 2008 22:41:53 +0000 (22:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mozilla-firefox-install.patch -> 1.1

mozilla-firefox-install.patch [new file with mode: 0644]

diff --git a/mozilla-firefox-install.patch b/mozilla-firefox-install.patch
new file mode 100644 (file)
index 0000000..7551791
--- /dev/null
@@ -0,0 +1,46 @@
+--- mozilla/toolkit/mozapps/installer/packager.mk      2006-12-23 03:38:32.302235167 +0200
++++ mozilla/toolkit/mozapps/installer/packager.mk      2008-03-05 22:33:38.554155518 +0000
+@@ -301,7 +301,7 @@
+ # NOTE: this must be a tar now that dist links into the tree so that we
+ # do not strip the binaries actually in the tree.
+       @echo "Creating package directory..."
+-      @mkdir $(DIST)/$(MOZ_PKG_APPNAME)
++      @mkdir $(DESTDIR)$(MOZ_PKG_APPDIR)
+ ifdef MOZ_PKG_MANIFEST
+       $(RM) -rf $(DIST)/xpt
+       $(PERL) -I$(topsrcdir)/xpinstall/packager -e 'use Packager; \
+@@ -316,7 +316,7 @@
+       @cd $(DIST) && rsync -auv --copy-unsafe-links $(_APPNAME) $(MOZ_PKG_APPNAME)
+ endif
+ else
+-      @cd $(DIST)/bin && tar $(TAR_CREATE_FLAGS) - * | (cd ../$(MOZ_PKG_APPNAME); tar -xf -)
++      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_APPDIR)
+ endif # DMG
+ endif # MOZ_PKG_MANIFEST
+ ifndef PKG_SKIP_STRIP
+@@ -328,13 +328,13 @@
+ # NOTE: this must be a tar now that dist links into the tree so that we
+ # do not strip the binaries actually in the tree.
+       @echo "Creating package directory..."
+-      @mkdir $(DESTDIR)$(MOZ_PKG_APPDIR)
++      @mkdir -p $(DESTDIR)$(MOZ_PKG_APPDIR)
+ ifdef MOZ_PKG_MANIFEST
+       $(RM) -rf $(DIST)/xpt
+       $(call PACKAGER_COPY, "$(DIST)",\
+-               "$(DIST)/$(MOZ_PKG_APPNAME)", \
++               "$(DESTDIR)/$(MOZ_PKG_APPDIR)", \
+               "$(MOZ_PKG_MANIFEST)", "$(PKGCP_OS)", 1, 0, 1)
+-      $(PERL) $(topsrcdir)/xpinstall/packager/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DIST)/$(MOZ_PKG_APPNAME)/components -v -x "$(XPIDL_LINK)"
++      $(PERL) $(topsrcdir)/xpinstall/packager/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DESTDIR)/$(MOZ_PKG_APPDIR)/components -v -x "$(XPIDL_LINK)"
+ else # !MOZ_PKG_MANIFEST
+ ifeq ($(MOZ_PKG_FORMAT),DMG)
+ # If UNIVERSAL_BINARY, the package will be made from an already-prepared
+@@ -348,7 +348,7 @@
+ endif
+       @echo "Removing unpackaged files..."
+ ifdef NO_PKG_FILES
+-      cd $(DIST)/$(STAGEPATH)$(MOZ_PKG_APPNAME)$(_BINPATH); rm -rf $(NO_PKG_FILES)
++      cd $(DESTDIR)$(MOZ_PKG_APPDIR)$(_BINPATH); rm -rf $(NO_PKG_FILES)
+ endif
+ ifdef MOZ_PKG_REMOVALS
+       $(SYSINSTALL) $(MOZ_PKG_REMOVALS_GEN) $(DIST)/$(STAGEPATH)$(MOZ_PKG_APPNAME)$(_BINPATH)
This page took 0.075079 seconds and 5 git commands to generate.