]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
- BR pkgconfig
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_without  verbose         # verbose build (V=1)
4
5 %if "%{pld_release}" == "ac"
6 # add suffix, but allow ccache, etc in ~/.rpmmacros
7 %{expand:%%define       __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
8 %{expand:%%define       __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
9 %{expand:%%define       __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
10 %endif
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Mosh mobile shell
14 Name:           mosh
15 Version:        1.2.2
16 Release:        1
17 License:        GPL v3+
18 Group:          X11/Applications
19 Source0:        https://github.com/downloads/keithw/mosh/%{name}-%{version}.tar.gz
20 # Source0-md5:  7ed5b857307685794dcd120afe5bdf52
21 URL:            http://mosh.mit.edu/
22 BuildRequires:  binutils >= 2.20.51.0.2
23 BuildRequires:  libstdc++-devel >= 5:4.0
24 BuildRequires:  libutempter-devel
25 BuildRequires:  ncurses-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  protobuf
28 BuildRequires:  protobuf-devel
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  zlib-devel
32 # gcc4 might be installed, but not current __cc
33 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
34 BuildRequires:  __cc >= 4.0
35 %endif
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Remote terminal application that allows roaming, supports intermittent
40 connectivity, and provides intelligent local echo and line editing of
41 user keystrokes.
42
43 Mosh is a replacement for SSH. It's more robust and responsive,
44 especially over Wi-Fi, cellular, and long-distance links.
45
46 %prep
47 %setup -q
48 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh
49
50 %build
51 %configure \
52         --enable-compile-warnings=error \
53         CPPFLAGS="-I/usr/include/ncurses"
54 %{__make} \
55         %{?with_verbose:V=1}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc AUTHORS ChangeLog NEWS THANKS
68 %attr(755,root,root) %{_bindir}/%{name}
69 %attr(755,root,root) %{_bindir}/%{name}-client
70 %attr(755,root,root) %{_bindir}/%{name}-server
71 %{_mandir}/man1/%{name}.1*
72 %{_mandir}/man1/%{name}-client.1*
73 %{_mandir}/man1/%{name}-server.1*
This page took 0.070208 seconds and 4 git commands to generate.