]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
f714243d3e197d45a8330570aae9a7e3b05f131d
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_with     agent           # with ssh agent forwarding patch
4
5 %define         protobuf_ver    2.6.1
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Mosh mobile shell
8 Name:           mosh
9 Version:        1.3.0
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/Networking
13 Source0:        https://mosh.org/%{name}-%{version}.tar.gz
14 # Source0-md5:  d961276995936953bf2d5a794068b076
15 Patch0:         https://github.com/keithw/mosh/pull/583.patch
16 # Patch0-md5:   7eb14665ef06072591e5bcd80780c0e4
17 URL:            https://mosh.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  binutils >= 2.20.51.0.2
21 BuildRequires:  libstdc++-devel >= 5:4.0
22 BuildRequires:  libtool
23 BuildRequires:  libutempter-devel
24 BuildRequires:  ncurses-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  patchutils
27 BuildRequires:  perl-base >= 1:5.14
28 BuildRequires:  pkgconfig
29 BuildRequires:  protobuf >= %{protobuf_ver}
30 BuildRequires:  protobuf-devel >= %{protobuf_ver}
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  zlib-devel
34 Requires:       protobuf-libs >= %{protobuf_ver}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # PLD stack protector flags are weaker than upstream, filter them out
38 # https://github.com/keithw/mosh/issues/203
39 %define         _ssp_cflags     %{nil}
40
41 %define         specflags       -Wno-error=non-virtual-dtor
42
43 %description
44 Remote terminal application that allows roaming, supports intermittent
45 connectivity, and provides intelligent local echo and line editing of
46 user keystrokes.
47
48 Mosh is a replacement for SSH. It's more robust and responsive,
49 especially over Wi-Fi, cellular, and long-distance links.
50
51 %prep
52 %setup -q
53 %if %{with agent}
54 %patch0 -p1
55 %endif
56 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh.pl
57
58 %build
59 %{__libtoolize}
60 %{__aclocal}
61 %{__autoconf}
62 %{__autoheader}
63 %{__automake}
64 %configure \
65         --disable-silent-rules \
66         --enable-compile-warnings=error
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog NEWS THANKS
80 %attr(755,root,root) %{_bindir}/%{name}
81 %attr(755,root,root) %{_bindir}/%{name}-client
82 %attr(755,root,root) %{_bindir}/%{name}-server
83 %{_mandir}/man1/%{name}.1*
84 %{_mandir}/man1/%{name}-client.1*
85 %{_mandir}/man1/%{name}-server.1*
This page took 0.124438 seconds and 2 git commands to generate.