]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
Up to 1.4.0
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_with     agent           # with ssh agent forwarding patch
4
5 %define         protobuf_ver    2.6.1
6 Summary:        Mosh mobile shell
7 Summary(pl.UTF-8):      Mosh - przenośna powłoka
8 Name:           mosh
9 Version:        1.4.0
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/Networking
13 Source0:        https://mosh.org/%{name}-%{version}.tar.gz
14 # Source0-md5:  c34a647f8545565d79188acacaea7559
15 Patch0:         https://github.com/keithw/mosh/pull/583.patch
16 # Patch0-md5:   7eb14665ef06072591e5bcd80780c0e4
17 Patch1:         %{name}-Werror.patch
18 Patch2:         %{name}-gcc8.patch
19 URL:            https://mosh.org/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  automake
22 BuildRequires:  binutils >= 2.20.51.0.2
23 BuildRequires:  libstdc++-devel >= 5:4.0
24 BuildRequires:  libtool
25 BuildRequires:  libutempter-devel
26 BuildRequires:  ncurses-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  patchutils
29 BuildRequires:  perl-base >= 1:5.14
30 BuildRequires:  pkgconfig
31 BuildRequires:  protobuf >= %{protobuf_ver}
32 BuildRequires:  protobuf-devel >= %{protobuf_ver}
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  zlib-devel
36 Requires:       protobuf-libs >= %{protobuf_ver}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # PLD stack protector flags are weaker than upstream, filter them out
40 # https://github.com/keithw/mosh/issues/203
41 %define         _ssp_cflags     %{nil}
42
43 %define         specflags       -Wno-error=non-virtual-dtor
44
45 %description
46 Remote terminal application that allows roaming, supports intermittent
47 connectivity, and provides intelligent local echo and line editing of
48 user keystrokes.
49
50 Mosh is a replacement for SSH. It's more robust and responsive,
51 especially over Wi-Fi, cellular, and long-distance links.
52
53 %description -l pl.UTF-8
54 Zdalna aplikacja terminala, pozwalająca na przemieszczanie,
55 obsługująca przerywaną łączność i zapewniająca inteligentne lokalne
56 echo oraz edycję linii.
57
58 Mosh to zamiennik SSH. Jest potężniejszy i responsywny, w
59 szczególności po połączeniach Wi-Fi, komórkowych i długodystansowych.
60
61 %prep
62 %setup -q
63 %if %{with agent}
64 %patch0 -p1
65 %endif
66 %patch1 -p1
67 %patch2 -p1
68 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh.pl
69
70 %build
71 %{__libtoolize}
72 %{__aclocal} -I m4
73 %{__autoconf}
74 %{__autoheader}
75 %{__automake}
76 %configure \
77         --disable-silent-rules \
78         --enable-compile-warnings=error
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS ChangeLog NEWS THANKS
93 %attr(755,root,root) %{_bindir}/%{name}
94 %attr(755,root,root) %{_bindir}/%{name}-client
95 %attr(755,root,root) %{_bindir}/%{name}-server
96 %{_mandir}/man1/%{name}.1*
97 %{_mandir}/man1/%{name}-client.1*
98 %{_mandir}/man1/%{name}-server.1*
This page took 0.13423 seconds and 3 git commands to generate.